Introdução aos fundamentos e conceitos de desenho

Desenhar modelos em 3D é diferente de desenhar imagens em 2D. Esta introdução básica e conceitual ao desenho explica algumas maneiras sobre a criação de bordas e faces (entidades básicas de qualquer modelo SketchUp). Você vai ver também como o mecanismo de inferência do SketchUp ajuda a colocar essas linhas e faces no eixo desejado.

Dica: as ferramentas básicas de formas utilizam uma linha sólida fina. Para criar linhas tracejadas, consulte Como aplicar linhas tracejadas a camadas.

Como desenhar uma linha

Utilize a ferramenta Linha para desenhar bordas (também chamadas de entidades de linha). As bordas formam a base estrutural de todos os modelos. Veja como desenhar linhas:

  1. Selecione a ferramenta Linha () na barra de ferramentas (ou pressione a tecla L). O cursor se transformará em um lápis.
  2. Clique para definir o ponto de partida da linha. Se clicar no lugar errado, pressione a tecla Esc para recomeçar. Ao mover o cursor pela área de desenho, observe o seguinte:
    • Uma linha acompanha o cursor.
    • O comprimento da linha é exibido de maneira dinâmica na caixa Medidas. (a caixa Medidas utiliza as unidades especificadas no modelo.)
    • A linha que companha o cursor fica vermelha, verde ou azul sempre que fica paralela ao eixo vermelho, verde ou azul, respectivamente. Se passar o mouse por um momento, aparece uma dica de tela, conforme a dica On Blue Axis (no eixo azul) indicada na imagem. Não há um fantasma na sua máquina; este é o mecanismo de inferência do SketchUp, sobre o qual você vai aprender mais adiante neste artigo.
  3. Clique para definir o ponto final da linha. Esse ponto final pode ser também o ponto de partida de outra linha. Pressione Esc ou selecione outra ferramenta quando terminar de desenhar as linhas. Após definir o ponto final, pressione Ctrl+Z (Microsoft Windows) ou Command+Z (macOS) para desfazer sua linha e recomeçar.

  4. (Opcional) Para que sua linha fique com um comprimento específico, digite um valor e pressione Enter (Microsoft Windows) ou Return (macOS). Você pode repetir esse processo quantas vezes quiser até desenhar outra linha ou selecionar outra ferramenta. Se não especificar uma unidade, o SketchUp usará a unidade especificada no modelo. No entanto, você pode digitar qualquer unidade no sistema imperial ou métrico para a linha. Ou seja, pode digitar 3 mm ou 5'2”, por exemplo. O valor será exibido na caixa Medidas enquanto você digita.

Observação: a caixa Medidas aceita também coordenadas em 3D para as linhas:
  • As coordenadas absolutas, como[3', 5', 7'], posicionam o fim da linha em relação aos eixos atuais. Colchetes indicam coordenadas absolutas.
  • As coordenadas relativas, como <1,5 m, 4 m, 2,75 m>, colocam a extremidade final da linha em relação ao ponto de partida da linha. Os sinais de maior e menor indicam coordenadas relativas.

Você pode editar o comprimento da linha, desde que ela não vincule nenhuma face. Veja como editar linhas:

  1. Selecione a ferramenta Mover ().
  2. Passe o cursor da ferramenta Mover sobre um dos pontos finais da linha.
  3. Clique e arraste o ponto final para alterar o comprimento da linha.

Dica: você pode também ajustar o comprimento na caixa de diálogo Informações da entidade. Clique com o botão de contexto na linha e selecione Informações da entidade, no menu exibido. Na caixa Comprimento, digite outro comprimento para a linha.

Como criar faces

Quando unimos várias linhas, transformando-a em uma forma, elas formam uma face.

Não será uma face engraçada ou uma face de em palhaço assustador, nem uma face de um filhote de cachorro fofinho. Por padrão, as faces são simples, mas muito importantes: são a outra metade da dupla, bordas e faces, que dão vida a cada modelo já criado no SketchUp.

Dica: por padrão, o SketchUp adiciona sombreamento a algumas faces, conforme indicado aqui, e as faces são opacas, para que você saiba que há realmente no modelo uma parede, um piso ou qualquer outro item a ser representado pela face no seu modelo 3D. (no entanto, o SketchUp traz uma vista que permite ver através das paredes, como se você fosse o super-homem. Consulte Como exibir um modelo para ver os detalhes).

As ferramentas de forma (retângulo, círculo e polígono) também criam faces. (consulte Como desenhar formas básicas para mais informações sobre essas ferramentas).

Como dividir faces

Quando desenhamos uma linha (ou uma curva) em uma face que já existe, dividimos a face.

Dica: este conceito é importante porque, depois de dividir uma face, podemos usar a ferramenta Empurrar/puxar para empurrar ou puxar uma parte da face enquanto a outra parte permanece inalterada, conforme indicado aqui. Consulte Como empurrar e puxar formas transformando-as em 3D para ver os detalhes sobre a ferramenta Empurrar/puxar.

Como abrir formas 3D apagando bordas e faces

Podemos apagar uma borda ou face para criar uma abertura na forma. Para ver como apagar uma borda afeta o seu modelo, primeiro selecione a ferramenta Apagar () na barra de ferramentas ou pressione a tecla E, depois clique em uma borda:

  • Clicando em uma borda apagamos a borda e qualquer face que a tocar. Podemos ter linhas sem face. No entanto, é necessário que a face esteja totalmente vinculada por bordas.
  • Clicando na face com o botão de contexto e selecionando Apagar, somente a face será excluída.

Na imagem, vemos o cubo original e como ele muda quando apagamos uma borda ou face.

Dica: caso queira ocultar uma linha em vez de apagá-la, mantenha a tecla Shift pressionada enquanto clica na linha com a ferramenta Apagar. Ou clique com o botão de contexto na linha e selecione Ocultar.

Como tratar faces excluídas

Se apagar uma face sem querer, veja como trazê-la de volta:

  • Se não tiver feito outras alterações que queira manter, basta selecionar Editar > Desfazer na barra de menu. Ou pressionar o atalho de teclado Ctrl+Z (Microsoft Windows) ou Command+Z (macOS).
  • Redesenhe a linha que fez com que as faces desaparecessem para que o SketchUp recrie as faces.

Como localizar e bloquear inferências

O SketchUp tem um mecanismo de inferência que ajuda a trabalhar no espaço 3D. Por exemplo, quando o cursor da ferramenta Linha está pairando sobre o ponto mediano de outra linha, o mecanismo de inferência indica esse ponto exibindo um ponto azul claro e uma dica de tela que diz, “Ponto mediano”, conforme indicado aqui. Toda inferência tem a sua própria cor e dica de tela. (leia Conheça os tipos de inferência para ver a lista completa.)

O mecanismo de inferência pode ajudar também a encontrar relações geométricas entre as linhas. Por exemplo, ele informa quando uma linha que você está desenhando está perpendicular a outra linha. Na imagem a seguir, veja que há um ponto colorido também no ponto de partida da linha, trazendo algumas outras informações.

Atenção: preste bastante atenção no mecanismo de inferência e orbite de vez em quando para analisar o seu desenho de diversos pontos de vista. Na imagem a seguir, as linhas podem parecer estar no plano vermelho e verde, até você orbitar para uma vista diferente. Para evitar essa cilada comum, o SketchUp ajuda colocando a direção ou o plano do desenho em vermelho, verde ou azul quando você está criando bordas ou planos paralelos a esses eixos (ou magenta se estiver muito paralelo/perpendicular a uma borda ou face no modelo).

Dica: às vezes, a inferência necessária pode não aparecer imediatamente ou o SketchUp pode optar por alinhamentos com a geometria errada. Nesses casos, você pode provocar a inferência ou aumentar as chances de um alinhamento específico pausando o cursor do mouse sobre o local de onde você quer que o SketchUp gere a inferência. Quando a indicação visual aparecer, o SketchUp priorizará brevemente esse alinhamento enquanto você desenha.

Alternância de inferência linear

Novo recurso! — SketchUp 2020.2

A inferência é um recurso fundamental do SketchUp e a maioria das ferramentas depende dele de alguma forma. No entanto, às vezes a inferência pode atrapalhar, especialmente quando se trabalha em uma área concorrida do modelo. Com a ferramenta Linha, você pode desativar e reativar a inferência linear com a ação de um modificador simples.

Para ativar e desativar a inferência linear na ferramenta Linha, clique uma vez para começar a desenhar a linha. Depois de iniciar a linha, mas antes de clicar para concluí-la, basta pressionar a tecla COMMAND no Mac ou ALT no Windows, para ativar/desativar os seguintes estados:

  • Todas as inferências ativadas
  • Todas as inferências desativadas
  • Somente paralela e perpendicular

Todas as inferências ativadas

Este é o comportamento padrão e o que você vem experimentando no SketchUp desde a primeira versão. A ferramenta Linha se alinhará aos eixos vermelho, verde e azul, e também ao eixo magenta (paralelo/perpendicular a uma borda especificada).

Todas as inferências desativadas

Nesse estado, a ferramenta Linha ignora todas as inferências lineares. Observe que o cursor se moverá de maneira mais livre pela tela enquanto você completa os segmentos de borda. Lembre-se de que ainda é possível encontrar outros tipos de inferência, tais como na face, pontos guia, pontos medianos e outros. Utilize esses outros tipos de inferência para ter certeza de que está desenhando nos planos que deseja.

Somente paralela e perpendicular

Esse estado exibe somente as inferências lineares paralelas e perpendiculares durante o uso da ferramenta Linha. Selecionando esta opção você vai conseguir desenhar a linha, garantindo o posicionamento paralelo ou perpendicular dela a outra geometria, sem se distrair com outras inferências lineares que queiram roubar sua linha.

Como travar inferências com o teclado

Travando as inferências conseguimos desenhar com firmeza na direção que pretendemos desenhar. Outro motivo para travar a inferência é manter a direção de desenho enquanto fazemos referência à geometria de outra parte do modelo. Essa é uma ação mais avançada, mas muito útil. A maneira mais fácil de travar uma inferência na direção dos eixos padrão é usar as teclas das setas:

>

Como travar a direção do desenho com as teclas das setas

Tecla Ação da ferramenta
Trava a direção ou o plano de desenho no eixo azul
Trava a direção ou o plano de desenho no eixo verde
Trava a direção ou o plano de desenho no eixo vermelho. Uma boa maneira de conseguir lembrar da distinção de esquerda e direita é dizer “direita trava vermelho”.
Ative e desative para travar a direção paralela/perpendicular de desenho ou o plano de desenho em uma borda ou plano inferido. Basicamente, tudo o que ficar magenta. A direção de desenho ficará magenta, assim como a borda da face que está sendo inferida.
Shift Trava a direção ou o plano de desenho na direção/plano de desenho ativo. Ou seja, se estiver desenhando sobre os eixos azuis e mantiver a tecla Shift pressionada, a inferência azul ficará travada.
Shift+Alt (Windows) ou Shift + Comando (macOS) Segurando a tecla shift para travar o plano de desenho também travamos a ferramenta no mesmo plano da face inferida. No entanto, para as ferramentas Rotar e Transferidor, pressione a tecla Alt (Microsoft Windows) ou a tecla Command (MacOS) para liberar essas ferramentas e poder mover o centro para outro local no modelo, mantendo o mesmo plano de desenho

Algumas ferramentas, como as ferramentas círculo e rotar, podem travar em um plano (em vez de em uma direção de desenho) conforme indicado abaixo. Para essas ferramentas, bloqueamos o plano de desenho escolhendo a direção colorida do eixo da ferramenta ou “normal”.

Como travar o plano de desenho com as teclas de seta

Como garantir o alinhamento das bordas aos eixos

Para garantir que as bordas se alinhem aos eixos, pode ser útil alterar o cursor para as cores dos eixos. Ou, se precisar verificar o alinhamento da geometria atual, altere as bordas para as cores dos eixos.

Para alterar o cursor para as cores dos eixos, siga estas etapas:

  • Selecione Janela > Preferências (Microsoft Windows) ou SketchUp > Preferências (macOS). A caixa de diálogo Preferências do SketchUp será exibida.
  • Selecione o item Desenho à esquerda.
  • Na área Diversos do painel Desenho, marque a caixa de seleção Exibir retículas.
  • Clique em OK para fechar a caixa de diálogo Preferências do SketchUp. O cursor exibe retículas da cor dos eixos, conforme indicado aqui.

Para que as bordas do modelo reflitam a cor do eixo à qual ele está alinhado, siga estas etapas:

  1. Selecione Janela > Estilos.
  2. Na caixa de diálogo Estilos, selecione No modelo na lista suspensa das bibliotecas de estilos.
  3. Clique na guia Editar.
  4. Clique no ícone Configurações de aresta, indicado na imagem.
  5. Na lista suspensa Cor, selecione Por eixo. As cores das bordas no modelo mudam para refletir o alinhamento com os eixos (se uma borda não estiver alinhada a um eixo, a cor da borda não será alterada). A imagem a seguir mostra quais bodas estão (e não estão) alinhadas aos três eixos.