그리기 기본 및 개념 소개

3D에서 모델을 그리는 것은 2D에서 이미지를 그리는 것과는 다릅니다. 그리기 기본 및 개념 소개에서는 가장자리와 면(SketchUp 모델의 기본 엔티티)을 만들 수 있는 몇 가지 방법을 설명합니다. 또한 SketchUp 추정 엔진을 사용하여 원하는 축에 선과 면을 배치하는 방법도 확인할 수 있습니다.

팁: 기본 도형 툴은 가는 실선을 사용합니다. 점선을 만들려면 레이어에 점선 적용을 참조하십시오.

선 그리기

선 툴을 사용하여 가장자리(선 엔티티라고도 함)를 그립니다. 가장자리는 모든 모델의 구조적 기초를 형성합니다. 선을 그리는 방법은 다음과 같습니다.

  1. 툴바에서 툴()을 선택합니다(또는 L 키를 누릅니다). 커서가 연필로 변경됩니다.
  2. 클릭하여 선 시작점을 설정합니다. 잘못된 위치를 클릭하면 Esc 키를 눌러서 다시 시작합니다. 커서를 도면 영역 주위로 이동하면서 다음을 주목합니다.
    • 선이 커서를 따라갑니다.
    • 선 길이가 측정 상자에 동적으로 표시됩니다. (측정 상자는 템플릿에 지정된 단위를 사용합니다.)
    • 선이 빨간색, 녹색 또는 파란색 축과 각각 평행할 때마다 커서를 따라오는 선이 빨간색, 녹색 또는 파란색으로 바뀝니다. 잠시 마우스를 올리면 그림에 표시된 파란색 축상 팁과 같은 ScreenTip이 나타납니다. 기계에 유령이 있는 것이 아닙니다. 이 문서에서 나중에 자세히 배울 SketchUp 추정 엔진입니다.
  3. 선의 끝점을 설정하려면 클릭합니다. 이 끝점은 다른 선의 시작점이 될 수도 있습니다. 선을 그렸으면 Esc를 누르거나 다른 툴을 선택합니다. 끝점을 설정한 후 Ctrl+Z(Microsoft Windows) 또는 Command+Z(macOS)를 눌러 선을 실행 취소하고 다시 시작할 수 있습니다.

  4. (옵션) 선을 정확한 길이로 만들려면 값을 입력하고 Enter(Microsoft Windows) 또는 Return(macOS)을 누릅니다. 새 선을 그리거나 다른 툴을 선택할 때까지 원하는 횟수만큼 이 프로세스를 반복할 수 있습니다. 단위를 지정하지 않는 경우, SketchUp은 템플릿에 지정된 단위를 사용합니다. 그러나 행에 대해 파운드 또는 미터 단위를 입력할 수 있습니다. 예를 들어, 3mm 또는 5'2"를 입력할 수 있습니다. 입력한 대로 측정 상자에 값이 표시됩니다.

참고: 측정 상자에는 행에 대한 3D 좌표도 입력할 수 있습니다.
  • 절대 좌표(예: [3', 5', 7'])는 현재 축을 기준으로 선의 끝을 배치합니다. 대괄호는 절대 좌표를 나타냅니다.
  • 상대 좌표(예: <1.5m, 4m, 2.75m>)는 선의 시작점을 기준으로 선의 끝을 배치합니다. 각진 괄호는 상대 좌표를 나타냅니다.

면에 결합되지 않은 선의 길이를 편집할 수 있습니다. 선을 편집하는 방법은 다음과 같습니다.

  1. 이동 툴()을 선택합니다.
  2. 선의 끝점 중 하나 위에 이동 툴 커서를 올립니다.
  3. 선의 길이를 변경하려면 끝점을 클릭하여 드래그합니다.

팁: 엔티티 정보 대화 상자에서도 길이를 조정할 수 있습니다. 컨텍스트에서 선을 클릭하고 표시되는 메뉴에서 엔티티 정보를 선택합니다. 길이 상자에 새 선 길이를 입력합니다.

면 만들기

여러 개의 선을 하나의 도형으로 결합하면 면이 형성됩니다.

웃기는 얼굴도, 무서운 광대 얼굴도, 귀여운 강아지 얼굴도 아닙니다. 기본적으로, 면은 평범하지만 매우 중요합니다. 모든 SketchUp 모델이 지원하는 듀오, 가장자리, 면의 나머지 절반을 차지합니다.

팁: 기본적으로, SketchUp에서는 여기에 표시된 것처럼 일부 면에 음영이 추가되어 있고 면은 불투명합니다. 따라서 실제 벽, 바닥 또는 사용자의 얼굴이 3D 모델에 표현된다는 것을 알 수 있습니다. (그러나, SketchUp에는 슈퍼맨처럼 벽을 관통해 볼 수 있는 뷰가 포함되어 있습니다. 자세한 내용은 모델 뷰를 참조하십시오.

직사각형, 원, 다각형의 도형 툴로도 면을 만들 수 있습니다. (이러한 툴에 대한 자세한 정보는 기본 도형 그리기를 참조하십시오.)

면 나누기

기존 면에 선(또는 곡선)을 그리면 면이 분할됩니다.

팁: 이 개념은 여기에 표시된 것처럼 면을 분할한 후 푸쉬/풀 툴을 사용하여 면의 다른 부분을 밀거나 당기는 데 사용할 수 있으므로 중요합니다. 푸쉬/풀 툴에 대한 자세한 내용은 3D로 도형 푸시 및 풀링을 참조하십시오.

가장자리를 지워서 3D 도형 열기

가장자리나 면을 지워서 도형에 구멍을 만들 수 있습니다. 가장자리 지우기가 모델에 미치는 영향을 확인하려면 먼저 툴바에서 지우개 툴()을 선택하거나 E 키를 누르고 가장자리를 클릭합니다.

  • 가장자리를 클릭하면 가장자리와 이 가장자리에 닿은 모든 면을 지워집니다. 빌리 아이돌이 비슷하게 노래했듯이 면 없는 선도 있을 수 있습니다. 그러나, 면의 경계는 완전히 가장자리로 구성되어야 합니다.
  • 컨텍스트에서 면을 클릭하고 지우기를 선택하면 면만 삭제됩니다.

그림에서는 원래 큐브와 가장자리 또는 면 지우기가 큐브를 어떻게 변화시키는지를 확인할 수 있습니다.

팁: 선을 지우기 대신 숨기려면, Shift 키를 누른 채로 지우개로 선을 클릭합니다. 또는 컨텍스트에서 선을 클릭하고 숨기기를 선택합니다.

삭제된 면 복원하기

실수로 면을 삭제한 경우 다음과 같은 방법이 있습니다.

  • 변경을 가하지 않은 경우 메뉴 표시줄에서 편집 > 실행 취소를 선택하면 됩니다. 또는 실행 취소의 키보드 단축키인 Ctrl+Z(Microsoft Windows) 또는 Command+Z(macOS)를 누릅니다.
  • 면이 사라지게 한 선을 다시 그으면 SketchUp에서 면이 다시 만들어집니다.

추정 찾기 및 잠금

SketchUp에는 3D 공간에서 작업하는 데 도움이 되는 추정 엔진이 있습니다. 예를 들어, 선 툴 커서를 다른 선의 중간점 위에 올리면 추정 엔진은 여기에 표시된 것처럼 밝은 파란색 점과 "중간점"이라고 표시된 ScreenTip을 표시하여 알려줍니다. 모든 추정에는 고유한 색상과 ScreenTip이 있습니다. (전체 목록은 추정 유형 확인하기를 참조하십시오.)

추정 엔진은 선들 사이의 기하학적 관계를 찾는 데에도 도움을 줄 수 있습니다. 예를 들어, 이 그래프는 그리는 선이 다른 선에 수직인 경우를 알려줍니다. 다음 그림에서는 색상으로 표시된 점이 선의 시작점에 나타나며 동시에 몇 비트의 모든 정보를 제공합니다.

경고: 여러 관점에서 그림을 점검할 때 추정 엔진과 궤도 이동에 주의를 기울이십시오. 다음 그림에서 선은 다른 보기로 이동할 때까지 빨간색 및 녹색 평면에 있을 수 있습니다. SketchUp은 이러한 일반적인 함정을 쉽게 구분할 수 있도록 그리기 방향 또는 그리기 평면을 빨간색, 녹색 또는 파란색으로 전환하거나 모델의 가장자리 또는 면에 평행/직각인 경우 자홍색으로 표시합니다.

팁: 때때로 필요한 추정이 즉시 나타나지 않을 수도 있고 SketchUp이 잘못된 형상과의 정렬을 선택할 수도 있습니다. 이러한 경우 SketchUp에서 추정할 위치 위에 마우스 커서를 놓으면 추정을 촉진하거나 특정 정렬의 가능성을 높일 수 있습니다. 시각적 단서가 나타나면 SketchUp은 그림을 그리는 과정에서 해당 정렬의 우선 순위를 간략히 지정합니다.

선형 추정 전환

새로운 기능 -SketchUp 2020.2

추정은 SketchUp의 기본 기능으로, 대부분 툴에 따라 다릅니다. 그러나, 모델의 혼잡한 영역을 작업할 때와 같은 경우에는 때때로 추정이 방해가 될 수 있습니다. 선 툴을 사용하면 간단한 수정자 작업을 사용하여 선형 추정 기능을 껐다가 다시 켤 수 있습니다.

선 툴에서 선형 추정을 전환하려면 한 번 클릭하여 선 그리기를 시작해야 합니다. 선을 시작한 후 클릭하여 완료하기 전에 Mac의 COMMAND 키 또는 Windows의 ALT 키를 누르면 다음과 같은 상태로 전환됩니다.

  • 전체 추정 켜기
  • 전체 추정 끄기
  • 평행 및 직각만

전체 추정 켜기

이것은 기본 동작이며 버전 1 이후 SketchUp에서도 지원되었던 것입니다. 선 툴은 빨강, 녹색 및 파랑 축과 자홍색 축(지정된 가장자리에 평행/수직으로)에 스냅됩니다.

전체 추정 끄기

이 상태에서 선 툴은 모든 선형 추정을 무시합니다. 가장자리 세그먼트를 완성하면 커서가 화면에서 더 자유롭게 움직이는 것을 볼 수 있습니다. 면 접촉, 안내 지점, 중간점 등과 같은 다른 추정 유형도 찾을 수 있습니다. 이러한 여러 추정 유형을 사용하여 원하는 평면에 선을 그릴 수 있습니다.

평행 및 직각만

이 상태는 선 툴을 사용할 때 평행 및 수직 선형 추정 만 표시합니다. 이 옵션을 선택하면 다른 선형 추정에 방해받지 않고도 다른 형상과 평행하거나 수직인지 확인하면서 선을 그릴 수 있습니다.

키보드로 추정 잠그기

추정을 잠그면 그리려는 방향을 따라 확실히 그릴 수 있습니다. 추정을 잠그는 또 다른 이유는 모델의 다른 부분에 있는 형상을 참조하는 동시에 일정한 그리기 방향을 유지하기 위함입니다. 이는 더 고급 방식의 동작으로, 매우 유용합니다. 추정을 기본 좌표축 방향으로 잠그는 가장 쉬운 방법은 화살표 키를 사용하는 것입니다.

>

화살표 키로 그리기 방향 잠그기
모양
그리기 방향 또는 그리기 평면을 파란색 축에 잠급니다.
그리기 방향 또는 그리기 평면을 녹색 축에 잠급니다.
그리기 방향 또는 그리기 평면을 빨간색 축에 잠급니다. 왼쪽에서 오른쪽 방향을 기억하는 좋은 방법은 "오른쪽 잠금 빨간색"이라고 외우는 것입니다.
평행/수직 그리기 방향 또는 그리기 평면을 추정된 모서리 또는 평면에 잠그려면 전환합니다. 기본적으로 자홍색으로 변하는 모든 것입니다. 추정되는 면의 가장자리뿐만 아니라 그리기 방향도 자홍색으로 변합니다.
Shift 그리기 방향 또는 그리기 평면을 활성 그리기 방향/평면으로 잠급니다. 따라서 파란색 축을 따라 그리는 경우 Shift 키를 누르면 파란색 추정이 잠깁니다.
Shift+Alt(Windows) 또는 Shift + Command(MacOS) Shift 키를 누른 채 그리기 평면을 잠그면 툴이 추정되는 것과 동일한 평면에 잠깁니다. 그러나 회전 및 각도기 툴의 경우 Alt 키(Microsoft Windows) 또는 Command 키(madOS)를 눌러 해당 툴을 해제하면 동일한 그리기 평면을 유지하면서 모델 내에서 다른 위치로 중심을 이동할 수 있습니다.

원 및 회전 툴과 같은 일부 툴은 아래와 같이 평면(그리기 방향 대신)에 잠길 수 있습니다. 이러한 툴의 경우 툴의 축 또는 "정상"에 대한 색상으로 표시된 방향을 선택하여 그리기 평면을 잠글 수 있습니다.

화살표 키로 그리기 평면 잠그기

가장자리가 축과 정렬되었는지 확인하기

가장자리를 축에 정렬하려면 커서를 축 색상으로 변경하는 것이 유용할 수 있습니다. 또는 기존 형상의 정렬을 확인해야 하는 경우 가장자리를 축 색상으로 변경합니다.

커서를 축 색상으로 변경하려면 다음 단계를 따르십시오.

  • Window > 기본 설정(Microsoft Windows) 또는 SketchUp > 기본 설정(MacOS)을 선택합니다. SketchUp 기본 설정" 대화 상자가 나타납니다.
  • 왼쪽에서 그리기 항목을 선택합니다.
  • 그리기 패널의 기타 영역에서 십자선 표시 확인란을 선택합니다.
  • 확인을 클릭하여 SketchUp 기본 설정 대화 상자를 닫습니다. 여기에 표시된 대로, 커서가 축의 색상대로 십자선을 표시합니다.

모델의 가장자리가 정렬된 축 색상을 반영하도록 하려면 다음 단계를 수행하십시오.

  1. Window > 스타일을 선택합니다.
  2. 스타일 대화 상자의 스타일 라이브러리 드롭다운 목록에서 모델을 선택합니다.
  3. 편집 탭을 클릭합니다.
  4. 그림에 표시된 대로 가장자리 설정 아이콘을 클릭합니다.
  5. 색상 드롭다운 목록에서 축 기준을 선택합니다. 모델의 가장자리 색상은 축에 대한 맞춤을 반영하도록 변경됩니다(가장자리가 축에 정렬되지 않은 경우에는 가장자리 색상이 변경되지 않습니다). 다음 그림은 세 축에 정렬된(및 정렬되지 않은) 가장자리를 보여줍니다.