ジオメトリを選択する

[選択] ツール([選択] ツール)では、SketchUp の他のツールやコマンドの適用対象となるエンティティを指定します。線の長さを変更する場合は、まず線を選択します。ボックスを拡大/縮小する場合は、まずそのボックスを選択します。線とボックスを移動させる場合は、両方を選択し、選択セットと呼ばれるものを作成します。

[選択] ツールは次の場所にあります。

  • 基本ツールバー(下図)、ラージツールセットツールバー、主要ツールバー(Microsoft Windows)
  • ツールパレット(macOS)
  • ツールメニュー

基本ツールバー

ヒント: [選択] ツールは SketchUp の 3D モデリングにとって非常に重要であるため、[選択] ツールには簡単なキーボードショートカットが設定されています。スペースバーを押すだけで、[選択] ツールがアクティブになります。

単一のエンティティを選択する

単一のエンティティを選択するには、以下の手順で操作します。

  1. [選択] ツール([選択] ツール)をアクティブ化します。ポインタの形が矢印に変わります。
  2. エンティティをクリックします。以下に示すソファーのクッションのように、選択したもの(エッジ、面、コンポーネントなど)が強調表示されます。
クッションが選択されました

正しいものが選択されない場合は、もう一度お試しください。選択を解除する場合は、描画ウィンドウの空白部分をクリックします。

複数のエンティティを選択する

複数のものを選択する必要がある場合、SketchUp はいくつかのオプションを提供しています。ビデオを見て、これらのオプションがどのように動作するかを確認し、複雑な選択を迅速かつ簡単に行うためのコツを身に付けてください。複数のエンティティを選択する方法を確認する場合は、このまま読み進めてください。

ヒント: アクティブなツールに関係なく、メニューバーから [編集] > [すべて選択] を選択するか、Ctrl+A(Microsoft Windows)または Command+A(macOS)を押すことで、モデル内のすべてのものを選択できます。
選択を解除する場合は、[編集] > [すべて選択解除] を選択するか、Ctrl+T(Microsoft Windows)または Shift+Command+A(macOS)を押すか、描画エリアの空白部分をクリックします。

[選択] ツールがアクティブな場合、以下のいずれかの方法で複数のエンティティを選択できます。

  • クリックアンドドラッグで選択ボックスを作成します。[選択] ツールがアクティブな場合、クリックアンドドラッグで、選択したいアイテム周辺に一時ボックスを作成します。マウスボタンを離すと、アイテムが選択されます。クリックして左にドラッグ(交差選択)すると、ボックス内に完全または部分的に表示されているものが選択されます。クリックして右にドラッグ(下図のウィンドウ選択)すると、ボックス内に完全に表示されているもののみが選択されます。たとえば、赤いクッションが 1 つだけ選択されている(2 つ目の赤いクッションが部分的にウィンドウ選択ボックスの内側にあっても) ことに注目してください。

    ウィンドウ選択
  • ダブルクリックまたはトリプルクリックします。クリックしたものに応じて、エッジと面の組み合わせを選択できます。以下の表にオプションの概要を示します。
    操作 選択されるもの
    面をダブルクリック面とその周りのすべてのエッジ(1)
    エッジをダブルクリックエッジとそのエッジに連結された面(2)
    エンティティをトリプルクリックすべての接続されたエンティティ。たとえば、立方体の 1 つの面をトリプルクリックすると、立方体全体が選択されます。(3)

    面またはエッジをダブルクリックします。エンティティをトリプルクリックして選択します。
  • エッジを右クリックします。エッジを右クリックすると、以下のオプションを含むコンテキストメニューが表示されます。
    • [選択] > [接続面] では、選択されているエンティティに連結されているすべての面が選択されます。
    • [選択] > [接続するものすべて] では、選択されているエンティティに連結されているすべてのエンティティが選択されます(結果はエンティティをトリプルクリックするのと同じです)。
    • [選択] > [同一レイヤ上のものすべて] では、選択されているエンティティと同じレイヤ上にあるエンティティがすべて選択されます。モデルにレイヤが含まれていない場合、結果はトリプルクリックするのと同じです。
  • 面を右クリックします。面を右クリックすると、エッジを右クリックするときに表示されるすべてのオプションと、以下の 2 つのオプションを含むコンテキストメニューが表示されます。
    • [選択] > [境界エッジ] では、選択された面の周りのすべてのエッジが選択されます。
    • [選択] > [同一マテリアルのものすべて] では、選択されている面と同じマテリアルを使っているすべてのエンティティが選択されます。たとえば、レンガのマテリアルや赤色の塗料が塗られている面をすべて選択し、そのマテリアルを別のものに変更する場合は、この方法を使用するとすばやく簡単に実行できます。

選択セットを追加および削除する

複数のエンティティを選択する場合、不要なエンティティを選択してしまったり、必要なエンティティが選択できなかったりすることがよくあります。選択セットにエンティティを追加したり、選択セットからエンティティを削除したりするには、[選択] ツールがアクティブであることを確認し、以下の表の修飾キーを使用して、選択範囲を調整します。たとえば、以下のように赤いクッションを両方選択するには、1 つのクッションを選択し、Ctrl キーを押しながらもう 1 つのクッションを選択します。

2 つのエンティティが選択されました。

ヒント: 修飾キーをアクティブにすると、[選択] ツールのカーソルで、矢印の隣にプラスまたはマイナス記号(修飾キーが選択された場合の [選択] ツールカーソル)が表示されます。
目的 押したままにするキー 同時に行うこと
選択セットにエンティティを 1 つずつ追加する Ctrl(Microsoft Windows)または Option(macOS) 選択されていないエンティティをクリックする
エンティティの選択状態を変更する(選択されていないエンティティを選択する、または選択されているエンティティをクリアする)Shift エンティティをクリックする
選択セットから削除する Shift+Ctrl(Microsoft Windows)または Shift+Option(macOS) 選択されているエンティティをクリックする

ヒント: 同じグループのアイテムをすばやく再選択する一時的な方法が必要な場合は、選択範囲をグループ化します。グループの作成の詳細については、「モデルの編成」を参照してください。

選択範囲を反転する

選択範囲を反転すると、木から葉を削除するような複雑な編集を簡単にすることができます。この例では、幹と枝を選択し、選択範囲を反転することですべての葉を選択するとします。

選択範囲を反転するには、まず選択し、Ctrl+Shift+I を押します。

選択範囲を反転するには、まず選択し、Command+Shift+I を押します。

あるいは、メニューバーから [編集] > [選択範囲を反転] を選択します。