描画の基本と概念の紹介

3Dでのモデルの描画は、2Dでのイメージの描画とは異なります。この描画の基本と概念の紹介では、エッジと面 (SketchUpモデルの基本エンティティ) を作成する方法をいくつか説明します。また、SketchUpの推定エンジンを使用して、目的の軸上にこれらの線と面を配置する方法についても説明します。

ヒント:基本的な [図形] ツールでは、細い実線が使用されます。破線を作成するには、破線をレイヤに適用するを参照してください。

線を描画する

線ツールを使用して、エッジ (線エンティティとも呼ばれます) を描画します。エッジは、すべてのモデルの構造基盤を形成します。線を描く方法は次のとおりです。

  1. ツールバーの [線] ツール () を選択するか、Lキーを押します。ポインタの形が鉛筆に変わります。
  2. クリックして線の始点を設定します。間違った場所をクリックした場合は、Escキーを押して最初からやり直します。描画領域の上でカーソルを移動すると、次のようになります。
    • カーソルに沿って線が表示されます。
    • 線の長さは、[測定] ボックスに動的に表示されます。([測定] ボックスには、テンプレートで指定されている単位が使用されます。)
    • カーソルが描く線は、赤、緑、青の軸と平行になるたびに、赤、緑、青に変わります。しばらくカーソルを置いていると、図に示す青軸上ヒントのような画面ヒントが表示されます。これはゴーストではなくSketchUpの推定エンジンで、詳細についてはこの記事の後半で説明します。
  3. クリックして線の終点を設定します。この終点は、別の線の始点にすることもできます。線の描画が終わったら、Escキーを押すか、別のツールを選択します。終点を設定したら、Ctrl + Z (Microsoft Windows) またはCommand + Z (macOS) を押して、線を元に戻し、最初からやり直すことができます。

  4. (オプション) 線を正確な長さにするには、値を入力してEnterキー (Microsoft Windows) またはReturnキー (macOS) を押します。このプロセスは、新しい線を描画するか、別のツールを選択するまで、何度でも繰り返すことができます。単位を指定しない場合、SketchUpはテンプレートで指定された単位を使用します。ただし、線は任意のインチまたはメートル単位で入力できます。たとえば、3mmまたは5'2”などと入力できます。入力した値は、[測定] ボックスに表示されます。

注:[測定] ボックスには、線の3D座標も入力できます。
  • [3’, 5’, 7’] などの絶対座標は、現在の軸を基準にして線の終点を配置します。角括弧は絶対座標を表します。
  • <1.5m, 4m, 2.75m> などの相対座標は、線の始点を基準にして線の終点を配置します。山括弧は相対座標を表します。

面の境界でなければ、線の長さを編集できます。線の編集方法は次のとおりです。

  1. 移動ツールを選択します ()。
  2. [移動] ツールカーソルを線の終点の1つに合わせます。
  3. 終点をクリックしてドラッグし、線の長さを変更します。

ヒント:[エンティティ情報] ダイアログボックスで長さを調整することもできます。線を右クリックし、表示されるメニューから [エンティティ情報] を選択します。[長さ] ボックスに、新しい線の長さを入力します。

面を作成する

複数の線をつなげて1つの図形にすると、それらの線が1つの面を形成します。

面白い顔、怖いピエロの顔、またはかわいい子犬の顔でもありません。既定では面は無地ですが、面は非常に重要です。エッジと面というコンビの片方であり、SketchUpで作成されたすべてのモデルの存在を可能にしています。

ヒント:既定では、SketchUpはここに示されているように、いくつかの面にシェーディングを追加し、その面は不透明になっています。これにより、モデルには実際の壁や床など、面を3Dモデルで表現できるあらゆるものが含まれていることがわかります。(ただし、SketchUpには、スーパーマンのように壁を透視できるビューが含まれています。詳細については、モデルの表示を参照してください。)

[図形] ツール (長方形、円、多角形) も面を作成します。(これらのツールの詳細については、基本図形の描画を参照してください)。

面を分割する

既存の面に線 (または曲線) を描画すると、面が分割されます。

ヒント:ここに示すように、面を分割した後、[プッシュ/プル] ツールを使用して、他の部分を置いたまま、面の一部を押したり引いたりできるため、この概念は重要です。[プッシュ/プル] ツールの詳細については、形状を3Dにプッシュ/プルするを参照してください。

エッジと面を消去して3D形状を開く

エッジまたは面を消去して、形状の開口部を作成できます。エッジの消去がモデルにどのように影響するかを確認するには、最初にツールバーの [消しゴム] ツール () を選択するか、Eキーを押してから、エッジをクリックします。

  • エッジをクリックすると、そのエッジとそのエッジに接しているすべての面が消去されます。面のない線が表示されます (ビリー・アイドルの歌にも、似たようなタイトルの曲がありましたね)。ただし、面は完全にエッジで囲まれていなければなりません。
  • 面を右クリックし、[消去] を選択すると、面のみが削除されます。

図は、元の立方体と、エッジや面を消すことで立方体がどのように変化するかを示しています。

ヒント:線を消去する代わりに非表示にするには、Shiftキーを押しながら消しゴムで線をクリックします。または、線を右クリックし、[非表示] を選択します。

削除された面を修復する

誤って面を削除してしまった場合、その面を元に戻す方法は次のとおりです。

  • 保持したい変更を他に行っていない場合は、メニューバーから [編集] > [元に戻す] を選択するだけです。または、「元に戻す」のキーボードショートカット、Ctrl + Z (Microsoft Windows) またはCommand + Z (macOS) を押します。
  • 面が非表示になった線を再描画すると、SketchUpによって面が再作成されます。

推定を見つけてロックする

SketchUpには、3D空間での作業に役立つ推定エンジンがあります。たとえば、[線] ツールのカーソルを別の線の中点に置くと、ここで示されているように、推定エンジンは、水色のドットと「中点」という画面ヒントを表示して通知します。すべての推定には独自の色と画面ヒントがあります。(完全なリストについては、推定の種類を知るを参照してください )。

推定エンジンは、線の間の幾何学的関係を見つけるのにも役立ちます。たとえば、描画している線が別の線に対して垂直である場合に通知します。次の図では、線の始点にも色のついた点が表示されているため、いくつかの情報を一度に得ることができます。

警告:推定エンジンと軌道に細心の注意を払い、さまざまな視点から描画を確認してください。次の図では、別のビューに軌道を変更するまで、線が赤と緑の平面上に表示されています。このよくある落とし穴を避けるために、SketchUpでは、これらの軸に平行なエッジや平面を作成するときに、描画方向や描画平面を赤、緑、青に変えています (モデルのエッジや面に平行/垂直な場合はマゼンタになります)。

ヒント:場合によっては、必要な推定がすぐに表示されなかったり、SketchUpが間違ったジオメトリの位置揃えを選択したりすることがあります。このような場合、SketchUpで推定したい場所にマウスカーソルを置くことで、推定を促したり、特定の位置揃えがうまくいく可能性を高めたりすることができます。視覚的な合図が表示される場合、SketchUpは描画を続行する際に、その位置揃えを一時的に優先します。

線形推定の切り替え

新機能! - SketchUp 2020.2

推定はSketchUpの基本機能であり、ほとんどのツールが何らかの形で推定に依存しています。ただし、特にモデルの込み入った領域で作業している時など、推定が邪魔になることがあります。[線] ツールを使用すると、単純な変更アクションを使用して線形推定をオフにしたり、オンに戻したりできます。

[線] ツールで線形推定を切り替えるには、線の描画を開始するために1回クリックする必要があります。線を開始したら、クリックして終了する前に、Macの場合はCOMMANDキーを、Windowsの場合はALTキーを押すだけで、次の状態が切り替わります。

  • すべての推定をオン
  • すべての推定をオフ
  • 平行および垂線のみ

すべての推定をオン

これは既定の動作であり、バージョン1以降のSketchUpで経験しているはずです。[線] ツールは、赤、緑、青の軸、およびマゼンタの軸 (指定したエッジに対して平行/垂直) にスナップします。

すべての推定をオフ

この状態では、[線] ツールはすべての線形推定を無視します。エッジセグメントを完成させると、カーソルが画面上でより自由に動くようになることがわかります。面上、ガイドポイント、中点など、他の推定タイプもあります。これらの他の推定タイプを使用して、線が目的の平面上に描画されるようにします。

平行および垂線のみ

この状態では、[線] ツールを使用するときに、平行および垂直な線形推定のみが表示されます。このオプションを選択すると、線を他のジオメトリに対して平行または垂直に描画できます。また、線を横取りしようとする他の線形推定に気を取られることなく、線を描画できます。

キーボードで推定をロックする

推定をロックすることで、描画する方向に沿って自信を持って描画できます。推定をロックするもう1つの理由は、モデルの別の部分からジオメトリを参照している間、1つの描画方向を維持できることです。これはより高度な技ですが、とても役に立ちます。推定を既定の軸方向にロックする最も簡単な方法は、矢印キーを使うことです。

>

矢印キーで描画方向をロックする

キー 特徴
描画方向または描画平面を青の軸にロックします
描画方向または描画平面を緑の軸にロックします
描画方向または描画平面を赤の軸にロックします。「右が赤」と覚えてください。
切り替えて、平行/垂直な描画方向または描画平面を推定したエッジまたは平面にロックします。基本的に、マゼンタになるものなら何でも切り替えることができます。描画方向がマゼンタ色になり、推定している面のエッジもマゼンタ色になります。
Shift 描画方向または描画平面を、アクティブな描画方向/平面にロックします。したがって、青の軸に沿って描画している状態でShiftキーを押すと、青の推定がロックされます。
Shift+Alt (Microsoft Windows) または Shift+Command (macOS) Shiftキーを押しながら描画平面をロックすると、ツールも推定された同じ面の平面にロックされます。ただし、[回転] ツールと [分度器] ツールの場合は、Altキー (Microsoft Windows) またはCommandキー (macOS) を押してツールを解放し、同じ描画平面を維持したまま中心をモデル内の別の場所に移動できます。

[円] ツールや [回転] ツールなどの一部のツールは、下図のように (描画方向ではなく) 平面にロックできます。これらのツールでは、ツールの軸または「法線」の色の付いた方向を選択して、描画平面をロックできます。

矢印キーで描画平面をロックする

エッジが軸に位置揃えされていることを確認する

エッジを軸と揃えるには、カーソルを軸の色に変更すると便利です。または、既存のジオメトリの位置揃えを確認する必要がある場合は、エッジを軸の色に変更します。

カーソルを軸の色に変更するには、以下の手順を実行します。

  • [ウィンドウ] メニューの [環境設定] (Microsoft Windows) または [SketchUp] メニューの [環境設定] (macOS) を選択します。[SketchUpシステム環境設定] ダイアログボックスが表示されます。
  • 左側の [描画] 項目を選択します。
  • [描画] パネルの [その他] 領域で、[十字線を表示] チェックボックスをオンにします。
  • [OK] をクリックして [SketchUpシステム環境設定] ダイアログボックスを閉じます。ここに示すように、カーソルには、軸の色と同じ十字線が表示されます。

モデルのエッジに位置揃えの軸の色を反映させるには、次の手順に従います。

  1. [ウィンドウ] > [スタイル] を選択します。
  2. [スタイル] ダイアログボックスで、スタイルライブラリのドロップダウンリストから [モデル内] を選択します。
  3. [編集] タブをクリックします。
  4. 図に示すように、[エッジ設定] アイコンをクリックします。
  5. [色] ドロップダウンリストから [軸別] を選択します。モデル内のエッジの色は、軸への位置揃えを反映するように変更されます (ただし、エッジが軸に位置揃えされていない場合、エッジの色は変化しません)。次の図は、どのエッジが3つの軸に位置揃えされている (位置揃えされていない) かを示しています。