Release Notes

SketchUp Desktop 2020.1.1

Released: May 27th, 2020

Version
20.1.235 (Win 64-bit)

LayOut Release Notes

  • This is a Windows only update to fix a frequent crash that occurred with users on the positive side of the UTC time standard (for example UTC+01:00). This crash would occur due to an error encountered when converting some local times to UTC when reloading a SketchUp file then saving.
SketchUp Desktop 2020.1

Released: April 30th, 2020

Version:
20.1.229 (Win 64-bit)
20.1.228 (Mac 64-bit)

Table of Contents

  1. What's New in SketchUp 2020.1?
  2. Improvements in LayOut
  3. SketchUp Release Notes
  4. LayOut Release Notes
  5. SketchUp Desktop Viewer Release
  6. SketchUp/LayOut API Release Notes

What's New in SketchUp 2020.1?

As we've said in the past, we take feedback from our users seriously. That's why we are excited to announce our 2020.1 release. For this release, we gathered some of your feedback and polished up existing features with exciting additions and improvements that will have your workflow beaming with pride. Explore all the greatness below.

Freshening up SketchUp Pro

Scenes Panel

Now that you have better toggling visibility with hidden geometry and objects, we decided to take it a step further. We split up hidden geometry and objects so you can save them separately on a Scene-by-Scene basis. You will see a new checkbox in the Scenes panel that lets you save the visibility state of hidden objects. This gives you better visibility control per Scene.

Section Planes & Scenes

Keeping with the Scene theme, you can now save Section Plane visibility per Scene. Why? Since Section Planes are grouped with objects, we want to make sure they behave like objects in terms of visibility per Scene. Before this change, only top-level visibility for Section Planes could be saved per Scene. Again, more control in your Scenes — and consistency. Winning!

Hidden Objects are now Editable

Good news...hidden objects are now editable. What does this mean, you ask? When you select a hidden object in the Outliner, instead of completely disappearing when you try to edit your object, it will appear as a mesh so you can more easily make edits. So keep on keeping on without any hinders to your editing workflow.

Improvements to Grips

A small, but powerful feature: you can now use the Rotate tool when toggling through ALL Grips — just like the Move tool! This provides more consistency between the tools so you can stay focused on your project.

Empty Objects

Picture this: you are working up a new table design and quickly add a lamp to make it look more realistic — but you run into an issue! You did it too fast and forgot to group your lamp and table separately. Because of this, everything is glued together as one, creating editing issues galore and wasted time. Fear no more! Now, you can right-click on an empty space and make a grouped object or component from scratch. No more triple-clicking, or drawing it elsewhere just to place it where you want it. And, an added bonus! When you create a new object from scratch, a window will pop up allowing you to name it right from the start. Say hello to better model organization from the very start of your project. Talk about speeding up your workflow!

Improvements in LayOut

Performance Improvements

For this release, we focused on improving LayOut's selection and deletion capabilities---they're now much faster! And don't worry: we're still committed to even more performance improvements in future releases.

But, that's not all… we also made some slick improvements to the Select Tool.

Improved Select Tool

The Select Tool just got some major love. We wanted to help you make intentional - not accidental - moves with your crossing and window selection workflows. Now, when you click-drag to create a crossing or window selection, you won't mistakenly move anything! Previously, you may have accidentally moved an object when you really just wanted to change your selection. Now you're more likely to get the result you wanted. Also, selections and moves now occur when clicking on the actual object as opposed to the object's bounding box, strengthening that intentional workflow.

If you're now wondering, "how do I move an object?" - no worries, we got you covered. Just pre-select an entity and move from there.

SketchUp Release Notes

Installers

  • To support Mac notarization requirements, the SketchUp installer is now being distributed as a .zip file instead of .dmg.To use this, after downloading the installer double-click the .zip file in Finder to extract the installer .app file.Next, double-click the .app file to launch the installer.

Bug fixes / small features added

Stability

  • Fixed an issue where reloading a component and then saving the reloaded component under a different name would cause a crash and would corrupt the saved component file.
  • Fixed a crash that could occur when changing from Share Component to Share Model and then uploading a model to 3D Warehouse.
  • Fixed an issue where StyleBuilder would sometimes crash when closing the EULA dialog.
  • Fixed an issue where the Move/Copy tool using 'From Point' or 'rotate grip' caused SketchUp to crash when hovering on the copied component and changing the distance.
  • (Mac) Fixed an issue where SketchUp would crash when resetting the workspace when the Tags or Fog dialogs were open.
  • (Mac) Fixed an issue where some Export Options dialogs would cause 100% CPU utilization.
  • (Mac) Fixed an issue where clicking in a blank portion of Outliner would sometimes cause a crash.
  • (Mac) Fixed an issue where the offline version of the installer would fail to install an L10n language when an Internet connection could not be made to the download server, even though the user chose to "Install Anyway."

Grips on bounding boxes and automatic transparency

  • Changed the key that cycles through grip types from the Down arrow key to 'Alt' on the PC and 'Command' on the Mac.
  • Fixed an issue where an obscured point on a component behind a section plane would unexpectedly become transparent.
  • Fixed an issue where geometry could display unexpected transparency on Move/Copy when moving copied geometry around the model.
  • Fixed an issue with Rotation tool when an ‘Active point' was obscured and transparency did not engage.
  • Fixed an issue where the Move tool rotate grips could not always be easily found due to favoring grips.
  • Fixed an issue where lines could disappear when moving a component via grips when "Use sun for shading" was turned on.
  • Fixed an issue where unexpected transparency could occur when hovering over grips with the Move and Rotate Tools in some models with Parallel Projection.
  • Fixed an issue where the Icon for an obscured grip displayed incorrectly for a component or group.
  • Fixed an issue where the origin inference did not display for some components.
  • (Mac) Fixed an issue where geometry could become unexpectedly transparent when inserting a library component from the Components browser.

Visibility

  • Improved the style thumbnail to reflect that hidden objects are activated.
  • Fixed an issue where copying and pasting hidden subcomponents in scenes would cause the pasted hidden subcomponents to become visible.
  • Fixed an issue where deeply nested hidden subcomponents could become visible after importing them.
  • Changed the wording of Hidden Geometry menu items under the View menu.
  • Fixed a geometry visibility issue with tags and root geometry where every tag has visible Top-Level Geometry and the Level 0 tag is in the hide state with flag View>Hidden Geometry on.

Outliner

  • Fixed an issue preventing a visibility change of multiple selected objects.
  • Fixed an issue in Outliner where clicking a visible subcomponent wouldn't show its hidden geometry as visible if its top parent component was hidden.
  • (Win) Fixed an issue preventing a multi-select in the Outliner if the Shift key was depressed before a selection was made.

Miscellaneous

  • Fixed an issue where the Area and Volume Display Precision fields did not display the comma separator.
  • Fixed an issue on the Scenes panel where the tooltips associated with checkbox labels for scene update properties were inaccurate.
  • Fixed an issue where the "Edit > Make Component" menu was not enabled when a group was selected.
  • Fixed an issue where the Make Component button was not always enabled when a group was selected.
  • Fixed inconsistent behavior when pressing a shortcut for Make Component with a component selected.
  • Improved the Welcome Window warning message when license files are copied to another machine.
  • Fixed an issue where an intersecting line drawn through a polygon caused the offset tool to improperly draw the offset.
  • Fixed an issue on the Welcome Window where the Unit type was not localized.
  • Made a change to remove empty components when saving a model as they can cause crashes and other bad behaviors.
  • Changed a reference from Layers to Tags in the Merge With Hidden warning.
  • Fixed an issue where the Undo menu item was titled Undo Edit Material instead of Undo Tags.
  • Fixed an automated sign-in message box so it does not fall behind the main application window.
  • Modified the workflow of the Welcome Window to prevent the possibility of getting stuck on the licensing page when using the Manage License button.
  • Fixed an issue where the automatic sign out event would take the user to the browser sign in page instead of the Welcome Window sign in page.
  • Added a trials troubleshooting link to the Your 30-day Trial Is Over screen.
  • Fixed an issue where the saving a component would orient the camera in the saved component file to always be a top view.
  • Fixed several issues with incorrect or missing localized language translations.
  • Fixed several problems that could occur when upgrading to a new version of SketchUp.
  • Fixed an issue where the text orientation on dimensions was not correct when exporting to 3D DWG.
  • (Win) Fixed an issue where the sort order of the Visible column was incorrect in the Tags dialog.
  • (Win) Fixed an issue where the "Make Component" shortcut did not work when a group was selected.
  • (Win) Fixed an issue where the Match Photo dialog was cut off on high resolution displays.
  • (Win) Fixed an issue where the Scenes browser could not be resized in List view.
  • (Win) Fixed an issue where the text for Default Tray was not being translated.
  • (Win) Fixed an issue where the Tags dialog would re-populate and re-draw slowly.
  • (Win) Fixed an issue where the Tags toolbar text would become truncated when using High DPI monitors.
  • (Mac) Fixed an issue where users could not view or edit sketchy edge settings in the Styles browser.
  • (Mac) Fixed an issue where the default menu keyboard shortcuts for 'Make Group' and 'Make Component' behaved incorrectly when a group was selected.
  • (Mac) Fixed an issue to ensure the Options dialog at the bottom of the Import dialog is displayed by default.
  • (Mac) Fixed an issue where changes to the Tags toolbar were not being applied to the selected entity.
  • (Mac) Fixed an issue where changes made in the Tag toolbar were not updated in the Entity Info dialog.
  • (Mac) Fixed an issue where clicking the Open Source Credits button didn't open the credits window.
  • (Mac) Fixed an issue that prevented the full display of 6 digits of precision and the units in the Extruded field.
  • (Mac) Fixed an issue where installing SketchUp with localized languages caused the End User License Agreement dialog to be translated into the first of the localized languages instead of English.
  • (Mac) Fixed an installer problem where translated language names were not sorted correctly on the Selected Languages and Select Languages screens.
  • (Mac) Fixed an installer issue where the Selected Languages screen was not large enough to include all possible languages, and no scroll bar was provided.
  • (Mac) Fixed an issue in (System Preferences/Language & Regions setting/Advanced with Grouping and Decimal) settings did not pass settings appropriately to SketchUp.
  • (Mac) Fixed an issue where DWG Import did not have metric units listed in the Units drop down menu.
  • (Mac) Fixed an issue where Import would unexpectedly switch to Use As Image.
  • (Mac) Improved error reporting for Mac installation failures.

Known Issues

  • (Win) If both SketchUp and the Checkup utility are installed on a system, uninstalling Checkup will prevent SketchUp from running. This problem can be remedied by reinstalling either SketchUp or Checkup.
  • (Mac) If the installer is launched while a previous version of SketchUp is still running, the installer will freeze, even after closing the SketchUp app that was running.
  • (Mac) When the Mac system is set to a non-English language, and some localized languages were previously installed, the SketchUp 2020.1 installer may not always pre-select the correct languages when upgrading from the previous version.

LayOut Release Notes

Bug fixes / small features added

Performance Improvements

  • Selection performance has increased by only populating inspectors after a window or crossing selection has finished.
  • Performance has been increased when deleting entities.

Miscellaneous

  • Fixed an issue where dimension and text arrowheads were larger than expected with inserted SU model on high dpi monitors.
  • Fixed an issue where a "\" (backslash) suffix would display in inspectors when using Decimal Inches on localized versions of LayOut.
  • Fixed an issue linking a SketchUp model to a different SketchUp model would not update the SketchUp model inspector.
  • Fixed an issue where a Raster rendered viewport would not export to .dwg if the viewport or layer was locked.
  • (Win) Fixed an issue where the document setup dialog could get stuck in an open state when adjusting the paper size or margins when using metric units with Russian builds.
  • (Win) Fixed an issue where Zoom to Page would zoom to some arbitrary page size.
  • (Mac) Fixed an issue where exported PDFs sometimes appeared washed out.
  • (Mac) Fixed an issue entering unicode characters into text boxes.
  • (Mac) Fixed an issue where the scale dropdown would display behind other dialogs on the Pattern Fill inspector.
  • (Mac) Fixed the strange artifacts that would show up at certain zoom levels.
  • (Mac) Fixed an issue where certain page numbers would get truncated in the Page inspector.

SketchUp Desktop Viewer Release

  • We are not releasing a 2020.1 version of Viewer on either Windows or Mac. But don't worry! Models created by SketchUp 2020.1 can be viewed with the 2020.0 version of Viewer.

SketchUp/Layout API Release Notes

What's New?

Weld a set of continuous edges functionality was added

This functionality was added to both the C API and the Ruby API.

Bug fixes / small features

  • SketchUp crash reading a SKP file created using SUSceneSetUseRenderingOptions
  • Changed LOImageSetClipMask to allow the clip mask entity to be SU_INVALID, indicating that we will remove any existing clip mask from the image entity
  • Fixed LOImageSetClipMask to return SU_ERROR_UNSUPPORTED instead of SU_ERROR_GENERIC when attempting to use an entity other than an LOPathRef, LORectangleRef, or LOEllipseRef
  • Changed LOSketchUpModelSetClipMask to allow the clip mask entity to be SU_INVALID, indicating that we will remove any existing clip mask from the SketchUpModel entity
  • Added an error code SU_ERROR_NO_DATA to LOConnectionPointCreateFromPID if the persistent id could not be found in the model

C API Additions and Improvements

  • Added SUEntitiesWeld
  • Added SULineStyleGetColor
  • Added SULineStyleSetColor
  • Added SUSceneGetUseHiddenGeometry
  • Added SUSceneGetUseHiddenObjects
  • Added SUSceneSetUseHiddenGeometry
  • Added SUSceneSetUseHiddenObjects
  • Added SULineStyleToEntity
  • Added LOGridSetMajorSpacing
  • Added LOGridSetMinorDivisions
  • Added LOGridSetMajorColor
  • Added LOGridSetMinorColor
  • Added LOGridSetShow
  • Added LOGridSetShowMajor
  • Added LOGridSetShowMinor
  • Added LOGridSetPrint
  • Added LOGridGetInFront
  • Added LOGridSetInFront
  • Added LOGridGetClipToMargins
  • Added LOGridSetClipToMargins
  • Fixed bug in LOLinearDimensionGetDimensionTextCopy where the display text of the copy returned the plain text instead
  • Fixed bug in LOAngularDimensionGetDimensionTextCopy where the display text of the copy returned the plain text instead
  • Added LOSketchUpModelGetCameraModified
  • Added LOSketchUpModelResetCamera
  • Added LOSketchUpModelGetEffectsModified
  • Added LOSketchUpModelResetEffects
  • Added LOSketchUpModelGetStyleModified
  • Added LOSketchUpModelResetStyle
  • Added LOSketchUpModelGetLayersModified
  • Added LOSketchUpModelResetLayers
  • Deprecated SUSceneGetUseHidden
    • Replaced by SUSceneGetUseHiddenGeometry and SUSceneGetUseHiddenObjects
  • Deprecated SuSceneSetUseHidden
    • Replaced by SUSceneSetUseHiddenGeometry and SUSceneSetUseHiddenObjects

Ruby API Additions and Improvements

  • Added Sketchup::Entities#weld
  • Added Sketchup::Page#use_hidden_geometry=
  • Added Sketchup::Page#use_hidden_geometry?
  • Added Sketchup::Page#use_hidden_objects=
  • Added Sketchup::Page#use_hidden_objects?
  • Deprecated Sketchup::Page#use_hidden?
  • Added Layout::Grid#major_spacing=
  • Added Layout::Grid#minor_divisions=
  • Added Layout::Grid#major_color=
  • Added Layout::Grid#minor_color=
  • Added Layout::Grid#show=
  • Added Layout::Grid#show_major=
  • Added Layout::Grid#show_minor=
  • Added Layout::Grid#print=
  • Added Layout::Grid#in_front?
  • Added Layout::Grid#in_front=
  • Added Layout::Grid#clip_to_margins?
  • Added Layout::Grid#clip_to_margins=
  • Fixed bug in Layout::LinearDimension#text where the display text of the copy returned the plain text instead
  • Fixed bug in Layout::AngularDimension#text where the display text of the copy returned the plain text instead
  • Added Layout::SketchUpModel#camera_modified?
  • Added Layout::SketchUpModel#reset_camera
  • Added Layout::SketchUpModel#effects_modified?
  • Added Layout::SketchUpModel#reset_effects
  • Added Layout::SketchUpModel#style_modified?
  • Added Layout::SketchUpModel#reset_style
  • Added Layout::SketchUpModel#layers_modified?
  • Added Layout::SketchUpModel#reset_layers
  • Fixed issues with Layout::SketchUpModel#current_scene and Layout::SketchUpModel#current_scene_modified? Unexpectedly raising an assert stating that "The most recently selected scene no longer exists"
  • Layout::Document#export documentation fixed
  • Layout::SketchUpModel#render documentation fixed
SketchUp Desktop 2020.0.1

Released: February 13th, 2020

Version:
20.0.373 (Win 64-bit)

SketchUp Release Notes

  • This is a Windows only update to fix a frequent crash that occurred when performing an array or any variation of the array on a Component or Group that contained sub-objects with the Outliner open.
SketchUp Desktop 2020.0

Released: January 28th, 2020

Version:
20.0.363 (Win 64-bit)
20.0.362 (Mac 64-bit)

What's New in SketchUp 2020.0?

We've spent a lot of time in 2019 learning more about what you, the user, wish SketchUp did better. We've been eyeing your comments on the forum and discussing ideas during our training events to see what trips up your workflow. So, thanks for speaking up! You helped us discover how you're using SketchUp and how we can improve your design process, resulting in workflow improvements galore! They're so good you'd think we'd been sneaking into design firms or something :).

Now, let's get to the good stuff...

SketchUp Desktop 2020: your [3D] creative space

This year, we focused on data structures and modeling behaviors. We want to make sure we continue to be the more intuitive, easier to use software that boosts your ability to crank out those stunning design projects.

Outliner

This leads us to our BIG model organization change. In an effort to increase model performance, you no longer have to create Layers upon Layers. You can do your main model organization straight within Outliner. We recommend using this (and our friendly eyeball icon) to toggle between the major chunks of your model.

Another bonus: Groups and components that are hidden by tag (formerly known as layers) now show up in the outliner.

Grips on bounding boxes and automatic transparency

Grab that sofa and put it in the corner! Just try it out, we need not explain more.

Selected groups and components now display grips on the bounding box corners, allowing for quick and accurate placement. If you'd rather grab the midpoint, center or centroid of the object, press the down arrow to cycle through the available grip points.

When you grab a point in an object and start to move it, your object will automatically go transparent as soon as something in your model interferes with the object you are moving. This works with both the Rotate tool and Move tool. Fancy, huh? This will literally ‘transform' your workflow. Don't take our word for it: start positioning those objects in hard to reach places to see that SketchUp magic!

Hidden objects

Announcing a big change to hiding objects in your models! You'll notice in your drop-down menu that we decoupled hiding objects from hiding geometry. How will this change your workflow? Well, this will give you the ability to better manage hidden geometry and hidden objects for an even easier modeling experience. For example, let's say you want to edit hidden edges in a landscape or smoothed surface, but you still want to be able to hide objects that are nearby (like trees, bushes, or a building)... yes you can do that in SketchUp! Landscape architects, rejoice!

The SketchUp Universe: Nomenclatures

After many conversations, we decided to update some of our naming conventions. This won't change your workflow, but we want you to know that it's not just you — we are talking about a few things differently now. We think they make logic a little more prevalent.

Objects are now a collective term for: groups, components, dynamic components and Section Planes. This just means we don't have to say "groups (slash) components" anymore. Now you can save those syllables for words like "stupendous" and "dapper" (Why, thank you! We think you are too.). Also, Layers are now referred to as "Tags". 'Layer' has been a rather unintuitive thing to call this organizational utility. Most new users with experience in Photoshop (and LayOut!) are disadvantaged by calling them layers, since it implies a 2D stacking order.

Don't worry these two terms are merely document naming conventions and won't hinder your workflow.

What's New in LayOut 2020.0?

It's all about taking back control...document control that is! For LayOut, we focused on improving the interaction between SketchUp & LayOut to save you time and [brain] energy. Way less going back and forth updating scenes in SketchUp to ensure your drawing comes out perfectly, now you have more editing ability right in LayOut.

Model Views

LayOut now understands a lot more about your SketchUp model and what you've overridden. Meaning, you can safely change a style or camera angle directly in LayOut without accidentally losing your changes (winning!). How do you know what's different in your LayOut viewport versus your SketchUp model, you ask? When you make changes in LayOut, parts of the menu bar will go dark gray, alerting you that you've made an override. Don't worry, just because you made some changes in LayOut, doesn't mean you're stuck with those. You can always resync your viewports back to your SketchUp model if you need to.

Customization

Take those LayOut docs to the next dimension with different models and views. If you have one SketchUp model that exists across several viewports, you can now relink just one of those viewports to another SketchUp model. Previously, you would need to delete that viewport, insert a new SKP model, and reset all your scale settings and viewport sizing. More efficient now? Yes!

And that's not all folks! You also have the ability to toggle tag visibility — straight in your LayOut doc! What does this mean for your workflow? This means you don't have to create extra scenes just for your LayOut files, saving you a ton of time going back and forth between LayOut and SketchUp.

New SketchUp Installers

What's New?

We are now using a different technology to install SketchUp, LayOut, Style Builder, Viewer, and Checkup.

  • If you are online when running the installer, you can now use a single installer file that will download selected languages at the time of installation.
  • If you will be offline when running the installer, you can download the "offline" installer which contains all supported languages.
  • English will be installed by default for everyone.
  • Rerunning the installer will allow you to add or remove languages.
  • To install on macOS, double-click on the large SketchUp icon in the installer dialog box.
Network Administrators can also perform a "silent installation" (similar to the MSI option from previous versions) when adding SketchUp to multiple computers across the network. You can learn more about how to install here.

SketchUp Pro 2020 Installer

  • All SketchUp-supported languages can now be installed using a single installer file, rather than a separate installer for each language.
  • You must be connected to the internet when running this installer for localized languages. Languages selected in the installation dialog will be automatically downloaded and installed (in addition to English).
  • Installation of Czech and Polish can only be done using the "offline" version of the installer.

SketchUp Pro 2020 Offline Installer

  • An offline installer is also available. This is an installation file that contains all languages bundled together, and is a much larger file. After it has been downloaded to your system, it can be used to install, add or remove languages even when you are not connected to the internet.

Known issues with the installers

  • (Win) The installer may fail with a message saying that the "COM Surrogate" application must be closed prior to installing SketchUp. Restart your system to resolve this problem.
  • (Win) Right-clicking on a .skp file may show incorrect "Open with" options if previous versions of SketchUp have been installed on your system.

SketchUp Release Notes

Bug fixes / small features added

Performance

  • Improved the performance of the Components dialog.
  • (Win) Improved performance when opening a file, allowing model interaction much quicker than before.
  • (Win) Improved the performance of the Materials dialog.
  • (Win) Improved the performance of the Tags (formally the Layers dialog).
  • (Win) Improved the performance of the Scenes dialog.
  • (Win) Improved the performance of the Styles dialog.
  • (Win) Improved the performance when opening large models with the Outliner dialog open.
  • (Win) Improved the performance unhiding a group of tags with the Outliner dialog open.
  • (Win) Improved the performance of creating a component in a model containing many components.
  • (Win) Overall performance improvement when editing objects via the Outliner.

Stability

  • Fixed a crash that could occur during DAE export.
  • Fixed an issue where the context menu would become incomplete and unresponsive with certain tools.
  • (Win) Fixed an issue where SketchUp would sometimes hang when moving the Tags tray after making hundreds of scene transitions.

Tools

  • Fixed an issue where you could lose sight of the geometry you are orbiting around in a component with large extents.
  • Fixed an issue where zooming could be too sensitive when zooming inside of a component.
  • Fixed an issue where a concave half circle offset incorrectly.

Outliner

  • Updated the Outliner user interface, adding a visibility icon and removing horizontal and vertical lines.
  • Added the ability to toggle the visibility of Objects.
  • Added the ability to identify the Tags visibility state on Objects.
  • Added the ability to "Show Hidden Tags" via a context menu.
  • Added the ability to rename via a double click on name.
  • (Mac) Changed the selected color in the Outliner hierarchy.
  • (Mac) Fixed an issue where the Outliner content would jump when performing actions via the context menu.

Materials

  • (Win) Fixed an issue where imported materials were duplicated when copied/pasted.
  • (Mac) Fixed an issue where the color of a material in the material browser was always black.
  • (Mac) Fixed an issue where adding transparent material with the Paint Tool duplicated material.
  • (Mac) Fixed an issue where painting with a duplicated material incorrectly applied the original material.
  • (Mac) Fixed an issue where Materials -> Selecting a color did not set the material as active.
  • (Mac) Fixed an issue where copy/paste duplicated materials.

Visibility

  • Separated View > Hidden Objects and View > Hidden Geometry options.
  • Subcomponent and subgroup visibility state is now saved per scene, instead of across all scenes.

Miscellaneous

  • Added new unit types (Yards, Gallons, Liters) and Area and Volume precision fields in the Units section of the Model Info dialog.
  • Fixed an issue where the Fractional dimension unit would display an incorrect unit when greyed out.
  • Updated the colors of the Simple Style used in templates and included in the Default Styles library.
  • Fixed an issue where renaming a scene caused multiple parentheses to be added to the scene name.
  • Fixed an issue where changes to a scene name would not be retained if the user used a mouse-click to navigate to another scene name (instead of using Tab).
  • Changed the insertion point of a component to be more predictable - it is always the component origin.
  • Improved consistency in SketchUp's Export Options dialog titles.
  • Combined the Animation format menu items into one dialog.
  • Removed support for exporting animations in avi, webm, and ogv file formats. The only supported video file format is now mp4. To create lossless animations, export png files and utilize a 3rd party tool to assemble the images into a video.
  • Provided updates to renewal messaging.
  • Fixed an issue that resulted in edges being incorrectly turned off when clicking on a style with a hidden line face style with edges off.
  • Fixed an issue where guides within components could disappear when zooming out.
  • Added a new set of Inference icons.
  • Fixed an issue where the URL for File > Trimble Connect > Launch Trimble Connect was incorrect.
  • Removed the Photo Texture option on the Location toolbar.
  • Added a message to indicate when you have been automatically signed out of your SketchUp account.
  • Fixed an issue where a renamed scene tab was not updated in the Scene details.
  • Corrected a problem where changes to the Model Info Units were not reflected in the Entity Info window.
  • Enlarged the Length field label in the Model Info > Units dialog to prevent translated strings from being truncated.
  • Fixed several incorrect translations in localized languages.
  • (Win) Fixed an issue where a SketchUp 2018 folder was created in the AppData Roaming and Local folders, when SketchUp 2019 was launched.
  • (Win) Fixed an issue where the Line Styles' dashes dropdown was too narrow.
  • (Win) Fixed a SketchUp Checkup issue where it incorrectly reported the current. version of OpenGL when there is an OpenGL requirement error.
  • (Win) Fixed problems that displayed error messages related to the installation of Microsoft Visual C++ 2017 Redistributables.
  • (Mac) Fixed an issue where imported PDFs appeared as black rectangles on macOS Catalina.
  • (Mac) Updated the BugSplat library. As a result, the BugSplat dialog now appears when SketchUp is re-launched after a crash.
  • (Mac) Fixed an issue where SU was incorrectly prompting to open a recovered, auto-save model.
  • (Mac) Fixed an issue where the large and small icon toolsets did not have the same set of tools.
  • (Mac) Fixed an issue when using Color by Tag then changing the Tag color would invoke the Paint Tool.
  • (Mac) Fixed an issue where the Fonts dialog was missing the text alignment buttons.

LayOut Release Notes

Bug fixes / small features added

Miscellaneous

  • Fixed an issue where a raster rendered viewport would require a re-render after exporting to PDF.
  • Fixed an issue when exploding a dimension would display the autotext brackets < > and not the distance value.
  • Added a small feature to support SketchUp's new Area and Volume unit type settings (Yards, Liters and Gallons) in LayOut. When these new units are used in SketchUp and brought over to LayOut, they are now available in the auto-text tag applied to Areas and Volumes.
  • Applied updates to the titles and strings for the LayOut Export Options dialog.
  • Fixed an issue where a black background could appear on Scrapbooks.
  • Added a preference to disable edit mode of a SketchUp Model Viewport.
  • Fixed an issue where strange lines could appear on a PDF export.
  • (Win) Fixed an issue where the document setup dialog could get stuck in an open state when adjusting the paper size or margins when using metric units with Russian builds.
  • (Mac) Fixed an issue where the Undo / Redo and Escape would become disabled after inserting a file in LayOut on macOS Catalina.

SketchUp API Release Notes

What's New?

Improvements were made to the SketchUp C API in multiple areas

  • Implemented the Layers to Tags name change in the APIs
  • Added SUModelIsDrawingElementVisible
  • Added SULayerSet/GetSceneBehavior
  • Added SULengthFormatterGet/SetAreaPrecision
  • Added SULengthFormatterGet/SetVolumePrecision
  • Added SUModelGetEntitiesByPersistentIDs
  • Added SUModelGetLayersByPeristentIDs
  • Added the correct return codes for SUSceneAddLayer and SUSceneRemoveLayer
  • Ensure the header file for SUApplicationGetActiveModel is included in the SDK package
  • (Added SUSceneSetDrawingElementHidden and SUSceneGetDrawingElementHidden to adjust element visibility in scenes.
  • (Win) SUModelSaveToFile updated to handle saving files 2GB and above.

Bug fixes / small features added

  • Fixed an issue where there was a performance bottleneck in SUEntitiesFill
  • Fixed an issue where UV mapping a face via the APIs could fail unexpectedly
  • Added AreaPrecision and VolumePrecision to the OptionsProvider Interface
  • Fixed SketchUpModelImporterInterface::ShowOptionsDialog to return the correct type for the MacOS API. This update was previous done in SketchUp 2019.2, API 7.1 for the Windows API.
  • Adjust page visibility function of drawing elements to match desktop behavior UI in limiting nested elements.

Ruby API Additions and Improvements

  • Added Geom.tesselate that takes a set of loop points and return triangle sets.
  • Added optional :normals parameter to Sketchup::View#draw allowing polygons to be drawn with lighting.
  • Added ability to draw textured polygons with Sketchup::View#draw and Sketchup::View#draw2d
    • Added optional :uvs and :texture parameters to Sketchup::View#draw and Sketchup::View#draw2d.
    • Added Sketchup::View#load_texture.
    • Added Sketchup::View#release_texture.
  • Added ability to vertically align text drawn with Sketchup::View#draw_text. New option parameter:vertical_align can be set to one of the following values: TextVerticalAlignBoundsTop, TextVerticalAlignBaseline, TextVerticalAlignCapHeight or TextVerticalAlignCenter.
  • Added Sketchup::View#text_bounds, returning the bounding box of the area SketchUp uses to draw text using Sketchup::View#draw_text.
  • Added Sketchup::Model#active_path= to allow the API to open an instance path for editing by the user.
  • Added new unit constants:
    • Length::SquareYard
    • Length::CubicYard
    • Length::Liter
    • Length::USGallon
  • Added AreaPrecision and VolumePrecision toSketchup.active_model.options["UnitsOptions"]
  • Additional entity types now return PIDs for Sketchup::Entity#persistent_id:
    • Sketchup::Layer
    • Sketchup::LineStyle
  • Added Sketchup::Layer#display_name - this will return "Untagged" for layer0 while the old layer.name will continue to return "Layer0".
  • Deprecated Sketchup::ComponentDefinition#insertion_point and Sketchup::ComponentDefinition#insertion_point= as this feature was removed in SketchUp. It now returns the origin of the definition and the setter is now a noop.
  • Added an extra return code for SUSceneAddLayer() and SUSceneRemoveLayer().
  • Added Sketchup::Page.get_drawingelement_visibility and Sketchup::Page.set_drawingelement_visibility to pages to adjust element visibility in scenes.

Ruby API Bug Fixes

  • Fixed model validation where it incorrectly flagged some valid UV mapping as invalid and reset it.
  • Fixed an issue where Materials created via the Ruby API would get duplicated when applied
  • (Win) Restored the missing Racc Ruby library
TAGS