Happy Holidays! Trimble is closed November 22nd & 23rd for the Thanksgiving Holiday - We will get back to you as soon as possible after the break, thank you in advance for your patience while we spend this time with our friends and families.

SketchUp best practices and applied principles

Introduction

To help you get started with SketchUp, this article provides practical examples and advice for some of the more common snags that beginners encounter. We start with best practices for drawing efficiently in SketchUp (drawing basics, using inferencing, extruding profiles, push/pull/scale rotate). The second section is dedicated to how you move geometry around your model and what you need to know when selecting your points. The third section gives more information about creating different types of arrays of objects based on whether you need to evenly fill a specific space or achieve a specific spacing. The fourth section walks through different methods to leverage (and when needed, avoid) the stickiness behavior of edges and faces and the fifth section explains how to use existing geometry as efficiently as possible by copying/moving it between other groups, components and also models. Finally there is a summary of the best practices for SketchUp.

Drawing efficiently in SketchUp

Drawing basics

Click on the Pencil tool to select it. Quickly click and release, or “tap”, the left mouse button on the screen (push down on the button and let up) to anchor the starting point of an edge. As you move your mouse cursor on the screen to finish the edge, if the rubber band line at the cursor is parallel with an axes direction (red, green, or blue), the rubber band line takes on the color of that direction. If you draw in any other direction, the rubber band line will show as black. Tap the mouse again to place the edge. This tap - move - tap method of mouse manipulation is the best to adopt for using SketchUp.

Pushing down and letting up on the left mouse button is the best method to use with all of SketchUp’s drawing and editing tools. Do not drag the mouse (press and hold the mouse button down). Dragging the mouse is one of the biggest problems new users encounter when learning how to draw in SketchUp.

The newly drawn edge will now display as black, and the cursor will continue to “chain”, drawing another edge from the last point you clicked. Be aware, if the rubber band line turns blue, you are drawing in the vertical direction and the edge will not be co-planar with edges drawn on the red-green ground plane, hence a surface will not be formed even if you close the loop of edges endpoint to endpoint.

Now draw a line in the blue direction and back down to one of the other points of the base triangle. Connect the top endpoint with the remaining base point, and you have created a prism in 3D space.

Combine inference points with fixed directions when drawing

Inferring in SketchUp allows you to align things without having to perform calculations. Using inference to single points is helpful (green endpoints, cyan midpoints, blue on face, red-X intersections). Power modeling comes when you learn to combine inference points with directions. Use the keyboard arrow keys to lock an inference. The right arrow key locks the cursor in the red direction, the up arrow locks in the blue, the left arrow locks the green, and the down arrow locks parallel and perpendicular.

Another method of inference locking is to hold the Shift key while pausing in the desired direction. To master inference locking, learn to use the Shift key. The Shift lock has the advantage of working in any orientation on any object in the model regardless of its orientation to the red- green- blue directions. As long as the Shift key remains pressed, the inference direction remains locked.To do this, pause the cursor in any direcction or on an edge, and hold down the shift key. The current tool will be locked along that direction. Pause the cursor on a face and hold down the shift key, and the tool will remain locked upon the plane indicated by the face. As long as you continue to hold the shift key the inference stays in focus. The two inferences that are not invoked until you have begun an operation are parallel and perpendicular. They only have meaning when you have already begun an operation that requires a direction from a base point. The parallel and perpendicular color is magenta, and may be locked with shift once you see it indicated on the screen.

Tip: Inferring along a direction back to a face is the way to fix a ‘bent face’ that will not heal into a single face. Here the illustration shows moving the vertex in the blue direction to be coplanar with the other triangle. Use this method to simplify complex triangulation that sometimes occurs with imported CAD geometry.

This can happen with the complex triangulation that sometimes occurs with imported CAD geometry.

A great use of inferring is when you want to draw from an imported 2D image file to create a 3D object. Here, we hover the rectangle tool over the side of the cooling unit and hold Shift to lock to that plane below. Then draw a rectangle using the CAD image above for the reference points. The points are traced on the CAD image, and the inference lock projects them down onto the face. Entire models can be generated using this method. (also from 2D CAD vector files)


 
Extrude a profile along a line with Follow-me

SketchUp does not have a revolve or lathe function. SketchUp accomplishes these tasks with the Follow-me tool. Place an extrude profile perpendicular to a path of edges. Click-drag on the profile face. The geometry to be created is shown as you move the cursor along the path. Let up on the mouse button when you are finished tracing the path and the geometry is added to the model. Follow-me can add geometry to the outside of a form or subtract it from the volume, filleting an edge.

For sweeps based upon closed paths, it is best to pre-select the path with the Select tool. Then pick the Follow-me tool and click the cursor on the profile face. The geometry will be created all at once, swept around the path, and the new geometry will close correctly with no gaps at the start/ end point.

To create a lathed object:

  1. Place a circle normal (perpendicular) to the profile to sweep.
  2. Pre-select the circular path
  3. Click the Follow-me tool on the profile.
  4. The profile is swept around the circle in a closed form.
  5. Here we can see the marked effects of arc and circle segmentation on the model’s polygon count (and hence file size). Be aware that this can quickly hurt a model’s performance.
  6. Decreasing the follow-me path’s circle segmentation, and minimizing the arc segmentation of arcs in the profile significantly reduces the polygon count without compromising the smooth appearance of the finished result.

Things can be quickly optimized in this way by simply reducing arc and circle segmentation. Follow-me creates geometry by first projecting the profile geometry normal to the path. Note that if your profile is not already normal to the path, this process will distort the desired result.

[Pro tip] Aligning Profiles Manually to Paths for Follow-me

You can quickly align profiles to a path using this Align Profile Tool. If you would like to do this manually, you can follow the three step process below to orient a profile normal to a path, regardless of the orientation of the beginning of the path.

Step 1, Align the profile along the first edge of the path:

  1. Make a quick group of the profile and place it at the start of the path.
  2. With the Rotate tool, click-drag the cursor starting from the endpoint of the path and ending at any endpoint on the profile perimeter (let up on the mouse). This orients the protractor perpendicular to the profile face.
  3. Set the base angle of rotation by clicking on any other endpoint of the profile.
  4. Finish the rotation by clicking on the other endpoint of the first edge of the path.
  5. Now the profile lies along the first edge of the path.

Step 2, Align the profile flat to the first path segment:

  1. Still with the profile selected and the Rotate tool, click-drag the cursor starting from the endpoint of the path and ending at the other endpoint of the first path edge. This orients the protractor normal to the first path edge.
  2. Set the base angle of rotation by clicking on an endpoint of the profile face.
  3. Finish the rotate by clicking on the third endpoint along the follow-me path. Now the profile is lying flat to the first path segment.

Step 3, Align the profile normal to the path:

  1. Still with the profile selected and the Rotate tool, Click-drag off the path endpoint and hover the cursor over the path segment
  2. Then move off and find the perpendicular to edge inference and let up. This places the protractor in line with the path edge.
  3. Set the base angle of rotation by clicking on an endpoint on the profile.
  4. Then rotate the profile 90 degrees. The profile is now normal to the path edge.
  5. If you need to, you can now rotate the profile in it’s own plane to orient it correctly, using the move tool’s red spin ticks.
  6. Explode the profile group, and triple click on the path to pre-select it.
  7. Finish the Follow-me along the path.

Tip: The Rotate tool protractor can be oriented normal to the cursor direction by Click-dragging the mouse away from the initial base point. Click-drag means to push down on the left mouse button and continue to hold it down while moving the cursor around on the screen. When you release the mouse button you complete the drag at that point and the protractor is placed 90 degrees to the cursor drag line.
The Push/Pull Scale and Rotate (PSR) method

The Push/Pull Scale and Rotate (PSR) method can be very helpful in modeling organic and complex forms. This method requires good judgement on the part of the modeler when determining the amount of accuracy. The Push pull tool in combination with the scale tool allows quick linear concentric modeling. This method works especially well when you have plan, section, and elevation drawings of the object.

Begin by drawing a profile shape. Then use successive push/ pull operations and scale and/or rotate on the new extruded profile. Notice that the center method was used for the scaling operation (Ctrl modifier [Option key on Mac])

Over the course of several of these iterations the object takes shape. The interior edges have been softened and smoothed with Ctrl-Erase [Option-Erase on Mac]

The profile can be modified at any stage by adding vertices and then adjusting the shape with the Move tool on a vertex. You can also vary the profile by changing the scaling points from center to corner or side . This allows the profile to change asymmetrically over the shape.

Here is an example of modeling a pen using this method. This method is not limited to concentric forms. Much more complex forms can be modeled from a tennis shoe to an automobile.

Moving geometry around your model

The Move tool can be one of the more difficult tools for new users to master. However, understanding a few key points will help remove this difficulty.

Relative vs. absolute moves

There are two types of move operations in 3D modeling, a general (relative) move, and a specific (absolute) move. General move means to shift something in space given very general directions. Think of when you tell someone to “move that drink away from the computer!”. The person can accomplish this without specific directions as to where to grab the cup, nor where or how to place it away from the computer. They just move it away some distance relative to where it was.

Most move operations in 3D modeling are specific or absolute in nature. This means that the modeler specifies an exact point as the start (base) of the move, and an exact point to which the geometry is to be attached or moved (finish point).

Problems usually come when a user tries to combine specific and general behavior in the same move operation. In SketchUp, the only exact known points (points that the user can consistently select) are Endpoints, Midpoints, and Intersection. An On Edge or On Face inference by definition is “somewhere” on the edge or face… and only the computer knows exactly what that point is in model space. Whenever you click the Move tool on an object, the software uses that exact (specific) point as the base point, even if it is unknown to the user. When you click to finish a move on a face, that is an exact point somewhere on the plane, not floating in air above the face.

Note: The start point does not need to be on the object you are moving. For example, you may want to move a window a set distance off the corner of a room.
Select the right start and end points when moving

Many of the SketchUp tools have active selection as part of their behavior. This means that, if nothing is currently selected in the model, the tool will automatically select whatever the tool cursor is touching. But this also means that the click point immediately becomes the base point of the operation. With the Move tool (and Rotate tool) this can be problematic because the base point for a move should usually be a specific, known point.

Consider this common scenario. A user places a tree into their model. Then they want to move the tree, so they click on it with the Move tool, usually up in the leaves somewhere, since this is the biggest target area. Then they move the cursor onto a hillside and click to place it… and the tree becomes a bush. This is because the exact point in the leaves gets placed on the ground, and the trunk sinks beneath the surface. This is the magic disappearing tree trick. A better starting base point would have been to click on the base of the tree trunk where it meets the ground. Then the tree will be placed at the finish point on the ground surface.

When moving sub-components around within a product model, pick endpoints or midpoints for your base move point and you will get consistent results with the move tool.

Tip: Often times the base and finish points are obscured by geometry. In these cases, use of the View > Face Style > X-ray mode can be invaluable.
Using guidelines to improve placement accuracy

Placing Guidelines can help with accurate placement of objects. You can infer to where guidelines and faces intersect. Guidelines help keep concentric assemblies lined up.

When to pre-select edges before moving

Another common situation is when trying to move an edge based upon its endpoint. If the Move tool is auto-selecting raw geometry, it cannot highlight an entire edge while at the same time highlighting a single endpoint. In this chair example, active selecting the endpoint on the arm and moving it causes the arm and side faces to fracture and subdivide (this is autofold behavior, view more about it here).

Pre-select the edges with the Select tool, then use the Move tool to incline the arms downward to the height of the side table. Move the arms down by using the endpoint of the arm as the base point, and infer the finish point to the side table.

Tip: Quite often it helps to pre-select the object(s) to be moved with the Select tool. Then switch to the Move tool to select the base and finish points for the move.
Beware of accidental moves

In SketchUp, a selection of items persists between tools. In other words, picking a new tool does not cause the software to drop the current selection. Nor does completion of an operation drop the current selection. For new users, this persistent selection can result in accidental moves of geometry.

There are two things to be aware of after you move something: first, the objects you have selected remain selected. Secondly, you are still in the move tool. So if you click the mouse again, that starts a new move operation on the same stuff. Do not try to move the cursor back to the same spot and click to put it back… it won’t work. Use the Escape key to interrupt the accidental move operation in progress. Don’t click the Undo button, there is nothing to undo!

Tip: For new users, it is helpful to switch to the Selection tool by hitting the spacebar (shortcut key for the Select tool) after a move operation to protect from accidental moves and mouse clicks.

There are three ways to clear a selection set:

  1. Click the Select tool in empty space to clear any current selection set, even if the set is off screen. Think of it as ‘selecting nothing’.
  2. Right click any tool in white space to clear the current selection.
  3. Ctrl+T on Windows [Shift+Cmd+A on Mac] to clear the current selection.

Interrupting the move command

Another thing to consider is that when you click on an object to move it in a general way, the base point is selected and begins the move operation. If you change your mind about the move, you cannot simply click the mouse back at the starting point. This will not work because you cannot be sure of the exact same point from which you started the move (unless it was an endpoint or midpoint).

The correct method whenever you are in the middle of performing a move operation is to hit the Escape key to interrupt the operation. Do not hit the undo button, because by definition, if you have not finished the operation, there is nothing to undo. In these cases, you will end up undoing your previous work, and if it is off the screen, you won’t even realize it! Always consider Escape before Undo. If you do click the finish point of a move that wasn’t what you wanted, then it’s the right time to use Undo. This is true of all editing and drawing tools in SketchUp.

Creating arrays

Activating the copy option for a tool

There is no specific copy tool in SketchUp. This is because there are several tools that can duplicate geometry, specifically the Move tool, the Rotate tool, and the Push/Pull tool. Because of this variety, things are copied within SketchUp by use of a modifier key while using a tool. Tapping the Ctrl key [Option key on Mac] will put a small plus sign ‘+’ at the tool cursor to let you know you are in copy mode.

With the geometry selected and the tool active, tapping the Ctrl [Option] toggles SketchUp into copy mode for that tool. Tapping Ctrl [Option] again puts the tool back into normal mode. Since this is a toggle, you may invoke it at any time within the operation of the tool.


 

 
Creating arrays of objects

Now that we understand copying, arrays of objects (groups or components) are merely an extension of this concept. The move tool makes linear arrays, and the rotate tool makes circular arrays. There are two types of arrays: external arrays and internal arrays. For external arrays you define the distance between each copy and the number of copies. For internal arrays you define the total distance between the first and last copy and the number of equal divisions in between.

To make an external linear array:

  1. Select the object(s) to array.
  2. Select the move tool and tap the start point of the copy.
  3. Tap Ctrl [Option] and move the copy away to where you want the first copy in the array and tap the mouse button to finish making the copy.
  4. Now type in the number of copies you desire, followed by an ‘x’ and hit Enter [return] (eg. 3x). This means, “copy it three more times”.
  5. At this point, If you want to adjust the distance between the copies, simply type in a distance value and hit Enter [return] and all the copies in the array will immediately be repositioned. If you want to change the number of copies, type in a number followed by ‘x’ and hit Enter [return].

To make an internal linear array:

  1. Select the object(s) to array.
  2. Select the move tool and tap the start point of the copy.
  3. Tap Ctrl [Option] and move the copy away to where you want the last copy in the array and tap the mouse button to finish making the copy.
  4. Now type in the number of equal spaces you want between the copies, followed by the divided by sign ‘/’ and hit Enter [return] (eg. 19/). This means, “divide the distance by 19 equal spaces”.
  5. At this point, If you want to change the number of spaces between the copies, simply type in a number followed by the divided by sign ‘/’ and hit Enter [return] and all the copies in the array will immediately be repositioned. If you want to change the out-to-out distance for the array, type in a distance number and hit Enter [return].

Tip: The key thing to remember when making arrays is: you must finish making the first copy of the object(s) so that SketchUp learns three things from you, 1. what you want arrayed, 2. how far apart you want them, and 3. in what direction you want them from each other.

To make an external circular array:

  1. Select the object(s) to array.
  2. Select the rotate tool and tap the mouse to place the protractor (the anchor point for the rotate).
  3. Tap the mouse for the start baseline for the rotation.
  4. Tap Ctrl [Option] and move the copy away to where you want the first copy in the array and tap the mouse button to finish making the copy.
  5. Now type in the number of copies you desire, followed by an ‘x’ and hit Enter [return] (eg. 3x). This means, “copy it three more times”.
  6. At this point, if you want to adjust the distance between the copies, simply type in a number for the angle between objects and hit Enter [return] and all the copies in the array will immediately be repositioned. If you want to change the number of copies, type in a number followed by ‘x’ and hit Enter [return].

To make an internal circular array:

  1. Select the object(s) to array.
  2. Select the rotate tool and tap the mouse to place the protractor (the anchor point for the rotate).
  3. Tap the mouse for the start baseline for the rotation.
  4. Tap Ctrl [Option] and move the copy away to where you want the last copy in the array and tap the mouse button to finish making the copy.
  5. Now type in the number of equal spaces you want between the copies, followed by the divided by sign ‘/’ and hit Enter [return] (eg. 4/). This means, “divide the arc distance by four equal spaces”.
  6. At this point, if you want to change the spacing between the copies, simply type in a number for the degrees and hit Enter [return] and all the copies in the array will immediately be repositioned. If you want to change the total out-to-out arc distance for the array, type in a number for the degrees in the arc and hit Enter [return].

Tip: For full circle arrays, just drag the copy any distance and place it, then immediately type ‘360’ and hit Enter [return] (this sets it to 360 degrees of arc), then the the number of internal spaces around the circle followed by ‘/’ and hit Enter [return].

Disconnecting and reconnecting geometry affected by stickiness

Interconnectedness of a SketchUp model

The stickiness of geometry in SketchUp often frustrates new users, especially those used to another CAD paradigm. Many times you will want to disengage some geometry from things around it so that editing operations do not affect the adjacent faces and edges.

Tip: The Erase tool only erases (deletes) edges. It will not select nor erase faces. To erase a face, you Right click [context click] on a face and select Erase, or Select the face and press the computer’s Delete key. There are some nuances to deleting connected faces and edges in SketchUp. Let’s look at them.
  1. Erase an edge from a face that is interior to another face ---> the interior face is destroyed (no longer a closed loop of edges) and the remaining edges are left on the face, but not merged to the face.


  2. Right click [context click] on a face and Erase, or Delete, a face from a face that is on (interior to) another face ---> the interior face is deleted, leaving a hole in the surrounding face.


  3. Deleting adjoining faces does not delete the edges surrounding the faces. This means that the common edge(s) between the faces will remain.


  4. Erasing an edge shared by two adjoining faces destroys both closed loops, and thereby both faces are deleted as well.


  5. Double click Select on an interior face, the face and all its edges are selected. Deleting this selection removes the interior face, leaving the surrounding face in-tact with no hole.


  6. Double click Select on a face that is interconnected to several other faces and all its edges are selected. Deleting this selection destroys all connected faces that were sharing those edges.


  7. Double click Select on a face that is interconnected to several other faces, the face and all its edges are selected. First make a Group of the selection. Then Delete the group. All the shared edges remain and all adjoining faces remain.


  8. Move a face that is interconnected to several other faces. All edges of the moved face that are shared with other faces are moved at the same time. This causes all the adjoining faces to be stretched or modified.


  9. To be able to unstick and Move a face that is interconnected to several other faces, first make a Group (or Component) of the desired face. Then that face may be moved independent of the adjoining faces.


Tip: Groups and Components isolate geometry from the rest of the model.
Using groups to isolate geometry

Groups are just like components but, unlike components, a copy of a group does not know about any other copies. That is, they are single instances of an object. Groups do not have definition names like components, and they do not show in the component browser. However, Groups do show in the Outliner. Groups in the outliner are shown with a solid square beside the name, Components are shown with a set of four smaller squares in a grid pattern to show this item is repeatable.

Tip: In general, if you are going to make a copy of a group, first make it into a component, then copy it.

Groups are for gathering geometry into a single object, either temporarily, or for long term use. As shown above, groups can be used to quickly isolate a piece of geometry from the rest of the model. Then edit that new group and make your editing changes, adding edges, moving points and edges, etc. Then close the group edit, and explode the group back to raw geometry. It will merge back with the adjacent geometry only where they share edges. With a little clean up, the changed geometry will be re-connected to the whole model.

Consider this airplane object (1). To Rotate the multiple flaps on the wings, all the adjoining faces of the wings get warped (2) due to the interconnectedness of the model because of autofold . Instead, select all the flaps and make a group of them. (3) Now that group can be rotated independently of the wings. Explode that group, and all the flaps become re-interconnected to the wings wherever their edges are shared.

Let’s look at a more complex example of this.

  1. Select the top surface geometry.
  2. A move stretches everything attached.
  3. Isolate geometry into a group and separate (Move) upwards.
  4. Modify the new group.
  5. Add geometry to the group.
  6. Explode back into the model.
  7. Reconnect to the rest of the model.
  8. Now everything reacts to adjacent geometry as before.

Tip: In step 4 in the preceding example, I could use double clicking on the Push/Pull tool to repeat the last amount of push/pull. For example, given four circles, perform the first push/pull on one of the cylinder faces. Then double click the cursor on any other faces and that amount of push/pull (distance and direction) is repeated for each face.

 

The Offset tool also repeats with a double click.

Paste in Place: a powerful design tool

Copy/move items between groups, components, and models

A corollary to the “group method” shown above, is to move geometry between components, groups, and the main model using Paste in Place. Here is where SketchUp shines. You can really begin to think of your design as very malleable and responsive to your direction.

Consider the table example again. While editing the table top group, we want to copy some other items from the rest of the model.

  1. The table top has been made into a group.
  2. Crossing select the existing spindles and copy to the clipboard (Ctrl+C [Cmd+C]).
  3. Edit into the table top group, and /b . Use View > Component Edit > Hide rest of model.
    Tip: Paste in Place puts the clipboard back into the model in the same relative point in space, but within the current context.
  4. Move spindles up in blue direction to underneath the bottom surface of the tabletop.
    Tip: Use the blue inference direction lock and click on the face.
  5. Window select all the bottoms of the spindles and Move them downwards to meet the other geometry. (use View > Component Edit > Hide rest of model)
  6. The finished table.

Often you will need to copy or move geometry into or out of a component or group. Many times it is best (and easier) to make a quick group of the items, then cut the group to the clipboard. Go into the target context and Edit > Paste in Place. Then, explode the quick group to make it merge into the target context. Mastery of this method is essential for efficient SketchUp modeling. You can seamlessly move geometry between components (or groups) in a model. This is where the Paste in Place method becomes pervasive in your workflow.

There is another use of the clipboard which is very powerful in SketchUp. You can move items between SketchUp models using this Paste in Place technique. This method works great on the Mac because you can have multiple models open at once, but in Windows it takes a little more time to open and close files, but it still works between files. SketchUp remembers the location of the clipboard stuff in the coordinates of its model world. You can open another file and paste the geometry in place into the second model at the same relative location in the second file (that is, relative to the origin of both files). The geometry is immediately placed into the model without you having to click the mouse at a location.

Finally, the Paste in Place method works through Time…
Say you are working on a model and you realize that you want to recover something you had done several steps back in time. To bring that something forward in time:

  1. Save the model.
  2. Use the Undo arrow (or Ctrl+Z [Cmd+Z]) to back up to the point at which you can select the things of interest.
  3. Select the stuff.
    1. Note, You can orbit and zoom in and out, combine stuff, modify stuff, just regular modeling.
  4. Copy the selection to the clipboard with Ctrl+C [Cmd+C]
  5. From the File menu select File > Revert
    1. This allows you to go back to the point where you last saved the file.
  6. From the menu select Edit > Paste in Place
And there it is, back from the past… How cool is that?!

Similarly, you can model into the Future and then bring the new design back into the past… For example, you have been modeling along and developed a part of the design, but you want to Undo back several steps in the rest of the model.

  1. Select the part of the design you like.
  2. Copy the selection to the clipboard with Ctrl+C [Cmd+C]
  3. Use the Undo arrow (or Ctrl+Z [Cmd+Z]) and step back to where you want in the design process
  4. From the menu select Edit > Paste in Place
And there it is, back from the future!

Summary of best practices for Sketch
  • Draw on Layer0
    Always draw on Layer0. In the Layers dialog keep the radio button dot on Layer0. The check boxes are how to turn things on and off in SketchUp.
  • Make a component before copying an object
    If you are going to copy something to use it more than once, make a component of it first, then copy it. If it is already a group, right click [context click] on it and select Make Component before copying it. Components and groups organize your model. Layers are for display only, they do not organize a model. Do not try to isolate geometry using layers. Make things into components and groups first, then develop your layers, and put those components and groups onto layers.
  • Orbit and zoom while modeling
    Learn to orbit and zoom constantly while modeling, there is no extra charge. You have all the viewing control right at the middle mouse button, so use it. SketchUp was designed to let you experience your model. Using the mouse to move around in the model gets your mind engaged with your hands, engaged with your eyes, and reinforces for the mind what the design is doing.
  • Tap, move, tap when drawing
    When you are new to SketchUp, try to use the tap, move, tap method with the mouse, rather than dragging and releasing the mouse.
  • Switching and cancelling commands
    Remember, you are always in an active tool in SketchUp. To switch to another tool you do not need to cancel what you are doing, just pick up another tool and it cancels the current operation for you. This is especially important with the Move tool. The Move tool will move whatever is currently selected any time you click your mouse, even if you can not see it on the screen. Don’t run with scissors… when you are finished with the move tool, put it down (pick another tool).
  • ESC vs Undo
    Try the ESC key before you hit Undo. ESC cancels a current unfinished operation, Undo un-models your model. Some things in SketchUp are not part of Undo, like creating scenes, switching scenes, modifying scenes, selecting stuff, de-selecting stuff, orbiting and viewing.
  • Use 3D
    It is habit for most folks who are used to 2D CAD to look at plans and elevations. SketchUp is 3D all the time. Try to view the model from a 45 degree ‘above a corner’ view whenever possible (as when viewing three surfaces of an idealized cube). This gives you more visual clues as to size and scale of your modeling as you progress, and gives you better control of the Push-Pull and Move tools.
  • Leveraging groups and paste-in-place
    Use groups & paste-in-place to quickly isolate and move geometry around in the model, both in 3D space and between and amongst other groups and components. This makes designing very fluid and responsive.
  • Infer, don't calculate
    Let SketchUp help you line things up, stretch them to size, and generally calculate distances for you based upon other elements in the design. Become a master at inference locking, using the arrow keys, but more importantly, using the Shift key.
  • Simplify early on
    SketchUp lets you change segmentation while things are simple 2D arcs and circles. Once you pull them into 3D shapes, you cannot easily eliminate segments, so make these simplification decisions early when drawing your model. Learn to use smooth edges on extruded arcs and circles to give a rounded appearance with minimal geometry. Use only the level of segmentation required to accurately represent your design from a regular viewing distance. Remember, the lower the polygon count, the more responsive a 3D model is for anyone working with it.