Personalizar el teclado y el ratón

Para dibujar modelos 3D en SketchUp, se necesita mucho movimiento entre el teclado y el ratón. A medida que adquieras más experiencia en el modelado de SketchUp, identificarás qué comandos y herramientas usas con más frecuencia y qué te gusta y qué no te gusta de la configuración predeterminada del teclado y el ratón.

Consejo: Los métodos abreviados de teclado son una de las formas más flexibles de adaptar SketchUp a tus necesidades de modelado. Si alguna vez has deseado poder abrir una función específica con solo pulsar una tecla, el panel de preferencias de métodos abreviados te encantará. Verás que es muy sencillo.

Debido a que SketchUp ya depende enormemente de las combinaciones de teclas y del ratón, las personalizaciones del ratón no son tan flexibles como los métodos abreviados de teclado. Sin embargo, puedes cambiar el zoom de la rueda de desplazamiento y la forma en que interactúan el ratón y la herramienta Línea. En las siguientes secciones se explican todos los detalles.

Crear métodos abreviados de teclado

En SketchUp puedes asignar métodos abreviados de teclado a los comandos que usas con más frecuencia, de modo que literalmente tengas los comandos en la yema de los dedos.

En general, puedes personalizar los métodos abreviados de teclado como quieras, pero te damos algunas pautas para ayudarte a entender qué puedes y qué no puedes hacer al asignar métodos abreviados:

  • No puedes comenzar con un número porque entraría en conflicto con la funcionalidad del cuadro Medidas de SketchUp y no puedes usar algunos otros comandos reservados.
  • Puedes agregar teclas modificadoras, como la tecla Mayús.
  • No puedes usar métodos abreviados que estén reservados para el sistema operativo. Si no hay un método abreviado disponible, SketchUp te avisará.
  • Puedes reasignar un método abreviado del teclado que ya existe en SketchUp. Por ejemplo, de forma predeterminada, la tecla O es el método abreviado para la herramienta Orbit (Orbitar), pero puedes reasignar la tecla, si quieres, al comando Abrir.

Para crear tus propios métodos abreviados de teclado, sigue estos pasos:

Windows

  1. Selecciona Window > Preferences (Ventana > Preferencias).
  2. En el cuadro de diálogo de preferencias de SketchUp, selecciona Shortcuts (Métodos abreviados) en la barra lateral de la izquierda.
  3. En el cuadro de lista Function (Función), selecciona el comando al que quieres asignar un método abreviado del teclado. Si tu selección ya tiene un método abreviado del teclado asignado, ese método abreviado aparece en el cuadro Assigned (Asignado).
    Consejo: Cuando escribes el nombre de un comando de forma total o parcial en el cuadro de texto Filter (Filtrar), las opciones del cuadro de lista Función se filtran solo para aquellas opciones que incluyen los caracteres que escribas. Por ejemplo, al escribir mater se filtra la lista para mostrar tres comandos relacionados con materiales, como se muestra en la figura siguiente.
  4. En el cuadro de texto Add Shortcut (Añadir método abreviado), escribe el método abreviado del teclado que quieres asignar al comando y haz clic en el botón +. El método abreviado que escribas se moverá al cuadro Assigned (Asignado). Si el método abreviado que elegiste ya está asignado a otro comando, SketchUp te preguntará si deseas reasignar el método abreviado al comando que seleccionaste en el Paso 3.
  5. Repite los pasos 3 y 4 hasta que hayas creado todos los métodos abreviados que desees. Cuando hayas terminado, haz clic en Aceptar.
Consejo: Si un método abreviado se interpone en tu camino, puedes eliminarlo. Simplemente, selecciona el comando cuyo método abreviado deseas eliminar en el cuadro de lista Function (Función). Luego selecciona su método abreviado en el cuadro Assigned (Asignado) y haz clic en el botón del signo menos. El método abreviado desaparece del cuadro Assigned (Asignado), es decir, de tu copia de SketchUp.

MacOS

  1. Selecciona SketchUp > Preferences (SketchUp > Preferencias).
  2. En el cuadro de diálogo de preferencias de SketchUp, selecciona Shortcuts (Métodos abreviados) en la barra lateral de la izquierda.
  3. En el cuadro de lista, selecciona el comando al que quieres asignar un método abreviado del teclado. Si tu selección ya tiene un método abreviado del teclado asignado, ese método abreviado aparece en la columna Key (Tecla).
    Consejo: Cuando escribes el nombre de un comando de forma total o parcial en el cuadro de texto Filter (Filtrar), la columna Function (Función) se filtra para mostrar solo aquellas opciones que incluyen los caracteres que escribas. Por ejemplo, al escribir mater se filtran las opciones para mostrar tres comandos relacionados con materiales, como se muestra en la figura siguiente.
  4. En el cuadro de texto de la parte inferior izquierda del panel de preferencias Shortcuts (Métodos abreviados), escribe el método abreviado del teclado que quieres asignar al comando. El método abreviado aparecerá en la columna Key (Tecla). Si el método abreviado que elegiste ya está asignado a otro comando, SketchUp te preguntará si deseas reasignar el método abreviado al comando que seleccionaste en el Paso 3.
    Precaución: ¡No pulses Intro, porque se borrará el valor introducido!
  5. Repite los pasos 3 y 4 hasta que hayas creado todos los métodos abreviados que desees. Cuando hayas terminado, basta con cerrar el cuadro de diálogo de preferencias de SketchUp.
Consejo: Si un método abreviado se interpone en tu camino, puedes eliminarlo. Simplemente, selecciona el comando cuyo método abreviado deseas eliminar en el cuadro de lista Function (Función). Luego elimina tu método abreviado del cuadro de texto en la parte inferior izquierda del panel de preferencias de métodos abreviados. El método abreviado desaparece del cuadro de la columna Key (Tecla), no de tu copia de SketchUp.

Si deseas restablecer todos los métodos abreviados de teclado a los valores predeterminados, haz clic en el botón Reset All (Restablecer todo) en el panel de preferencias de métodos abreviados. Si quieres cargar tus métodos abreviados de teclado a otra copia de SketchUp, descubre cómo exportar e importar preferencias en Personalización del espacio de trabajo.

Invertir la rueda de desplazamiento

Si de forma predeterminada usas SketchUp con un ratón con rueda de desplazamiento (lo cual facilita enormemente la tarea de dibujar en SketchUp), gira la rueda de desplazamiento hacia arriba para acercar y hacia abajo para alejar.

Windows

En Microsoft Windows, puedes cambiar este comportamiento mediante estos pasos:

  1. Selecciona Window > Preferences (Ventana > Preferencias).
  2. En la barra lateral de la izquierda, selecciona Compatibility (Compatibilidad).
  3. En el área Mouse Wheel Style (Estilo de rueda del ratón), selecciona la casilla Invert (Invertir).
  4. Haz clic en Aceptar y prueba la rueda de desplazamiento invertida.

MacOS

En Mac, esta función de preferencia es nueva en SketchUp 2017. Para invertir el comportamiento de desplazamiento, sigue estos pasos:

  1. Selecciona SketchUp > Preferences (SketchUp > Preferencias).
  2. En la barra lateral de la izquierda, selecciona Compatibility (Compatibilidad).
  3. En el área Mouse Wheel Style (Estilo de rueda del ratón), selecciona la casilla Invert (Invertir).
  4. Haz clic en el botón rojo de cerrar y prueba la rueda de desplazamiento invertida.

Reasignar botones del ratón

"Reasignar los botones del ratón" significa personalizar la forma en que funcionan los botones. Si has usado las preferencias de tu sistema operativo para invertir los botones derecho e izquierdo del ratón porque eres zurdo, tu ratón reasignado debería funcionar bien en SketchUp.

Sin embargo, si has usado una utilidad especial para asignar comandos a los botones del ratón, puede producirse un comportamiento imprevisible o perder funcionalidad en SketchUp.

Advertencia: Debido a que en SketchUp se usan mucho los botones del ratón junto con varias teclas modificadoras (Ctrl, Alt, Mayús), puedes perder funcionalidad fácilmente al reasignar los botones del ratón.

Elegir las preferencias de clic del ratón para la herramienta Línea

Si quieres personalizar la forma en la que el cursor de la herramienta Line (Línea) responde a tus clics, encontrarás algunas opciones en el panel de preferencias Drawing (Dibujo). A continuación se explica brevemente cómo personalizar el comportamiento de la herramienta Línea:

  • Botón de selección Click-Drag-Release (Clic-Arrastrar-Soltar): Selecciona esta opción si quieres que la herramienta Línea dibuje una línea solo si haces clic en el botón del ratón y lo mantienes pulsado para definir el punto inicial de la línea, lo arrastras para extender la línea y lo sueltas para establecer el punto final de la línea.
  • Botón de selección Auto Detect (Detección automática): Cuando esta opción está seleccionada (es la predeterminada), puedes hacer clic, arrastrar y soltar, o bien hacer clic, mover y hacer clic, según sea necesario.
  • Botón de selección Click-Move-Click (Clic-Mover-Clic): Obliga a la herramienta Línea a dibujar mediante un clic para definir el punto inicial de la línea, un movimiento del ratón para extender la línea y otro clic para establecer el punto final de la línea.
  • Casilla Continue Line Drawing (Líneas continuas): Cuando se selecciona Detección automática o Clic-Mover-Clic, puedes elegir si quieres activar o desactivar esta casilla. (De forma predeterminada está seleccionada). Cuando la casilla está seleccionada, la herramienta Línea trata un punto final como el inicio de una nueva línea; de este modo, ya no es necesario el clic adicional para establecer un nuevo punto inicial. Si ese comportamiento no te gusta, desmarca la casilla. Luego disfruta de una taza de té sabiendo que la herramienta Línea ahora funciona como siempre quisiste.