SketchUp Help Center

How Can We Help?

A beginning guide for product manufacturers familiar with CAD software

Table of Contents
  1. Introduction
  2. Viewing and creating a model
    1. Viewing the 3D model
    2. Perspective vs. Isometric
    3. We do not have a grid
    4. Drawing accurately
    5. Working with different units
    6. Modeling by inferring to existing geometry (Inferencing)
    7. Stickiness - the dynamic interconnectedness of edges and faces
    8. To do… or to undo
  3. Managing model information and geometry
    1. Groups and components
    2. Nesting groups and components
    3. Using layers and scenes
    4. Hidden geometry
  4. Level of detail and quality considerations
    1. Minimizing model size
    2. Using textures to add detail
    3. Quality guidelines for sharing models in 3D Warehouse


If you want to get your products in front of millions of architects and designers, a great way to do so is to create SketchUp models and put them on the 3D Warehouse. Whether you have existing CAD files of your products or you plan on creating your 3D models from scratch in SketchUp, this article is for you. This has been written for those who are already somewhat adept at 3D modeling, so the goal of this document is to shorten your learning curve.

SketchUp is a different kind of 3D modeling program from most traditional CAD/CAM modeling software. Though both types of programs create 3D models, traditional CAD/CAM systems are often solids-based modelers and are very structured and hierarchical in their organization of the model. A lot of them make models that can drive a production CNC machine.

Many product manufacturers already have 2D and 3D CAD geometry representing their products. In almost all cases this geometry will need some cleanup and optimization to make it suitable for 3D Warehouse.

There are three general principles that should always be addressed in your product models:

  1. proper component origin
  2. proper real-world scale
  3. simple geometry

If you stick to these principles, your models will be lightweight and will have an appropriate number of polygons to represent the geometry correctly. SketchUp is fun and the learning curve may be faster than other software, but it still takes some time to learn and master.

Viewing and creating a model

Viewing the 3D model

SketchUp is a simulated 3D environment on a 2D computer screen. The software presents you with your design in a very immediate and dynamic way. There are no split view screens or proscribed views. If you want to see a different aspect of your model, simply orbit and look at it. Zoom in and move inside the model dynamically, real-time. Everything in SketchUp is in 3D, and every viewing angle in SketchUp is a 3D view of a 3D model, even if the 3D model is a single 2D face. Orbit often as you draw, there is no extra charge.

If you’re new to SketchUp, learn to orbit and zoom CONSTANTLY, especially during a drawing operation.

If you feel out in mid-air without ‘standard’ views, use the Views Toolbar or Camera > Standard Views menu to give you some quick reassurance. Each button places your eye (the camera) in a familiar viewing position relative to the model axes. (View > Toolbars > Views) [Customize toolbar on Mac]

The most handy of these quick camera placements is the Iso view button.
This will put you in the closest one of eight standard isometric orientations based upon your current viewing direction. Isometric view refers to the "centered" or directly-on-corner view angle (i.e., the camera at 100,100,100 looking at target 0,0,0)

Zoom in very close when selecting specific points and geometry. For the most part, you should avoid working in plan and elevation. Instead, work in an axonometric view where the red, green, and blue axes are distinct from one another. This will help you feel more comfortable with the SketchUp interface, and make it easier for you to be accurate with the inference directions.

In SketchUp the middle mouse wheel is also a mouse button. In SketchUp, if you hold down and drag the middle wheel the cursor becomes the Orbit tool. The Orbit tool is for constantly viewing your model in 3D space. This is different from traditional CAD which tends to be standard view or ‘previous zoom’ based. So you can be in a tool, say the Move tool, and press the middle mouse wheel to orbit to a better vantage point, then let go of the mouse wheel and you are still in the previous tool (here the Move tool). Holding Shift while holding down the middle mouse wheel puts you in the Pan tool. Rolling on the mouse wheel Zooms your view in and out on the model. This allows you to orbit, zoom, and pan constantly while drawing and editing, without interruption.

Here is a video about navigation within SketchUp.

Perspective vs. Isometric

Many CAD systems work with the model in isometric mode where lines do not converge, with the same scale being applied to all three directions. This is an abstraction of reality and can appear “wrong” or “unnatural” to the viewer. SketchUp allows you to model and think in perspective, just like you experience the real world. You should use it (use Camera > Perspective).

Remember, in perspective, the viewing length of objects become foreshortened, so you cannot scale a perspective printout.

We do not have a grid

The SketchUp modeling environment is governed by the three cardinal directions: up and down is the “blue” direction or ‘z’ direction, east and west is the “red” direction or ‘x’ direction, and north and south is the “green” direction or ‘y’ direction. The negative direction of each is shown dotted. The only “fixed coordinate” in SketchUp is the axes origin where the red, green, and blue axes intersect. Exact points in space are not indicated by (x,y,z) coordinates like other software.

Edges are drawn with the Line tool, indicated by a Pencil cursor. To start, just draw on the screen with the pencil, and use the red, green and blue directions to help guide you as you draw. SketchUp allows you to draw on the computer as if you’re using a pencil, and the software will interpret your “lines” as edges and put skin over them, creating a faceted model. Lines and edges are interchangeable terms within SketchUp.

Drawing accurately

Everything in SketchUp is drawn with real dimensions, even if you aren't aware, so take control and learn to draw accurately. To specify a distance, dimension, or variable for a tool, simply type a numeric value on your keyboard. It will automatically show up in SketchUp’s Measurements Box at the lower right corner of the drawing window. The Measurements box is not a dialog box, so you cannot click into it. It is always listening for input from your keyboard.

SketchUp “listens” for input from your mouse first and from the keyboard second, so leave your mouse still when you type, or a mouse move will overwrite your typing value.

Given the edges paradigm in SketchUp, by definition anything that can be created in SketchUp can be done using the Pencil tool. When an operation seems to be failing for you, sometimes it is easiest to just pick up the Pencil and draw in the edges manually.

The drawing tools, Rectangle, Push/Pull, Circle, Arc, Offset, and Follow-me, simply speed up the creation of edges (and hence faces).

For more information on each of the tools in SketchUp, start with the Concepts Guide or go to the Knowledge Center and explore help on each particular tool.

Working with different units

You can work in either the Imperial or Metric measurement system, and also work between them at any time. Simply include the unit of measure delimiter when typing in the measurement value. For example, if I am generally working in Architectural inches (Window > Model Info > Units - Architectural - inches) but I want to add a 1.5 x 3 meter face to the model, simply type in 1.5m,3m during the rectangle tool.

You do not need to type the delimiter for your default units. So if Architectural - inches is set as model units, a number value alone is interpreted as inches, if Architectural - millimeters is set as model units, a number alone is interpreted as millimeters.

It is important to note, you do not need to set or change your model units (Window > Model Info > Units) each time you want to use a different unit system. Just type the value with the correct delimiter. If you want to specify imperial units, include the feet and inches characters, for example 1’5”,3’ . You can even mix units, for example 2 foot by .8 meters (2’,0.8m).

Modeling by inferring to existing geometry (Inferencing)

In SketchUp use inferencing instead of inputting absolute x, y, z values. SketchUp is driven by an inference engine that helps the designer navigate all tools in 3D space on a 2D computer screen. There is no grid or modeling volume.

Edges have three inference points, each indicated with a unique color dot when the cursor hovers over it: endpoints (green), midpoint (cyan), and on edge (red). When edges form a face, the face has the same inference points around its boundary, and a blue on face dot anywhere on the plane of the face.

When these concepts are extended into 3D, all the same simplicity exists, with the addition of a vertical dimension and a point where an edge intersects a face with a red X. Here the “directions” of the lines are shown in their red, green, and blue colors.

The SketchUp inference engine enables users to draw and place geometry relative to previously drawn items. When you work in SketchUp, place geometry off of known geometry by using the red, green, and blue inference directions to triangulate the new location. Inference points and directions can be combined to find unique, accurate points in 3D space. Inference directions may be ‘locked’ to enable the cursor to easily combine a direction with another inference anywhere in the model.

In SketchUp 2016, enhanced inferencing options were added.

This is why a 3D grid isn’t needed in SketchUp. Use what you have already drawn as your reference for what you draw in the future. The non-procedural nature of drawing in SketchUp was designed to be as much like drawing with paper and pencil as possible within a computer environment. The inference engine keeps all this freedom accurate. Inference points have unique colors, as mentioned earlier, to make the user interaction easily learned and recognizable. Mastery of the inference engine in SketchUp is essential for correct and efficient modeling.

Stickiness - the dynamic interconnectedness of edges and faces

The main difference from standard CAD is to remember that edges govern the 3D geometry, and edges are shared between faces. Think of this as: things that touch in a model are aware of the things adjacent to them. In traditional CAD software solids, mass elements, primitives, modified primitives, or bodies govern the model, not edges.

The properties of Edges are that they have a length determined by two endpoints. In addition they have a midpoint. The properties of Faces are that they have an area, a front face color and a back face color. When a series of edges all lie in the same plane and connect endpoint to endpoint, they form a closed loop. SketchUp creates a face that acts as a skin to these wire-frame edges.

When a face is bisected by a new edge, the original face is broken into two separate but connected faces. The two faces formed are not independent of one another; they are joined along the shared edge. If that shared edge is moved in space, both faces are changed in size and orientation.

So if one shared endpoint is moved in space, both faces will change in size. If one face is moved, the shared edge is moved as well. This dynamic interconnectedness of edges is known as “stickiness” in SketchUp.

The stickiness of geometry in SketchUp often frustrates new users, especially those used to another CAD paradigm. There are some nuances to deleting connected faces and edges in SketchUp. Please see the article SketchUp Best Practices and Applied Principles to better understand this unique feature in SketchUp. This article discusses various modeling concepts using the SketchUp software.

To do… or to undo

You should become familiar with the Undo function in SketchUp (either the undo button, Ctrl+Z, or [Cmd+Z on the Mac]). As you progress in developing a model, each of your editing and drawing operations is stored or remembered in reverse order in what is known as a “stack” of information within the computer memory. It is in reverse order, because each thing you do is put on top of the stack. The next operation gets put on top of the stack, and so on. To Undo things, the software works down the stack from top to bottom.

In SketchUp, only operations that affect the construction of the model are considered part of the undo stack. This means that many things you do, like zooming, orbiting, turning on shadows, setting arc segmentation, setting up scenes, etc. are not part of the undo stack. Many other CAD systems store everything in the undo stack, including your view changes of the model. Not so in SketchUp.

New users sometimes make the mistake of continuously hitting undo, trying to “zoom previous”, and all the while, their model is being deconstructed one click at a time. Don’t make this mistake! If you need to zoom previous, use this viewing button , but usually it is easier to orbit or pan back to the view you want.

Think of SketchUp’s main toolbar as a toolbox. Just like when you use a toolbox at home, you generally use one tool at a time. When you want to move to another task, you put down the tool you have and you pick out another one. You keep holding onto your current tool until you pick another. SketchUp behaves the same way. There is no ‘command prompt’ waiting for input in SketchUp. You are always doing something until you decide to do something else.

Another common problems for new users is to remember they are still in the Move tool after they finish a move operation. Don’t forget to change tools! Choosing the Select tool (spacebar) is a safe bet.

You can switch between tools while operating on a selection of items, and the same selection of items persists across the tools. This is why the selection set is not part of the undo stack of commands. This is also why the orbit and viewing tools are not part of the undo stack.

Managing model information and geometry

Groups and components

The Stickiness behavior explained earlier can be frustrating for some CAD modelers. Other modeling programs disconnect or separate geometry by putting it on different layers. Not so in SketchUp. Draw everything on Layer0 when making groups and components, we’ll talk about layers in the next section.

To keep geometry from interacting, put the geometry into a Group, or when the geometry is to be copied and repeated, put it into a Component.

Components make your modeling more efficient. Components are stored as a named definition of some geometry, and then that definition is recreated at each location, or instance, where that component is placed within the model. When you change one instance, the definition is changed for all instances simultaneously. This is what makes your modeling more efficient. As a general rule, if an object will be repeated within the model, make it into a Component.

Dynamic Components are an advanced form of Components that allow a great deal of parametric-like behavior and can accommodate programming within and between components. These can be very complex objects. You do not need to use Dynamic Components to accomplish normal modeling within SketchUp; however, they can be quite useful when you need to create lots of your products.

Product models are shared as components and typically each product model is a separate file (unless many products are combined together, e.g. as a vignette). Many manufacturers have multiple products to put into 3D Warehouse. Anytime you have multiple files, developing a methodology of systematic component and file naming is important. Also you should be consistent across your collections. For more information about file naming see the following article: File management, uploading & branding
Nesting groups and components

There is no parametric hierarchy of Groups and Components as is common in other CAD/CAM software. However, Groups and Components may be nested within each other to any level of complexity you find useful. The Outliner is a great feature of SketchUp that helps you to quickly review the structure, or organization, of model nesting. For more in-depth discussion on components and how they work, please see the articles: Working with Components in SketchUp and SketchUp best practices and applied principles

Using layers and scenes

Layers in SketchUp are for viewing the model, and are simply on/off visibility switches for the contents of each layer. Instances of groups and components may be placed on separate layers to provide for variable display of the model.

Model each part of your product as an interactive set of faces and edges. Put each of these sets of geometry into a group or component object. Then create any layers you need and place these objects on those layers as appropriate. To summarize:

  1. Model first
  2. Create Groups/Components second
  3. Add Layers third.
The default layer, Layer0, is where you create geometry. Draw everything on Layer0... all the time.

Scenes are saved model states (not versions). Scenes store the current Camera Location, layer visibility states, as well as Hidden Geometry, and several other items. Scenes and Layers can be closely tied. Setting a scene to remember visible layers lets you set up several scenes that present different aspects of the model.

Do not rely on Scenes to store hidden visibility of items. This setting actually remembers what things are set to hidden at the current time the scene is saved. It does not remember the state of View > Hidden Geometry. This means that a scene can actually turn things hidden that you want to be visible or vice versa… so beware.
Hidden geometry

Components and groups isolate geometry, one from another. So editing a component keeps you from accidentally changing anything else in the model. This makes specific editing more secure, but there are times when one part obscures the viewing of another part you are modeling. This leads to the difference between hiding something, and turning it off via layers. The Edit > Hide menu command or context menu > Hide lets you hide geometry and objects. You can toggle hidden geometry on and off (View > Hidden Geometry). Hidden geometry is displayed as dotted lines and cross-hatched faces. Hidden geometry is editable when visible, but it’s rendering properties (dots and cross-hatch) do not change.

The difference between hiding geometry and using layer visibility is a degree of flexibility. Hidden geometry is displayed as either all on or all off. Layers can be displayed individually. It is preferable to use Layers to control visibility while modeling. Hidden geometry is useful as part of the process of creating smooth surfaces from multiple faces and for cutting holes.

Level of detail and quality considerations

Minimizing model size

Another issue of importance is that of excessive model geometry. You want to keep your polygon count to a minimum but still represent the dimensions of the object accurately. Every face in Sketchup adds to the file size of the model. Remember, the end user does not want to manufacture your product, they simply want to use a 3D representation of it within a much larger design context.

Circles and arcs in SketchUp are made up of a series of short line segments. The higher the number of segments, the smoother the curve will appear and the greater the number of faces that will be created from push/pulling the circle or arc. This segmentation also determines the number of faces generated by a Follow Me operation along a curved path or around a circle.

Keeping arc and circle segmentation to an acceptable minimum is one of the most effective ways to conserve file size.

Decide on an acceptable minimum resolution for your products and keep your models light-weight in polygon count. Occasionally zoom out to a normal viewing distance while modeling and check to see that the product still represents well, but simply.

Using textures to add detail

Often times use of a photo texture provides more visual information than an increased number of polygons. Below are two sofas with the same polygon count, but the one on the right contains photo textures making the sofa appear more detailed without increasing the model size. This is especially helpful for items like the tacks as shown on the arms of this couch.

Another way to simplify model geometry, and hence file size, is to model only what the user will see. That is, don’t model interior parts of a component that will not be needed by the average user.

As your model becomes more complicated, you need to be aware of techniques to help in modeling complex objects with many sub-parts.

Please see the article How to model efficiently using existing 2D and 3D sources for a discussion of using existing CAD files and image files as a basis for developing your product components.

Quality guidelines for sharing models in 3D Warehouse

The goal is to get your products on 3D Warehouse and expose them to a world of architects and designers. To get everybody on the same page, we have developed a checklist that should help you double-check that you’ve created beautiful, useful, and easy-to-operate 3D Warehouse models. To go with the checklist, we’ve also created an article and a video series that digs deeper into what each item on the checklist means to help you achieve the desired results.


Need Help Fast?

SketchUp’s outstanding community of passionate experts have answers to your questions.