SketchUp Help Center

How Can We Help?

Solving a Blank Dialog or SDK Error When Exporting

You're exporting a SketchUp file to one of these formats: FBX, OBJ, 3DS, VRM, or XSI. On the Windows platform your export fails with a blank dialog box. On a Mac you get an error message like "SketchUp SDK error: An error has occurred resulting in an invalid output file..."

Most likely this problem is caused by materials based on images that have no extension. For example, your material may be based on an image named "brick" rather than "brick.jpg" or "brick.png"

To resolve this error you'll need to identify which materials in your file are missing extensions and either remove or fix them. This can be difficult in models with many textures, so you may want to follow the Ruby steps below to identify the offending materials:

  1. Browse to the Window > Ruby Console, which will open the Ruby Console
  2. Copy and paste the following line into the Ruby Console:

    Sketchup.active_model.materials.each {|m| puts "\n" + m.display_name if (not m.texture.nil? and not m.texture.filename.include? "." )}
  3. Press the Enter key. if you have any materials in your model that are based on textures that have no file extensions, the names of the materials will be printed in the Ruby Console and you should do the following with each of them:
    1. Go to Window > Materials to open the Materials dialog.
    2. Click on the Home button to view your In Model materials.
    3. Either delete the materials printed from the Ruby command or fix them to have valid file extensions 
      On the PC, click Details button > List view to view your materials by name, which will make it easier to find them.

If you want to fix your materials to have valid file extensions, here are some suggested steps:

  1. Select the first problematic material in your Materials browser.
  2. Right click and choose Export texture image and export the texture to your desktop, making sure it has a valid file extension like “my_texture.jpg”
  3. Click the Edit tab of the Materials browser.
  4. Click the Browse button under the “Use texture image” section and browse to the texture you exported in step two.
  5. Click the Open button. Your material should now be based on a texture that has a file extension.
  6. Repeat steps 2-5 with any other materials that are missing file extensions.
  7. Try exporting again; the export should be successful.
  1. Select the first problematic material from the Materials browser.
  2. Right-click and click Edit... This will open the texture tweaker on the bottom.
  3. Click the Edit texture image with external editor button (i.e. the brown cube with the orange arrow) and the image will open with your default image editing program, which will probably be Preview.
  4. Assuming that the image was opened in Preview, click File > Save As or File > Export and save the image to your Desktop, making sure it has a valid file extension like “my_texture.jpg”
  5. Back in SketchUp, double-click on the same material in the Materials browser to expand the texture tweaker again.
  6. Click the Texture drop-down menu and select Load.
  7. Browse to your Desktop and select the image you saved in step 4. 
    Note: in the texture tweaker area, the name will still appear to be missing the file extension as the Mac does not show file extensions.
  8. Repeat steps 2-5 with any other materials that are missing file extensions.
  9. Try exporting again; the export should be successful.



Need Help Fast?

SketchUp’s outstanding community of passionate experts have answers to your questions.