SketchUp Help Center

How Can We Help?

System setup for product modeling

Table of Contents

Template setup

When SketchUp starts, it uses either a template file as the basis for a new model file or it opens an existing model file. Some template files contain information meant to help newcomers to computer modeling get comfortable with a 3D environment, such as sky and ground plane and scaled human figures. This is not necessary for experienced CAD folks doing product modeling.

A simple template with a white background works well. A template file should be in the units with which you work, should be at a scale (zoom factor) for the size of products you deal with, and contain any office standards that you develop, such as layers, scenes, materials, etc.

A template that will work well is one that is in plan view looking down upon a white surface or ground plane, with no color and no scale figures. Here’s how you can develop a standard template that you can use for your products.

  1. When you start SketchUp, choose either the Construction Documentation- Feet and Inches Construction Documentation- Millimeters or Construction Documentation- Meters template, depending upon the unit of measure you prefer.
  2. Draw a rectangle on the ground plane the general size of the items you will be modeling. Keep the rectangle generally centered around the origin.
  3. Use the Zoom Extents tool and zoom the view to fill the screen.
  4. Paint any office standard materials and colors onto the rectangle, one after another, overwriting each one in turn.
  5. Erase the rectangle.
  6. Create any office standard Layers you will use during product development.
  7. Set the style settings to your office standards.
  8. Go to menu File > Save As Template… and give the template a name and description for office use, and set it as the default template.

Toolbar setup

SketchUp has a small number of native tools. They are broken into toolbars. There is a ‘Large Tool Set' toolbar that contains all the main tools in a standard arrangement. Go to View > Toolbars… and click the Large Tool Set on Windows, or [View > Tool Palettes > Large Tool Set on the Mac]. If you’re using the Large Tool Set, The Getting Started toolset can be turned off. On the Mac, the Getting Started toolset is on the toolbar across the top of the screen by default. To remove these buttons on a Mac, Context Click on the toolbar, and select Customize Toolbar… and drag them off the bar to discard them.

Tip: A good working layout is to put the toolbars Standard, Styles, and Views across the top of your screen, with the Large Tool Set down the left edge.

It is also a good idea to set the Push/Pull tool to active selection mode. Go to Window > Preferences > Drawing and checkmark the Disable Pre-pick on Push/Pull tool in Windows [on Mac, Sketchup > Preferences… > Drawing].

Shortcut keys

SketchUp allows for the use of shortcut keys. This makes modeling more efficient. Go to Window > Preferences > Shortcuts on Windows, or [SketchUp > Preferences > Shortcuts on Mac] to assign shortcuts. Click your cursor into the Filter box and type in a relevant term like: hide. You will see a list of all menu commands that use the word hide. Select the command you want to assign, and in the Add box, type in a key, (or modifier(s) and a key). On Windows, you need to click on the Add button (the plus button) to add it to your shortcuts. On Mac, as soon as you type the shortcut, it is added to the program.

In addition to the default shortcut keys, you should also include the following:

tilde key (~)
Edit > Hide
Edit > Unhide Last
Edit > Make Group
Edit > Make Component...
Edit > Paste In Place
Edit > Select None
View > Component Edit > Hide Rest of Model
View > Component Edit > Hide Similar Components
View > Face Style > X-ray
View > Hidden Geometry
Camera > Zoom Extents
Context menu > Reverse Faces


These shortcuts are included based upon a proven workflow, but you can set these commands to any key combinations you find comfortable.

Tip: Use a mnemonic approach when possible so you remember phonetically. For example G would be good for Group because, in English, group starts with G. T for Transparency describes what you’re viewing, but X (X-ray) would be more literal because x-ray is the name of the SketchUp display mode. Either way is fine. Find whatever works for you.

For similar tasks, group modifiers with the mnemonic key. So for example, if H hides the currently selected objects, Shift+H can show hidden geometry. If G creates a group object, Shift+G can make a component object (both make objects).

Finally, C is used for Hide Rest of Model and Hide Similar Components because it deals with Components (even though the default C is for Circle). The Shift and Shift+Alt modifiers allow the shortcut to be used simultaneously while holding Shift for inference locking.

Tip: Often, turning off the rest of the model helps to make a unique selection of items for a move edit. A move begins with inference locking, but then, to see the rest of the model to finish the move, it helps to turn on the rest of the to model to find the other point. In this way you can keep holding shift the whole time.

Need Help Fast?

SketchUp’s outstanding community of passionate experts have answers to your questions.