SketchUp Desktop 2022.0

SketchUp Pro 2022.0
22.0.316 Win 64-bit
22.0.315 Mac 64-bit

Table of Contents

What's New in SketchUp and LayOut 2022.0?

General Notes

  • The OS support for SU 2022.0 includes Windows 11 and macOS Monterey. The macOS Mojave (10.14) is no longer officially supported.

SketchUp

Search SketchUp

First introduced in SketchUp for Web, Search SketchUp is now a desktop feature that allows you to look up and activate commands by typing. Search supports queries for commands by name as well as by 'concept.' This means you can search for workflow-related queries -- such as 'elevation,' 'boolean,' or 'chamfer' -- and see related SketchUp results. In SketchUp Pro, Search also provides results for installed extension commands with associated toolbar or menu listings. Activate Search with its toolbar icon (far left in the Getting Started toolbar), from the Help menu, or by its default shortcut (Shift + S).


Lasso

Lasso is a selection tool that lets you create hand-drawn selection bounds. To create a window bounding loop (where only entities entirely inside are selected), click-drag and move the cursor clockwise. Move counterclockwise to make a crossing bounding loop (where partially contained entities are selected). A stippled vector line distinguishes the crossing selection. If you like, you can reverse Lasso's directional behavior in Preferences > Drawing.

Additionally, Lasso can select entities one click at a time and works with the same modifier patterns as Select. For Lasso, we are introducing a new default shortcut: Shift + Spacebar.

Tag

The Tag tool lets you apply tags by clicking entities in the modeling window. To specify a tag, select an individual tag in the Tags panel or use the tool's Sample modifier to grab a tag from an entity in your model. Keep an eye out for tooltips that affirm the tag about to be applied or sampled. When you click to tag entities, a purple bounding highlight blinks to confirm the operation. Learn more about the Using the Tag tool and its modifier actions...


The Tag tool may also be used on pre-selected entities, so we've added commands improve bulk selection:

  • Select > All with Tag (modeling context menu): Select all entities in the active modeling context that share any tag with the pre-selection.
  • Select > All Instances (modeling context menu): Select all component instances (in the active modeling context) that share a definition with the selection.
  • Select All Tagged (tag tree context menu): Select all entities in the model (in the active modeling context) that share a tag with a pre-selection in the Tags panel. This command is available by right-clicking the tag tree and can be used on either tags or tag folders.

Freehand "+"

We've made a considerable upgrade to the Freehand tool, allowing you to create much smoother curve entities. These improved freehand curves generally contain more segments. Immediately after drawing a curve, you may decrease the segmentation of the curve incrementally, and SketchUp will provide visual feedback with each increment. Segment control is available by modifier keypresses specified in the Status Bar. Freehand has also received axis locking input to set a drawing plane (available before a user starts drawing). And it is now possible to draw across adjacent faces on different planes.


2-Point Arc and 3-Point Arc: Tangent Inference Lock

There is now a tangent inference lock for the 2-Point and 3-Point Arc tools. This new toggle makes it possible to lock tangency from an existing edge so that the next click creates a tangent arc. To toggle on this inference lock, tap the Alt key on Windows or Command key on Mac.

With tangency locked, what you see is what you get. Click to set the tangent arc and start drawing a new one.

When multiple edges intersect, you may hover over an edge to request it as the basis for tangency before clicking to begin the arc. This behavior is available whether or not the inference is locked.

With tangency locked, what you see is what you get. Click to set the tangent arc and start drawing a new one.

Scene search

When models have a ton of scenes, it can be a bear to scan a long list to identify a desired scene to jump to or configure. In SketchUp 2022, we've added a new search filter -- available adjacent to Scene Tabs (when there are two or more scenes) that lets you type to find a scene name. Click a scene from the search results to jump to that scene and also select it in the Scenes panel.

Native Apple silicon Support

In SketchUp 2022, we are offering a universal installer that enables SketchUp Pro to run 'natively' on Mac devices that run with Apple silicon (introduced in late 2020). Previously, SketchUp has been running on these devices using the Rosetta translation service.

The 2022 installer also supports SketchUp's installation and operation on Mac devices with Intel processors. Apple users will not need to distinguish which chipset powers their Mac to install SketchUp Pro.

Explode performance

When you explode a large object in SketchUp, there is often a noticeable hang. In 2022.0, we have made a significant improvement to Explode operations. In large models, we expect users may experience a 2-3x improvement with Explode.

Other notable improvements

Section plane improvements

When you need to use section planes in a model, it's a good bet you don't just need one or two. As the number of section planes grows, section plane visibility becomes mutually exclusive with selection, sampling, or painting. In this update, we've changed picking logic so that if section planes are visible, entities they obscure are still pickable. That means it's now a lot easier to pick, paint, tag, and sample when section planes are visible.

You can still select a section plane by clicking its border or symbol, or by using Outliner.

Clipping improvements

'Clipping' is a longstanding problem that occurs when users navigate to modeling window views where the camera cannot appropriately interpret model geometry. The result is 'clipped' geometry that displays inappropriately. In this release, we have made changes that should improve a few scenarios where people experience clipping. These include:

  • Switching to parallel projection camera views. When switching camera modes, it was very common for model views to be (extraordinarily) clipped. SketchUp 2022 resolves this problem.
  • Perspective clipping in models with large extents. When the expanse of a model is vast, zooming into a small part of the model will still produce clipping. But now, when you enable the 'Hide Rest of Model' display setting, SketchUp will re-interpret the view to display geometry properly. This means you can entirely mitigate clipping in these scenarios through the use of groups and components along with the 'Hide Rest of Model' command.
Standard Views respect model axes

In previous versions of SketchUp, Standard View commands -- Top, Front, Right... -- did not respect customized model axes. So, you would need to use the Align View command to produce camera views for properly aligned elevation and section views. Now, the Standard Views will behave as expected to produce properly aligned views to customized axes. One other small change: the Align View command is now accessible in the Context Menu, even if other entities (like edges or objects) are also in the selection set.

Tape Measure tweaks

We have made some modifications to smooth over a few rough spots in measurement and guide operations. These include:

  • When Tape Measure is active, both the Measurements box and tooltips provide previews for length, area, or coordinates. In this release, when you click to set a guide or take a measurement, the Measurements box will hold that value, even if you move your cursor. (Previously, moving the cursor would clear the value of your guide or measurement to display previews). After measurement operations, previews are still available in tooltips. And resetting Tape Measure (by hitting its shortcut or toolbar icon) will restore previews in the Measurements box.
  • Guides that are being created will now appear in the same color as guides that have been placed. Previously, 'in-process' guides would appear light gray and be hard to see in some camera positions.
  • When 'View Guides' is toggled off, creating a new guide will now toggle on guide visibility. Previously, users could forget that guide visibility was off and unnecessarily repeat guide creation until remembering... or cursing SketchUp in a white-hot rage.
Directional inference tooltips

In SketchUp 2021.1, we added the ability to 'pre-lock' a directional inference for Line, Freehand, 2-point Arc, 3-Point Arc, Move, and Tape Measure. In this update, tooltips confirm when an inference is locked using the arrow keys, before the first click of an operation.

Smart size restrictions for 2D exports

In previous releases, SketchUp capped the maximum 2D image export size to 9999 pixels (wide or high). This limitation was meant to prevent SketchUp from freezing if people asked their systems for more memory than was available. As the available system memory varies across our users' devices, we have now adjusted our 2D exports to be less restrictive and more responsive to the working memory on a given device. Now users may enter any value into the image size fields. If SketchUp thinks that the resulting image will exceed the available system memory, a dialog will advise users to reduce the image size.

Faster model checking

SketchUp's 'Automatically fix problems' service has not handled small geometry well. In many cases, faces could be deleted when model validity checking was enabled. In this update, we've improved both the fidelity and performance of validity checking and repair, so that small faces are not deleted and that the entire process goes significantly faster (between a 1.5 and 5x improvement in the 90+ models we tested).

LayOut

Zoom Selection

When LayOut pages grow in detail and complexity, they often become cumbersome to use with scroll-to-zoom functionality. Using LayOut's new Zoom Selection command, you can jump your view to a selection, decreasing the likelihood you will experience lags on zoom in (and then zoom out, when you end up zooming too far in! 😡). This command is available from the context menu, the View menu, the page navigation menu, and as a customizable toolbar icon. There is also a new default shortcut: Alt + Z on Windows and Option + Z on Mac.

Viewport-based Auto-Text labels

In addition to existing labels that pull attributes from SketchUp entities, we are introducing new tags that can either be selected from the Auto-Text menu in label creation or utilized in scrapbook labels. To enable these tags, label leaders must be pointing to geometry in a viewport.

Labels can be used in scrapbooks (and with transparent leaders). This means that users may drag Auto-Text labels in from a scrapbook, then hit enter to drag the label leader to automatically display a value associated with a viewport, even in cases where no leader line is desirable..

<SceneName> & <SceneDescription>

<SceneName> Pulls the name of the scene that a viewport is set to display. If you slightly modify the camera position of a viewport, this tag will still display the last chosen scene.

Since many drawing titles would be too long to display in a SketchUp scene name, we are also exposing <SceneDescription> as an auto-text tag. Using this scene attribute -- defined in SketchUp's Scenes panel -- allows you to use abbreviated scene names to manage large numbers of scenes and longer strings for scene descriptions/drawing titles.

<Scale> and <Ratio>

These tag displays the current orthographic scale of a viewport. Use the <Scale> tag to display a scale as a unit translation - for instance, 1" = 1' or 1mm = 1m. Use <Ratio> to express the viewport scale as a unit-less scale: 1:12 or 1:1000.

<Coordinates(x,y,z)>

We are also introducing a new way to customize the value of certain Auto-Text tags by specifying a parameter in the tag.

In the case of the existing <Coordinates> tag, you may specify x, y, and/or z values for the tag. So for a given vertex at 12', 6', 32':

  • <Coordinates(z)> → 32'
  • <Coordinates(x,y) → 12', 6'
  • <Coordinates(z,x) → 32', 12'

Output values match the specified model units in SketchUp and correspond to the axes of a viewport's scene. Another improvement: coordinate values can now be pulled from a point on an edge or face.

Page Management Auto-Text

We are introducing some new and improved Auto-Text with the intention of enabling more efficient title block management, as well as the creation of tables of contents.

<PageCount>

Complementing our existing <PageNumber> tag, <PageCount> yields the number of pages in a user-defined range in the document. Similar to <PageCount> users may specify:

<PageCount> includes a customization value for 'End Page' which determines where the count ends. By default, End Page is set to Last Page, whatever that page is. As pages are added to the document in the count range, this tag will update. Learn more about <PageCount>...

<PageName()>

Parameter input for the existing <PageName> tag will display the name of a page that is not the current page. The value you set in the parentheses reflects the relative position of a page in the LayOut document. So, <PageName(3)> will output the name of the third page in your document (as specified in the Pages panel). Learn more about Page Management Auto-Text in LayOut...

Sequence Auto-Text

We are introducing a new Auto-Text tag that automatically increments when duplicated. These tags may be used to rapidly annotate drawings and figures, create numbered drawing titles, index legends, and many other use cases that would previously require text editing between each copy. For guidance on usage and customization, learn more about Sequence Auto-Text in LayOut.

Find & Replace Text

There are several ways to quickly create and copy text across multiple pages in a LayOut document. But, until now, modifying text across a page or an entire document has been a real pain in the butt. With Find & Replace in LayOut, making changes in a selection, a page, or an entire document can go much quicker.

Find & Replace can be activated with the Ctrl + F shortcut (Command + F on Mac) as well as from the Text menu in LayOut. Learn more about Find & Replace...


Auto-Text Scrapbooks

To highlight Auto-Text functionality and capabilities, we are adding two new pages to each of LayOut's English title block scrapbooks: the graphics packages which complement title block templates. These include a collection of viewport-based Auto-Text labels and a table of contents template. Learn more about the objects in Auto-Text scrapbooks...


SketchUp Release Notes

Bug fixes / small features added

Stability
  • Fixed an issue where copy and paste of a section plane could lead to a crash.
  • Fixed a possible file corruption that could occur with extremely large models.
  • Performance improvement when copy and pasting a lot of geometry from one file into another large model.
  • Fixed an issue where corrupt geometry could prevent a paste from happening.
  • Fixed an issue where using the Offset tool to offset something by a very small amount would lead to a crash.
  • Fixed an issue where opening a file that was corrupted would never finish attempting to open the file. Now it will quickly show a file error message.
  • Fixed an issue where certain corrupt SketchUp documents would lead to a crash, instead of showing an error message.
  • Fixed memory leak issue when thumbnail images were created.
  • (Win) Added error trapping to cope with an infrequent Windows related misread of a directory.
  • (Mac) Fixed an issue where closing a SketchUp document while SketchUp was in the background could lead to a crash.
Tools
  • Fixed a scaling issue, where the selected object did not scale to the size of a typed in value.
  • Removed object grips artifact, where the grips would stay visible in the old location after doing a move operation.
  • Rotation handles were not appearing when hovering over a cut hole component with the Move tool.
  • Added help tips to show axis locking before a drawing action is started with the Line, Freehand, 2- and 3-point Arc, Move, and Tape Measure tools.
  • Fixed an issue where drawing a freehand curve across an edge would explode the curve. Now freehand drawing across edges will only create as many curves as necessary.
  • Improved help tips when hovering over cardinal points with the Move tool, to indicate that the object will resize when that point is moved.
  • The Measurements box will now display a Tape Measure measurement until a new measurement is made or the tool is reset (by hitting its shortcut). Live measurement previews for Length, Area, and Coordinates are still available before a measurement is taken and in tooltips (before and after a measurement).
  • Fixed an issue where the Offset tool would offset by an incorrect amount when being used with curved edges.
  • Fixed an issue where a section plane would prevent the Paint Bucket tool from applying or sampling materials on the far side of the section plane.
  • Copy and paste of a section plane would lose its current active state.
  • Embedded section planes would show distorted handles if the parent object was non-uniformly scaled.
  • Fixed an issue where hidden section planes were still being picked up by inference when using the Line tool.
  • Fixed an issue where curved geometry was remaining selected when using the Shift key with the Select tool.
  • Fixed an issue where the protractor symbol used in Move and Rotate tools would appear at the origin instead of at the cursor location.
  • Guides being placed by the Tape Measure and Rotate tools were in a dark gray color that could be hard to see against darker faces. They are now shown in the guides color as set in the current style.
  • When adding a guide with guide visibility disabled in the View menu, the guide would seem to disappear. Now guide visibility is enabled when creating a new guide.
  • Fixed an issue where using the Move tool in Copy mode, clicking on an edge and typing the distance value, would not create the duplicate edge.
  • Added ability to type in the value needed for the second point when creating a 2 or 3 point arc.
  • Status bar text was not being updated for some tools until the cursor was moved.
  • Fixed an issue where edges remain selected when using the Eraser tool in its Unhide mode.
  • Fixed an issue where the Move tool in Copy mode would fail to copy a curve.
  • Fixed an issue where moving or copying of cut face components to a different face on the same plane wasn't cutting holes.
  • Enabled array creation and typing a distance value when using the Move tool in Stamp mode.
  • (Win) Using a keyboard shortcut that includes a modifier key would change the mode of the Move tool.
Miscellaneous
  • Localized templates display shadow settings based on selected language.
  • Working inside a component in a model that is very spread out could lead to clipping issues, even if Hide Rest of Model was being used. Now if the rest of the model is hidden, only the geometry inside the component is considered, and very little clipping should occur.
  • Moving the camera's location into the middle of the model's geometry, then switching to Parallel Projection, would lead to severe clipping. Now the camera is backed away from the geometry, and no clipping should occur.
  • Improved handling of files that had corrupt materials, which would prevent the file from opening.
  • Standard Views will now align to custom axes in any modeling context (in or outside of groups and components).
  • Downloading models from 3D Warehouse while inside a group or component would place the new component at the root level of the document, instead of inside the object being edited.
  • The Advanced Camera Tools extension no longer ships with SketchUp Pro. Advanced Camera Tools is still available on Extension Warehouse.
  • Fixed an issue where any changes made in the View menu were not updating the scene when working in a demanding model.
  • Fixed an issue where exporting an .stl as selected would result in an empty file.
  • Fixed an issue where resetting the axes position of a component which has a different orientation than the global axes was causing unexpected orbit behavior.
  • Fixed an issue where orbiting a model was showing unsmooth transitions after using the Align Axes command.
  • The Align View command is now available in the Context menu when a user right-clicks a face in a selection set that also contains other entities.
  • Fixed an issue where a component would fail to cut a hole if the Untagged tag was hidden.
  • Fixed an issue where switching between scenes and orbiting was causing location issues for the model.
  • Fixed an issue where models weren't opening due to file corruption. Opening corrupted files will now show details of the invalid items causing the problem.
  • Added new contextual menu items to enable selecting objects with the same tag.
  • Added file import functionality in Trimble Connect extension.
  • Fixed an issue with an untranslated string in the IFC 2x3 Export dialog.
  • Export size of 2D images can now be higher than 9999 pixels across, provided the system memory needed to create the image is available.
  • Fixed an issue where Add Location tiles occasionally import blank if one of the imported tiles was a 32 bit image.
  • Renaming a scene then clicking on another scene no longer displays an error.
  • Scenes can no longer be named with a blank name.
  • Right-clicking on a scene name updates the Scene details correctly.
  • Import Visual Reference is a new command in the Trimble Connect Extension that imports 3D models as a locked instance. If working file is published to Trimble Connect, these "references" are removed from the model.
  • (Win) Fixed an issue where a second SketchUp instance would show a recovered file that was currently open for editing in the first instance of SketchUp.
  • (Win) Added error checks to prevent installation of SketchUp into the system root directory (C:/) or into a non-empty directory.
  • (Win) Fixed a problem where installation of the C++ redistributable library failed.
  • (Win) New icon for SketchUp Viewer.
  • (Win) Fixed a crash when clicking the Expert Dimension Settings button in Model Info
  • (Win) Fixed an issue where the Ctrl modifier was not enabling the Move tool Copy mode.
  • (Win) Fixed an issue where clicking the Tag visibility button twice would enter renaming the tag.
  • (Mac) Fixed an issue where textures displayed with an unexpected grid pattern when using nicer transparency on an M1 Mac.
  • (Mac) Application icon is now the same size as other macOS application icons.
  • (Mac) Improved the UI styling of the Delete Tag confirmation dialog.
  • (Win) Fixed an issue where clicking the Tag visibility button twice would enter renaming the tag.
  • (Mac) Fixed an issue so that when a row in the Tags panel is selected, the tag/folder name and "Default" label in Dashes column will be displayed in white to ensure they are more clearly visible.
  • (Mac) Fixed a crash that could occur when using an U.S. International -PC input keyboard.
  • The EULA has been updated with a new set of Trimble's General Product Terms. Exceptions to the General Product Terms are specified on help.sketchup.com.

LayOut Release Notes

Bug fixes / small features added

DWG Import/Export
  • We have updated the DWG Importer and Exporter plugin library for LayOut.
Stability
  • Fixed a crash when inserting a reference file.
  • (Win) Fixed a crash that would happen when reloading a SketchUp model.
  • (Win) Fixed a crash that could occur when editing a Scrapbook and changing pages.
Miscellaneous
  • Fixed a text selection glitch when using the Shift and arrow keys.
  • Fixed an issue where there were no highlights when editing line weights.
  • Fixed an issue with precision when moving an entity.
  • Fixed an issue when a Label associated with an Auto-text entity is moved to a different Auto-text entity, the Label will update properly.
  • Label coordinates are now based on the axis of a viewport's assigned scene or the Last SketchUp View.
  • Coordinates can now be pulled from labels pointing to edges and faces, in addition to vertices (endpoints, guide points, arc centers).
  • (Win) Fixed an error in paper size where the height and width values had decimal points.
  • (Win) Fixed an issue when an inspector panel was minimized then maximized using a shortcut key, the order of the inspectors would change.
  • (Mac) Fixed an issue where the line in 'Shape Style' inspector displayed over the pull-down menu.
  • (Mac) Fixed an issue where a tag line style other than the default would display incorrectly.
  • (Mac) Fixed an issue where the preferences window 'Close' button did not display properly.

SketchUp API Release Notes

Apple Silicon support

We now support universal binaries on macOS that run natively on both Apple silicon and Intel-based Mac computers.

EntitiesBuilder

We added a new interface, Sketchup::EntitiesBuilder, with the purpose of being able to generate bulk geometry with similar speed to Geom::PolygonMesh + Sketchup::Entities#fill_from_mesh but with the simplicity and per-entity control that Sketchup::Entities offer. This is particularly useful for importers where you can expect to see major performance improvements by switching from Sketchup::Entities#add_face to Sketchup::EntitiesBuilder#add_face.

The existing way to add entities (faces, edges, construction geometry, etc) is to define a single entity, then add it to the model. The SketchUp engine processes each addition separately, performing operations like collision detection between the new and the existing geometry, or setting edge properties for every separate entity added. The time required to do this is negligible for small operations. But the performance degrades quickly once a large amount of geometry (1000+ entities) is involved. In internal testing, we found that generating a model with 10K faces is over 40 times faster with this new API. For REALLY large operations, with 100,000+ faces - SketchUp will now complete operations that previously would have hung the application with modest wait times (10-30 seconds).

We added a Generating Geometry section to the Ruby API Documentation.

C API Additions and Improvements
  • Added SUFaceClearTexturePosition()
  • Added SUClassificationsGetNumSchemas()
  • Added SUClassificationsGetSchemas()
  • Added SUSceneGetDescription()
  • Added SUSceneSetDescription()
  • Added SUSchemaGetSchemaName()
  • Deprecated SUComponentInstanceSaveAs()
  • Added SUComponentDefinitionSaveToFile()
  • Added SUModelVersion_Current to enum SUModelVersion
  • Moved SUModelVersion to new model_version.h header file
  • Remove obsolete NamedOptions options provider that never worked correctly
  • Added a new dll to the LayOut C API package - LayOutUtils.dll
  • Added LOAutoTextDefinitionType::LOAutoTextDefinitionType_ModelSceneName mandatory auto-text type
  • Added LOAutoTextDefinitionType::LOAutoTextDefinitionType_ModelSceneDescription mandatory auto-text type
  • Added LOAutoTextDefinitionType::LOAutoTextDefinitionType_ModelScale mandatory auto-text type
  • Added LOAutoTextDefinitionType::LOAutoTextDefinitionType_ModelSectionName mandatory auto-text type
  • Added LOAutoTextDefinitionType::LOAutoTextDefinitionType_ModelSectionSymbol mandatory auto-text type
  • Added LOAutoTextDefinitionType::LOAutoTextDefinitionType_PageCount auto-text type
  • Added LOAutoTextDefinitionType::LOAutoTextDefinitionType_Sequence auto-text type
  • Deprecated LOAutoTextDefinitionGetPageNumberStyle()
  • Deprecated LOAutoTextDefinitionSetPageNumberStyle()
  • Deprecated LOAutoTextDefinitionGetPageNumberStartIndex()
  • Deprecated LOAutoTextDefinitionSetPageNumberStartIndex()
  • Added LOAutoTextDefinitionGetNumberStyle()
  • Added LOAutoTextDefinitionSetNumberStyle()
  • Added LOAutoTextDefinitionGetStartIndex()
  • Added LOAutoTextDefinitionSetStartIndex()
  • Added LOAutoTextDefinitionGetStartPage()
  • Added LOAutoTextDefinitionSetStartPage()
  • Added LOAutoTextDefinitionGetEndPage()
  • Added LOAutoTextDefinitionSetEndPage()
  • Added LOAutoTextDefinitionGetIncrement()
  • Added LOAutoTextDefinitionSetIncrement()
  • Added LOAutoTextDefinitionGetSequenceFormat()
  • Added LOAutoTextDefinitionSetSequenceFormat()
  • Added LOAutoTextDefinitionRenumberSequence()
  • Added missing rendering options DisplaySectionCuts, DrawBackEdges, SectionCutDrawEdges, DrawHiddenGeometry and DrawHiddenObjects to the SURenderingOptions documentation.
  • Removed rendering option FaceColorMode from SURenderingOptions documentation. This option was removed from the SDK in SketchUp 2019.1.
Ruby API Additions and Improvements
  • The version of OpenSSL in Ruby was updated to 1.1.1l.
  • Added method Sketchup::ComponentDefinition#save_copy
  • Added method overload to Sketchup::ComponentDefinition#save_as allowing saving as older versions
  • Added method Sketchup::Face#clear_texture_position
  • Added method Layout::AutoTextDefinition#number_style, Deprecated Layout::AutoTextDefinition#page_number_style
  • Added method Layout::AutoTextDefinition#number_style=, Deprecated Layout::AutoTextDefinition#page_number_style=
  • Added method Layout::AutoTextDefinition#end_page
  • Added method Layout::AutoTextDefinition#end_page=
  • Added method Layout::AutoTextDefinition#start_page
  • Added method Layout::AutoTextDefinition#start_page=
  • Added method Layout::AutoTextDefinition#increment
  • Added method Layout::AutoTextDefinition#increment=
  • Added method Layout::AutoTextDefinition#sequence_format
  • Added method Layout::AutoTextDefinition#sequence_format=
  • Added method Layout::AutoTextDefinition#renumber
  • Added Layout::AutoTextDefinition::TYPE_MODEL_SCENE_NAME
  • Added Layout::AutoTextDefinition::TYPE_MODEL_SCENE_DESCRIPTION
  • Added Layout::AutoTextDefinition::TYPE_MODEL_SCALE
  • Added Layout::AutoTextDefinition::TYPE_MODEL_SECTION_NAME
  • Added Layout::AutoTextDefinition::TYPE_MODEL_SECTION_SYMBOL
  • Added Layout::AutoTextDefinition::TYPE_PAGE_COUNT
  • Added Layout::AutoTextDefinition::TYPE_SEQUENCE
  • Added method Sketchup::Entities#build
  • Added class Sketchup::EntitiesBuilder
  • Added method UI::Command#proc
  • Added method UI::Command#get_validation_proc
  • Added method UI::Command#extension
  • Added method UI::Command#extension=
  • Added method Sketchup::AppObserver#onExtensionsLoaded
  • Added new API to improve extension compatibility with Search, specifically for extensions enabled by libraries such as LibFredo. (UI::Command#extension= to explicitly associate a command with an extension.)
Ruby Console Improvements

Earlier versions of SketchUp printed the return values to Ruby Console commands different depending on the platform. This has been made consistent following the pattern of Ruby's own IRB tool. A side effect of this is that the console now uses `.inspect` instead of `.puts` when printing the returned value which makes it less ambiguous in many cases. For example `nil` vs `""` that would otherwise print a blank line in both cases.

Ruby API Bug Fixes
  • Fixed a bug in UI::HtmlDialog#initialize where max_height and max_width were swapped when use_content_size was set to true.
  • Fixed a bug where UI::HtmlDialog position was set incorrectly when use_content_size was set to true.
  • Fixed a bug in UI::HtmlDialog where use_content_size was not persisted (when preference_key is set). Due to this bug, in some instances, HtmlDialog changed size when it was re-created.
  • Fixed "EntityInfo" not being a supported parameter for UI.show_inspector
  • Fixed "EntityInfo" not being being listed in UI.inspector_names
  • Fixed a bug on Mac where the size and the position of the UI::HtmlDialog were not persisted when SketchUp was closed without first closing the UI::HtmlDialog window.
  • Fixed Sketchup::Face#uv_tile_at could return incorrect values in some edge cases.