Context menu items for entities

All of the context menu items for all entities in SketchUp follow.

Active Cut

The Active Cut menu item is used to activate and de-activate the Section Plane Object, as indicated by the check mark. Activating a Section Plane will automatically de-activate all other planes in that context.

This menu item is available for the Section Plane entity.

Align View

The Align View menu item is used to align the SketchUp Camera to the currently selected face.

This menu item is available for Face, Section Plane, and Surface entities.

Align Axes

The Align Axes menu item is used to align the Drawing Axes to the currently selected face.

This menu item is available for the Face and Surface entities.

Area

The Area sub-menu of the Face context menu is used to calculate the surface area in your SketchUp model. The results of the calculation are displayed in a Area dialog box.

This menu item is available for the Face and Surface entities.

Selection: The Selection menu item is used to calculate the total surface area of the currently selected face.

Layer: The Layer menu item is used to calculate the total area for all faces in the layer of the currently selected face.

Materials: The Materials menu item is used to calculate the total area of the faces in the entire model, hidden or unhidden, with the material of the currently selected face.

This menu item is available for the Face and Surface entities.

Arrow

Click on the Arrow sub-menu menu to select the end point type for the leader line. Choose between None, Dot, Closed Arrow, and Open Arrow.

Change Axes

The Change Axes menu item is used to redefine the origin axes of the selected component. This option is similar to changing the local coordinate system in other 3D applications.

This menu item is available for the Component entity.

Close Component

The Close Component menu item is used to end an editing session and close the component. You can also click outside of the component with the Select tool, or press the Esc key to close the component.

This menu item is available for the Component entity.

Close Group

The Close Group menu item is used to end an editing session and close the group. You can also click outside of the group with the Select tool, or press the Esc key to close the group.

This menu item is available for the Group entity.

Combine Textures

The Combine Textures menu item is used to create a texture which is unique to the set of parallel Face entities. This menu item is primarily used to stitch together photographs.

This menu item is available for a selection set of parallel Face entities (where at least one face has a texture).

Convert to Polygon

The Convert to Polygon menu item is used to convert the entity into a polygon arc, which will remain editable yet generate standard facets when extruded.

This menu item is available for the 3D Polyline, Circle, and Curve entities.

Create Group from Slice

Generates new edges, encapsulated within a Group, wherever the section intersects with a face.

This menu item is available for the Section Plane entity.

Divide

The Divide menu item is used to divide an entity into any number of equal segments. This menu item is not available when an arc bounds a curved surface.

Dynamic Components

The Dynamic Components submenu contains menu items for configuring and creating dynamic components.

Component Options: The Component Options menu item is used to display the Component Options dialog box used to configure a dynamic component.

Component Attributes: The Component Attributes menu item is used to display the Component Attributes dialog box used to develop a dynamic component.

This menu item is available for any Component entity.

Swap Component: Use the Swap Component menu item to swap the currently selected component with another component. For example, use this option to swap all windows of a specific type or manufacturer with windows of another type or manufacturer.

Note: Components that have attributes with the same name and value will retain their settings when swapped. For example, a window with a color attribute set to green will remain green when swapped with another component containing a color attribute set to green.

This menu item is available for any Component entity.

Generate Report: The Generate Report menu item is used to display the Generate Report dialog box used to generate various dynamic components reports.

Edit Component

The Edit Component menu item is used to edit the currently selected component. You can also use the Select tool to double-click on the component, or select the component and press Enter (Microsoft Windows) or Return (Mac OS X) key to edit a component.

This menu item is available for the Component entity.

Edit Group

The Edit Group menu item is used to edit the currently selected group. You can also use the Select tool to double-click on the group, or select the group and press the Enter (Microsoft Windows) or Return (Mac OS X) key to edit a group.

This menu item is available for the Group entity.

Edit Text

The Edit Text menu item is used to edit the dimension text. Type in the new text and press the Enter (Microsoft Windows) or Return (Mac OS X) key to accept your changes.

This menu item is available for the Dimension and Text entities.

Entity Info

The Entity Info menu item is used to display the Entity Info dialog box for viewing and changing the entity's attributes.

This menu item is available for all entities.

Erase

The Erase menu item is used to delete the selected entity from your model.

This menu item is available for the all entities.

Export

The Export menu item is used to save the image entity to a file that can be edited in an image editor.

This menu item is available for the Image entity.

Explode

The Explode menu item is used to break the entity into the separate entities. An exploded entity will appear the same, but it can no longer be edited, and will no longer respond to tool operations as a single entity.

This menu item is available for the 3D Polyline, Component, Group, and Image entities.

Explode Curve

The Explode Curve menu item is used to break the entity into regular edges. An exploded entity will appear the same, but it can no longer be edited, and will no longer respond to tool operations as a single entity.

This menu item is available for the 3D Polyline, Circle, Curve, and Polygon entities.

Flip Along

The Flip Along menu item is used to mirror the selected geometry along an axis. You can use the Axis tool to reposition the drawing axes, allowing you to flip in virtually any direction.

This menu item is available for the Component and Group entities.

Group

This creates a Group entity out of the selected geometry.

Hide/Unhide

The Hide/Unhide menu item hides or unhides the select entity. All hidden entities are displayed in a ghosted pattern, allowing you to select them, if View > Show Hidden Geometry is enabled. This menu item changes to Unhide when selected geometry is hidden. Select Unhide to restore visibility for the entity.

This menu item is available for all entities.

Intersect Faces

The Intersect Faces menu item is used to intersect two elements, such as a box and a tube, and automatically create new faces where the elements intersect. These faces can then be pushed, pulled or deleted to create new geometry.

With Model

Complex geometry in SketchUp can be easily created using the Intersect Faces menu item (also called the 'Intersector'). Use the With Model menu item to intersect all entities overlapping with the currently selected entity (such as a box component and a tube component).

With Selected

Select the With Selection to intersect only those items that are selected.

With Context

Select the With Context menu item to intersect two entities within the current context (excluding all entities outside of the context).

These menu items are available for the Component, Face, Group, and Surface entities.

Leader

Click on the Leader sub-menu to select between View Based, Pushpin, and Hidden leader types. A View Based leader will always retain its 2D screen orientation. A Pushpin leader is aligned in 3D space, and rotates with your model as you change your view.

Lock/Unlock

The Lock menu item is used to lock the component so that it cannot be moved or edited. Additional copies of the component can be dragged into the work area from the Components Browser, however.

The Unlock menu item is used to unlock the component so it can be edited.

Make Component

The Make Component menu item converts the entities into a new Component entity (component definition).

This menu item is available for the Group entity.

Make Unique

The Make Unique menu item converts the currently selected component into a unique component, with a new definition. The original component definition and all other instances will not be affected when you edit the component after using the Make Unique menu item.

This menu item is available for the Component entity.

Make Unique Texture

The Make Unique Texture menu item is used to create a texture which is unique to that face. This menu item is not available if SketchUp already considers the texture to be 'unique' and applies to the side of the face which is visible at the time you select the menu.

The Make Unique Texture menu item is also available for a face which doesn't already have a texture applied. The Texture Size dialog box is displayed when you select a face without a texture and then select the Make Unique Texture menu item. This dialog box prompts you to enter a texture size.

This menu item is available for the Face entity.

Note: The Make Unique Texture menu item will not be available again for a face unless you change the size of the face, edit the material size, or reposition the texture on the face.


Orient Faces

The Orient Faces menu item is used to automatically orient all the connected faces of your model to the orientation of the currently selected face. This option could lead to unexpected results when an edge of a face bounds three or more other faces.

This menu item is available for the Face and Surface entities.

Photo Textures

The Photo Textures menu item is displays the Photo Textures dialog box used to capture a texture from Street View and apply it to the currently selected face.

This menu item is available for the Face entity.

Point at Center

The Point at Center menu item is used to place a point at the center of your arc or circle entity. This menu item is generated by a Ruby script.

This menu item is available for the 3D Polyline, Circle, and Polygon entities.

Reload

The Reload menu item is used to update the currently selected component with a new revision from the file system.

This menu item is available for the Component and Image entities.

Reverse

The Reverse menu item is used to reverse the direction of a Section Plane entity.

This menu item is available for the Section Plane entity.

Reverse Faces

The Reverse Faces menu item is used to flip the front and back sides of the currently selected face. However, when exporting SketchUp geometry to a file format that only supports single-sided faced polygons (like DXF, DWG, and 3DS), it becomes important to know which side of the face will be exported.

This menu item is available for the Face, Section, and Surface entities.

Reset Scale

The Reset Scale menu item is used to remove any scaling operations applied to the component.

This menu item is available for the Component and Group entities.

Reset Skew

The Reset Skew menu item is used to remove any skewing applied to the component.

This menu item is available for the Component and Group entities.

Save As

The Save As menu item is used to save the selected component to a separate SketchUp file, with a new name and location in your file system. This menu item is commonly used to create component files that can be included in the component collection or reused in other models.

This menu item is available for the Component entity.

Scale Definition

The Scale Definition menu item applies any scaling operation, to the currently selected component, to the component definition in the Components Browser.

This menu item is available for the Component entity.

Select

The Select submenu contains several options for selecting geometry related to the entity.

Bounding Edges: The Bounding Edges menu item is used to select all of the edges currently bounding the selected entity.

Connected Faces: The Connected Faces menu item is used to select all of the faces currently connected to the selected entity.

All Connected: The All Connected menu item is used to select all of the elements currently connected to the selected arc.

All on same Layer: The All on same Layer menu item is used to select all of the elements on the current layer.

This menu item is available for the 3D Polyline, Circle, Curve, Face, Line, Polygon, and Surface entities.

Shadows

The Shadows submenu contains cast and receive shadow options for the Image entity.

Cast: The Cast Shadows menu item allows the face of the entity to cast a shadow.

Receive: The Receive Shadows menu item allows the face of the entity to receive a shadows cast by other entities.

This menu item is available for the Image entity

Soften

The Soften menu item is used to soften a faceted surface. Softened edges are not visible unless displayed in profile.

This menu item is available for the 3D Polyline, Circle, Curve, Line, and Polygon entities.

Texture

The Texture submenu contains several options for repositioning textures on a face. This menu item only appears when a texture is painted on the face. See Position Texture tool for additional information.

Position: The Position menu item is used to manipulate textures (reposition, stretch, skew, and so on) directly on a face.

Reset Position: The Reset Position menu item is used to reset the texture to its previous state.

Projected: The Projected menu item is used to wrap images and textures over forms as though projected onto the form.

This menu item is available for the Face and Surface entities.

Text Position

The Text Position menu item is used to position text either at the start of the dimension line (Outside Start), center (Centered), our end of the dimension line (Outside End).

This menu item is available for the Dimension entity.

Unglue

The Unglue menu item is used to free a component from a face (if you've attached a hole-cutting component to a face).

This menu item is available for the Component, Group,and Image entities.

Upload Component

Select the Upload Component menu item to upload the currently selected component to the 3D Warehouse.

This menu item is available for Component entities, including Dynamic Components.

Use As Material (Microsoft Windows)

The Use As Material menu item is used to create a material, in the In Model section of the Material Browser, from the image.

This menu item is available for the Image entity.

Use As Material (Mac OS X)

The Use As Material menu item is used to create a material, in the Colors In Model section of the Material Browser, from the image.

This menu item is available for the Image entity.

With Model

The With Model menu item is used to intersect two elements, such as a box and a tube, and automatically create new faces where the elements intersect. These faces can then be pushed, pulled or deleted to create new geometry.

Zoom Extents

The Zoom Extents menu item is used to zoom your view to a distance where the whole entity is visible and centered in the drawing window.

This menu item is available for the 3D Polyline, Circle, Component, Curve, Face, Group, Image, Line, Polygon, and Surface entities.