How should I prepare a CAD file for import into SketchUp?

      Avviso: SketchUp 2015 è qui! Quando si guarda a questo articolo di Knowledge Center, assicurarsi di scegliere "SketchUp 2015" la scatola rossa sopra per vedere la versione 2015 di quel contenuto. Se non non c'è nessuna selezione versione, questo contenuto si applica a tutte le versioni di SketchUp.


What version of DWG/DXF files should I import into SketchUp? When SketchUp imports an AutoCAD file, it strips the information to its basic geometric components. Because of this, regardless of AutoCAD file format (2010, 2007, etc...), the end result is essentially the same. To maximize compatibility, however, we suggest importing AutoCAD files that are in R13 format.

You may not need to do anything special, but performing a little preparation often helps make the imported data more efficient.

SketchUp automatically discards any entities in the imported CAD file that have no 3D relevance, for example, text, dimensioning, hatching, logos, and so on. However, SketchUp won't discard the layers holding these entities, so you may want to delete those layers from the CAD file prior to import, or you can easily delete them all in SketchUp after import by opening the Layers browser (Window > Layers) and using the Purge command on the flyout menu, which purges all unused layers.

When geometry is many miles or kilometers away from the origin (0,0) in SketchUp, you can experience performance problems. Because of this, if you are importing, for example, Autodesk AutoCAD DWG files such as civil site plans in order to work with the contour lines, if the graphic or geometry is far away from the origin, it is helpful to move it close to the origin before importing into SketchUp. Alternatively, clear the SketchUp Preserve drawing origin option when importing (File › Import › Options › Scale).

CAD imports are generally successful when the file size 15MB or less. Larger file sizes may fail upon import.

AutoCAD objects are not directly supported, but there is a way you can use them. Examples of these objects are doors, windows, stairs, and contour lines created in created in the Autodesk Architectural Desktop or Autodesk Land Desktop. In order to make the entities in these objects available for use, you can explode them in the Desktop application. The first explode results in a block entity. A second explode results in polylines. Block entities are imported into SketchUp as components, which can also be exploded in SketchUp. An alternative is to use the File › Export to AutoCAD command in the Desktop application. If the Desktop application is in plan view prior to export, this command creates 2D line work for SketchUp to import; if it is in a 3D view, it creates 3D faces for SketchUp to import.

Here are a couple suggestions for handling CAD graphics after you have imported them into SketchUp:

  • For imported data that won't be used for 3D extrusion, but that you need to view or show to others, such as property lines, parking lot markers, and so on: The goal with this type of data is to have it available, but to prevent it from impacting performance. To accomplish this, you need to isolate this data so SketchUp doesn't need to use its Face Finder functionality to analyze all of the points that make up this data. You can do this by selecting all these entities and creating a component from them (this is easiest to accomplish if these entities are all on their own layer). Be sure to use the Replace selection with component option when you create the component.
  • For imported data that will be used for 3D extrusion: As long as the imported edges are connected endpoint to endpoint, all you have to do is trace one edge from endpoint to endpoint, and then SketchUp's Face Finder creates the face whose perimeter is defined by the edges connected to that edge.