Come possiamo essere d'aiuto?

Introducing Drawing Basics and Concepts

Drawing a model in 3D is different from drawing an image in 2D. This introduction to drawing basics and concepts explains a few ways you can create edges and faces (the basic entities of any SketchUp model). You also discover how the SketchUp inference engine helps you place those lines and faces on your desired axis.

Table of Contents
  1. Drawing a line
  2. Creating a face
  3. Dividing faces
  4. Opening 3D shapes by erasing edges
  5. Healing deleted faces
  6. Finding and locking an inference
  7. Knowing your inference types
  8. Locking inferences with the keyboard
  9. Ensuring edges are aligned to axes

Drawing a line

Use the Line tool to draw edges (also called line entities). Edges form the structural foundation of all models. Here’s how to draw a line:

  1. Select the Line tool () on the toolbar (or press the L key). The cursor changes to a pencil.
  2. Click to set the starting point of your line. If you click the wrong place, press the Esc key to start over. As you move your cursor around the drawing area, notice the following:
    • A line follows your cursor.
    • The line length is displayed dynamically in the Measurements box. (The Measurements box uses the units specified in your template.)
    • The line that’s following your cursor turns red, green, or blue whenever the line is parallel with the red, green, or blue axis, respectively. If you hover for a moment, a ScreenTip appears, like the On Blue Axis tip shown in the figure. There is no ghost in your machine; that’s the SketchUp inference engine, which you learn more about later in this article.
  3. Click to set the line’s end point. This end point can also be the starting point of another line. Press Esc or select a different tool when you’re done drawing lines. After you set the end point, you can press Ctrl+Z (Microsoft Windows) or Command+Z (Mac OS X) to undo your line and start over.

  4. (Optional) To make your line a precise length, type a value and press Enter (Microsoft Windows) or Return (Mac OS X). You can repeat this process as many times as you like until you draw a new line or select another tool. If you don’t specify a unit, SketchUp uses the unit specified in your template. However, you can type any imperial or metric unit for your line. So you can type 3mm or 5’2” for example. Your value appears in the Measurements box as you type.

Note: The Measurements box also accepts 3D coordinates for lines:
  • An absolute coordinate, such as [3’, 5’, 7’], places the end of the line relative to the current axes. Square brackets indicate an absolute coordinate.
  • A relative coordinate, such as <1.5m, 4m, 2.75m>, places the end of the line relative to the starting point of your line. Angle brackets indicate a relative coordinate.

You can edit the length of a line as long as it doesn’t bound a face. Here’s how to edit a line:

  1. Select the Move tool ().
  2. Hover the Move tool cursor over one of the line’s end points.
  3. Click and drag the end point to change the line’s length.

Tip: You can also adjust the length in the Entity Info dialog box. Context-click the line, and choose Entity Info from the menu that appears. In the Length box, type a new line length.

Creating a face

When you join several lines into a shape, they form a face.

Not a funny face, or a scary clown face, or even a cute puppy face. By default, faces are plain, but super important: They’re the other half of the duo, edges and faces, which enable every SketchUp model ever made to exist.

Tip: By default, SketchUp adds shading to some faces, as shown here, and the faces are opaque, so you know your model has an actual wall, floor, or whatever your face is supposed to represent in your 3D model. (However, SketchUp does include a view that enables you to see through walls, just like Superman. See Viewing a Model for details.)

The shape tools — Rectangle, Circle, and Polygon — also create faces. (See Drawing Basic Shapes for more about those tools.)

Dividing faces

When you draw a line (or a curve) on an existing face, you split the face.

Tip: This concept is important because, after you split a face, you can use the Push/Pull tool to push or pull one part of the face while the other part stays put, as shown here. See Pushing and Pulling Shapes into 3D for details about the Push/Pull tool.

Opening 3D shapes by erasing edges and faces

You can erase an edge or face to create an opening in a shape. To see how erasing an edge affects your model, first select the Eraser tool () in the toolbar or press the E key, and then click an edge:

  • Clicking an edge erases the edge and any face that touched that edge. As Billy Idol almost sang, you can have lines without a face. However, a face must be completely bound by edges.
  • Context-clicking a face and choosing Erase deletes only the face.

In the figure, you see the original cube and how erasing an edge or face changes the cube.

Tip: If you want to hide a line instead of erasing it, hold down the Shift key as you click the line with the Eraser. Or context-click the line and select Hide.

Healing deleted faces

If you accidentally delete a face, here’s how to bring it back:

  • If you haven’t made any other changes that you’d like to keep, simply select Edit > Undo from the menu bar. Or press the keyboard shortcut for Undo, Ctrl+Z (Microsoft Windows) or Command+Z (Mac OS X).
  • Redraw the line that caused the faces to disappear, and SketchUp will re-create the faces.

Finding and locking an inference

SketchUp has an inference engine that helps you work in 3D space. For example, when the Line tool cursor is hovering over the midpoint of another line, the inference engine tells you by displaying a light blue dot and ScreenTip that says, “Midpoint,” as shown here. Every inference has its own color and ScreenTip. (See Knowing your inference types for a full list.)

The inference engine can also help you find geometric relationships between lines. For example, it tells you when a line you’re drawing is perpendicular to another line. In the following figure, notice that a colored dot also appears at the start point of the line, giving you a few bits of information all at once.

Warning: Pay close attention to the inference engine and orbit occasionally to check your drawing from different viewpoints. In the following figure, the lines might appear to be on the red and green plane until you orbit to a different view. To avoid this common pitfall, SketchUp helps by turning your drawing direction or drawing plane red, green, or blue when you're creating edges or planes parallel to those axes (or magenta if you're parallel/perpendicular to an edge or face in your model).

Tip: At times, the inference you need may not come up immediately or SketchUp might choose alignments with the wrong geometry. In these cases, you can encourage an inference, or increase the chances of a particular alignment by pausing your mouse cursor over the location that you want SketchUp to infer from. When the visual cue appears, SketchUp will briefly prioritize that alignment as you continue drawing.

Knowing your inference types

SketchUp displays several types of inferences: point, linear, and shape. SketchUp often combines inferences together to form a complex inference. Also, components and dynamic components have their own inference types.

A point inference is based on the exact point of your cursor in your model. The following table lists the point inference types.

Point Inference Type What It Looks Like What It Means
Endpoint End of a line or arcEnd of a line, arc, or arc segment
Midpoint Middle point on a line or edgeMiddle point on a line, edge, or arc segment
Arc Midpoint Middle point on an arc
Intersection Point where a line intersects another line or face
Intersection with Hidden Section Point where an edge that is generated by a hidden section plane intersects with the drawing tool
On Face A point that lies on a face
On Edge A point that lies on an edge
Center Center of a circle or arcCenter of a circle, arc, or polygon
Guide Point A guide point
On Line A point along a guide line
Note: All these point inference types are magenta in color when the geometry is inside a group or component.

A linear inference snaps along a line or direction in space. In addition to a ScreenTip, a linear inference sometimes displays a temporary dotted line while you draw.

Linear Inference Type What It Looks Like What It Means
On Red Axis Linear alignment to the red drawing axis (Click and drag as you draw to see the inference.)
On Green Axis Linear alignment to green drawing axis (Click and drag as you draw.)
On Blue Axis Linear alignment to the blue drawing axis (Click and drag as you draw.)
From Point Linear alignment from a point; the dotted line’s color corresponds to the axis direction
Through Point Draw from one point, hover over another point then hold Shift to lock the direction from the start of the drawing through the second point.
Parallel Parallel alignment to an edge
Extend Edge Continuation of an existing edge
Perpendicular Perpendicular alignment to an edge
Tangent at Vertex Arc whose vertex is tangent to a previously drawn arc's vertex

Shape inferences help you pinpoint the moment when a rectangle becomes a square, for example. The following table lists all the shape inferences.

Tip: If your drawing needs to follow specific proportions, shape inferences are a huge help, because shapes in 3D perspective don’t look the same as they do in 2D.
Shape Inference Type What It Looks Like What It Means
Square A rectangle whose sides are all the same size
Golden Section A rectangle whose properties match the Golden Ratio as found in mathematics and the arts
Half Circle, Quarter Circle, or Three-Quarter Circle An arc that is exactly one half of a circle, one quarter circle, or three-quarters of a circle, respectively.
Arc Side and Center An arc shows edge and center inferences when a drawing tool hovers on the arc.
Circle/Polygon Center A circle shows and center inferences when a drawing tool hovers on the circle edge.

Note: All inferences apply on geometry inside component entities or group entities. Group and component inference indicators are the same shape, but are magenta color. Group and component ScreenTips also indicate that the inference is in a group or component entity by appending the phrase “in group” or “in component” to the end of an inference ScreenTip. See Adding Premade Components and Dynamic Components for information about components.

And you can see how inferencing has changed in SketchUp 2016

Locking inferences with a keyboard

By locking inferences, you can confidently draw along the direction you intend to draw. Another reason to lock an inference is to maintain one drawing direction while you reference geometry from another part of the model. That’s a more advanced move, but very helpful. The easiest way to lock an inference to the default axes directions is to use the arrow keys:

Locking the drawing direction with arrow keys

Key What it looks like
Locks the drawing direction or drawing plane to the Blue axis
Locks the drawing direction or drawing plane to the Green axis
Locks the drawing direction or drawing plane to the Red axis. A good way to remember left from right is to say “Right locks Red.”
Locks the drawing direction to the Blue axis Toggle to lock the parallel/perpendicular drawing direction or drawing plane to an inferenced edge or plane. Basically, anything that turns magenta. The drawing direction will turn magenta in color as well as the edge of face that is being inference.
Shift Locks the drawing direction or drawing plane to the active drawing direction/plane. So if you’re drawing along the Blue axes and hold down Shift, the Blue inference will lock.
Shift + AltShift + Command Holding shift to lock the drawing plane also locks the tool to the same face plane that is inferenced. For the Rotate and Protractor tools, however, tap the Alt key (Microsoft Windows) or Command key (OS X) to free those tools so that you can move the center to another place in the model while maintaining the same drawing plane

Some tools, like the circle and rotate tools, can lock to a plane (instead of a drawing direction) as shown below. For these tools you can lock the drawing plane by choosing the colored direction for the tool’s axis or “normal”.

Locking the drawing plane with arrow keys

Ensuring edges are aligned to axes

To ensure your edges align to axes, you may find it helpful to change the cursor to the axes colors. Or if you need to check the alignment of existing geometry, change your edges to the axes colors.

To change your cursor to axes colors, follow these steps:

  1. Select Window > Preferences (Microsoft Windows) or SketchUp > Preferences (Mac OS X). The System Preferences dialog box appears.
  2. Select the Drawing item on the left.
  3. In the Miscellaneous area of the Drawing panel, select the Display cross hairs checkbox.
  4. Click OK to close the System Preferences dialog box. The cursor displays cross hairs that are the color of the axes, as shown here.

To make the edges in your model reflect the axis color to which it is aligned, follow these steps:

  1. Select Window > Styles.
  2. In the Styles dialog box, select In Model from the drop-down list of styles libraries.
  3. Click the Edit tab.
  4. Click the Edge Settings icon, shown in the figure.
  5. From the Color drop-down list, select By axis. The colors of the edges in your model change to reflect their alignment to the axes (unless an edge isn’t aligned to an axis, and then the edge color does not change). The following figure shows which edges are (and are not) aligned to the three axes.


Need Help Fast?

SketchUp’s outstanding community of passionate experts have answers to your questions.