Components browser controls

      Avis: SketchUp 2015 est ici ! Quand vous regardez cet article Knowledge Center, soyez sûr de sélectionner « SketchUp 2015 » de la zone rouge ci-dessus pour voir la version 2015 de ce contenu. S'il n'y a aucun sélecteur de version, ce contenu s'applique à toutes les versions de SketchUp.

Use Components browser controls to navigate among components in your component libraries.

Component thumbnail

The component thumbnail displays the currently selected component.

Component name field

The component name field displays the name of the currently selected component.

Component description field

The component description field displays a description of the currently selected component.

Display secondary selection pane button

The Display secondary selection pane button displays a second select panel below the primary select panel. This feature allows you to display both your component collections and the In Model components at the same time. This feature is useful when you want to drag components between collections and the In Model components.

Select tab

Click on the Select tab to display the select panel . Use the select panel to navigate between component libraries, components in your model, and components in the 3D Warehouse.

View options drop-down list

Click on the View options drop-down list to list several options for viewing your components in Components browser.

Small thumbnails: Click the Small thumbnails menu item to display small thumbnail representations of your components.

Large thumbnails: Click the Large thumbnails menu item to display large thumbnail representations of your components.

Details: Click on the Details menu item to display large thumbnails representations of your components along with the component name, author, and description.

List: Click on the List menu item to display a list of all component names.

Refresh: Click on the Refresh menu item to refresh the current list of components.

In Model Button

Click on the In Model button to navigate to the In Model components. The In Model components contain all of the component currently included with your model file.

Note: You can have components in your In Model components that are not being used by your model.

Collections and searches drop-down list
Click on the Collections and searches drop-down list to list all of the component collections in SketchUp. Click on a collection to select the collection. The Collections and searches drop-down list is divided into three sections: Collections at the top, a list of the user's favorite collections or searches (local or in the 3D Warehouse), and a list of the five most-recently viewed local collections and 3D Warehouse searches.

Search field
Type the name of any components you want to find in the search field. For example, to search for all plane components, type [ plane ].

Search button (Microsoft Windows)
Click the Search button to initiate a search of a component whose name you have typed in the Search field.

Search button (Mac OS X)
Click the Search button view a list of recent searches. Select the 'Clear' menu item to clear the list.

Note: SketchUp lists all individual models and collections with the search term.

Details menu
Click on the Details arrow to display the Details menu. The following lists all options found on the details menu in both Microsoft Windows and Mac OS X versions of SketchUp.

Add to favorites: Select the Add to favorites menu item to add the current collection to a list of favorite collections in the Collections and Searches drop-down list.

Create a local collection (Mac OS X): Select the Create a local collection menu item to create a new collection folder.

Expand: Select the Expand menu item to see all sub-components within the components the In Model components.

Open a local collection: Select the Open a local collection menu item to open all the components in a collection folder.

Open or create a local collection (Microsoft Windows): Select the Open or create a local collection menu item to open all the components in a collection folder or create a new collection folder.

Purge unused (In Model only): Select the Purge unused to remove all components in the In Model collection that are not currently used in your model.

Remove from favorites: Select the Remove from favorites menu item to remove the current collection from the list of favorite collections in the Collections and Searches drop-down list.

Save as a local collection: Select the Save as a local collection menu item to save all components in the In Model collection as a collection on your local hard drive.

View in 3D Warehouse: Select the View in 3D Warehouse menu item to view the search results in the 3D Warehouse.

3D Warehouse Terms of Service: Select the 3D Warehouse Terms of Service menu item to launch a Web browser and view the 3D Warehouse Terms of Service document.

Component list
The component list contains a listing of all components in the model, in a favorite, resulting from a search, and so on. Individual components are indicated by a single box around the component thumbnail. Collections are identified by a stack of 3 overlapping boxes around a component thumbnail.

Previous button
Click on the Previous button (displayed after performing a search) to view the previous twelve 3D Warehouse search results.

Next button
Click on the Next button (displayed after performing a search) to view the next twelve 3D Warehouse search results.

Edit tab

The Edit tab contains properties specific to the currently selected component. These properties can only be edited for components that are selected in the In Model components. These are the same properties, whose values you define, when a component is created, for the exception of the Loaded From field. See the 'Create Component dialog box' for further information on these properties.

Glue to
Refer to The Create Component dialog box

Cut opening
Refer to The Create Component dialog box

Always face camera
Refer to The Create Component dialog box

Shadows face sun
Refer to The Create Component dialog box

Loaded from
The Loaded from field displays the location of the component on the file system.

Statistics tab

The Statistics reports quantities of various elements, such as faces, edges, construction lines, within the component. Select All geometry from the drop-down list to see statistics for all geometry in the component or group. Alternatively, select Components from the drop-down list to see statistics for all components in the component. Finally, click on Expand to see components and groups nested within the currently selected component or group.