Authorize SketchUp Pro for Windows with a Network License.

Quick Summary

  1. Install SketchUp Pro on one workstation.
  2. Authorize with your serial number and authorization code (Help > License > Authorize).
  3. Copy the "server.dat" file (search your computer for this file) to a shared location on your network or to a USB flash drive.
  4. Install SketchUp Pro on the other systems, but don't open SketchUp yet.
  5. Paste the "server.dat" file to other users' systems in the same folder you identified in step 3.


Complete Instructions

  1. If you haven't downloaded and installed SketchUp Pro, please do.
  2. Close SketchUp Pro if it's open.
  3. Create a shared folder on a server in your network that is on the same subnet as the computers that will be using SketchUp Pro. To avoid permissions problems, create the folder in the root directory of the server. You may need to contact an IT Administrator for assistance creating a shared folder. All user accounts accessing the network license need full read and write permissions to the folder you create.
  4. Ensure that the time on all computers using SketchUp Pro are synchronized.
  5. Click the Windows Start button on your computer.
  6. Type "run" in the search box and click the Run program.
  7. Enter the path to the shared folder using the Universal Naming Convention (UNC). Here's an example of what a UNC path looks like:

    \\servername\SketchUpLic

  8. A Windows Explorer window should open. If the window doesn't open, please verify the path and your permissions to the folder.
  9. Click File > New >Text Document menu. This will create a file called "New Text Document.txt."
  10. Double-click on New Text Document.txt.
  11. Enter the letters "ABC" in to the text file.
  12. Click File > Save. If you can save successfully, then the permissions on the shared folder are correct.
  13. Click on the text file, and press the Delete button on your keyboard.
  14. Launch SketchUp by right-clicking the SketchUp icon on your Desktop and selecting Run as an administrator (Windows XP: Double-click on the SketchUp icon).
  15. When the Welcome window opens, click the Add License button. If the Welcome window doesn't open, start using SketchUp and click Help > License > Authorize.
  16. Open the license confirmation email that you received shortly after purchasing your license.
  17. Copy and paste your User Name, Serial Number, and Autorization Number into the dialog box.
  18. Click OK.
  19. Browse to the location of the shared folder you created earlier, and click OK.


    If you don't see your server in the browse dialog box, contact your IT administrator and ask that they enable network browsing. Please also ensure that the server with the shared folder is on the same subnet as the networked computers that will be using SketchUp Pro.
    The SketchUp licensing mechanism doesn't support mapped network drives. When you're prompted to browse for the license folder, navigate to the server itself.

To authorize the remaining workstatations, there are two options:

  • Option 1: (Recommended) Copy the server.dat file to the other workstations:

    1. Copy the server.dat file on the original local workstation to a portable media like a jump drive.
    2. Install SketchUp on each of the other workstations, but don't start it.
    3. On each of the other workstations, paste the server.dat file into the correct folder:
      • SketchUp Pro 2013 (Windows Vista / Windows 7 / Windows 8) --
        C:\ProgramData\SketchUp\SketchUp 2013\
        Note that the "ProgramData" folder is a hidden folder.
      • SketchUp Pro 2013 (Windows XP) --
        C:\Documents and Settings\All Users\Application Data\SketchUp\SketchUp 2013
        Note that the "Application Data" folder is a hidden folder.
      • SketchUp Pro 8 and older --
        C:\Program Files\Google\Google SketchUp #\
      • SketchUp Pro 8 and older (64-bit Windows Vista / Windows 7 / Windows 8) --
        C:\Users\USER_NAME\AppData\Local\VirtualStore\Program Files (x86)\Google\Google SketchUp #


  • Option 2: Point the other workstations to the license file.

    1. Install SketchUp on each of the other workstations.
    2. Close all instances of SketchUp to avoid reaching the maximum number of license seats during the authorization process.
    3. Working on one computer at a time, start SketchUp (on Windows Vista/Windows 7, right-click and select Run as an administrator).
    4. In SketchUp, open the Help menu, point to License, and then click Set Network License File.
    5. Point to the SketchUp#.lf file in the license folder on the server.