¿Cómo podemos ayudar?

Slicing a Model to Peer Inside

In SketchUp, section planes cut a model along a plane so that you can peer inside the model — without moving or hiding any geometry. In a 3D model, an active section plane hides everything on one side of the plane, as shown in the following figure.

You can use section planes for all types of applications:

  • Cut a building horizontally to see the floor plan. In architectural drawing, this two-dimensional top-down cut is called a planimetric view.
  • Cut a building vertically to see inside the rooms of several floors at once. This type of cut is called a sectional view (not to be confused with SketchUp’s section planes).

Tip: To create a planimetric view like an architect, place the section plane 48 inches above the floor’s surface. This placement usually enables you to see windows and doors in the slice without cutting through countertops or furniture. To create a sectional view, don’t cut through columns, because they’ll look like walls instead of objects that people can walk around; do cut through stairs or elevators, because this shows how people move through the building.

In SketchUp, you can insert multiple section panes, but only one section plane can be active in each context. You create more than one context in a model by creating groups or components, each of which has a separate context. For example, say your model contains several ovens, each of which is a separate group, as shown in the following figure. You can display an active section plane in each group to see that none of the ovens contains a warm apple pie or chocolate chip cookies. (Darn it!) See Grouping Geometry and Creating a Basic Component for details about creating groups or components and how to open or close a group or component context.

Tip: Want to show off multiple interior views of a model? SketchUp enables you to show section cuts in animations. Animating Sections and Scenes explains how to create animations of your model.

The following video introduces you to section planes and gives you a sneak peek at section plane animation. In the upcoming sections, you find detailed steps that walk you through the many things section planes can do.

Table of Contents
  1. Adding a section plane
  2. Creating new geometry from a section plane
  3. Hiding section planes and cuts
  4. Exporting section cut effects

Adding a section plane

Inserting a section plane is easy as pie. Make sure nothing in your model is selected, and open the group or component context where you want to add the section plane. Also, if you want to place the section plane at a specific height, such as 48 inches above the floor surface, use the Tape Measure tool to set a guide line that will help you place the section plane precisely where you want it.

When you’re ready to add a section plane, follow these steps:

  1. Select the Section Plane tool () or select Tools > Section Plane. Microsoft Windows users find the Section Plane tool on the Sections toolbar. On both Microsoft Windows and Mac OS X, the Section Plane tool is on the Large Tool Set palette.
  2. With the section plane cursor, shown in the following figure, click a face to place your section plane.

    Tip: If you have trouble keeping the section plane in your desired orientation, hover over a face that matches the orientation you want and hold down the Shift key to lock the section plane cursor’s direction.

After you click a face, your section plane appears, as shown in the following figure.

After you place a section plane, you can reposition it or adjust it as follows:

  • Adjust the placement with the Move tool or the Rotate tool.
  • Reverse the cutting direction by context-clicking the section plane and selecting Reverse from the menu that appears. For example, if you make a vertical cut, you can reverse the cut to display the inside of the other half of your building.
  • Align SketchUp’s camera with the section plane by context-clicking the section plane and selecting Align View. In the preceding figure, aligning the view to your section plane takes you to a top view of the model.
  • Select which section plane is the active cut, if you have more than one, by context-clicking the section plane you want to make active and selecting Active Cut from the menu.

Tip: When you use the Align View command in Parallel Projection perspective, you can quickly generate sectional elevation or one-point perspective views of your model.

Creating new geometry from a section plane

Where a section plane intersects with a model, SketchUp enables you to create geometry, which is automatically organized into a group. You can then move that group to a new location in your model, so you have a copy to work with, as shown in the following figure. Or explode the group so you can use the geometry to divide your model.

To create geometry in this way, context-click a section plane and select Create Group from Slice from the menu that appears.

Tip: If you have trouble seeing or selecting the group, select the group in the Outliner.

Hiding section planes and cuts

When a section plane cuts your model, the cut isn’t permanent, and you can control the visibility of the plane and the cut independently of each other. Hiding the section plane makes the transparent plane with its color handles disappear. Hiding the section cut makes your model look whole again.

Here’s how to control the visibility of your section planes and cuts:

  • Hide all section planes: By default, a colorful section plane appears every time you create a section plane. To toggle the visibility of all the section planes in your model, select the Display Section Panes tool (). Click this tool again to redisplay the section panes. Alternately, select View > Section Planes from the menu bar.
  • Hide a single section plane: If you have multiple section planes but want to hide only one, context-click the section pane and select Hide. When you hide a single selection pane, its visibility no longer toggles on and off with the Display Section Panes tool until you unhide the section plane by displaying hidden geometry and selecting Unhide from the context menu.
  • Hide all section cuts: Click the Display Section Cuts tool ().

Tip: Microsoft Windows users can find all the section tools on the Section toolbar. Mac OS X users can add section tools to the main toolbar. See Customizing Your Workspace for details.

Exporting section cut effects

No matter what version of SketchUp you have (Make or Pro), you can export an image of your model displaying section cut effects. You can use these images in portfolios, presentations, websites, or basically anywhere you might want to show off an image of your work. Just make sure your model shows the section cut as you want it to appear in your image. See Using SketchUp Data with Other Modeling Programs or Tools for details about exporting a model as an image or other file type.

With SketchUp Pro, you can also export a section slice, which is a 2D vector image of geometry along a section plane. Here are a just a few ways you might use a section slice:

  • Create scaled drawings in a CAD program. If you created a 3D model with precise measurements and angles, the section slice feature enables you to scale the slice. (Technically, you can scale imprecise models, too; the scale just doesn’t mean anything.)
  • Edit the slice as a vector image. Because the 2D slice is exported as a vector graphic, you may be able to open the exported file in programs like Adobe Illustrator.

Tip: When the scale of your 2D slice is important, pay close attention to your view in SketchUp. If your view is set to Perspective, you can’t export to scale. If you’re viewing your model in Parallel Projection view, only faces whose normals are perpendicular to the view angle are measurable. Viewing a Model explains what the different views show and how to change your view.

To export a section slice from SketchUp Pro, follow these steps:

  1. If your section plane is within a group or component context, double-click the group or component to open its context.
  2. Select the section plane with the section cut that you want to export.
  3. Select File > Export > Section Slice. The Export 2D Section Slice dialog box appears, as shown in the following figure.
  4. Choose where you want to save the file. By default, the file is saved in your Documents folder.
  5. Type a name for the exported file in the File Name box (Microsoft Windows) or Save As box (Mac OS X).
  6. Select what type of file you want to export from the Export TypeSave as type box (Microsoft Windows) or Format box (Mac OS X). The default option is .dwg or you can select .dxf. Both of these are AutoCAD file types.
  7. (Optional) Click the Options button to open the 2D Section Slice Export Options dialog box. The following list outlines what your options mean. After you’re done selecting options, click OK to return to the Export 2D Section Slice dialog box.
  8. Click the Export button. Your file is saved in the location you selected in Step 4.

When you export a 2D slice, you can choose from the following options:

  • True Section (Orthographic) exports the section slice as a true orthographic drawing. This is useful for creating templates for CAD drawings or any other time you want to generate accurate, measurable slices.
  • Screen Projection projects the section cut as you see it on your SketchUp screen, including any perspective distortion. This is most useful for diagrams that you don’t need to measure.
  • AutoCAD Version enables you to select the version of AutoCAD you plan to use from the drop-down list.
  • Drawing Scale options enable you to configure the scale of the exported section slice. If Full Scale is selected, SketchUp exports the file at a 1:1 scale. The In Drawing and In Model options enable you to specify a drawing scale, where In Drawing is the measurement of the exported geometry and In Model is the object’s actual measurement. For example, for a scale of 1:4, enter 1" in the In Drawing box and 4" in the In Model box.
  • Section Lines options enable you to choose how the section cut lines in your exported slice appear. None exports the lines at normal width. Polylines with Width turns the lines into polylines. Wide Line Entities (only available when exporting .dwg files to AutoCAD 2000 or later) makes the lines in the exported file wider than normal. If you want to set the line width automatically, leave the Automatic checkbox selected. Or deselect Automatic and enter a value in the Width box to set an exact line width.

On Microsoft Windows, you also see Section Line options for separating profile edges on a layer and always being prompted for section slice options.

  • The Separate on a Layer option creates a single additional layer for profile edges. This layer is useful if you would like to plot profile lines using a different pen weight or quickly change the line width of all profile lines in a separate CAD or illustration program.

    Tip: The Separate on a Layer option is different from layer assignments in SketchUp. SketchUp Layer assignments do not translate directly when exporting 2D hidden line vectors.
  • Enable the Always Prompt for Section Slice Options checkbox, and SketchUp displays the 2D Section Slice Options dialog box every time you export a section slice. When this feature is disabled, by default, SketchUp uses the whatever options were selected last time.


Need Help Fast?

SketchUp’s outstanding community of passionate experts have answers to your questions.