¿Cómo podemos ayudar?

Getting Started in SketchUp

When you first run SketchUp, the Welcome to SketchUp dialog box appears, as shown here. This dialog box is your starting point for creating a model and appears every time you start SketchUp (unless you deselect the Always show on startup check box).

Welcome to SketchUp dialog box

In the Welcome to SketchUp dialog box, you can choose a template for your model, license a copy of SketchUp Pro (see Understanding Your License for details), and learn more about SketchUp.

Tip: If you’re new to SketchUp, this article is a great place to warm up your 3D modeling skills. You find an overview of how to select a template, move around the SketchUp interface, create a basic model, and save your model.
Table of Contents
  1. Selecting a template
  2. Exploring the SketchUp interface
  3. Learning how to use SketchUp tools
  4. Viewing the Quick Reference Card
  5. Creating your first 3D model in SketchUp
  6. Saving and reopening a model

Selecting a template

Every model in SketchUp is based on a template, which has predefined settings for your model’s background and units of measurement. Here’s how to select a template in the Welcome to SketchUp dialog box:

  1. At the top of the dialog box, the Default Template field tells you the name of the currently selected template. To change the template, click the Choose Template button or click the arrow next to the Template tab. The Templates tab opens with a list of templates that come with SketchUp, as shown here.
  2. Scroll through the list and select your desired template. (Note that the examples in the rest of this article are based on Simple Template - Feet and Inches.)
  3. Click the Start using SketchUp button, and SketchUp opens, ready for you to start 3D modeling.
Templates tab

Tip: If you deselect the Always show on startup check box, you can still access the Welcome to SketchUp dialog box. On the Help menu, select Welcome to SketchUp, and the Welcome to SketchUp dialog box is instantly at your service. After you become comfortable creating 3D models in SketchUp, you can create a custom template that reflects your preferences.

Note: Click the arrow next to the Learn tab to display several options for learning about SketchUp.

Exploring the SketchUp interface

When SketchUp opens, ready for you to start creating a 3D model, you see a screen that includes the following:

  1. Title bar
  2. Menu bar
  3. Getting Started toolbar
  4. Drawing area
  5. Status bar
  6. Measurements box
  7. Window resize handle

SketchUp interface in Windows

SketchUp interface in Mac OS X

Title bar

The title bar contains the standard window controls (close, minimize, and maximize) and the name of the currently open file. When you start SketchUp, the name of the currently open file is Untitled, indicating that you have not yet saved your work.

The majority of SketchUp tools, commands, and settings are available within the menus on the menu bar. The menus are: SketchUp (Mac only), File, Edit, View, Camera, Draw, Tools, Window, and Help.

Getting Started toolbar

When you begin using SketchUp, the Getting Started toolbar is the one you see by default. It contains the basic tools you need to begin creating 3D models.

To display additional toolbars, select View > Toolbars. In the Toolbars dialog box that opens, select the toolbars you want to see and click Close. In Mac OS X, you can display tool palettes by selecting View > Tool Palettes. (Learn more about the toolbars and how to customize them in the Customizing SketchUp section of the Knowledge Center.)

Tip: This article introduces you to a few basic tools. As you continue learning how to create 3D models in SketchUp, the Instructor can teach you (or remind you) how to use each tool. See Learning how to use SketchUp tools for details.

Drawing area

The drawing area is where you create your model. The 3D space of the drawing area is identified visually by the drawing axes, which provide a sense of direction in 3D space while you work.

The drawing area also contains a simple model of a person to give you a sense of 3D space.

Status bar

When you’re getting started with SketchUp, the two important elements on the status bar are the tips in the middle and the Measurements box on the right:

  • Tips for using the tools: In the middle area of the status bar, click the question mark icon to display the Instructor window, which offers basic information about using whatever tool you select in the toolbar. The middle area also displays a brief sentence about using the selected tool. This area is helpful when you’re not sure how a tool works.
  • Measurements box: This box is a critical tool for creating accurate models. The box displays dimensions as you draw. You can also use this box to manipulate currently selected entities (such as creating a line that’s a specific length) or to create evenly spaced copies of entities (such as columns, fencing, or housing blocks in a post-industrial dystopia).
Status bar

Tip: Did the Measurements box disappear? The most likely reason is that your SketchUp window size is larger than your available screen viewing area. To recover your view of the Measurements box, click the Maximize button in the title bar.
If you’re a Windows user and enable the Auto-Hide the taskbar option, the Measurements box can slip behind the taskbar when you have the taskbar displayed. In this case, the Measurements box reappears when you’re done using the taskbar.

Note: On the left side of the status bar, you find buttons to geo-locate, claim credit, and sign in to your Google Account, respectively. These options help you work with advanced SketchUp features that are beyond the scope of this article.

Window resize handle

To the right of the Measurements box is the window resize handle, which you can click and drag to change the size of the application window.

Learning how to use SketchUp tools

As you use SketchUp, the Instructor and the status bar give you pointers on using each tool.

The Instructor teaches you how to use the currently selected tool. To turn on the Instructor, shown here, select Window > Instructor on the menu bar open the Instructor dialog box in the Default Tray , or click the question mark icon in the status bar. Here’s what the Instructor has to offer:

  • An animation that shows basic use of the selected tool
  • A description of what the tool does
  • Steps for using the tool, which correspond to the animation
  • Modifier keys that enable the tool perform additional functions
  • Links to Knowledge Center articles about advanced functions of the tool

Intstructor window

If the Instructor offers more detail that you need, remember that the status bar also offers tips on using the selected tool. See the Status bar section earlier in this article for details.

Viewing the SketchUp Quick Reference Card

The Quick Reference Card is an easy-to-print guide to all the SketchUp tools and their modifier keys. Keep it handy as you start using SketchUp and you’ll learn to model quickly and efficiently. Here's what the Quick Reference card looks like:

To download a PDF of the Quick Reference card, click the link that corresponds to your operating system:
Looking for the LayOut quick reference cards? Click here.

Creating your first 3D model in SketchUp

If you’ve never done 3D modeling in SketchUp (or any other modeling program), the following steps offer a quick overview the basics:

  1. Select the person, context-click the selection, and select Erase in the context menu that appears.
  2. In the Getting Started toolbar, select the Rectangle tool ().
  3. On the ground plane, in the space between the red and green axis, click the Rectangle tool cursor (). Then move your cursor to the right and click again. A rectangle appears on the ground, as shown here.
    A rectangle drawn on the groundplane
  4. On the Getting Started toolbar, select the Push/Pull tool (), and place the Push/Pull cursor over the rectangle you just created, as shown in the following figure.
  5. Click and drag your rectangle up into a 3D shape. Keep an eye on the Measurements box and release the cursor when your shape is about 5 feet tall.
    Place the Push/Pull cursor over the rectangle.
  6. Without clicking or selecting anything, simply type 6’ and press Enter. Notice how the height of your shape changed to exactly 6 feet tall, and the value you entered appears in the Measurements box.
  7. In the Getting Started toolbar, select the Orbit tool (). Place the Orbit cursor above your shape. Then click and hold while you move the mouse down. Notice how the view of your shape changes, as shown in the following figure. Practice clicking and dragging with the Orbit tool as much as you like. It’s a pretty fun tool!
    The Orbit tool changes the view of your 3D model.
  8. In the Getting Started toolbar, click the Zoom Extents button (). If you orbit around until you lose track of where you are in your model, the Zoom Extents button is a handy way to reorient yourself.
  9. If you have a scroll-wheel mouse, scroll down to zoom out a bit. Working in SketchUp is much easier with a scroll-wheel mouse. However, if your mouse lacks a scroll wheel, click the Zoom tool () and you can zoom in and out that way, too.
    Tip: No matter what tool is selected, holding down the scroll wheel activates the Orbit tool until you release the scroll wheel.

  10. In the Getting Started toolbar, click the Paint Bucket tool ().
  11. In the Materials dialog box that appears, select Colors from the drop-down menu, as shown here. Then select a color from the options that appear on the Select tab.
    Select Colors in the Materials dialog box.
  12. Click one side of your model with the Paint Bucket cursor to apply your selected color. Experiment a bit with the different options in the drop-down menu if you like. For example, select Groundcover from the drop-down menu and apply pebbles to your model. Select Tile from the drop-down menu and apply a tile pattern that you like. Orbit around and apply different materials to each side of your model, as shown here.
    Apply materials to a 3D model.
  13. Close the Materials dialog box and select Window > Styles open the Styles dialog box in the Default Tray . From the drop-down menu, select Sketchy Edges and then select a style option. In the following figure, Marker Wide is selected. Notice that the style completely overrides all the materials and colors applied. To see them again, select In Model from the drop-down menu and then select the Simple Style option.
    The Marker Wide style is selected.

Saving and reopening a model

To save your model, follow these steps:

  1. On the menu bar, select File > Save. If this is the first time you’re saving a model, the Save As dialog box appears, as shown here. To save an already saved model with a new name, select File > Save As.
    Save As dialog box
  2. Use the Save In area at the top of the dialog box to select where you’d like to save your model.
  3. In the File Name box, type a name for your model. SketchUp model files end with the .SKP file extension.
    Note: If you’d like your model to be compatible with earlier versions of SketchUp, select a version from the Save As Type drop-down list.
  4. Click the Save button.
    Tip: After you save a model, you can reopen it later and continue working on it. (Simply double-click the file wherever you’ve saved it, or in SketchUp, select File > Open.) Or if your model is complete, you can show it off by exporting it as a graphic or creating a virtual walk-through.

Backing up a SketchUp file or restoring an Auto-save file

SketchUp creates a backup file the second time you successfully save your SketchUp file and any subsequent saves. This file is an exact copy of the previously saved version of the file. The backup file uses the naming convention FILENAME.skb on Windows and FILENAME~.skp on OS X, and it's located in the same folder as the original file.

By default, SketchUp automatically saves your files every five minutes while you're actively working. If, for example, you're working on a file named FILENAME.skp, the automatic save creates a file named AutoSave_FILENAME.skp. The auto-save file is kept until you successfully save your original file or specifically confirm that you don't want to save changes. If SketchUp crashes while you're working on a model the auto-save file is not deleted. You can recover your work from the point the last auto-save was performed by opening the auto-save file in the same location as your original file. If you've never saved your work the auto-save file is stored in your "My Documents" folder.~/Library/Application Support/SketchUp 201620152014/SketchUp/Autosave/


Need Help Fast?

SketchUp’s outstanding community of passionate experts have answers to your questions.