Edit menu (Mac OS X)

      Aviso: SketchUp 2015 está aquí! Cuando usted mira este artículo de Knowledge Center, asegúrese de escoger "SketchUp 2015" la caja roja arriba para ver la versión 2015 de ese contenido. Si no hay ningún selector de versión, este contenido se aplica a todas las versiones de SketchUp.

The Edit menu contains items allowing you to perform editing functions on SketchUp geometry. These menu items include those for creating and editing groups and components, visibility operations, and standard cut, copy, paste commands.

Undo

Use the Undo menu item to undo the last drawing or editing commands performed. SketchUp allows you to undo all operations you have performed, one at a time, to the state at which you saved your file. The number of possible sequential Undo commands is limited to 100 steps.

Keyboard Shortcut: Command+Z

Note: Undo will undo any operation that creates or modifies geometry, but it does not undo changes to your point of view. Use the Previous menu item under the Camera menu to undo a point of view change.

Redo

The Redo menu item returns the last undo to its previous state.

Keyboard Shortcut: Shift+Command+Z

Cut

The Cut menu item removes the selected elements from your model and places them in the clipboard. The contents of the clipboard can then be inserted back into any open SketchUp document by using the Paste menu item.

You can use cut, copy and paste to move geometry between open SketchUp windows. Contents of the clipboard will remain on the clipboard until replaced with other content using an additional Cut or a Copy command.

Keyboard Shortcut: Command+X

Copy

The Copy menu item copies the selected items to the clipboard without deleting the items from the model. The contents of the clipboard can then be inserted back into any open SketchUp document by using the Paste menu item.

You can use cut, copy and paste to move geometry between open SketchUp windows. Contents of the clipboard will remain on the clipboard until replaced with other content using an additional Cut or a Copy operation.

Keyboard Shortcut: Command+C

Paste

Use the Paste menu item to paste the contents of the clipboard into the current SketchUp document. The pasted geometry will be attached to and placed by the point of the cursor, allowing you to position the new geometry when it is pasted.

You can use cut, copy and paste to move geometry between open SketchUp windows. Contents of the clipboard will remain on the clipboard until replaced with other content using an additional Cut or a Copy operation.

Keyboard Shortcut: Command+V

Paste in Place

Use the Paste in Place menu item to paste an item at the same location where it was cut or copied.

Delete

Use the Delete menu item to remove the currently selected entities from your model.

Delete Guides

Use the Delete Guides menu item to delete all of the guides that are in the drawing area.

Select All

Use the Select All menu item to select all selectable entities in the model. Hidden entities, any items on a hidden layer, or geometry that is clipped away using a section plane cannot be selected with the Select All menu item.

Keyboard Shortcut: Command+A

Select None

The Select None menu item clears the selection set, deselecting any currently selected items in the model.

Keyboard Shortcut: Shift+Command+A

Hide

Use the Hide menu item to hide any selected object. Hiding geometry can help simplify your current view, or enable viewing and working inside tight areas.

Keyboard Shortcut: Command+E

Unhide

The Unhide submenu contains options for unhiding hidden entities.

Selected

The Selected menu item unhides any selected hidden object. Ensure Show Hidden Geometry is enabled under the View menu to view and select hidden geometry.

Last

The Last menu item unhides the last entities hidden with the Hide command.

All

The All menu item unhides all hidden entities in your current document.

Keyboard Shortcut: Shift+Command+E

Lock

The Lock menu item is used to lock any component or group that you do not want to be able to be moved or edited.

Unlock

The Unlock submenu contains options for unlocking components and groups.

Selected

Use the Selected menu item to unlock all components and groups in a selection set.

All

Use the All menu item to unlock all components and groups in your drawing area.

Make Component

Use the Make Component menu item to create a component entity from the selected entities.

Keyboard Shortcut: Shift+Command+G

Make Group

The Make Group menu item creates a Group entity from the selected entities.

Keyboard Shortcut: Command+G

Close Group/Component

Use the Close Group/Component menu item to exit from a group or component's context or editing session.

Keyboard Shortcut: Control-Shift+Command+G

Intersect Faces

The Intersect Faces sub-menu contains menu items for intersecting geometry with other geometry.

With Model

Complex geometry in SketchUp can be easily created using the With Model menu item (also called the 'Intersector'). Use the With Model menu item to intersect all entities overlapping with the currently selected entity (such as a box component and a tube component).

With Selected

Select the With Selection to intersect only those items that are selected.

With Context

Select the With Context menu item to intersect two entities within the current context (excluding all entities outside of the context).

Entity Commands Sub-Menu

The Entity Commands sub-menu contains all of the commands available to manipulate the currently selected entity (which are the same as the commands found in the entity's context menu). The sub-menu's name and contents will change depending on the entity that you have selected.

Special Characters (Mac OS X)

The Special Characters menu item opens the Mac OS X Character Palette allowing you to insert special characters, such as mathematical symbols, letters with accent marks, arrows, and other 'dingbats,' into your model. The Mac OS X help system contains additional help on this feature.