How Can We Help?

Downloading, Installing, and Authorizing SketchUp 2016


Downloading SketchUp

To get started, please download the appropriate installer for SketchUp 2016:

SketchUp Make includes 30 days of Pro Trial time and will revert to the free functionality at the end of the trial.
SketchUp Make and SketchUp Pro can't be installed on the same computer.

Installing SketchUp

Please note:
  • A single user license can only be used by the registered user.
  • The registered user can authorize up to 2 personal computers.

A Note about permissions

PC - In order to successfully install and authorize SketchUp Pro, you must first log in to Windows as a user who has either Administrator or Power User rights.

Once successfully installed and authorized, SketchUp Pro requires a Windows profile with at least Power User permissions. You may need to contact your Help Desk or IT department to assist you with these changes.

Mac - In order to successfully install SketchUp Pro or SketchUp on a Mac, you must first log in to Mac OS X as a user who has Admin privileges. Note that you will be prompted for a username and password during the installation process as well.

Tip: Installing SketchUp 2016 does not install over older versions of SketchUp. Multiple versions of SketchUp can be installed on the same computer. But if you don't need the older versions, uninstalling those versions makes a tidier computer.

Windows After downloading the file, follow these steps to install SketchUp:

  1. Log in to the computer with a user account that has administrator rights.
  2. Double-click on the EXE install file.
    Windows Windows 7/Windows 8: right-click and select Run as an administrator.
  3. Click Next in the Welcome dialog box.
  4. Click on the I accept the terms of this license agreement button in the End User License Agreement if you agree to the terms.
  5. Click the Next button to install SketchUp in the default location.
  6. Click the Install button if you're satisfied with the settings.
  7. Click on the Finish button when prompted.
    Windows Windows 7/Windows 8: Be sure to close SketchUp Pro after installing prior to authorizing.
  8. Launch SketchUp once before logging out of the administrative user account. If you have a SketchUp Pro license, please be aware that you must authorize while logged in to an administrative account. See the links below for help authorizing.

Mac - After downloading the file, follow these steps to install SketchUp.

  1. Double-click on the DMG install file. This will mount the installer drive and launch a Finder window.
  2. Click and drag the application to the Applications folder. You'll be asked to provide your user account password.

Transferring SketchUp to a new Computer

A Single-user license is associated with one person. That individual can install the license on up to 2 computers he or she is using, but only one computer can run SketchUp Pro at a particular time. To use your license on another computer, or transfer your license to a new computer, please note the following steps:

  1. If you'll no longer be using it, remove your license from your current computer following the steps in the How to Remove a License article.
  2. Install SketchUp on the new computer. Please visit the download page to get the install file.
  3. Use your license information to authorize it.
  4. If you're no longer going to use SketchUp on the original computer, you should uninstall it.
If you need to run SketchUp on more than one computer at the same time, you may consider purchasing additional single-user licenses.

Removing a license from SketchUp

SketchUp Pro single user licenses are "locked" to the machine on which you licensed SketchUp. If you purchase a new machine and want to transfer your SketchUp license to that new machine, you will want to remove your license from your old machine. To remove the license:

  1. Select SketchUp > License (OSX) or Help > License (Windows)
  2. Click the link labeled "Remove License" - you will see a confirmation dialog.
  3. Click the Remove License button - your license will be removed.
If you wish to re-apply your license to this computer you may still do so by clicking "Add License" at the top right of the screen.

Authorizing SketchUp - Single User

    Windows:
  1. If you haven't downloaded and installed SketchUp, please do so.
  2. Right-click on the SketchUp 2014 icon on the Desktop and select Run as Administrator.
  3. Double-click on the SketchUp 2015 icon on the Desktop.
  4. Double-click on the SketchUp 2016 icon on the Desktop.
  5. On the "Welcome to SketchUp" dialog, click the Add License button at the top of the dialog.
    If you don't see the "Welcome to SketchUp" dialog, select Help > License.
  6. Open the license confirmation email that you received shortly after purchasing your license.
  7. Copy and paste your User Name, Serial Number, and Authorization Number into the dialog box.
  8. Copy and paste your Serial Number, and Authorization Code into the dialog box.
  9. Click Add License.
  10. Click Add License. This will download a license file from the cloud to your computer.
    Mac -
  1. If you haven't downloaded and installed SketchUp, please do so.
  2. Open Finder and click on Applications.
  3. Browse to the SketchUp 2014 folder.
  4. Browse to the SketchUp 2015 folder.
  5. Browse to the SketchUp 2016 folder.
  6. Click on the SketchUp icon.
  7. On the "Welcome to SketchUp" dialog, click the Add License button at the top of the dialog.
    If you don't see the "Welcome to SketchUp" dialog, select SketchUp > License...
  8. Open the license confirmation email that you received shortly after purchasing your license.
  9. Copy and paste your User Name, Serial Number, and Key into the dialog box.
  10. Copy and paste your Serial Number and Authorization Code into the dialog boxes.
  11. Click Add License.
  12. Click Add License. This will download a license file from the Internet to your computer.

Authorizing SketchUp on a Network as an Administrator

Authorizing a network license on OS X is the same method as used for the single user license.

If you're distributing SketchUp across a larger network we recommend using a disk imaging package such as Norton Ghost or Deep Freeze. Once you've installed SketchUp on all client computers you can simplify the licensing process by including a file which will pre-populate the serial number and authorization code for users so they won't need to type it in themselves.

To use this procedure:

  1. Ensure that SketchUp Pro 2015 is installed on all computers.
  2. Ensure that SketchUp Pro 2016 is installed on all computers.
  3. Create a file named activation_info.txt
  4. In that file, add your network serial number and authorization code in the following format: {"serial_number":"<your serial number>", "auth_code":"<your auth code>"}
  5. Save the file and distribute it to the following location on each machine:
    Windows: C:\ProgramData\SketchUp\SketchUp 2015
    OS X: /Library/Application Support/SketchUp 2015
  6. Windows: C:\ProgramData\SketchUp\SketchUp 2016
    OS X: /Library/Application Support/SketchUp 2016
  7. Launch SketchUp on each machine or ask your users to open SketchUp Pro.
  8. In the Welcome to SketchUp dialog, click the License tab. The serial number and authorization code should be pre-populated in the fields, saving the user from typing anything.
  9. The user will need to click on the Add License... button to complete the operation on launch.
  1. If you haven't downloaded and installed SketchUp Pro, please do.
  2. Close SketchUp Pro if it's open.
  3. Create a shared folder on a server in your network that is on the same subnet as the computers that will be using SketchUp Pro. To avoid permissions problems, create the folder in the root directory of the server. You may need to contact an IT Administrator for assistance creating a shared folder. All user accounts accessing the network license need full read and write permissions to the folder you create.
  4. Ensure that the time on all computers using SketchUp Pro are synchronized.
  5. Click the Windows Start button on your computer.
  6. Type "run" in the search box and click the Run program.
  7. Enter the path to the shared folder using the Universal Naming Convention (UNC). Here's an example of what a UNC path looks like:

    \\servername\SketchUpLic

  8. A Windows Explorer window should open. If the window doesn't open, please verify the path and your permissions to the folder.
  9. Click File > New >Text Document menu. This will create a file called "New Text Document.txt."
  10. Double-click on New Text Document.txt.
  11. Enter the letters "ABC" in to the text file.
  12. Click File > Save. If you can save successfully, then the permissions on the shared folder are correct.
  13. Click on the text file, and press the Delete button on your keyboard.
  14. Launch SketchUp by right-clicking the SketchUp icon on your Desktop and selecting Run as an administrator.
  15. When the Welcome window opens, click the Add License button. If the Welcome window doesn't open, start using SketchUp and click Help > License > Authorize.
  16. Open the license confirmation email that you received shortly after purchasing your license.
  17. Copy and paste your User Name, Serial Number, and Autorization Number into the dialog box.
  18. Click OK.
  19. Browse to the location of the shared folder you created earlier, and click OK.
    If you don't see your server in the browse dialog box, contact your IT administrator and ask that they enable network browsing. Please also ensure that the server with the shared folder is on the same subnet as the networked computers that will be using SketchUp Pro.
    The SketchUp licensing mechanism doesn't support mapped network drives. When you're prompted to browse for the license folder, navigate to the server itself.

To authorize the remaining workstatations, there are two options:
  • Option 1: (Recommended) Copy the server.dat file to the other workstations:
    1. Copy the server.dat file on the original local workstation to a portable media like a jump drive.
    2. Install SketchUp on each of the other workstations, but don't start it.
    3. On each of the other workstations, paste the server.dat file into the correct folder:
      • SketchUp Pro 2014 (Windows Vista / Windows 7 / Windows 8) --
        C:\ProgramData\SketchUp\SketchUp 2014\
        Note that the "ProgramData" folder is a hidden folder.

  • Option 2: Point the other workstations to the license file.
    1. Install SketchUp on each of the other workstations.
    2. Close all instances of SketchUp to avoid reaching the maximum number of license seats during the authorization process.
    3. Working on one computer at a time, start SketchUp (on Windows Vista/Windows 7, right-click and select Run as an administrator).
    4. In SketchUp, open the Help menu, point to License, and then click Set Network License File.
    5. Point to the SketchUp#.lf file in the license folder on the server.
If you encounter issues during the authorization process, see our license troubleshooting topic for more assistance.

Migrating from previous versions of SketchUp

SketchUp 2014 introduced the new Ruby 2.0 library which may have affected your favorite plugin. If you're upgrading from SketchUp 2013 or older please read our article on SketchUp Plugin Compatibility before you start installing or transferring plugins.

Note: At this time, there isn't a way to migrate the toolbar configuration between major versions of SketchUp.
Migrating Materials & Components
  1. (If you're migrating from SketchUp 8 and older) Navigate to the root folder in SketchUp 8 and older. This is typically,
    C:\Program Files\Google\Google SketchUp #\Materials (or Components)
    (If you're migrating from SketchUp 2013) Navigate to the root folder in SketchUp 8 and older. This is typically,
    C:\Program Files\SketchUp\SketchUp 2013\Materials (or Components)
  2. Select the files in the Plugins folder and press Ctrl+C to copy the items.
  3. Navigate to C:\Program Files\SketchUp\SketchUp #\Materials (or Components)
  4. Press Ctrl+V on your keyboard to paste the files. On Windows 7, you'll be asked if you want to Merge the folders and "Confirm Folder Replace." Click Yes to the warnings.
  5. You'll then be prompted with each subsequent material file to either "Copy and replace" or "Don't copy." We recommend you select "Don't copy" so you can retain the new content with the same file name. Any new content files that you created, however, will be copied without any problem. You can also select the "Do this for the next ### conflicts" so you don't have to approve each file.
  6. Open SketchUp 2014 or newer and your new materials should be in the Materials dialog box, and/or your new components will be in the Components dialog box.
Migrating Plugins

We've been investing heavily in extensions because we know that the power of SketchUp shines when customers install the right extensions to solve their needs. That's why we've built the Extension Warehouse, worked carefully with developers so they can get their plugin in the Extension Warehouse, and addressed long standing requests like updating the Ruby environment to version 2.0 (which is why some plugins may be breaking at the moment - we made the change that developers have been asking for!). The problem is that the current way of managing extensions, plus the updated Ruby version, doesn't support the old way of managing plugins very well. This makes migrating plugins to SketchUp 2014 and newer a bit tricky. We also don't have all the possible plugins in the Extension Warehouse. We feel that finding and managing SketchUp Extensions is getting better and brighter all the time, but we're not at our ideal yet. For some customers, they will need to go through their old plugin list, plugin by plugin, search for that plugin in the Extension Warehouse, install the plugin, and move on to the next. Once your plugins are managed by the Extension Warehouse, it will be significantly easier to re-install these extensions when newer versions of SketchUp are released in the future, or if you get a new computer and have to install a fresh copy of SketchUp. If you've installed plugins from the Extension Warehouse in SketchUp 2013 and you need to install the same plugin in a newer version of SketchUp, we added an Install All button in the Extension Warehouse which will install any of your SketchUp 2013 plugins into SketchUp in one click, but only if those plugins have been updated to support new versions, which most of them have. Only after you've tried installing plugins from the Extension Warehouse, or downloading an updated version of plugins that you've paid for from those plugin developers, do we suggest attempting to copy and paste plugins between folders:

If you have a plugin that utilized a custom installer (i.e. you double-clicked on a file that installed the plugin), you need to contact the plugin developer for specific instructions on updating to support SketchUp 2014 or newer. These instructions are intended for users who copy and pasted .RB, .RBS, or .RBZ files into the SketchUp plugins folder:

  1. Open a new Windows Explorer window.
  2. ( From SketchUp 8 )Navigate to the root folder for the older version of SketchUp. This is typically,
    C:\Program Files\Google\Google SketchUp #\Plugins
    ( From SketchUp 2013 or 2014 ) Navigate to the root folder for the older version of SketchUp. This is typically,
    C:\Program Files\SketchUp\SketchUp 2013\Plugins
  3. Select the files in the Plugins folder and press Ctrl+C to copy the items.
  4. Navigate to C:\Users\USERNAME\AppData\Roaming\SketchUp\SketchUp #\SketchUp\Plugins
  5. Press Ctrl+V on your keyboard to paste the files.
  6. Open SketchUp 2014 or newer and access the plugins as you have in the past. Note that there may be some older plugins that are not compatible with your current version of SketchUp. In this case, please contact the plugin developer for additional assistance.
Note: Not all SketchUp plugins are compatible with the current version of SketchUp. Please contact the plugin developer if you need additional assistance.
Migrating Materials & Components

Watch the video

  1. Open a new Finder window.
  2. Open the Go menu and choose "Go to Folder"
  3. ( If you're migrating from SketchUp 8 ) Enter the following and click Go
    ~/Library/Application Support/Google SketchUp 8/SketchUp/Materials
    ( If you're migrating from SketchUp 2013 ) Enter the following and click Go
    ~/Library/Application Support/SketchUp 2013/SketchUp
  4. Select the files in the Materials folder and press Command+C to copy the items.
  5. Open the Go menu and choose "Go to Folder"
  6. Enter the following and click Go
    ~/Library/Application Support/SketchUp 2015/SketchUp ~/Library/Application Support/SketchUp 2014/SketchUp
  7. Note: If there is no "Materials" folder, you will need to create one.
  8. Press Command+V on your keyboard to paste the files.
  9. Open SketchUp 2014 or newer and your new materials should be in the Materials dialog box, and/or your new components will be in the Components dialog box.
Migrating Plugins

We've been investing heavily in extensions because we know that the power of SketchUp shines when customers install the right extensions to solve their needs. That's why we've built the Extension Warehouse, worked carefully with developers so they can get their plugin in the Extension Warehouse, and addressed long standing requests like updating the Ruby environment to version 2.0 (which is why some plugins may be breaking at the moment - we made the change that developers have been asking for!). The problem is that the current way of managing extensions, plus the updated Ruby version, doesn't support the old way of managing plugins very well. This makes migrating plugins to SketchUp 2014 and newer a bit tricky. We also don't have all the possible plugins in the Extension Warehouse. We feel that finding and managing SketchUp Extensions is getting better and brighter all the time, but we're not at our ideal yet. For some customers, they will need to go through their old plugin list, plugin by plugin, search for that plugin in the Extension Warehouse, install the plugin, and move on to the next. Once your plugins are managed by the Extension Warehouse, it will be significantly easier to re-install these extensions when newer versions of SketchUp are released in the future, or if you get a new computer and have to install a fresh copy of SketchUp. If you've installed plugins from the Extension Warehouse in SketchUp 2013 and you need to install the same plugin in a newer version of SketchUp, we added an Install All button in the Extension Warehouse which will install any of your SketchUp 2013 plugins into SketchUp in one click, but only if those plugins have been updated to support new versions, which most of them have. Only after you've tried installing plugins from the Extension Warehouse, or downloading an updated version of plugins that you've paid for from those plugin developers, do we suggest attempting to copy and paste plugins between folders:

  1. Open a new Finder window.
  2. Open the Go menu and choose "Go to Folder"
  3. ( If you're migrating from SketchUp 8 ) Enter the following and click Go
    ~/Library/Application Support/Google SketchUp 8/SketchUp/plugins
    ( If you're migrating from SketchUp 2013 ) Enter the following and click Go
    ~/Library/Application Support/SketchUp 2013/SketchUp/
  4. Select the files in the Plugins folder and press Command+C to copy the items.
  5. Open the Go menu and choose "Go to Folder"
  6. Enter the following and click Go
    ~/Library/Application Support/SketchUp 2015/SketchUp ~/Library/Application Support/SketchUp 2014/SketchUp
    NOTE: If there is no "Plugins" folder, you will need to create one.
  7. Press Command+V on your keyboard to paste the files.
  8. Open SketchUp 2014 or newer and access the plugins as you have in the past. Note that there may be some older plugins that are not compatible with the current version of SketchUp. In this case, please contact the plugin developer for additional assistance.
Note: Not all SketchUp plugins are compatible with the current version of SketchUp. Please contact the plugin developer if you need additional assistance.

Migrating LayOut

You can define the location where Templates, Scrapbooks and Pattern-Fills are stored with each version of LayOut in the Preferences dialog box under the Folders section. By default any newly created Templates and Scrapbooks are stored in the paths below. When upgrading from an older version of SketchUp just locate the appropriate folder below, copy the contents and paste them into the new folder. Alternatively you may wish to create a folder in a location of your choosing, such as in your Documents folder, and then point LayOut to that location under the Preferences dialog box.

Templates
  • LayOut 2014 C:\Users\USERNAME\AppData\Roaming\SketchUp\SketchUp 2014\LayOut\Templates
  • LayOut 2015 C:\Users\USERNAME\AppData\Roaming\SketchUp\SketchUp 2015\LayOut\Templates
  • LayOut 2015 C:\Users\USERNAME\AppData\Roaming\SketchUp\SketchUp 2015\LayOut\Templates
Scrapbooks
  • LayOut 2014 C:\Users\USERNAME\AppData\Roaming\SketchUp\SketchUp 2014\LayOut\Scrapbooks
  • LayOut 2015 C:\Users\USERNAME\AppData\Roaming\SketchUp\SketchUp 2015\LayOut\Scrapbooks
  • LayOut 2015 C:\Users\USERNAME\AppData\Roaming\SketchUp\SketchUp 2015\LayOut\Scrapbooks
Pattern-Fill Images
  • LayOut 2014 No User Folder
  • LayOut 2015 No User Folder
Note - You may notice when defining the storage location under Preferences that each item is also stored under ProgramData, this is typically a System level storage location and we discourage placing your content directly into this location.
Be aware that the tilde (~) at the beginning of each path indicates the "User Level" folder structure, often depicted as Users/USERNAME/. If a Templates or Scrapbooks folder doesn't already exist you may need to create a folder manually.
Templates
  • LayOut 2014 ~/Library/Application Support/SketchUp/SketchUp 2014/LayOut/Templates
  • LayOut 2015 ~/Library/Application Support/SketchUp/SketchUp 2015/LayOut/Templates
  • LayOut 2016 ~/Library/Application Support/SketchUp/SketchUp 2016/LayOut/Templates
Scrapbooks
  • LayOut 2014 ~/Library/Application Support/SketchUp/SketchUp 2014/LayOut/Scrapbooks
  • LayOut 2015 ~/Library/Application Support/SketchUp/SketchUp 2015/LayOut/Scrapbooks
  • LayOut 2016 ~/Library/Application Support/SketchUp/SketchUp 2016/LayOut/Scrapbooks
Pattern-Fill Images
  • LayOut 2014 - No User Folder
  • LayOut 2015 - No User Folder
  • LayOut 2016 - No User Folder
Note - You may notice when defining the storage location under Preferences that each item is also stored under Contents, this is a System level storage location and we discourage placing your content directly into this location.

Uninstalling SketchUp

Instructions are for SketchUp and SketchUp Pro

If you are uninstalling SketchUp permanently from your computer, be sure to remove your license first. Open SketchUp, click the License tab in the Welcome Window, then click the red Remove License button.
Windows

Windows XP: Click the Start menu > Control Panel > Add/Remove Programs > SketchUp #.

Windows Vista/Windows 7: Click the Start (Windows logo) menu > Control Panel > Programs > Programs and Features > SketchUp #.

To uninstall SketchUp, select Remove (Uninstall on Vista or Windows 7). When asked if you'd like to remove SketchUp, click Yes.

If you are having problems with SketchUp, you can try the Change option, which begins the process of reinstalling the program features that were installed during the last installation. This can fix any application files that were corrupted (this doesn't affect or fix your SketchUp drawing files, the SKP files). If that doesn't work, try uninstalling and reinstalling SketchUp.

Mac OS X
  1. Quit SketchUp. (If you have more than one instance of SketchUp open, make sure you quit all instances of SketchUp.)
  2. Open a Finder window.
  3. (SketchUp 8 and older) Delete the SketchUp folder from the main library:
    1. In the left pane of the Finder window, click Macintosh HD.
    2. In the right pane, click Library, and then Application Support.
    3. In the Application Support folder, find the Google SketchUp # folder, and then drag it to the trash.
      For SketchUp 2013 the folder will simply be "SketchUp 2013".
  4. Delete the SketchUp folder from your user library:
    1. In the left pane of the Finder window, click your user name, then click Library* in the right pane.
      1. *If you're using Mac OS X 10.7 or newer, hold down the Option (Alt) button on your keyboard, click Go in the menubar, then select the Library option in the drop-down list. Here's an example video.
    2. Open the Application Support folder.
    3. In the Application Support folder, find the SketchUp # folder, and then drag it to the trash.
  5. Delete the SketchUp application:
    1. In the left pane of the Finder window, click Applications.
    2. In the right pane, find SketchUp # folder, and then drag it to the trash.
  6. Delete the plist file:
    1. In the left pane of the Finder window, click your user name.
    2. In the right pane, click Library*, and then Preferences.
      1. *If you're using Mac OS X 10.7 or newer, hold down the Option (Alt) button on your keyboard, click Go in the menubar, then select the Library option in the drop-down list. Here's an example video.
    3. In the Preferences folder, drag any of the following files, if present, to the trash:
      • com.atlast.sketchup.plist
      • com.google.sketchuppro.plist
      • com.google.sketchupfree.plist
      • com.google.sketchuppro7.plist
      • com.google.sketchupfree7.plist
      • com.google.sketchuppro8.plist
      • com.google.sketchupfree8.plist
      • com.google.LayOut.plist
      • com.google.style_builder.plist
      • com.sketchup.SketchUp.plist
      • com.sketchup.LayOut.plist
      • com.sketchup.StyleBuilder.plist
      • com.sketchup.SketchUp.2014.plist
      • com.sketchup.LayOut.2014.plist
      • com.sketchup.StyleBuilder.2014.plist
      • com.sketchup.SketchUp.2015.plist
      • com.sketchup.LayOut.2015.plist
      • com.sketchup.StyleBuilder.2015.plist
  7. Empty the trash.
OS:

Need Help Fast?

SketchUp’s outstanding community of passionate experts have answers to your questions.