Authorize SketchUp with a Network License

      NOTICE: SketchUp 2015 is here! When you look at this Knowledge Center article, be sure to pick "SketchUp 2015" from the red box above to see the 2015 version of that content. If there is no version picker, this content applies to all versions of SketchUp.
Authorizing SketchUp as a User

Authorizing SketchUp with a network license is no different than authorizing it with a single user license as documented in our article on Authorizing SketchUp. Though, a network license can be authorized the same as a single user license, there is one important caveat to allow the authorization to be successful: Ports 5053 and 50530 must be open for your network license to work. See your Network administrator if these ports are not open.

Authorizing SketchUp on a Network as an Administrator

If you're distributing SketchUp across a larger network, you may wish to use the MSI file (Windows 32-bit installer | Windows 64-bit installer) or to use a disk imaging package such as Norton Ghost or Deep Freeze. In the case of either distributed installation strategies, you can simplify the licensing process by including a file which will pre-populate the serial number and authorization code for users so they won’t need to type it in themselves.

Note: Users will still need to click the Add License button to add the license.

To use this procedure:

  1. Ensure that SketchUp Pro 2015 is installed on all computers.
  2. Create a file named activation_info.txt. You will need to use a plain text editor, such as Notepad (Microsoft Windows) or TextMate (Mac OS X).
  3. In that file, add your network serial number and authorization code in the following format:

    {"serial_number":"YOUR SERIAL NUMBER", "auth_code":"YOUR AUTHORIZATION CODE"}

  4. Save the file and distribute it to the following location on each machine:

    Windows - C:\ProgramData\SketchUp\SketchUp 2015

    • Note that it's the hidden ProgramData folder, not the common Program Files folder.

    OS X - /Library/Application Support/SketchUp 2015

    • Note that this is the root-level Library folder, not the user-level Library folder.
    • You will need to create the SketchUp 2015 folder. There is no SketchUp 2015 folder in the rool-level /Library/Application Support folder by default.
  5. Launch SketchUp on each machine or ask your users to open SketchUp Pro.
  6. In the Welcome to SketchUp dialog, click the License tab. The serial number and authorization code should be pre-populated in the fields, saving the user from typing anything.
  7. Click on the Add License... button.
Note: SketchUp must be run as an Administrator on first run to properly apply the license.

Quick Summary

  1. Install SketchUp Pro on one workstation.
  2. Authorize with your serial number and authorization code (Help > License > Authorize).
  3. Copy the "server.dat" file (search your computer for this file) to a shared location on your network or to a USB flash drive.
  4. Install SketchUp Pro on the other systems, but don't open SketchUp yet.
  5. Paste the "server.dat" file to other users' systems in the same folder you identified in step 3.


Complete Instructions

  1. If you haven't downloaded and installed SketchUp Pro, please do.
  2. Close SketchUp Pro if it's open.
  3. Create a shared folder on a server in your network that is on the same subnet as the computers that will be using SketchUp Pro. To avoid permissions problems, create the folder in the root directory of the server. You may need to contact an IT Administrator for assistance creating a shared folder. All user accounts accessing the network license need full read and write permissions to the folder you create.
  4. Ensure that the time on all computers using SketchUp Pro are synchronized.
  5. Click the Windows Start button on your computer.
  6. Type "run" in the search box and click the Run program.
  7. Enter the path to the shared folder using the Universal Naming Convention (UNC). Here's an example of what a UNC path looks like:

    \\servername\SketchUpLic

  8. A Windows Explorer window should open. If the window doesn't open, please verify the path and your permissions to the folder.
  9. Click File > New >Text Document menu. This will create a file called "New Text Document.txt."
  10. Double-click on New Text Document.txt.
  11. Enter the letters "ABC" in to the text file.
  12. Click File > Save. If you can save successfully, then the permissions on the shared folder are correct.
  13. Click on the text file, and press the Delete button on your keyboard.
  14. Launch SketchUp by right-clicking the SketchUp icon on your Desktop and selecting Run as an administrator (Windows XP: Double-click on the SketchUp icon).
  15. When the Welcome window opens, click the Add License button. If the Welcome window doesn't open, start using SketchUp and click Help > License > Authorize.
  16. Open the license confirmation email that you received shortly after purchasing your license.
  17. Copy and paste your User Name, Serial Number, and Autorization Number into the dialog box.
  18. Click OK.
  19. Browse to the location of the shared folder you created earlier, and click OK.


    If you don't see your server in the browse dialog box, contact your IT administrator and ask that they enable network browsing. Please also ensure that the server with the shared folder is on the same subnet as the networked computers that will be using SketchUp Pro.
    The SketchUp licensing mechanism doesn't support mapped network drives. When you're prompted to browse for the license folder, navigate to the server itself.

To authorize the remaining workstatations, there are two options:

  • Option 1: (Recommended) Copy the server.dat file to the other workstations:

    1. Copy the server.dat file on the original local workstation to a portable media like a jump drive.
    2. Install SketchUp on each of the other workstations, but don't start it.
    3. On each of the other workstations, paste the server.dat file into the correct folder:
      • SketchUp Pro 2014 (Windows Vista / Windows 7 / Windows 8) --
        C:\ProgramData\SketchUp\SketchUp 2014\
        Note that the "ProgramData" folder is a hidden folder.
      • SketchUp Pro 2013 (Windows Vista / Windows 7 / Windows 8) --
        C:\ProgramData\SketchUp\SketchUp 2013\
        Note that the "ProgramData" folder is a hidden folder.
      • SketchUp Pro 2013 (Windows XP) --
        C:\Documents and Settings\All Users\Application Data\SketchUp\SketchUp 2013
        Note that the "Application Data" folder is a hidden folder.
      • SketchUp Pro 8 and older --
        C:\Program Files\Google\Google SketchUp #\
      • SketchUp Pro 8 and older (64-bit Windows Vista / Windows 7 / Windows 8) --
        C:\Users\USER_NAME\AppData\Local\VirtualStore\Program Files (x86)\Google\Google SketchUp #


  • Option 2: Point the other workstations to the license file.

    1. Install SketchUp on each of the other workstations.
    2. Close all instances of SketchUp to avoid reaching the maximum number of license seats during the authorization process.
    3. Working on one computer at a time, start SketchUp (on Windows Vista/Windows 7, right-click and select Run as an administrator).
    4. In SketchUp, open the Help menu, point to License, and then click Set Network License File.
    5. Point to the SketchUp#.lf file in the license folder on the server.