Controlling shadow settings in SketchUp

      NOTICE: SketchUp 2015 is here! When you look at this Knowledge Center article, be sure to pick "SketchUp 2015" from the red box above to see the 2015 version of that content. If there is no version picker, this content applies to all versions of SketchUp.

The SketchUp Shadow tools are designed to give you a general idea of how the sun and shadows affect your model during the course of a day and throughout the year. The calculations are based on the location (latitude and longitude) and directional orientation of the model, as well as the associated time zone. The time is not adjusted for Daylight Saving Time.

Using SketchUp, you can set the location and directional orientation by importing an image from Google Earth:

  1. In SketchUp, click Add Location. The Add Location dialog box opens.
  2. Search for or zoom in to your desired location.
  3. Clicking Select Region will bring up selection pins.
  4. Drag and drop the pins to enclose your region.
  5. Click Grab, and SketchUp imports that area.
  6. The SketchUp model is now set to the same latitude and longitude as the location you chose. The imported terrain image is aligned with the axes in SketchUp (the solid green axis points north and the solid red axis points east). The time zone in SketchUp is approximated based on the coordinates. Because some actual time zones lines zigzag rather dramatically, the automatically calculated time zone for some locations may be off by an hour. In a few cases, the variance can be even longer.

You can also manually set the location, time zone, and solar orientation:

  1. Open the Window menu.
  2. Click Model Info.
  3. In the left pane, click Geo-location.
  4. In the right pane, you can use the Add Location option listed above, or you can click Set Manual location to set a precise latitude and longitude.
Note: To use the Shadow tools, enable the Shadows toolbar (open the View menu, point to Toolbars, and then click Shadows). You can fine tune the shadows in the Shadow Settings dialog box (Window > Shadows).

For more information about directions in SketchUp (up, down, east, west, north, and south), click here.