What are templates and how do I change the default template?

A template file contains default settings from the Model Info, Style, and Shadow dialog boxes. Templates can also contain base geometry like the person who's standing in the default SketchUp template. Different templates are geared toward different types of users like architects or geo-modelers, so you'll want to select a template that's best-suited for the types of models you build. Your selected template will automatically load when you open SketchUp.

There are couple ways you can change the template that SketchUp uses whenever you open a new file:

Select a different template

SketchUp is installed with several templates, including: Architectural - US, Centimeter, Meters, and Millimeters. To change to a different template:

  1. Open the Window menu (Mac = SketchUp menu).
  2. Click Preferences.
  3. In the left pane, click Template.
  4. In the right pane, select a drawing template.
  5. Click OK to close the System Preferences dialog box.
  6. To open a new model using the selected template, open the File menu, and click New.
  7. The selected template is also used after you close and restart SketchUp.

Make changes to the default template you are using

  1. Open the File menu.
  2. Click Save As.
  3. In the Save As dialog box, browse to the SketchUp Templates folder, which is installed by default to:
    • SketchUp Pro 8 for PC - C:\Program Files\Google\Google SketchUp #\Resources\en-US\Templates.
    • SketchUp Pro 8 for Mac - ~/Library/Application Support/Google SketchUp #/SketchUp/Templates.
    • SketchUp 2014 for PC - C:\Program Files (x86)\SketchUp\SketchUp 2014\Resources\en-US\Templates
    • SketchUp 2014 for Mac -~/Library/Application Support/SketchUp 2014/SketchUp
  4. Save the template using the existing template name or a new name, for example, "My Template."
  5. Back in SketchUp, if you saved your changes using a new template name, select that new template (follow the preceding "Select a different template" procedure).
  6. To open a new model using the selected template, open the File menu, and click New.
  7. The selected template is also used after you close and restart SketchUp.

How are preferences saved?

SketchUp Preferences includes settings such as keyboard shortcuts and toolbar position. Preferences are saved for each user account, rather than in the template. For more information about sharing your preferences, see our Exporting preferences article.