How Can We Help?

Installing Ruby Plugins (Extensions)

The Extension Warehouse
You can download extensions from the Extension Warehouse, which is an online repository of extensions/plugins. To get started, open SketchUp and click Window > Extension Warehouse. After signing into your Google Account (learn more), you can search for a specific extension, or browse through categories of extensions such as 3d printing, for example. Once you find the extension you want, simply click Install and follow the instructions.

Extension Manager
With SketchUp 2017 we have a new and improved Extension Manager with new options. Please visit our Help Center article on the Extension Manager for further support.

SketchUp and .rbz files
It's also possible to install zipped Ruby files (.rbz) from within SketchUp. If your plugin has a standard (.zip) extension, then you may be able to change the extension name from .zip to .rbz and follow the instructions below for installation.

To install a SketchUp  Ruby plugin script with the .rbz format:

  1. We recommend logging into your computer as an admin before installing any Ruby scripts. This will make the installation go more smoothly and ensure that files get installed in the proper places.
  2. Select Window > Preferences (Microsoft Windows) or SketchUp > Preferences (Mac OS X). The Preferences dialog box is displayed.
  3. Click on Extensions. The Extensions panel is displayed.
  4. Click on the Install Extension button. The Open dialog box is displayed.
  5. Locate the Ruby zip file to install (.rbz).
  6. Click on the Open button. The Ruby plugin appears in the list of extensions.

*.rb files
If you have a file with the .rb extension, you can install the plugin by placing the Ruby script file into the appropriate folder, and then restarting SketchUp.

Windows - the default location is:

  • SketchUp 2017: C:\Users\YOUR USERNAME\AppData\Roaming\SketchUp\SketchUp 2017\SketchUp\Plugins
  • SketchUp 2016: C:\Users\YOUR USERNAME\AppData\Roaming\SketchUp\SketchUp 2016\SketchUp\Plugins
  • SketchUp 2015: C:\Users\YOUR USERNAME\AppData\Roaming\SketchUp\SketchUp 2015\SketchUp\Plugins
  • SketchUp 2014: C:\Users\YOUR USERNAME\AppData\Roaming\SketchUp\SketchUp 2014\SketchUp\Plugins
  • SketchUp 2013: C:\Program Files\SketchUp\SketchUp ####\Plugins.

Mac OS X - the default location is:

Version 2013 and newer: Open a new Finder window, press and hold the Option key on your keyboard, the click Go in the menu bar > Library > Application Support > SketchUp # > SketchUp > Plugins

Tip: you may need to create your plugins folder in the SketchUp folder. To do so click File > New folder in your Finder window.

Once you have restarted SketchUp, you should see that the script's commands have been added to the appropriate menus. You can also run the script using the Ruby Console (open the "Windows" menu, and then click Ruby Console).

OS:

Need Help Fast?

SketchUp’s outstanding community of passionate experts have answers to your questions.