How Can We Help?

Introducing the LayOut Interface

If you’re new to creating documents and presentations in LayOut, a quick tour of the interface and few mousing tips can help orient you to LayOut’s basic tools and features.

Parts of the LayOut interface, like the Measurements box and some of the mousing tricks, look and feel like SketchUp. Other parts, like some menus and dialog boxes, are unique to LayOut.

Ready to tour the interface? Let the following sections be your guide.

Tip: If you’re looking to customize the LayOut interface for the way you work, see Customizing the Interface and Setting Preferences.
Table of Contents
  1. Touring the LayOut interface
  2. Mousing around the LayOut interface
  3. Viewing the Quick Reference Card

Touring the LayOut interface

After you open LayOut and choose a template, the LayOut interface for your current operating system looks like the following figure. Here’s a quick look at the basic interface elements, and you find more details in the upcoming sections.

  1. Menu bar
  2. Default toolbar
  3. Document area
  4. Tray and panels
  5. Status bar
  6. Measurements box
  7. Zoom menu
LayOut interface in Microsoft Windows
LayOut interface in Mac OS X

You find most of LayOut’s available commands on the menu bar. As you add elements your LayOut document, the Arrange menu enables you to move elements to the front or back and center, flip, and align elements. The Pages menu enables you to add, duplicate, and navigate through pages in your LayOut document.

The other menus are File, Edit, View, Tools, Window, and Help. On Mac OS X, you also see a LayOut menu on the far left.

Tip: If you ever need a hand, select Help > Help Center, and you jump directly to the LayOut section of the Knowledge Center.

2. Default toolbar

The default toolbar contains the tools beginners use most often. The following table gives you quick explanation for each tool.

Tool Name What You Can Do with It Find Out More
Select Select entities onscreen. Selecting Things
Line Draw straight lines. Drawing Lines and Shapes
Freehand Draw lines and curves freehand. Drawing Lines and Shapes
Arc Draw an arc based on an angle. Drawing Lines and Shapes
2 Point Arc Draw arc endpoints and drag the arc’s bulge. Drawing Lines and Shapes
3 Point Arc Draw an arc from a pivot point. Drawing Lines and Shapes
Pie Create a closed arc, like a slice of pie. Drawing Lines and Shapes
Rectangle Draw a basic rectangle. Drawing Lines and Shapes
Rounded Rectangle Create a rectangle with rounded corners. Drawing Lines and Shapes
Lozenge Create a rectangle with extremely rounded corners. Drawing Lines and Shapes
Bulged Rectangle Draw a rectangle with two sides that bulge out. Drawing Lines and Shapes
Circle Draw a circle. Drawing Lines and Shapes
Ellipse Draw an ellipse. Drawing Lines and Shapes
Polygon Create a polygon with a specific number of sides. Drawing Lines and Shapes
Text Add text in a bounded or unbounded text box. Adding Text, Labels, and Dimensions
Label Label specific items in your document. Adding Text, Labels, and Dimensions
Linear Dimension Mark a straight dimension in the units you specify. Adding Text, Labels, and Dimensions
Angular Dimension Mark the size of an angle. Adding Text, Labels, and Dimensions
Erase Erase an element onscreen. Copying, Pasting, Erasing, and Other Editing Tasks
Style Sample an element’s fill and stroke settings and apply them to other elements. Applying Styles
Split Split lines or shapes. Drawing Lines and Shapes
Join Join overlapping shapes. Drawing Lines and Shapes
Start Presentation Switch to the full-screen presentation mode. Presenting Your LayOut Project
Add Page Add a page to your LayOut document. Managing and Navigating Pages
Next Page Move to the next page. Managing and Navigating Pages
Previous Page Move to the previous page. Managing and Navigating Pages

3. Document area

The document area is where you insert SketchUp models or images and then add shapes, text, dimensions, and other details to create your document or presentation.

When you create a new LayOut document, the template you choose determines the document area’s size and orientation. (See Creating and Saving a LayOut Document for details.)

4. Tray and panels

On the right side of the screen, all the panels appear stacked one on top of the other. These panels enable you access shape line and fill options, color options, text and dimension styles, and much more.

In Microsoft Windows, all the panels appear in a tray. On Mac OS X, the panels are stacked together, but you can drag a panel to the left so it breaks out of the stack and floats on its own.

  • To open a panel, click its title bar. Click the title bar again to hide the panel.
  • To close a panel, click its Close button. On Microsoft Windows, that’s the X on the right of the panel’s title bar. On Mac OS X, that’s the red close icon on the left of the panel’s title bar.
  • To create more space in the document area, you have a few options:
    • On Microsoft Windows, click the Auto Hide icon in the upper right, next to the tray name, and the tray disappears behind a tab. To see the tray, hover over the tab, and you see the panels in a slimmed-down format. To close the tray completely, click the X next to the tray name or select Window > Hide Tray. To see the tray and its panels again, select Window > Show Tray.
    • On Mac OS X, you don’t have the tray, but you can close all the panels so they take up less space or click the Close button on every panel so they’re totally out of your way.

Tip: The Instructor panel teaches you how to use the currently selected tool. You see an animation of the tool in action, steps for using the tool, and what modifier keys (if any) add special functionality to the tool. If you’re ever not sure how a LayOut tool works, the Instructor panel is always ready to help.

5. Status bar

The status bar is the gray box at the bottom of the LayOut window. On the left, the status bar displays helpful tips for the currently selected tool. The status bar also lets you know when LayOut autosaves your document.

On the right side of the status bar, you find the Measurements box and a Zoom menu.

6. Measurements box

The Measurements box has a couple of jobs: displaying coordinates and modifying entities.

The Measurements box displays coordinates when you need to click to begin drawing an element. For example, if you select the Rectangle tool, the Measurements box displays the coordinates that the Rectangle cursor is currently hovering over. When the Measurements box is displaying coordinates, the coordinates are relative to the upper-left corner of the document area, which is coordinate 0,0.

You can enter values in the Measurements box to modify entities if your current tool enables you to do so. For example, when you use the Polygon tool, you can enter coordinates to set the polygon’s center point or enter how many sides the polygon should have.

7. Zoom menu

The Zoom menu enables you to zoom to a specific value, such as 50%, 75%, 100%, 150%, and so on. The menu also has a handy Scale to Fit (Microsoft Windows) or Zoom to Fit (Mac OS X) option, which sizes the document area to the maximum size the window will allow.

Mousing around the LayOut interface

Your mouse is your primary tool for interacting with the LayOut interface.

Either a three-button or one-button mouse (common on Mac computers) works just fine, but you can work more efficiently with a three-button mouse (where one button is actually the scroll wheel). Note that the Magic Mouse that comes with newer Macs has some of the scroll-wheel functionality that a three-button mouse has.

The following table outlines the key ways your mouse enables you to interact with LayOut’s interface.

Action Three-Button Mouse One-Button Mouse Magic Mouse
Click or select Press and release the left mouse button Press and release the mouse button Press and release the mouse
Click and drag Press and hold down the left mouse button while moving the mouse Press and hold the mouse button while dragging Press and hold down the mouse while dragging
Scroll Roll the scroll wheel forward or backward Not available Move your finger along the top of the mouse
Context-click Click the right mouse button Press and hold the Option key while clicking Press and hold the Option key while clicking

Tip: When you context-click an item in the LayOut interface, this action typically opens a context menu with commands related to the item. For example, context-clicking a shape opens a menu of commands for working with shapes, such as Cut, Copy, Delete, Arrange, Center, Flip, and more.

Viewing the LayOut Quick Reference Card

The Quick Reference Card is an easy-to-print guide to all the LayOut tools and their modifier keys. Keep it handy as you start using LayOut and you’ll learn to model quickly and efficiently. Here's what the Quick Reference card looks like:

To download a PDF of the Quick Reference card, click the link that corresponds to your operating system:

Need Help Fast?

SketchUp’s outstanding community of passionate experts have answers to your questions.