How Can We Help?

Importing and Exporting 3DS Files

The 3DS format is one of those oldies but goodies. The format is native to the original DOS-based 3D Studio modeling and animation application. Although the 3DS format is obsolete in many ways, it’s still widely used. You can import 3DS models into SketchUp, and if you have SketchUp Pro, you can export SketchUp models into 3DS format, too.

Tip: 3DS offers a direct way to export simpler SketchUp models into a wide range of 3D modeling packages. Because 3DS preserves material assignments, texture mapping, and camera position, 3DS can often transfer ideas that you generate in SketchUp to other programs with greater fidelity than CAD formats can.

This article walks you through the steps for importing and exporting 3DS files and explains the options you encounter along the way.

Table of Contents
  1. Importing 3DS files
  2. Exporting 3DS files

Importing 3DS files

Before you import a 3DS file into SketchUp, check whether the file has textures that you want to import. If so, make sure the texture files are saved in the same folder as the 3DS file.

When you’re ready, follow these steps to import your 3DS file into SketchUp:

  1. Select File > Import. The Open dialog box appears.
  2. Navigate to your 3DS file and select it.
  3. From the Files of Type drop-down list, make sure 3DS Files (*.3ds) is selected.
  4. Click the Options button. The 3DS Import Options dialog box appears.
  5. (Optional) When selected, the Merge Coplanar Faces option removes triangulated lines from coplanar faces. If you want to remove these lines, selecting this option tells SketchUp to remove the lines automatically and saves you the tedious work of removing these lines by hand. Leave the option deselected to leave triangulated faces as they are.
  6. (Optional) From the Units drop-down list, select the unit of measure that the 3DS file uses to import your 3DS geometry at a 1:1 scale. Or change the scale by changing the units. For example, a face that is 1 cm x 1 cm is imported into SketchUp as 1cm x 1cm if your 3DS file has its units value set to centimeters and you select Model Units in this drop-down list. A 1cm x 1cm face imports into SketchUp with dimensions of 1 in x 1 in if you choose Inches in the drop-down list. If SketchUp doesn’t detect a units value in the 3DS file, SketchUp imports the 3DS file in inches, unless you specify a different value here.

    Tip: SketchUp only recognizes faces of .001 square inches and larger. It is possible to have very small faces on import if you select millimeters as your SketchUp units but the model was originally intended to be displayed in feet. Therefore, use a large unit type, such as feet or meters, if you do not know the units used in the original file. Resize the model as necessary after it is imported.
  7. Click OK in the 3DS Import Options dialog box.
  8. Back in the Open dialog box, click Open to begin importing your file. If your file is large, the process can take a while.
  9. Click OK in the Import Results dialog box. The model appears in the drawing area at the origin. If you don’t see your model, click the Zoom Extents tool ().
  1. Select File > Import. An open dialog box appears.
  2. Navigate to your 3DS file and select it.
  3. From the Format drop-down list, make sure 3DS Files (*.3ds) is selected.
  4. Click the Options button. The 3DS Import Options dialog box appears.
  5. (Optional) When selected, the Merge Coplanar Faces option removes triangulated lines from coplanar faces. If you want to remove these lines, selecting this option tells SketchUp to remove the lines automatically and saves you the tedious work of removing these lines by hand. Leave the option deselected to leave triangulated faces as they are.
  6. (Optional) From the Units drop-down list, select the unit of measure that the 3DS file uses to import your 3DS geometry at a 1:1 scale. Or change the scale by changing the units. For example, a face that is 1 cm x 1 cm is imported into SketchUp as 1cm x 1cm if your 3DS file has its units value set to centimeters and you select Model Units in this drop-down list. A 1cm x 1cm face imports into SketchUp with dimensions of 1 in x 1 in if you choose Inches in the drop-down list. If SketchUp doesn’t detect a units value in the 3DS file, SketchUp imports the 3DS file in inches, unless you specify a different value here.

    Tip: SketchUp only recognizes faces of .001 square inches and larger. It’s possible to have very small faces on import if you select millimeters as your SketchUp units but the model was originally intended to be displayed in feet. Therefore, use a large unit type, such as feet or meters, if you do not know the units used in the original file. Resize the model as necessary after it is imported.
  7. Click OK in the 3DS Import Options dialog box.
  8. Back in the open dialog box, click Import to begin importing your file. If your file is large, the process can take a while.
  9. Click OK in the Import Results dialog box. The model appears in the drawing area at the origin. If you don’t see your model, click the Zoom Extents tool ().

Exporting 3DS files

If you’re a SketchUp Pro user, you can export your SketchUp models as 3DS files. The following sections explain how to prepare your SketchUp model for export, export to a 3DS file, select export options, and handle known issues with 3DS exports.

Prepare your SketchUp model

Before you export your SketchUp model, you need to do a little preparation:

  • Make sure the front of all your SketchUp faces point outward. (Remember that every face in SketchUp has a front and back.) To check that the face fronts point outward in SketchUp, select View > Face Style > Monochrome to see whether the back sides of a any faces point outward. By default, the face fronts are white and face backs are dark gray. To reverse a face, context-click it and select Reverse Faces.
    In the following figure, you see a basic model with materials (left) and in monochrome (right). The left, side face needs to be reversed.
    In monochrome, you see whether a face needs to be reversed.

    Tip: Sometimes, it’s difficult to determine whether a face is truly facing outward or just shaded to show perspective. If you’re having trouble, orbit so you have a straight-ahead view of the face. Or, in the Styles browser, you can use the Face Settings to edit the default back face color so that the backs of faces stand out more than they do in the default gray. Or, instead of checking and reversing faces, you can select the Export Two-Sided Faces option when you export your 3DS file, as explained later in this section.
  • Show all the geometry you want to export. Only entities that are currently visible in SketchUp are output to the 3DS file. Rendering display options are not taken into account, which means that faces are output even if SketchUp is in wireframe mode. Faces are not output, however, if they are hidden or reside on a hidden layer.
  • Make sure you can live without your layers. The 3DS format does not support layers. Any layers you assign in SketchUp don’t appear in your exported 3DS file. If you need to export layers, exporting to the DWG format might be a better solution.

Export a 3DS file

When your SketchUp model is ready to export to 3DS, follow these steps:

  1. Select File > Export > 3D Model. The Export Model dialog box appears.
  2. Navigate to the location where you want to save your file.
  3. From the Export Type drop-down list, select 3DS File (*.3ds).
  4. (Optional) By default, the 3DS file has the same name as your SketchUp model. You can change the file name if you like in the File Name box.
  5. Click the Options button. The 3DS Export Options dialog box appears. Select your options, which are explained in the following list, and click OK to return to the Export Model dialog box.
  6. Click Export, and your file is saved in the location you selected.
  1. Select File > Export > 3D Model. An export dialog box appears.
  2. Navigate to the location where you want to save your file.
  3. From the Format drop-down list, select 3DS File (*.3ds).
  4. (Optional) By default, the 3DS file has the same name as your SketchUp model. You can change the file name if you like in the Save As box.
  5. Click the Options button. The Export Options dialog box appears. Select your options, which are explained in the following list, and click OK to return to the export dialog box.
  6. Click Export, and your file is saved in the location you selected.

Select 3DS export options

When you open the 3DS Export Options dialog box, you see a long list of options. The rest of this section helps you decode how each of these options impacts your exported 3DS file.

In the Geometry area, you find options for how SketchUp geometry appears in a 3DS file:

  • Export drop-down list: Choose how you want to organize meshes in the exported 3DS file.
    • Full Hierarchy: This option, selected by default, creates meshes for each top-level nested component and group and for non-grouped entities based on the connection of faces. These meshes are organized according to their place in the component and group hierarchy. This option enables you (using a tree view in Autodesk 3DS Max, for example) to select individual components and groups with all their children and each connected face set as separate meshes. This option preserves the name of the component or group using the following rule for components: If an instance name exists, that name is used; if an instance name does not exist, the definition name is used.
    • By Layer: This option creates separate meshes based on how faces are connected and on what layer (from SketchUp) the faces appear. All faces that are connected and are on the same layer are grouped in separate meshes. These meshes are then organized based on the layer to which they belong. This option enables you (using a tree view in Autodesk 3DS Max, for example) to select all objects on a layer using the organization scheme and then to drill down and select individual meshes within that layer. No hierarchy is created with this option. If you used SketchUp layers in the recommended way, however, all your geometry is on Layer0 and you’ve assigned only groups or components to other layers in order to control visibility.
    • By Material: This option creates separate meshes based on how faces are connected and their material. All faces that are connected and have the same material are grouped together in a mesh. These meshes are then organized based on their materials. In this organization scheme, you can select all objects with the same material and then drill down to select individual meshes having that material. No hierarchy is created with this option.
    • Single Object: This option exports your SketchUp model as a single 3DS mesh, which is simple to select and manipulate after you import it into another application. However, because the 3DS format limits meshes to 65,536 vertices and faces, you’ll find more than one mesh in your exported file if it exceeds this limit.
  • Export Only Current Selection: If you select geometry in your SketchUp file before you begin the export process, selecting this option tells SketchUp to export only the selection. If you have no selection or leave this checkbox deselected, your whole model is exported.
  • Export Two-Sided Faces: When selected, this option tells SketchUp to export faces twice: once for the front and once for the back. The vertices of the front and back faces are welded together, according to the logic for texture mapping and welding explained in the upcoming Export Texture Maps option. This option doubles the number of polygons in the resulting 3DS file and can slow down rendering. However, this option ensures that your model appears more like it appears in SketchUp when you open the 3DS file in another program. Both faces will always render, and materials applied to front and back faces are preserved.
  • Export Stand-Alone Edges: SketchUp’s support for stand-alone line entities (that is, lines not connected to a face) is unique. The 3DS format doesn’t support them, nor do many other 3D programs. When you select this option, SketchUp transforms stand-alone edges into thin rectangles that look like stand-alone lines in the 3DS file. Although this solution seems simple, the reality is that it doesn’t always work: The result may create invalid texture coordinates or create an altogether invalid 3DS file. If you run into problems with stand-alone edges, try exporting to the VRML format instead.

In the Materials section, the Export Texture Maps option enables you to select how you’d like to export materials and textures applied to your model. Select Export Texture Maps to assign texture maps to 3DS materials whenever the corresponding SketchUp material uses a texture image. The 3DS format allows only one mapping coordinate per vertex, which means two faces that share the same vertex can’t have two different maps. Given this limitation of the 3DS format, you need to make a tradeoff between preserving texture coordinates and welding geometry. You can guide how SketchUp makes this tradeoff by selecting one of the following Favor radio buttons:

  • Preserving Texture Coordinates: When you select this option, the goal is to preserve textures. Whenever SketchUp finds conflicting texture maps, SketchUp breaks up geometry so that each coplanar group has its own vertices. In other words, vertices aren’t welded together, and faces aren’t smoothed. Vertices are welded when welded faces have identical texture maps.
  • Welding Vertices: When you select this option, welding and smoothing get top priority. If two faces share a vertex but have different texture maps, only one texture map is preserved in the exported file.

In the Cameras area, select the Generate Cameras from Scenes checkbox to create a camera for the default view as well as any SketchUp scenes that you’ve created. The current SketchUp view is exported with the name Default Camera, and other scene camera definitions are labeled with their scene name. See Creating Scenes for details about creating and naming scenes in your SketchUp model.

In the Scale area, use the Units drop-down list to determine the unit of measurement in the exported 3DS file.

The Units setting can affect the way geometry is described within the 3DS file. For example, a 1 meter cube in SketchUp exports to 3DS with sides of length 1 when units are set to meters. If you change the export units to centimeters, the same cube exports to 3DS with a length of 100.

The 3DS format contains extra information that indicates the original units using a scale factor. This information allows an application that reads 3DS to automatically adjust a 3DS model to its original size. Unfortunately, many applications ignore this unit scale information. As a result, the centimeter cube imports as 100 times larger than the 1 meter cube, instead of at the same size. Worse, it isn’t always clear in which unit a 3DS file was saved, so you have to discover the original size through trial and error. In these cases, the best work-around is simply to export files at the units setting that the 3DS importing application expects.

Understand known issues with files exported to 3DS

Because 3DS is an older format, transitioning to newer software and operating system contexts isn’t always easy. Here are a few known issues you may encounter after you import your 3DS file into another program:

  • Textures and materials exported with the Export Two-Sided Faces checkbox selected can become flipped in certain applications, such as Maya. A 3DS mesh does not store any normal data, so the target system must compute the model’s normals. Some importers might compute the normals incorrectly, resulting in flipped textures.
  • Truncated texture map file names are also common. Because the 3DS format was designed in the DOS age, it’s not capable of storing texture file names that exceed the 8.3 DOS character limit. If you’ve used modern OS file names (and you probably have), SketchUp creates unique names for each texture by adding unique suffixes to file names. For example, a file named corrugated metal.jpg is described in the 3DS file as corrugat.jpg. Any other files that use the same first six letters are truncated, and the suffix 01, 02, and so on, is added.
  • 3DS format can’t store an orthographic camera. This format is simulated through a perspective camera with a very small field of view or a very large lens length. The eye point is moved as far away as possible to yield the same width and height of the projection plane. Certain applications might have problems with a small field of view. For example, Maya does not read the field of view at all and only lets it become as small as 2.5.
OS:

Need Help Fast?

SketchUp’s outstanding community of passionate experts have answers to your questions.