How Can We Help?

Viewing Your Model in Google Earth

Previewing a SketchUp model in Google Earth is great way to see how your model looks in the context of its surroundings.

You start the process in SketchUp, where you optimize the model for viewing in Google Earth. Because Google Earth and SketchUp models can both use a lot of your graphics card’s processing power, your model needs to be as light as possible.

When your model is ready, you can preview your model in Google Earth directly from SketchUp. All it takes is a single click!

When your model is ready, you can preview your model in Google Earth by easily exporting to KMZ from SketchUp.

Of course, all this assumes you have Google Earth installed on your computer. If not, Google Earth is free, and you can download the software at

In the sections that follow, you find help with optimizing your model, previewing your geo-located model in Google Earth, and finding additional online learning resources.

Tip: For an in-depth look at site-modeling in SketchUp, check out the following video. The video walks you through an architectural workflow for creating a site model by combining SketchUp, Google Earth, and Google Maps.

Table of Contents
  1. Optimizing a model for display in Google Earth
  2. Previewing a model in Google Earth
  3. Placing models in the ocean
  4. Saving a model in Google Earth
  5. Finding help with Google Earth

Optimizing a model for display in Google Earth

When you create a 3D model that you want to display in Google Earth, you can create your model in SketchUp so that your model looks its best in Google Earth. This section explains the SketchUp modeling techniques that work best with Google Earth.

Geolocate your model

To geolocate your model, import terrain using the Add Location tool. Or to add a location manually in SketchUp Pro, select Window > Model Info, select the Geo-location option in the sidebar on the left, click Set Manual Location, and enter a latitude and longitude in the dialog box that appears. When you geolocate your model, you ensure your model appears in the correct location in Google Earth.

Tip: When you geolocate your model with the Add Location tool, you can import terrain that enables you to create your model based on the site where you plan to build it (or just display it in Google Earth). Wherever you place your model on imported terrain in SketchUp determines the location of your model when you preview it in Google Earth. See Modeling Terrain and Other Rounded Shapes for details about importing and sculpting terrain as well as tips for modeling terrain that you want to display in Google Earth.

If you don’t geolocate your model, your model appears in Google Earth at a default location.

Note: Your default location depends on the language associated with SketchUp. For example, if you downloaded the American English version of SketchUp, SketchUp’s default location is Boulder, Colorado. Other default locations include London, Paris, Berlin, Rome, Tokyo, Barcelona, Taipei, Brasilia, Seoul, Beijing, Moscow, and Amsterdam.

Create a precise model

When you display your model in Google Earth, your model dimensions need to be accurate so that your model’s scale is proportional to the surrounding landscape or buildings in Google Earth.

Measuring Angles and Distances to Model Precisely explains how to create a model with precise dimensions. If you create a model with the Match Photo feature, you can scale the model after you’re done creating it.

Minimize the edges and faces

Tip: The key to optimizing a SketchUp model for Google Earth is to keep the model complexity as light as possible.

For example, the following figure shows a model of the Eiffel tower optimized for display in Google Earth. Without textures projected onto the model (as explained in a moment), you can see how minimal the underlying geometry can be, even when you’re modeling a complex structure.

Textures off

As you create a model with minimal geometry, remember that you can reduce the number of sides in a circle or an arc.

Make sure fronts of faces are facing outward

Remember that SketchUp faces have a front and back. If the back side of a face points outward, the face appears black in Google Earth, no matter what material is applied to the back side of the face.

To check that the face fronts point outward in SketchUp, select View > Face Style > Monochrome to see whether the back sides of a any faces point outward. By default, the face fronts are white and face backs are dark gray. To reverse a face, context-click it and select Reverse Faces.

In the following figure, you see a basic model with materials (left) and in monochrome (right); the left, side face needs to be reversed.

Tip: Sometimes, it’s difficult to determine whether a face is truly facing outward or just shaded to show perspective. If you’re having trouble, orbit so you have a straight-ahead view of the face. Or, in the Styles browser, you can use the Face Settings to edit the default back face color so that the backs of faces stand out more than they do in the default gray.

Convey model details by projecting image textures onto your model

In a model that’s optimized for viewing in Google Earth, the geometry itself conveys little detail about the building. Instead, you use photos applied to each face to show the detail.

In SketchUp, applying a photo to a face is called projecting a texture. You can project a texture by importing a photo as a texture or projecting textures after you use the Match Photo feature.

You can use Google imagery, digital photos, or graphics you create as photo textures in SketchUp. For example:

  • If you’re modeling an existing building, you might be able to import images from Google or take your photos with a digital camera. (The article on using the Match Photo feature includes tips on taking photos for 3D modeling.)
  • If you’re modeling a building plan, you can create a building image in a graphics editor and export it in one of the image formats that SketchUp photo textures support, such as .png. Or apply custom photo textures to your model as materials, and project the textures before viewing your model in Google Earth. For details, see Applying Colors, Photos, Materials, and Textures.

Tip: Because your overall goal in optimizing your model for Google Earth is the smallest file size, make sure your images are optimized for the Web. Both .png and .jpg files can be compressed to lower the file size. If you’re using images taken with a digital camera, be sure to optimize the images for the web in your image editor before importing the images into SketchUp.

Texture your model with images that support transparency

If you need to be able to look through part of your building, create transparent areas in the images that you use to texture your model. You may need to convert your images to a file format that supports transparency, such as .png, and then create the transparent areas in an image editor.

In the following figure, you see the Eiffel tower model with photo textures that contain areas of transparency. On the left, you see the model in Google Earth, and on the right, you see the same model in SketchUp. Notice that the model looks realistic and that you can look through the structure, just as you can with the real tower.

In Google Earth and SketchUp

Previewing a model in Google Earth

With many projects, the preparation is the hardest part. Previewing a model in Google Earth is no exception. When your model is ready to preview, all you need to do is click the Preview Model in Google Earth tool () or select File > Preview in Google Earth.

With many projects, the preparation is the hardest part. Previewing a model in Google Earth is no exception. When your model is ready to preview, all you need to do is export your SketchUp model as a Google Earth KMZ file. Simply open the KMZ with Google Earth and viola!

For example, the following figure shows a model of a garden shed placed on imported terrain.

After you tell SketchUp that you want to preview the model in Google Earth, Google Earth loads your model and zooms to show in the location you indicated, as shown in the following figure.

Note that sometimes Google Earth imagery is a little older than what’s in Google Maps’ aerial or Street View photography. Also, in flat areas or areas with mostly rectilinear buildings, you can see your model in the context of the surrounding area more easily than you can in a neighborhood with lots of mature trees.

Within Google Earth, you can use Google Earth’s navigation tools to move around the area and see how your model looks on its intended site.

Note: Instead of using SketchUp’s Preview in Google Earth feature, you can export a SketchUp model as a .kmz file. (See Using SketchUp Data with Other Modeling Programs or Tools for details about exporting SketchUp files to other file formats.) When you double-click the .kmz file on your hard drive to open it, the file opens in Google Earth instead of SketchUp.

Placing models in the ocean

Google Earth has an Ocean layer, and you can preview models in the ocean by completing a few extra steps.

First, in SketchUp, select Window > Extension Warehouse, and in the Extension Warehouse window that opens, search for the Ocean Modeling extension. After you select the extension to open its page, you can click an Install button the upper right.

After the Ocean Modeling extension installed, you can locate your model in the ocean and preview it in Google Earth. The following figure shows the garden shed floating the Pacific Ocean, off the coast of Los Angeles, California.

Saving a model in Google Earth

When you preview a model in Google Earth, the model is loaded into Temporary Places. If you want to save your model in Google Earth, context-click the temporary model name in the Temporary Places folder and select Save to My Places. The model then moves from the Temporary Places folder to the My Places folder, as shown in the following figure.

After your model is saved in Google Earth, you can open Google Earth directly, select the model, and fly to it. You don’t need to use the preview feature in SketchUp.

Tip: By default, your model is named SUPreview0 in Google Earth. To give your model a more descriptive name, context-click the model name in Google Earth’s Places pane and select Rename. If you need to delete a model from Google Earth, context-click its name in the Places pane and select Delete.

Finding help with Google Earth

Although SketchUp includes tools for previewing your model in Google Earth, Trimble doesn’t offer full Google Earth support.

You find several Google Earth tutorials for beginning and advanced users on Google Earth’s Learn page. You can also take a full tour of the Google Earth interface.

On Google Earth’s Connect page, you find links to the Google Earth community, including its user forum, and newsletter.


Need Help Fast?

SketchUp’s outstanding community of passionate experts have answers to your questions.