How Can We Help?

Animating Sections and Scenes

SketchUp can animate scenes of a 3D model. Animations are a great way to show off your model from different angles or share shadow studies. For example, say you create a scene with a morning shadow, another scene with a noon shadow, and a third with an evening shadow. With SketchUp’s animation feature, you can watch the shadow transition from morning to evening.

Before you create an animation, create scenes of your model, each with different settings, as explained in the article, Creating Scenes. When the scenes are ready to be animated, you can create the animation in one of three ways:

  • Play an animation of the scenes in SketchUp.
  • Export the animation to a video file, such as .mp4, which plays on most devices.
  • Export an image set, which is a collection of image files that you can animate with video software. (SketchUp Pro only)

Tip: Use SketchUp for simple presentations or when the customer has SketchUp Mobile Viewer. The animation export features are handy when you can’t use SketchUp to play an animation. Here are a few examples of when you might need to export your animation:
  • Presenting your model to a client who doesn’t have SketchUp or SketchUp Mobile Viewer.
  • Sharing a video export on your website or via a video sharing service.
  • Post-processing the animation in another application.
Table of Contents
  1. Animating scenes in SketchUp
  2. Exporting video animations
  3. Exporting image sets

Animating scenes in SketchUp

After you create and sequence your scenes, animating scenes in SketchUp is easy. You can play the animation in one of two ways:

  • Context-click the scene tab that you want to begin the animation and select Play Animation from the menu that appears.
  • In the Scenes manager, select the scene that you want to begin the animation, and select View > Animation > Play from the menu bar.

To customize the animation, select View > Animation > Settings or select Window > Model Info and select the Animation option in the sidebar. Either way, you see the following settings in the Model Info window:

  • Scene Transitions: The Enable Scene Transitions checkbox is selected by default, and when selected, SketchUp animates a smooth transition from one scene to the next. Below the checkbox, enter a number in the Seconds box to set the length of each transition.
  • Scene Delay: Type a number in the Seconds box to set how long a scene appears before SketchUp begins to transition to the next scene.

Exporting video animations

You can export an animation to a video file, although your options in SketchUp Make are bit more limited than those you have with SketchUp Pro.

To export your animation, follow these steps:

  1. Select File > Export > Animation > Video. The Export Animation dialog box appears.
  2. Navigate to the place where you want to save your video file.
  3. Type a name for the file in the File Name text box.
  4. Select a file format from the Export TypeSave as type drop-down list. The following table explains your file format options.
  5. Click Options to open the Animation Export Options dialog box, where you can set the resolution, aspect ratio, frame size, frame rate, and more. See the upcoming list for details about each option.
  6. After you finish setting your options, click OK in the Animation Export Options dialog box to return to the Export Animation dialog box.
  7. Click Export and SketchUp renders your animation as a video file.

To export your animation, follow these steps:

  1. Select File > Export > Animation. A dialog box appears.
  2. Navigate to the place where you want to save your video file.
  3. Type a name for the file in the Save As text box.
  4. Select a file format from the Format drop-down list. The following table explains your file format options.
  5. Click Options to open the Export Options dialog box, where you can set the resolution, aspect ratio, frame size, frame rate, and more. See the upcoming list for details about each option.
  6. After you finish setting your options, click OK in the Export Options dialog box to return to the main dialog box.
  7. Click Export and SketchUp renders your animation as a video file.

The table outlines your codec (which compresses the video) and file format options and what you need to know about each one.

Option Where to Play This File Type Good to Know
H.264 codec .mp4 In a web browser, with many video programs, and on many hardware devices .mp4 is a compressed video format, and one of the most broadly supported video file types.
Uncompressed .avi In Windows Media Player or on a Mac, in VLC Uncompressed .avi generates a larger video file and also plays on most computers and devices. You may want uncompressed video if you plan to edit the video in video-editing software.
Vp8 codec .webm In the Chrome, Firefox, or Opera web browser, or with a few media player applications, such as VLC. .webm is a compressed open media file format that works with the HTML5 video tag. The format was designed as an open format for the web.
Theora codec .ogv In a web browser or with a media player, such as VLC An .ogv file is often embedded in a web page via the HTML5 video tag as an alternate to the .webm format. This way, website visitors can use whichever file their preferred browser supports.

Before you render your video, you can choose from the following options, which can make your file size larger or smaller and change the physical dimensions of the video. Here’s quick overview of the export options:

  • Resolution: Choose among three preset resolutions: 1080p Full HD, 720p HD, or 480p SD. The lower the number, the lower the resolution. The highest resolution looks great when played full screen on a large monitor. However, it also has the biggest file size, which may not be great for video played over the web on a mobile device. The lowest resolution has an aspect ratio for monitors with a standard 4:3 aspect ratio, which is more square than a widescreen monitor (with a 16:9 aspect ratio). The preset options cover most video outputs, but if you’re video savvy and have SketchUp Pro, you can create a custom setup: Select Custom to set the Aspect Ratio and Frame Size on your own.
  • Aspect Ratio: Choose from 16:9 for widescreen monitors, 4:3 for standard monitors, or Custom to modify the frame’s width and height independently of each other.
  • Frame Size: This setting is locked by default. By choosing Custom from the Resolution drop-down list, you can alter the height. By choosing Custom for the Aspect Ratio drop-down list, you can alter both the Width and Height.
  • Preview Frame Size: Click this button to check how your video will look in the frame size that you’ve selected.
  • Frame Rate: The higher the frame rate, the smoother the video and the larger the file size will be. In SketchUp Make, your only option is 29.97 frames per second (fps). In SketchUp Pro, the default setting is 24 frames per second, but you can select 15, 25, 29.97, or 30 to lower or raise the frame rate.
  • Loop to Starting Scene: In SketchUp Pro, this option is enabled by default. When selected, the animation plays in a continuous loop. Deselect this option if you don’t want the video to loop. SketchUp Make users do not have this option.
  • Anti-alias Rendering: This option is enabled by default and smooths vector lines if they appear choppy or jagged. In SketchUp Make, this option is enabled, and you cannot deselect the checkbox.
  • Transparent Background (Mac OS X only): When selected, background imagery is set to transparent. By default, this option is deselected.
  • Always Prompt for Animation Options (Microsoft Windows only): When selected, you’re prompted to set animation options before you export the file. By default, this option is deselected.
  • Restore Defaults: Click this button to reset the export options to SketchUp’s default options.

Exporting image sets

If you’re a SketchUp Pro user, you can export an animation to series of images called an image set.

To create an image set, follow these steps:

  1. Select File > Export > Animation > Image Set.
  2. In the Export Animation dialog box, select where you want SketchUp to save your images. Because the process typically generates a few hundred images, creating a folder just for these images is a good way to keep them organized.
  3. In the File Name box, type the root name for your images. SketchUp appends a number to each image as it renders the image set, so that the images stay in order for the animation.
  4. In the Export TypeSave as type drop-down list, select an image type. The .png file type works for most applications, but you can also choose from .jpg, .tif, and .bmp. The .tif format produces large image files that are less compressed and typically less compatible with other software than .jpg or .png.
  5. Click Options to open the Animation Export Options dialog box, where you can set the resolution, aspect ratio, frame size, frame rate, and more. Refer to the preceding section for details about each option, but note that the Anti-alias Rendering option is not available for image sets. Click OK when you’re done setting your options to return to the Export Animation dialog box.
  6. Click Export, and SketchUp begins creating your image set. The process can take a few minutes or longer, depending on the length of your animation.

To create an image set, follow these steps:

  1. Select File > Export > Animation.
  2. In the dialog box that appears, select where you want SketchUp to save your images. Because the process typically generates a few hundred images, creating a folder just for these images is a good way to keep them organized.
  3. In the Save As text box, type the root name for your images. SketchUp appends a number to each image as it renders the image set, so that the images stay in order for the animation.
  4. From the Format drop-down list, select one of the three image types: .png, .jpg, or .tif. The .png file type works for most applications. The .tif format produces large image files that are less compressed and typically less compatible with other software than .jpg or .png.
  5. Click Options to open the Export Options dialog box, where you can set the resolution, aspect ratio, frame size, frame rate, and more. See the list in the preceding section for details about each option.
  6. After you finish setting your options, click OK in the Export Options dialog box to return to the main dialog box.
  7. Click Export, and SketchUp begins rendering your image set.
OS:

Need Help Fast?

SketchUp’s outstanding community of passionate experts have answers to your questions.