How Can We Help?

Setting Up Templates

Your model’s template determines your model’s default settings. SketchUp includes several templates for common applications, like architecture, construction, urban planning, landscape architecture, woodworking, interior and production design, and 3D printing.

Your template determines a model’s default units of measurement. In each of SketchUp’s included templates, the default units reflect each template’s application. For example, 3D printing and woodworking require a high degree of precision, so the 3D printing and woodworking template units are either millimeters or inches. However, if you’re designing a building or a landscape, working in millimeters or inches would be annoying and impractical. That’s why those templates default to feet and inches or meters.

If the default templates aren’t quite to your liking, you can add your own custom touches and save them as a custom template file. Here’s a quick look at the types of things you can save to a template:

  • All the settings in the Model Info dialog box: This dialog box sets the defaults for your model as a whole. You will find a quick introduction to this dialog box at the end of this section.
  • Geometry you’ve created in the drawing area: For example, some templates include a 2D person standing at the axis origin. When you save geometry to a template, any new model based on the template includes the geometry you saved.
  • Styles: In the Styles browser, you find bundled sets of styles or you can edit the face, edge, background, and watermark individually. See Choosing a Style for details.
  • Shadows: Shadows are often a finishing touch on a model, but you can also use them to explore shadow behavior or simply enhance the contours of an object. See Communicating Your Designs for details. Keep in mind, however, that because shadows require extra memory, so they’re typically not turned on by default. This keeps your model light, as explained in Improving Performance
Table of Contents
  1. Changing your default template
  2. Creating a template
  3. Exploring the Model Info dialog box

Changing your default template

You selected a default template when you first started SketchUp (as explained in Getting Started in SketchUp). If you ever want to change the default template, just follow these steps:

  1. Select Window > Preferences (Microsoft Windows) or SketchUp > Preferences (Mac OS X).
  2. In the sidebar on the left, select the Template option.
  3. Select one of the templates in the Drawing Template list box. Or click the Browse button to navigate to a template that you’ve saved locally, select the template file, and click Open.
  4. Click OK (Microsoft Windows) or simply close the dialog box (Mac OS X). The next time you create a new model file, SketchUp uses your new default template.

Creating a template

If you’re always making the same change or set of changes when you create a new model, you can save all those changes to a new template so that you can start creating your model right away.

To create a new template, follow these steps:

  1. Create a new SketchUp file with your current default template.
  2. Make only the modifications that you want to save with the template. Templates include all the settings in the Model Info dialog box, Style settings, and Shadow settings. You can also create any base geometry. For an overview of the Model Info dialog box, see the next section.
  3. Select File > Save As Template.
  4. Navigate to the location where you want to save your template.
  5. Give the template a name.
  6. Click the Save button.

After you save the template, you need to follow the steps in the preceding section to make the modified template your default template.

Note: Technically, you can overwrite the existing template with your changes by saving the template under its installed filename in SketchUp’s installed Templates folder. However, you’ll like need to make changes in your operating system first. On Microsoft Windows, you need permission to save files to SketchUp’s Template’s folder, which you find at the following location: C:\Program Files\SketchUp\SketchUp Version\Resources\en-US\Templates. On Mac OS X, you need to make your Library files visible in order to see them, and your templates are saved in this location: ~/Library/Application Support/SketchUp 2014/SketchUp.

Exploring the Model Info dialog box

The Model Info dialog box is where you apply settings for your entire model, so it makes sense that templates reflect all the settings you make here. To open the Model Info dialog box, shown in the following figure, select Window > Model Info. To access the different types of settings, select an option from the sidebar on the left.

The following list introduces each of the options in the sidebar:

  • Animation: If you animate scenes, as explained in Communicating Your Designs, the settings here set the timing for the transitions and delay between scenes.
  • Classifications: If you use BIM (building information modeling) and classification data, as explained in Classifying Objects, you can import classification systems via this panel.
  • Components: Set preferences for how components and groups appear when you’re editing inside the component or group context. You can also toggle the visibility of component axes. See Grouping Geometry and Developing Components and Dynamic Components for details.
  • Credits: You can view who created a model or click Claim Credit to add the name of the SketchUp license owner to the model. If your model contains components, see who created the components, too. This feature is handy if you’re collaborating with a team to create a model, or if you upload or download models and components via the 3D Warehouse.
  • Dimensions: Set the defaults for dimension text. See Adding Text to a Model.
  • File: See basic data about the model file.
  • Geo-location: Check whether your model is geolocated. If not, you can add a location via Google. SketchUp Pro users can also enter geographic coordinates manually. See Modeling Terrain and Other Rounded Shapes for an introduction to geolocated models.
  • Rendering: You find a setting here for anti-aliased textures, which improves performance. See Improving Performance for more about customizing SketchUp to manage performance issues.
  • Statistics: This pane keeps track of all the entities your model contains. You find tools for purging unused entities and fixing problems, too.
  • Text: Set defaults for screen text and leader text, as explained in Adding Text to a Model.
  • Units: Choose the default unit of measurement for your model. Start with the options in the Format drop-down list: Architectural, Decimal, Engineering, or Fractional. If you choose Decimal, you can also choose whether your model uses inches, feet, millimeters, centimeters, or meters as the default unit.

Need Help Fast?

SketchUp’s outstanding community of passionate experts have answers to your questions.