How Can We Help?

Customizing Your Workspace

You know how you like to work, and SketchUp enables you to customize the overall workspace to reflect that.

In this article, find out what workspace preference options you have and how those options work. Also, check out the tips and tricks for customizing your toolbars and tidying up dialog boxes that you like to keep open. You’re almost certain to find a few ways to draw more efficiently in SketchUp.

Table of Contents
  1. Running SketchUp on multiple displays
  2. Setting preferences to customize your workspace
  3. Exporting and importing SketchUp preferences
  4. Migrating plugins, materials, and components
  5. Viewing and customizing toolbars
  6. Arranging dialog boxes
  7. Arranging dialog boxes and trays
  8. Changing colors of selected items and other on-screen aids

Running SketchUp on multiple displays

For most people who have a multiple-display system, it’s hard to imagine ever working on a single monitor again. If that describes you, the good news is that you might be able to run SketchUp on a multiple-display system. The not-so-good news is that SketchUp doesn’t officially support multiple-display systems, so if you encounter issues running SketchUp on multiple monitors, Trimble doesn’t provide support for those issues.

Setting preferences to customize your workspace

In SketchUp, preferences options enable you to customize your workspace.

To access these preferences, select Window > Preferences (Microsoft Windows) or SketchUp > Preferences (Mac OS X) from the menu bar. In the sidebar on the left, select the preference panel that you need.

The following table outlines how you can customize the workspace and what preference panel enables you to make a change.

To Do This Open this Preference Panel Good to Know
Set the default image editor. Applications Determines what image editor opens when you want to edit a texture in an external editor. Click Choose and select an application on your operating system.
Display crosshairs on your cursor that correspond to axes colors. Drawing Select the Display Crosshairs checkbox in the Miscellaneous area.
Activate the Paint Bucket tool after you click a material swatch (Mac OS X only). Drawing This checkbox is enabled by default. Deselect Auto-activate Paint Tool to disable it.
Toggle the Push/Pull tool’s pre-pick feature. Drawing Pre-pick is enabled by default so that you can select a face, orbit, and push/pull the face even when the selected face doesn’t appear in the current view. Select Disable Pre-pick on Push/Pull Tool to disable the feature.
Display a component bounding box and its edges in different colors. Compatibility (Microsoft Windows) or Drawing (Mac OS X) This feature is disabled by default. Select the Bounding Box Only checkbox, and a component’s edges appear in a different color from the component box when you select the component.
Enable SketchUp extensions that you download from the Extension Warehouse. Extensions After you download an extension, select its check box and click Install Extension. See the Knowledge Center’s Extension Warehouse section for details about extensions.
Change the size of the toolbar buttons. Workspace The large buttons are enabled by default because they’re easier to see and use. For smaller buttons and a larger drawing area, deselect the Use Large Tool Buttons checkbox.
Select whether windows cascade and the default window size (Mac OS X only). Workspace On a Mac, windows cascade by default. Deselect Cascade Main Windows to turn off cascading. Click the Save Current Window Size button to make the size of the active window your default window size in SketchUp.
Reset your workspace to the default configuration, with all dialog boxes closed. Workspace Click the Reset Workspace button and everything snaps closed.

Exporting and importing your SketchUp preferences

When you make changes to your preferences, SketchUp saves your preferences automatically. If you work on your 3D models on two different computers or are upgrading from one computer to another, you can export your preferences from one copy of SketchUp and import them into another. This section explains how to export and import preferences for your current operating system.

To export your preferences in Microsoft Windows, follow these steps:

  1. Select Window > Preferences.
  2. Select Files in the sidebar on the left.
  3. Click the Export button. The Export Preferences dialog box appears.
  4. Navigate to the folder where you want to save the preferences file. The file is called Preferences.dat by default but you can rename it if you like.
  5. (Optional) By default, your keyboard shortcuts and file locations are exported with your other preferences. If you don’t want to export either of these, click the Options button to open the Export Preferences Options dialog box. Deselect the Shortcuts and File Locations checkboxes and click OK when you’re done.
  6. In the Export Preferences dialog box, click the Export button, and the preferences file is saved to the location you specified. You can now save the file to your new or other computer and import your preferences into another copy of SketchUp.

When you’re ready to import your preferences into SketchUp on another computer, follow these steps:

  1. Select Window > Preferences.
  2. Select Files in the sidebar on the left.
  3. Click the Import button.
  4. Navigate to the location on your computer where you saved the exported preferences file and select the file.
  5. (Optional) Click the Options button and, in the Import Preferences Options dialog box, deselect the Shortcuts or File Locations checkbox if you don’t want to import keyboard shortcuts or file locations. Click OK when you’re done.
  6. Click the Import button, and your preferences are imported into SketchUp.

On Mac OS X, you can save your keyboard shortcuts file to your new or other computer. Your keyboard shortcuts are automatically saved in the following location: MachintoshHD/Users/[User name]/Library/Application Support/SketchUp #/SketchUp/Shortcuts.plist

Simply copy the file to the same location on another Mac, and your shortcuts will work.

Migrating plugins, materials, and components

SketchUp 2014 introduced options for Ruby scripting which may have affected your favorite plugin. If you're upgrading to a newer version of SketchUp from SketchUp 2013 or older please read our article on SketchUp Plugin Compatibility before you start installing or transferring plugins.

Note: At this time, there isn't a way to migrate the toolbar configuration between major versions of SketchUp.
Migrating Materials & Components
  1. ( If you're migrating from SketchUp 8 and older ) Navigate to the root folder in SketchUp 8 and older. This is typically,
    C:\Program Files\Google\Google SketchUp #\Materials (or Components)
    ( If you're migrating from SketchUp 2013 or newer ) Navigate to the root folder in SketchUp 2013 and newer. This is typically,
    C:\Program Files\SketchUp\SketchUp 201#\Materials (or Components) where # is the most recent version of SketchUp installed.
  2. Select the files in the Materials folder and press Ctrl+C to copy the items.
  3. Navigate to C:\Program Files\SketchUp\SketchUp #\Materials (or Components)
  4. Press Ctrl+V on your keyboard to paste the files. On Windows 7, you'll be asked if you want to Merge the folders and "Confirm Folder Replace." Click Yes to the warnings.
  5. You'll then be prompted with each subsequent material file to either "Copy and replace" or "Don't copy." We recommend you select "Don't copy" so you can retain the new content with the same file name. Any new content files that you created, however, will be copied without any problem. You can also select the "Do this for the next ### conflicts" so you don't have to approve each file.
  6. Open SketchUp 2014 or newer and your new materials should be in the Materials dialog box, and/or your new components will be in the Components dialog box.
Migrating Plugins

We've been investing heavily in extensions because we know that the power of SketchUp shines when customers install the right extensions to solve their needs. That's why we've built the Extension Warehouse, worked carefully with developers so they can get their plugin in the Extension Warehouse, and addressed long standing requests like updating the Ruby environment to version 2.0 (which is why some plugins may be breaking at the moment - we made the change that developers have been asking for!). The problem is that the current way of managing extensions, plus the updated Ruby version, doesn't support the old way of managing plugins very well. This makes migrating plugins to SketchUp 2014 and newer a bit tricky. We also don't have all the possible plugins in the Extension Warehouse. We feel that finding and managing SketchUp Extensions is getting better and brighter all the time, but we're not at our ideal yet. For some customers, they will need to go through their old plugin list, plugin by plugin, search for that plugin in the Extension Warehouse, install the plugin, and move on to the next. Once your plugins are managed by the Extension Warehouse, it will be significantly easier to re-install these extensions when newer versions of SketchUp are released in the future, or if you get a new computer and have to install a fresh copy of SketchUp. If you've installed plugins from the Extension Warehouse in an older version of SketchUp and you need to install the same plugin in a newer version of SketchUp, we added an Install All button in the Extension Warehouse which will install any of your SketchUp 2013 plugins into SketchUp in one click, but only if those plugins have been updated to support new versions, which most of them have. Only after you've tried installing plugins from the Extension Warehouse, or downloading an updated version of plugins that you've paid for from those plugin developers, do we suggest attempting to copy and paste plugins between folders:

If you have a plugin that utilized a custom installer (i.e. you double-clicked on a file that installed the plugin), you need to contact the plugin developer for specific instructions on updating to support SketchUp 2014 or newer. These instructions are intended for users who copy and pasted .RB, .RBS, or .RBZ files into the SketchUp plugins folder:

  1. Open a new Windows Explorer window.
  2. ( From SketchUp 8 )Navigate to the root folder for the older version of SketchUp. This is typically,
    C:\Program Files\Google\Google SketchUp #\Plugins
    ( From SketchUp 2013 ) Navigate to the root folder for the older version of SketchUp. This is typically,
    C:\Program Files\SketchUp\SketchUp 2013\Plugins
  3. Select the files in the Plugins folder and press Ctrl+C to copy the items.
  4. Navigate to C:\Users\USERNAME\AppData\Roaming\SketchUp\SketchUp #\SketchUp\Plugins
  5. Press Ctrl+V on your keyboard to paste the files.
  6. Open SketchUp 2014 or newer and access the plugins as you have in the past. Note that there may be some older plugins that are not compatible with your current version of SketchUp. In this case, please contact the plugin developer for additional assistance.
Note: Not all SketchUp plugins are compatible with the current version of SketchUp. Please contact the plugin developer if you need additional assistance.
Migrating Materials & Components

Watch the video

  1. Open a new Finder window.
  2. Open the Go menu and choose "Go to Folder"
  3. ( If you're migrating from SketchUp 8 ) Enter the following and click Go
    ~/Library/Application Support/Google SketchUp 8/SketchUp/Materials
    ( If you're migrating from SketchUp 2013 ) Enter the following and click Go
    ~/Library/Application Support/SketchUp 2013/SketchUp
  4. Select the files in the Materials folder and press Command+C to copy the items.
  5. Open the Go menu and choose "Go to Folder"
  6. Enter the following and click Go
    ~/Library/Application Support/SketchUp 2015/SketchUp ~/Library/Application Support/SketchUp 2014/SketchUp
  7. NOTE: If there is no "Materials" folder, you will need to create one.
  8. Press Command+V on your keyboard to paste the files.
  9. Open SketchUp 2014 or newer and your new materials should be in the Materials dialog box, and/or your new components will be in the Components dialog box.
Migrating Plugins

We've been investing heavily in extensions because we know that the power of SketchUp shines when customers install the right extensions to solve their needs. That's why we've built the Extension Warehouse, worked carefully with developers so they can get their plugin in the Extension Warehouse, and addressed long standing requests like updating the Ruby environment to version 2.0 (which is why some plugins may be breaking at the moment - we made the change that developers have been asking for!). The problem is that the current way of managing extensions, plus the updated Ruby version, doesn't support the old way of managing plugins very well. This makes migrating plugins to SketchUp 2014 and newer a bit tricky. We also don't have all the possible plugins in the Extension Warehouse. We feel that finding and managing SketchUp Extensions is getting better and brighter all the time, but we're not at our ideal yet. For some customers, they will need to go through their old plugin list, plugin by plugin, search for that plugin in the Extension Warehouse, install the plugin, and move on to the next. Once your plugins are managed by the Extension Warehouse, it will be significantly easier to re-install these extensions when newer versions of SketchUp are released in the future, or if you get a new computer and have to install a fresh copy of SketchUp. If you've installed plugins from the Extension Warehouse in an older version of SketchUp and you need to install the same plugin in a newer version of SketchUp, we added an Install All button in the Extension Warehouse which will install any of your SketchUp 2013 plugins into SketchUp in one click, but only if those plugins have been updated to support new versions, which most of them have. Only after you've tried installing plugins from the Extension Warehouse, or downloading an updated version of plugins that you've paid for from those plugin developers, do we suggest attempting to copy and paste plugins between folders:

  1. Open a new Finder window.
  2. Open the Go menu and choose "Go to Folder"
  3. ( If you're migrating from SketchUp 8 ) Enter the following and click Go
    ~/Library/Application Support/Google SketchUp 8/SketchUp/plugins
    ( If you're migrating from SketchUp 2013 ) Enter the following and click Go
    ~/Library/Application Support/SketchUp 2013/SketchUp/
  4. Select the files in the Plugins folder and press Command+C to copy the items.
  5. Open the Go menu and choose "Go to Folder"
  6. Enter the following and click Go
    ~/Library/Application Support/SketchUp 2015/SketchUp ~/Library/Application Support/SketchUp 2014/SketchUp
    NOTE: If there is no "Plugins" folder, you will need to create one.
  7. Press Command+V on your keyboard to paste the files.
  8. Open SketchUp 2014 or newer and access the plugins as you have in the past. Note that there may be some older plugins that are not compatible with the current version of SketchUp. In this case, please contact the plugin developer for additional assistance.
Note: Not all SketchUp plugins are compatible with the current version of SketchUp. Please contact the plugin developer if you need additional assistance.
Migrating Materials & Components
  1. Navigate to the root folder in SketchUp 8 and older. This is typically, C:\Program Files\Google\Google SketchUp #\Materials (or Components)
  2. Select the files in the Plugins folder and press Ctrl+C to copy the items.
  3. Navigate to C:\Program Files\SketchUp\SketchUp 2013\Materials (or Components)
  4. Press Ctrl+V on your keyboard to paste the files. On Windows 7, you'll be asked if you want to Merge the folders and "Confirm Folder Replace." Click Yes to the warnings.
  5. You'll then be prompted with each subsequent material file to either "Copy and replace" or "Don't copy." We recommend you select "Don't copy" so you can retain the new content with the same file name. Any new content files that you created, however, will be copied without any problem. You can also select the "Do this for the next ### conflicts" so you don't have to approve each file.
  6. Open SketchUp 2013 and your new materials should be in the Materials dialog box, and/or your new components will be in the Components dialog box.
Migrating Plugins

Before transferring plugins, be sure to check out the Extension Warehouse first. Your favorite plugin might already be there. If so, installing the plugin in SketchUp 2013 can be done with one click. Otherwise, give these steps a try:

If you have a plugin that utilized a custom installer (i.e. you double-clicked on a file that installed the plugin), you need to contact the plugin developer for specific instructions on updating to support SketchUp 2013. These instructions are intended for users who copy and pasted .RB, .RBS, or .RBZ files into the SketchUp plugins folder

  1. Open a new Windows Explorer window.
  2. Navigate to the root folder for the older version of SketchUp. This is typically, C:\Program Files\Google\Google SketchUp #\Plugins
  3. Select the files in the Plugins folder and press Ctrl+C to copy the items.
  4. Navigate to C:\Program Files\SketchUp\SketchUp 2013\Plugins
  5. Press Ctrl+V on your keyboard to paste the files.
  6. Open SketchUp 2013 and access the plugins as you have in the past. Note that there may be some older plugins that are not compatible with 2013. In this case, please contact the plugin developer for additional assistance.
Note: Not all SketchUp plugins are compatible with version 2013 just yet. Please contact the plugin developer if you need additional assistance.
Migrating Materials & Components

Watch the video

  1. Open a new Finder window.
  2. Open the Go menu and choose "Go to Folder"
  3. ( If you're migrating from SketchUp 8 ) Enter the following and click Go
    ~/Library/Application Support/Google SketchUp 8/SketchUp/Materials
  4. Select the files in the Materials folder and press Command+C to copy the items.
  5. Open the Go menu and choose "Go to Folder"
  6. Enter the following and click Go
    ~/Library/Application Support/SketchUp 2013/SketchUp
  7. NOTE: If there is no "Materials" folder, you will need to create one.
  8. Press Command+V on your keyboard to paste the files.
  9. Open SketchUp 2013 and your new materials should be in the Materials dialog box, and/or your new components will be in the Components dialog box.
Migrating Plugins

Before transferring plugins, be sure to check out the Extension Warehouse first. Your favorite plugin might already be there. If so, installing the plugin in SketchUp 2013 can be done with one click. Otherwise, give these steps a try:

  1. Open a new Finder window.
  2. Open the Go menu and choose "Go to Folder"
  3. Enter the following and click Go
    ~/Library/Application Support/Google SketchUp 8/SketchUp/plugins
  4. Select the files in the Plugins folder and press Command+C to copy the items.
  5. Open the Go menu and choose "Go to Folder"
  6. Enter the following and click Go
    ~/Library/Application Support/SketchUp 2013/SketchUp
    NOTE: If there is no "Plugins" folder, you will need to create one.
  7. Press Command+V on your keyboard to paste the files.
  8. Open SketchUp 2013 and access the plugins as you have in the past. Note that there may be some older plugins that are not compatible with 2013. In this case, please contact the plugin developer for additional assistance.
Note: Not all SketchUp plugins are compatible with version 2013 just yet. Please contact the plugin developer if you need additional assistance.

Viewing and customizing toolbars

Depending on what you model in SketchUp or where you are in the 3D modeling process, you’re likely to favor some tools over others. In SketchUp, you can decide which toolbars you want to see. Toolbars are organized differently on Microsoft Windows and Mac OS X. In this section, you discover the options for customizing SketchUp toolbars for your current operating system.

On Microsoft Windows, you can change which toolbars appear in your SketchUp workspace by selecting View > Toolbars. In the Toolbars dialog box that appears, select the checkbox next to any toolbar you want to see, or deselect the checkbox for any toolbar you don’t want to see. Then click the Close button.

The following table introduces each toolbar and when the toolbar is most useful.

Toolbar Name Toolbar This Toolbar Is Handy When …
Advanced Camera Tools Modeling movie sets with the ACT tools
Camera Looking at your model from many different angles
Classifier Modeling with BIM (Building Information Modeling) and IFC data.
Construction Modeling precisely
Drawing Drawing a 3D model
Dynamic Components Developing dynamic components
Edit Editing an existing model
Getting Started Learning to draw in SketchUp
Google Accessing Google Earth for images, geolocation data, or terrain
Large Tool Set Displays the Principal, Drawing, Edit, Construction, and Camera toolbars as well as the Section tool in a long narrow toolbar that docks to the left side of the drawing area. You need an all-purpose toolbar.
Layers Organizing groups or components into layers to control visibility, especially after you have experience working with SketchUp’s layers feature.
Location Accessing maps for images, geolocation data, or terrain
Principal You need only a basic tool set and want to maximize the drawing area
Sandbox Modeling TINs to create terrain or rounded objects
Section Adding section planes that create a view inside your model
Shadows Adjusting shadow settings or studying shadows at different times of day
Solid Tools Modeling complex shapes with the Solid tools
Standard Accessing basic file and clipboard commands from a toolbar would be helpful
Styles Switching among SketchUp’s face styles frequently, such as when tracing a floor plan in X-Ray view and then checking your geometry in Shaded with Textures view
Views Switching among the standard views, such as Top, Front, Iso, and so on
Warehouse Sharing models via the 3D Warehouse or adding extensions via the Extension Warehouse

On Mac OS X, SketchUp has a toolbar at the top as well as several tool palettes. You can customize what tools appear on the toolbar and choose whether to see the toolbar and tool palettes.

To customize the toolbar at the top of SketchUp’s interface, you can do the following:

  • Choose how the icons and text appear. Context-click the toolbar, and you can select whether you want to see icons, icons and text, or just text on the toolbar.
  • Hide or show the toolbar. If you want more drawing area or just don’t use the toolbar, select View > Hide Toolbar, and it disappears. Alternately, context-click the toolbar and select Hide Toolbar. If the toolbar is hidden and you want to see it again, select View > Show Toolbar.
  • Select what tools appear on the toolbar. If you only want to see the tools that you use the most or to order tools in a specific sequence, you’ll love this feature. Select View > Customize Toolbar or context-click the toolbar and select Customize Toolbar from the menu that appears. You see the dialog box shown in the following figure, which contains all of SketchUp’s tools. To add a tool, drag it to the toolbar. To remove a tool, drag it off the toolbar. If you want to restore the default set, drag it from the bottom of the dialog box to the toolbar. You can also drag tools into whatever position you prefer. When you’re finished customizing the toolbar, click Done.

You can also customize what tools you see by showing and hiding tool palettes. To see a palette, select View > Tool Palettes and select your desired tool palette from the submenu that appears. Your options are as follows:

  • Large Tool Set: This palette offers a handy set of tools used most often when drawing, editing, and viewing a 3D model.
  • Google: This palette is handy when accessing Google Earth for images, geolocation data, or terrain.
  • Warehouse: If you want to share models with the 3D Warehouse or download extensions from the Extension Warehouse, this palette keeps all the relevant tools at the ready.
  • Sandbox: This palette contains tools for modeling TINs to create terrain or rounded objects. For SketchUp Pro users, the Sandbox tools are enabled by default. SketchUp Make users see the Sandbox tools after enabling them via the Extensions preferences. See Setting preferences to customize your workspace earlier in this article for details.

SketchUp Pro users also see the following options:

  • Solid Tools: All these tools help you model complex shapes from other shapes. For example, use a peg to create the hole into which the peg must fit.
  • Advanced Camera Tools: This palette is for anyone who uses the ACT tools to model movie sets.
  • Dynamic Components: Display this palette when you’re developing dynamic components.

Arranging dialog boxes

In SketchUp, many dialog boxes are designed to remain open as you create a 3D model. (Technically, these dialog boxes are called modeless, meaning you don’t have to input something and close the dialog box to continue your work.)

Here are a few examples of how you might use modeless dialog boxes:

  • When you apply materials to your model, the Materials browser stays open so that you can move in and out of the browser as you apply materials or edit photo textures.
  • As you place tree and shrub components around a building, you may need to keep the Components browser open to select your components and use the Outliner so that you can easily select a component and replace it with another.

All these modeless dialog boxes are handy until you need to continue drawing or editing your model. Then, the dialog boxes can clutter the drawing area.

Tip: SketchUp’s dialog boxes are designed so that you can keep the dialog boxes that you need open but move them out of the way quickly and easily. You find most of the modeless dialog boxes on the Window menu.

As you create your 3D models, try the following techniques for arranging modeless dialog boxes:

  • Stack them up: The dialog boxes’ top and bottom edges stick together, so that you can create a stack. Click and drag the title bar of the topmost dialog box to move the whole stack at once.
  • Shrink them down: Click a dialog box’s title bar to collapse the dialog box, so that you see only the title bar. Click a collapsed dialog box to open it again.
  • Snap the stack: Drag the stack to the outer edge of the application window, and the stack snaps to the edge.
  • Shuffle the stack: Drag a dialog box’s title bar to the left to break it from the stack. You can then drag the dialog box back into the stack wherever you’d like to place it. If a dialog box is at the bottom of the stack, you can drag it down to break it from the stack.

In the following figure, you see how stacking the dialog boxes helps you tidy up the SketchUp interface.

Tip: Some dialog boxes, such as the Components browser, can be resized. Hover the cursor over the lower-right corner until you see the resize cursor. Then click and drag to resize the dialog box.

Arranging dialog boxes and trays

In SketchUp, dialog boxes are maintained in a tray. You can customize the tray in terms of which dialog boxes are expanded or collapsed, as well as which dialog boxes are in a given tray, and the location of the tray on your screen. The default tray has many of the most commonly used dialog boxes.

As you create your 3D models, try the following techniques for arranging dialog boxes in a tray:

  • Expand or Open them: Click the dialog box’s title bar to expand or open the dialog box so you can see the contents. If enough dialog boxes are opened so that they go below the SketchUp window, move your mouse cursor over the tray and scroll your mouse.
  • Collapse or Close them: Click a dialog box’s title bar to collapse the dialog box, so that you see only the title bar. Click a collapsed dialog box to open it again.
  • Add/Remove them: Select Window > Manage Trays… to open the tray manager. Select the tray you want to modify in the left pane, then add a checkmark to dialog boxes you want to see in the tray, and remove the checkmark next to dialog box names that you want to remove from the tray.
  • Shuffle or Move them: Drag a dialog box’s title bar up or down through the tray to change the order of the dialog boxes. You can do this if the dialog box is expanded or collapsed, though it’s a bit easier to see what you’re doing if you shuffle the dialog boxes when they’re collapsed. To move a dialog box between trays, drag the dialog box to the destination tray tab at the bottom of the tray window where you would like to move the dialog box.
Tip: You can assign keyboard shortcuts to trays including which dialog boxes to open, toggling the visibility of a tray, and open Manage Trays... or New Tray... dialogs.

Managing Trays

When you first install SketchUp, a default tray will be created for you and it will contain the most commonly used dialog boxes. Over time, you may want to create new trays that contain only the dialog boxes you want. To create a new tray, simply select Window > New Tray... This will open the New Tray manager. Give a name to the tray – don’t worry, you can change this name later if you’d like – and select which dialog boxes you want to add to the tray. To toggle between the trays, click the tray name in the tabs listed at the bottom of the tray area.

Note: You can hide any tray as well as delete any tray – but note the difference. Hiding a tray removes the tray from the drawing window. You can do this clicking on the close button in the top right corner of the tray (the red square with the white X) or by clicking Window > [Tray Name] > Hide Tray. To show the tray again, select Window > [Tray Name] > Show Tray. If you want to delete a tray, select Window > [Tray Name] > Delete Tray. You can’t delete the Default tray, however.

What’s great about the tray system is that if you would like to have a clean drawing space with no dialog boxes, select the pin icon in the top right corner of the tray. This puts the tray in Auto Hide mode. Move your mouse to the drawing area and the tray will disappear. To unhide the tray, move your mouse to the right side of the drawing window and over the tab with the tray name. If you created additional trays, those trays will also appear as a tab.

Tip: You can move trays, too! Simply select the top bar of the tray – where the tray name is located – and drag the tray to the top, bottom, left, or right side of the drawing window. You can even drop the tray anywhere on your screen to make it a “floating” tray. The tray can’t be moved while in Auto Hide mode, however.
Tip 2: You can change the tray width by dragging the side edge of the tray left or right. Likewise, if the tray is floating (i.e. not docked), you can also drag the lower edge up or down – ideal for smaller trays as it can remove empty white space.

Understanding Tray States

Tray States isn't a nickname for States in the US that resemble a cafeteria tray (sorry Colorado). "States" in this case refers to the ways that trays can be positioned on your computer screen when using SketchUp. The three tray states are Pinned, Auto Hide, and Floating. This section will also cover how to dock, undock, and organize trays.

  • Pinned: This is the default state when you first create a new tray. Pinned trays are stuck to the side of the window and always visible – and you can have multiple pinned trays. If you create a new tray, it will pin itself to the side of your window and you will have two tabs at the bottom of the window. Click the X on a tray to hide that tray. Click the thumb tack icon to unpin and re-pin trays.
  • Auto Hide: Trays will hide and show when you move your cursor over the tray name on the side of your screen. To auto hide a tray, click the thumb tack icon.
  • Floating: A floating tray will sit wherever you put it on the screen. If you have multiple pinned trays (i.e. you see tabs at the bottom), they will all stay in the floating tray.

Docking, undocking, and organizing trays

To make a tray float, grab the tray header and drag it off the side of the screen. To doc a floating tray grab the header and place it on one of the tray icons that appear. If you are docking a floating tray over a pinned tray note that you can doc it to the side or add it as a tab by dropping it over the center icon showing the tray tabs.

Moving tray in SketchUp around the screen

Changing colors of selected items and other on-screen aids

You can customize the colors of selected, locked, and other on-screen aids. Perhaps you have trouble seeing a particular color, or your model’s materials closely match a specific color on-screen.

Here’s a quick list of the on-screen aids whose color you can customize:

  • Selected item
  • Locked geometry
  • Guides
  • Inactive section planes
  • Active section plane
  • Section cuts

To customize the colors of these items, follow these steps:

  1. Select Window > Styles to open the Styles browser. Open the Styles dialog box in the Default Tray.
  2. Click the Edit tab.
  3. Click the Modeling Settings icon (), and you see color swatches for the items you can customize, as shown in the following figure.
  4. Click the color swatch for the item you want to customize.
  5. In the Choose Color dialog box, select a new color and click OK. For details about selecting colors, see Mixing Colors in the Color Picker. Your model reflects the new color immediately.

Tip: On the Modeling pane, you can toggle the visibility of items by selecting or deselecting the checkboxes in the middle of the pane. For example, to hide all the guides in your model, you can deselect the Guides checkbox.

See Matching a Photo to a Model (or a Model to a Photo) for details about the Match Photo settings.

OS:

Need Help Fast?

SketchUp’s outstanding community of passionate experts have answers to your questions.