How Can We Help?

Classifying Objects

Some philosophers say that naming something is the first step toward figuring out what makes that thing different from all the other things in the world.

In a SketchUp 3D model, this idea isn’t some wishy-washy concept. When you use the Classifier to embed data into groups or or components, those groups or components become objects. When objects that have names, descriptions, and so on, you can manage the details about all the classified objects.

The details that you can track and manage can represent so much more than simply what the modeled object looks like. Consider the following:

  • You can count, measure, dimension, and tag objects.
  • You can generate reports. When your model contains classified objects, SketchUp’s Generate Report feature enables you to output that the classification data however you need to see it.
  • You can analyze your model. If you want to analyze a model for energy performance, cost, schedule or even just render a beautiful photorealistic picture from it, you need more information than exists in SketchUp’s native geometry of lines and faces. SketchUp objects can carry that information, which means you can do BIM (Building Information Modeling).
  • You can export the objects into other formats or programs. When you export SketchUp objects, they can contain all kinds of higher-order representations of things. For example, if your project workflows use BIM, you can export objects classified using the IFC 2x3 schema from SketchUp into the open BIM data exchange standard, IFC. (IFC stands for Industry Foundation Classes, an open data model standard for building information.) Rendering applications can use these attributes, such as material type and light sources, to simulate a scene. SketchUp’s APIs expose all the additional data that developers need to make rich importers and exporters from just about any information modeling format.

The upshot is that if you classify your data in SketchUp, you can use BIM to create models that not only look realistic, but also contain practical data about all the objects that need to be assembled in order to keep the rain out.

To use SketchUp’s Classifier tool and its related features covered in this article, you need a SketchUp Pro license.

Tip: To learn more about BIM and IFC, visit the Building Smart website.

In the sections that follow, you find out how to classify objects in SketchUp and generate a report based on that data. If you need to use classification data other than the IFC standard that SketchUp supports, learn how to import and export classifications or create your own classification data file.

Table of Contents
  1. Classifying objects in the SketchUp interface
  2. Generating an attribute report
  3. Importing, exporting, and deleting classifications
  4. Creating an SKC file

Classifying objects in the SketchUp interface

Before you start classifying objects, make sure your model is ready:

  • Your soon-to-be objects must start as components. Developing Components and Dynamic Components explains how to transform everyday geometry into a component.

    Tip: When you create a component, you can assign it a type by selection an option from the Type drop-down list in the Create Component dialog box.
  • The classification system must be loaded into your template. If you create a 3D using SketchUp’s Architectural Design - Feet and Inches template, the IFC classification system is ready to go. (Otherwise, you need to import classifications.)
  • You probably want to display the Classifier toolbar. IF you don’t see it, select View > Toolbars and select the Classifier checkbox

After you complete the basic housekeeping, you’re ready to start classifying objects. With the Classifier toolbar, all you have to do is click a couple of things:

  1. Select your component.
  2. Open the drop-down menu in the Classifier toolbar, click the arrow next to IFC 2x3 (or whatever your classification system is), and select an object type, as shown in the following figure.

Tip: If you’re having trouble finding the classification you need, type part of its name in the Filter text box, which narrows down the options.

The toolbar also has the Classifier tool (). Here are a few things to keep in mind as you classify objects with the Classifier tool:

  • If the drop-down menu has a white background and a type, this indicates that the Classifier tool is active and clicking objects with the Classifier tool will apply the type displayed in the toolbar.
  • If you click a component, the classification type is assigned to all the instances of the same component unless you hold down the Shift key as you click with the Classifier tool. Holding down the Shift key makes the component instance you click unique and applies the type data only to that component instance.
  • To remove a type from an object, make Type: <undefined> active in the drop-down menu and then click an object to remove the type data. Alternatively, select the same type from the list of classification options.

If you prefer, you can select classification data from the Entity Info window:

  1. Context-click your component and select Entity Info from the menu that appears.
  2. In the Entity Info window, shown in the following figure, select a classification from the Type drop-down menu. This displays the same interface you see when use the Classifier toolbar.

You can also sample an object’s classification and apply it to another component. First make sure no geometry is selected. Then, click the Classifier tool (). Hold down the Alt key (Microsoft Windows) or Command key (Mac OS X) as you click a classified object. Release the modifier key and click another component to apply the object’s classification type.

Tip: When you assign an IFC type to a component, know that the type is assigned to the component definition (not a single component instance). If you copy components in your model, know that you’re assigning that classification type to all component instances.

If you need to separate a component into two different definitions, you can do that. For example, say both a floor and a ceiling are the same shape and they both need IfcSlab classifications. You don’t want to redraw the geometry, but you do want to distinguish between floors and ceilings in your information modeling. Here’s how to set up that information modeling structure with the least amount of work:

  1. Copy a classified object and move it into its new position. In the example, you copy the floor and move the copy to create a ceiling.
  2. Context-click the copy and select Make Unique from the menu that appears.
  3. Open the Entity Info window for the copy (in this case, the ceiling).
  4. Type a new definition in the Definition text box. In the following figure, you can see the Entity Info windows for the two example components; notice how they both have the same IFC type but different definitions.

Generating an attribute report

To create a report of your classified model, follow these steps:

  1. Select one or more entities in the model.
  2. Select File > Generate Report.
  3. In the Generate Report dialog box that appears, select the All Model Attributes radio button to save a report with all attributes in your model. Or select the Current Selection Attributes radio button to save a report with the attributes in your current selection.
  4. Click the Generate HTML File button or Generate CSV File button to generate either an HTML or CSV file.
  5. Click Save to save your report.

The image below shows a basic model from SketchUp with several component definitions. Note that each component definition is labeled, some are arrayed to illustrate how copies are displayed in the report.

Note: To use the new Generate Report features you need to be online so SketchUp can contact our servers. If you're offline these features will be unavailable.

Getting Started

Report templates are currently saved with a model so new models will not have a template. Below is what you'll see with a fresh file that has not had a report template set up. Click the Create New Report button to begin.

Tip: If you want a report with the Quantity attribute, make a duplicate of the Component Quantities Report template and work from that copy – don't create a new report. Click the Duplicate button on the Generate Report dialog.

Setting up a report

To start creating a report and template you'll need to choose the high level filtering by running the report on the Entire Model or only the Current Selection. Additionally you can choose to narrow the Nesting Levels to run the report on a range of nested components. Note that the SketchUp model itself is identified as Level 1 while any Group or Component at the root level will display as a Level 2 object.

The next step is to select and order the columns in the report. The stack on the left is your selected attribute columns and their ordering. Select attributes on the left and use the arrow buttons or drag and drop to move them to the right. Note that top to bottom order will correspond to left to right ordering in the report.

Click Continue to preview your report in the next page

Viewing the Report and Saving a Template

Below is a sample report which is based on the above settings. Note how any of the columns can be used to sort the entire report.

Click Save Changes to save the report template to your model so you can quickly re-run the report as you make changes to your model. See the next image for setting up the name and info for your report template.

Click the Download button to save a CSV file to your local machine.

Template Info

When saving a report as a template you can name the template, view it's time stamp, add an author name and description. Make sure you click Save to Model to store the template with your model.

  • The Trash Icon will discard the template.
  • Edit allows you to adjust the Filtering and Column selections.
  • Run will re-run the report and display it in the dialog

Save Report to Machine

Save a report to your local machine by clicking Download and choose where to save the CSV file. At this time we do not supporting HTML files.

Tip: With a CSV file, you can import your report into a spreadsheet program for further analysis. For example, select all cabinets in a scene that has cost attributes. Then, use the SUM formula in Microsoft Excel to calculate the total cost of all items in the selection set. This same method can be used to calculate total board feet for wood used in a project, and so on.

Tip: To get a glance at the status of classified objects in your model without having to generate a report, select Window > Model Info > Statistics. In the list, you can see the number of Classification Types used and the number of Classified Entities.

Importing, exporting, and deleting classifications

As you work with classification files, know that SketchUp uses classification systems that are in the .skc or .xsd file formats.

To import a classification into a SketchUp model, follow these steps:

  1. Select Window > Model Info.
  2. In the Model Info window, select Classifications on the left.
  3. In the Classifications panel, click Import. By default, a file browser opens to your user Classifications folder.
  4. If you copy your .skc or .xsd file to the Classifications folder, select the file you want and click Open. Otherwise, click the Browse button to import a file from another location.

When you import a classification, that data is embedded into the SketchUp file. So if you share a SketchUp model with someone else and they open the file on their copy of SketchUp, they can reference and use the same classification.

Tip: You can also create a SketchUp template with your favorite classification so you don’t have to import the .skc or .xsd file every time you create a new SketchUp file. SketchUp’s Architectural Design and Construction Documentation templates have the IFC 2x3 classification in them by default.

If you receive a SketchUp file that has an embedded classification, you can export that classification to a .skc file on your computer. To do so, open the Classifications panel in the Model Info window. Select the classification from the list that appears, and click the Export button. This is helpful if you want to have a local copy of a .skc classification file to use in other SketchUp models.

When you remove a classification from your SketchUp model, you remove the type and attribute data from that SketchUp file, too. However, any classifications that exist locally on your computer stay where they are. To delete a classification from a SketchUp model, open the Model Info windows Classifications panel, select the classification, and click Delete.

Creating an SKC file

In SketchUp, the .skc file format stores the classification data that you see in the Classification tool. Each .skc file contains XML schema definition files and other files that help define additional schema metadata. All these files are zipped up in one file.

In this section, you learn about the guts of the .skc file and find steps that walk you through creating one.

For the purposes of this tutorial, you modify a sample ifcXML4.skc file to create a new SKC file with your schema data. Follow these steps to get started:

  1. Click here to download the sample ifcXML4.skc file.
  2. Rename the file from ifcXML4.skc to something else, like my_schema.zip.
  3. Unzip my_schema.zip.

In the sections that follow, you find a introduction to each of the files in my_schema.zip. You also find details about what you can change and how to customize your classification data. After you learn about each file, you find out how to back the .zip file back into an .skc file.

doc_thumbnail.png

This image file visually represents your schema. You can replace this file with your own image file and name it however you like. (Note that SketchUp 2014 and 2015 don’t currently use this file but may do so in a future release.)

documentProperties.xml

This file is required, and you cannot change its name. However, you may want to change several fields in this file. Although SketchUp 2014 and 2015 display only your change to the title field, future releases of SketchUp may take advantage of the other fields in this file. Here’s a list of all the fields in the documentProperties.xml file and what you can and can’t change:

  • The title field contains the name of your schema that appears throughout the SketchUp UI. Change it to reflect your schema’s name.
  • The description field contains the schema’s description. Change it to describe your schema.
  • The creator field contains the the schema creator’s name. Change it to reflect the creator of your schema.
  • The revision field reflects the revision of your schema. Change it if you would like or leave this field as it is. This field must have a value.
  • The created and modified fields reflect the created and modified dates of the schema. You can change these fields or leave them as they are but they can’t be blank. If you change the dates, the values must follow this format: YYYY-MM-DDThh:mm:ss. For example, sometime on January 30, 2014 looks like this: 2014-01-30T12:00:00
  • The thumbnail field points to your schema’s thumbnail. If you are using a schema-specific thumbnail, change this field to reflect the name of your schema’s thumbnail.

The following figure shows the data you might want to change in the documentProperties.xml file. Don’t modify any data other than what’s highlighted here.

references.xml

This file is required to properly load the .skc file. You can’t rename it or modify anything within it.

Schemas folder

This folder holds your schema’s .xsd files. You also have the option of saving filter files in this folder. Filter files control what type data is displayed, as explained a little later in this section. Copy your .xsd files to this subfolder and delete the sample ifcXML4.xsd file.

SketchUp can process any valid .xsd file or collection of files that use the http://www.w3.org/2001/XMLSchema namespace, with the following exceptions:

  • The XML Schema format allows for circular importing of .xsd files (i.e. two files referencing each other with the element). This is only supported in SketchUp 2015 and later.
  • The XML Schema format allows for externally referenced .xsd files. This is only supported in SketchUp 2014 M1 and later.
  • Any <xsd:list> or <xsd:choice> attributes don’t appear in the Component Options dialog box where classification attribute data is displayed. These attributes may become visible in future versions of SketchUp.

Note: If your schema file contains included or imported .xsd files, the XML Schema file hierarchy must be maintained.

Filter files

Filter files enable you to restrict what type and attribute data is visible in the SketchUp UI by default. If an .xsd.filter file exists, a Simplify button appears in the SketchUp UI wherever type data is displayed. This Simplify button enables users to toggle between the restricted view of the schema data that you set up and the full set of data. If an .xsd file has no filter file, all types and attributes are visible.

Filter files can whitelist types and their attributes, and they can blacklist attributes:

  • Whitelisting makes the types and attributes visible in the UI. When you whitelist a type, you can choose what attributes for that type appear in the Component Options dialog box.
  • Blacklisted attributes are not displayed. Blacklisting an attribute affects all types that haven’t whitelisted that attribute.

To create a filter file, follow these steps:

  1. Create a file with the same name as the .xsd file that you want to filter and a .filter file extension.
  2. List the type names you want to make visible by default in the UI.
  3. (Optional) In curly braces ({}), list any attribute data you want to make visible by default.

For example, here’s how the my_schema.xsd.filter file shown in the following figure impacts the SketchUp interface:

  • A Simplify button appears for the my_schema schema.
  • By default, only the IfcBeam type as well as its Name, Description, ObjectType, and Tag attributes are visible. A user can, however, click the Simplify button to toggle the display all schema data and the simplified version you set up.
  • The blacklisted instanceAttributes attribute isn’t visible.

As you create your own filter files, the following tips are also good to know:

  • To add comments to this file, start each line with a double forward slash (//).
  • To create an attribute blacklist (instead of a whitelist), don’t add a type name to the line before the open curly brace ({).
  • Save a .filter file with its .xsd counterpart. For example, if base.xsd is saved in the Schemas\base folder, you need to save base.xsd.filter in the same folder.
  • The .filter file format is subject to change in future versions of SketchUp.

document.xml

This file indicates the relative path to the root .xsd file for your schema. This file is required and you can’t rename it. As shown in the following figure, change xsdFile="Schemas/ifcXML4.xsd" to point at your root .xsd file that you copied to the Schemas folder.

Repackaging your .zip file

After you customize the files, you simply have to zip them back together. Include only the necessary files — not the folder that contains all your files. If you include that folder, SketchUp can’t import your schema.

After you create the .zip file, change the extension from .zip to .skc and optionally rename the file. You are now ready to load your .skc file into SketchUp!

OS:

Need Help Fast?

SketchUp’s outstanding community of passionate experts have answers to your questions.