How Can We Help?

Adding Premade Components and Dynamic Components

SketchUp components enable you to reuse objects.

For example, pretty much every building has at least one door and window. Instead of modeling these common objects, you can insert a component that someone else has already made. Like all geometry in SketchUp, a component is still made of edges and faces. The edges and faces are simply part of a special component group. (You can also create components to reuse your own geometry, but that’s covered in Developing Components and Dynamic Components.)

Before you start inserting components, you need to know that every component has a definition and an instance:

  • A component definition provides a blueprint for how all components of a specific type appear and behave in the drawing area.
  • When you insert a component into a model, you create a component instance, which is based on its definition.

So, say you want to use a premade component called Framed Half Door with Double Panel. The component definition outlines what that door looks like, and you can insert as many instances of that component into your model as you like. In the following model, you see two instances of Framed Half Door with Double Panel. Inserting components, later in this article, explains how insert one or more component instances.

All this business about the definition and instances is important, because when you edit entities within a component instance, you edit the definition, too. Change the door’s glass, and the glass in all component instances changes. Change the double panel into a single panel, and all the doors in your model have a single panel, too. However, you can scale, rotate, and flip a whole component without changing the other instances. Editing components explains how to edit component entities or the component as a whole.

You can also replace all component instances with another component. If you (or a client) decide you don’t like the Framed Half Door with Double Panel, you can easily swap that component with a different one. See Replacing components, later in this article, for details.

Dynamic components have even more capabilities than regular components. If a component is dynamic, it has at least one of the following elements:

  • Constrained values: For example, a dynamic cabinet door component might have a frame that’s constrained to 3 inches. Whether the panel inside the frame is 12 x 24 inches or 24 x 48 inches or some other dimension, the frame remains 3 inches wide all the way around the door, as shown in the following figure.
  • Repetitive elements: A dynamic component can have subcomponents that repeat as you scale the component. For example, a repetitive dynamic component might add steps to a staircase, cushions to couch, pickets to a fence, studs to construction framing, and so on.
  • Configurable values: A dynamic component can have a predefined set of values that you can configure, such as a couch’s length or the picket spacing in a fence component.
  • Animated features: An animated dynamic component moves when you click it with the Interact tool (). With animated dynamic components, your model can have doors and windows that open. Interacting with components, later in this article, explains how to open and close animated components.

You can find a few sample components in SketchUp’s Components browser, but components’ true home is the 3D Warehouse, an online tool for searching and downloading 3D models created in SketchUp. This article helps you navigate the Components browser and start searching for components in the 3D Warehouse via tools available in SketchUp.

After you become comfortable inserting and editing components, you might develop a special fondness for components that you find in the 3D Warehouse or create yourself. To keep your favorite components handy and organized, you can create collections in the Components browser.

In the following video, you see a brief introduction to components, how components are different from groups, and ways you can edit components. Although this video was created on an older version of SketchUp, the basic component behavior and features are the same in current SketchUp versions. In the sections that follow, you find detailed steps that walk you through the basics of inserting and working with components and dynamic components.

Table of Contents
  1. Inserting components
  2. Replacing components
  3. Interacting with dynamic components
  4. Searching for components
  5. Adjusting a component’s insertion point
  6. Editing components
  7. Organizing component collections
  8. Gathering intelligence about components

Inserting components

You can insert a component instance into your model in three ways:

  • Select or download a component via the Components browser.
  • Import a SketchUp file (with the .skp file extension).
  • Drag a SketchUp file from File Explorer (Microsoft Windows) or the Finder (Mac OS X) into your model.

Premade components are most often inserted from the Components browser into a model. Follow these steps:

  1. Select Window > Components Open the Components dialog box in the Default Tray . By default, the Components browser opens to the Components Sampler collection, as shown in the figure.

  2. You can select one of the sample components and proceed to the next step. However, the sampler’s selection is limited compared to the vast selection in the 3D Warehouse. To try the 3D Warehouse, type a search term in the 3D Warehouse search box. (Searching for components, later in this article, explains other ways to search the 3D Warehouse.) To browse collections, click the down arrow next to the In Model icon () and select a collection. (See Organizing component collections for details about the existing collections and how to create your own.) After you select or download a component, SketchUp loads the component onto the Move cursor.
  3. Click in the drawing area to place the component in your model.

Tip: If you have trouble seeing the components in the Components browser, try changing your view options. Click the View Options button () and choose from Small Thumbnails, Large Thumbnails, Details, or List.

If you have a SketchUp model saved to your hard drive, you can import that model as a component in another model. Follow these steps:

  1. Open the model into which you want to import a SketchUp file.
  2. Select File > Import.
  3. In the Open dialog box that appears, navigate to the SketchUp file. If you don’t see your file, in the Files of Type drop-down list, select SketchUp Files (.skp).
  4. Select the SketchUp file, and click Open. SketchUp loads the component onto the Move cursor.
  5. Click in the drawing area to place the component in your model.

Dragging a SketchUp file from the File Explorer (Microsoft Windows) or the Finder (Mac OS X) into an open model also loads the SketchUp file onto the Move cursor. Simply click to place the component in your model.

Tip: When your component is loaded onto the Move tool cursor, the Move tool is anchored to the component’s axis origin point. If that doesn’t work for you, change the location of the component’s axis origin before you insert the component. Doing so will change the default insertion point. See Adjusting a component’s insertion point for details.

Replacing components

People like to see different options, and they change their minds all the time. When indecision strikes or your design just hasn’t become clear to you yet, know that you can easily replace one component with another component. Here’s how the process works:

  1. Add the new component to your model. If you don’t have anywhere to put it, just place it in an empty area in your model by following the steps in the preceding section. Placing the component somewhere in your model ensures that the component appears in your In Model collection. (Even if you then delete the component for now, the component remains in your In Model collection until you purge unused components.)
  2. In the Components browser, click the In Model icon () to see your In Model collection.
  3. Select the component or components that you want to replace.

    Tip: To select all instances of a component, context-click the component in the Components browser and choose Select Instances, as shown in the figure.

  4. In the Components browser, context-click the component you want to use instead of the existing one and choose Replace Selected from the context menu. In this example, that’s the Large Panel Door component. The old door is now replaced with the new door, as shown in the following figure.

Tip: SketchUp Pro users have an additional tool: the Swap Component command, which works with dynamic components.

To swap out a series of dynamic components in SketchUp Pro, follow these steps:

  1. Select the dynamic components you want to replace. The components are highlighted in the drawing window.
  2. Context-click one component, and select Dynamic Components > Swap Component. The Select a SKP dialog box is displayed.
  3. Select the SketchUp file containing the dynamic component that will replace the currently selected components.
  4. Click the Open button. The new dynamic component replaces the previously selected dynamic components.

Interacting with dynamic components

Your ability to interact with a dynamic component depends on its variables. In the following figure, you see a basic building with two instances of a dynamic door component.

To activate the component’s animation, select the Interact tool () on the Dynamic Components toolbar or select Tools > Interact. When you click the door with the Interact tool cursor, the door opens, as shown in the following figure.

This dynamic component also has configurable values. To see these values, click the Component Options tool () on the Dynamic Components toolbar or select Window > Component Options. In the Component Options window, shown in the following figure, you can choose from preset options for the frame width, frame height, door type, and more.

Searching for components

You can search for components in the Components browser or the 3D Warehouse.

In the Components browser, on the Select tab, you can use the following features to browse or search for components:

  • In Model icon: Click the In Model icon (), and you see the In Model collection, which shows all the components currently saved with your model. Note that a component doesn’t have to actually appear in your model to be saved with it.
  • In Model drown-down menu: Click the down arrow next to the In Model icon, and from the list that appears, you can select premade collections such as Architecture, Landscape, People, and Transportation. This menu may also show collections you’ve created, collections you’ve designated as a favorite, or collections you’ve visited recently. (Organizing component collections, later in this article, explains how to create and manage collections.)
  • 3D Warehouse search box: Type a search term in the box and press Enter (Microsoft Windows) or Return (Mac OS X), and you see a list of components from the 3D Warehouse. To connect to the 3D Warehouse, your computer needs to an Internet connection. If your search brings up multiple results, you can click the arrows at the bottom of the Components browser to see more results. You may find it easier to search the 3D Warehouse in a full browser window than the Components browser, which is too small to show much detail in the component thumbnails.

To access the 3D Warehouse directly from SketchUp, click the Get Models tool (), which you find in the following parts of SketchUp’s interface:

  • Getting Started toolbar
  • Warehouse toolbar

You can also select File > 3D Warehouse > Get Models.

Whichever method you use, the 3D Warehouse opens, as shown in the following figure. From the opening screen, you can browse the featured models, featured manufacturer catalogs, featured collections, and recent models. However, you most likely want to use the Search box at the top. Type a search term and click the Search button.

Tip: *Start with the most specific search term. For example, if you’re looking for a window that’s a dynamic component with a cut plane that makes a hole in your model, type a search term like, dynamic component window cuts face*. If you don’t find a component you like, make your search term less specific from there.

When you find a result that interests you, click it to open its details page. Click the Download button in the upper right to download the component into your model. You then return to SketchUp, where the Move cursor is loaded with the component. Click in the drawing area to place the component in your model.

Adjusting a component’s insertion point

A component has its own axis origin point, which determines the component’s insertion point, or the point that’s loaded onto the Move cursor when you place a component in your model.

If the component is box-shaped (such as a dresser, cabinet, or the Mesopotamian Tablet of Destinies), the insertion point is typically the front, lower-left corner, as shown in the figure. That placement works great — unless you need to place the component against other components or otherwise work around existing geometry.

Whatever your reasons for moving the insertion point, here’s how to reset a component’s axis origin:

  1. Select the component in your model.
  2. Context-click the component and select Change Axes.
  3. With the Axes tool cursor that appears, reset the axis origin. See Adjusting the Drawing Axes for details about working with the Axes tool. The only difference is that you’re setting the axis origin for a component, not the whole model.

Tip: After you place a component in your model, you can move the component by any point you like. Simply select the Move tool (), click the point you want to use for moving the component, and click again to place the component. For example, after placing a cabinet component in your model, you might need to move the cabinet by its midpoint so you can slide the cabinet next to existing cabinets. See Moving Entities Around for more about moving entities with the Move tool.

Editing components

You can edit a component as a whole or edit individual entities within a component.

Editing or modifying a component instance as a whole affects only the component instance, not the component definition or other instances. Here are some of the edits you can make to a component as a whole:

  • Scale: Scaling a component as a whole scales the individual component instance, not the component definition, allowing you to have differently scaled instances of the same component in your model. A component can become skewed when you scale the component in multiple directions. You can reset a component’s scale and skew by context-clicking the component and selecting Reset Scale or Reset Skew. To scale a component, use the Scale tool(), as explained in the article, Scaling Your Model or Parts of Your Model.
  • Flip: You can flip (or mirror) a component along an axis. Context-click the component, select Flip Along, and select an axis (Component’s Red, Component’s Green, or Component’s Blue).
  • Rotate: You can rotate a component with the Rotate tool () or the Move tool (). When you use the Rotate tool, you have more control over the rotate plane and center of rotation.

Flipping and Rotating explains how to flip and rotate geometry. To rotate a component with the Move tool, hover the Move tool over a face that’s perpendicular to the desired axis of rotation until four rotation handles and a protractor appear on the face, as shown in the following figure. Then click a rotation handle and rotate the component.

Editing entities within a component changes the component definition, and thus changes all other component instances in your model. To edit entities within a component, you have to open the component’s context, which is like an invisible force field surrounding the component: You can’t see the context until you’re within it. Unlike the force fields on Star Trek, breaking into a SketchUp component’s force field — er, context — is easy: All you have to do is double-click the component with the Select tool ().

In the following figure, you see three instances of a spaceship component. The box made of dotted lines surrounds the component whose context is open. After you’re inside a component’s context, you can use any of SketchUp’s drawing tools to edit the component instance, which changes all the component instances in your model. Click an empty space in the drawing area to close the component’s context.

You can also save edits to your component, revert an edited component to the original file, or explode the component:

  • To save an edited component as a separate file with a new name, select the component, context-click it, and select Save As from the menu that appears. Navigate to where you want to save the .skp file, type a new name, and click Save.
  • To reload a component from its original file, which overrides any edits, context-click the component and select Reload.
  • To break a component back into its entities, select your component and then select Edit > Component Instance > Explode from the menu bar. Or context-click the component and select Explode from the menu that appears. Your component is no longer a component with a special force field. It returns to plain old geometry, kind of like a captain returning to civilian life.

Note: You can edit properties of a component, such as whether it cuts a hole in a face, or set variables for a dynamic component. Because these advanced tasks are closely related to creating components, you find out how to work with these properties in Developing Your Own Components or Dynamic Components.

Organizing component collections

In SketchUp’s Components browser, collections help you organize components.

The In Model collection is a special collection that’s an important part of the Components browser. It holds all the components saved with your model, whether or not those components currently appear in your model. When you context-click a component in this collection, you see commands not available in other collections, such as Select Instances, Reload, and more. To see your In Model collection, click the In Model icon (). If you’ve inserted several components that you no longer need to save with your model, click the Details arrow () and select Purge Unused.

SketchUp includes a few prebuilt collections, such as Architecture, Landscape, Construction, and so on. You find these collections by clicking the down arrow next to the In Model icon, as shown in the following figure.

Tip: By creating your own collections, you can organize components in whatever way makes sense to you. If you use certain components all the time, create a My Favorite Components collection. If you use specific components for a certain client or project, organize them into a collection so they’re accessible from a single collection.

The following steps explain how to create a component collection for your current operating system (Microsoft Windows or Mac OS X):

  1. Select Window > Components Open the Components dialog box in the Default Tray to open the Components browser.
  2. Click the Details arrow () and select Open or Create a Local Collection.
  3. In the Browse for FolderSelect Folder dialog box that appears, navigate to the folder where you want to save your collection. To create a subfolder for the collection, click the Make New Folder button and create the folder.
  4. Select the folder where you want to save the components collection and click OKSelect Folder. You see a blank collection on the Components browser’s Select tab.
  5. Click the Display Secondary Selection Pane icon ().
  6. In the secondary selection pane, navigate to a component that you want to add to your collection and drag it into the blank collection. In the following figure, the Galaxy Class Starship component in the In Model collection (bottom) was added to the newly created Components collection (top).
  7. Continue navigating to components in the secondary selection pane and adding them to your new collection until your collection is complete.

  1. Select Window > Components Open the Components dialog box in the Default Tray to open the Components browser.
  2. Click the Details arrow () and select Create a New Collection.
  3. In the Save dialog box that appears, navigate to the folder where you want to save your collection. To create a subfolder for the collection, click the New Folder button and create the folder.
  4. Select the folder where you want to save the components collection and click Save. You see a blank collection on the Components browser’s Select tab.
  5. For each component you want to add to your collection, save it as an .skp file in the folder that you selected in the preceding step. (If the component is in your model, context-click it and select Save As.) The following figure shows the Galaxy Class Starship component saved in a collection called Favorite Components.

Tip: After you have a few collections, you can add them to a list of favorite collections that always appears on the In Model drop-down menu. First, display the collection the Components browser: If you used the collection recently, you can select the collection by name from the In Model drop-down menu. If the collection doesn’t appear there, click the Details arrow and select the Open or Create Local Collection (Microsoft Windows) or Open a Local Collection (Mac OS X). After your collection appears in the Components browser, click the Details arrow and select Add to Favorites or Remove from Favorites.

Gathering intelligence about components

SketchUp provides a few tools that enable you to find important details about components:

  • The Entity Info window is the most basic. To open it, context-click a component and select Entity Info. Or select a component and then select Window > Entity Info open the Entity Info dialog box in the Default Tray . If your entity is indeed a component, you see Component in the upper left and how many of instances of the selected component appear in your model.
  • In the Components browser, you see the component’s name, thumbnail, and description at the top. Click the Statistics tab, and you see a report of how many elements, such as faces, edges, construction lines, appear within the component. Select All Geometry from the drop-down list to see statistics for all geometry in the component or group. Alternatively, select Components from the drop-down list to see statistics for all components in the component. Finally, click Expand to see components and groups nested within the currently selected component or group.
OS:

Need Help Fast?

SketchUp’s outstanding community of passionate experts have answers to your questions.