How Can We Help?

Adding Colors and Textures with Materials

To add detail and realism to your models, SketchUp enables you to paint materials on faces. Materials are essentially paints that have a color and optional texture (defined within an image file). For example, in the following figure, the siding material has a grey color and a texture that simulates siding. The shingle roofing and grass are also materials that have a color and texture.

After you apply materials like these to your model, the special capabilities of SketchUp’s materials can help you do any of the following:

  • Replace one material with another: Say you want to show a metal roof instead of shingles. You can swap the roofing material for shingles quickly and easily.
  • Edit the material: Because the color and texture are separate, you can change them independently of each other. For example, you can change the siding color (how does yellow look?) but keep the same texture. You can also edit a material’s opacity, which controls how opaque or transparent the material is.
  • Calculate how much material you need: SketchUp can tell you the area of all the shingles or the siding. Of course, for this calculation to mean anything, you need to create a precise model so that the numbers reflect your model’s actual size.

Tip: SketchUp includes all sorts of materials collections: carpet, tile, groundcover, glass, wood, and more. However, if the specific material you need isn’t available, you can create your own material. This feature is especially handy if you’re a decorator or builder who needs to show precise finishes to your clients.

In the SketchUp interface, you model materials with the Paint Bucket tool () and the Materials browser (Microsoft Windows) or the Colors browser (Mac OS X). The Materials or Colors browser also enables you to view, manage, and organize the materials. The Materials or Colors browser keeps track of the materials in your model, and you can create custom materials collections specific to your projects or workflows.

Note: If you switch between computers running Microsoft Windows and Mac OS X, note that the Materials browser interface and Colors browser interface are unique to their respective operating systems. In the following sections, you see instructions for Microsoft Windows or Mac OS X, depending on which operating system you’re using.

In the following video, you see how to apply materials and make a few common changes, such as replacing one material for another. For steps that walk you through how to use materials in detail, check out the following sections.

Table of Contents
  1. Applying materials
  2. Replacing one material with another
  3. Editing materials
  4. Repositioning textures
  5. Calculating material area automatically
  6. Managing and organizing materials
  7. Creating your own materials

Applying materials

Applying materials to your model is pretty simple: Select a face or faces and then select your desired material. If you’re painting groups or components, check out the tips at the end of this section, which can make applying materials even easier.

You apply materials to your model with the Paint Bucket tool (), which you find in the following parts of SketchUp’s interface:

  • Getting Started toolbar
  • Large Tool Set toolbar
  • Principal toolbar
  • Tools > Paint Bucket on the menu bar
  • Tool palette (Mac OS X)

To start applying materials to your model, follow these steps (Microsoft Windows):

  1. Select the Paint Bucket tool ().
  2. In the Materials browser that appears, click the Select tab. If the Materials browser does not open in the tray, the dialog may be in a hidden tray. In this case, hover your mouse cursor over the hidden tray tab. This will expand the tray. You can then open the Materials browser in the tray.
  3. From the drop-down list, select a materials collection.
  4. Click the material you want to use.

    Tip: To sample a material that’s already in your model, hold down the Alt key to change from the Paint Bucket tool to a Sample tool. With the sample tool’s eyedropper cursor, click the face whose material you want to sample. Release the Alt key to return to the Paint Bucket tool.
  5. Back in the drawing area, click a face or faces to apply the material.

Tip: To restore the default colors, follow the preceding steps, but instead of clicking a material, click Select Material to Paint with Default in the upper right and click a face in your model to apply the default colors.

To start applying materials to your model, follow these steps:

  1. Select the Paint Bucket tool (). In the Colors browser that appears, you can select a color in on one of the four color picker tabs or use the materials collections.
  2. To browse the materials collections, click the Texture Palettes tab, which has a brick icon. (See Mixing Colors in the Color Picker for details about using the other tabs, which are for selecting colors.)
  3. From the drop-down list, select a materials collection.
  4. Click the material you want to apply to your model.

    Tip: To sample a material that’s already in your model, click the Eyedropper tool at the bottom of the Texture Palettes tab. With the big circle cursor, click the face whose material you want to sample. This loads the material onto the sample swatch, and you see the Paint Bucket cursor again.
  5. Back in the drawing area, click a face or faces to apply the material.

Alternatively, click and drag a material swatch from the Texture Palette tab to a face in your model.

Tip: To revert to the default colors, select the Default swatch in the Colors In Model collection.

Tip: If the selected material doesn’t appear after you click a face, your model is likely using a style that doesn’t display textures. To check, select Window > Styles open the Styles dialog box in the Default Tray . In the Styles browser, select the Edit tab, and click the Face Settings icon. In the Style area, make sure that the Display Shaded Using Textures option is selected. For details about styles, read the articles in Choosing a Style. If your styles are showing textures, your computer may have insufficient memory to display materials in your model. See Fixing an Issue in SketchUp for help.

You can paint multiple faces and edges at once. This capability is handy because painting an edge on its own can be tricky. You have to be very precise with your cursor placement. To paint edges and faces at once, simply select your edges and faces with the Select tool (). Then switch to the Paint Bucket tool and apply a material. (See Selecting Geometry for tips on making selections.)

When you apply materials to several faces at once, remember the following:

  • Faces have two sides: a front and a back. You can paint the front or the back of all the selected faces, but not a combination. The side you paint is determined by the side you click with the Paint Bucket cursor. In the following figure, clicking the front of a face paints all the front faces, even though you see two front faces and two back faces.
  • Control how the back edges look with a style. When you select a face and all edges and paint the front of the face, all the selected edges are painted. Paint the back faces, however, and none of the edges are painted. To blend back edges with materials, select Window > Styles open the Styles dialog box in the Default Tray , click the Edit tab, click the Edge Settings icon, and select By Material from the Color drop-down list. See Choosing a Style for details about edge settings.

You can apply materials to a group or component as whole or to specific geometry within the group or component:

  • To paint a whole group or component, select it and apply a material. When you select a group or component and apply a material, only faces in the default material are painted.
  • To paint geometry within the group or component, double-click it to open its context. Then select the faces you want to paint with a material.

The following video demonstrates several tips and tricks for applying materials to components. Or read on for steps that walk you through how to paint all or part of your components.

Tip: To model variations in materials quickly and easily, combine the techniques for painting all and part of your components.

To see how this tip works, say you’re modeling a chair with a wood frame and two cushions, and you want to show four cushion colors. The Outliner, shown here, shows that each chair element (the frame and two cushions) is a group, all of which are nested within a group, which is then nested in a component. (See Organizing a Model for more about the Outliner.)

The following steps explain the easiest way to apply materials and show the four color options:

  1. Because the frame is the same on every chair, select the frame’s group and apply the wood material, as shown here.
  2. Create a copy for each cushion color. (Copying What You’ve Already Drawn explains how.)
  3. Select a component and apply a cushion color material. Because the frame is already painted but the cushions are still the default color, only the cushions are painted with the color material. The frame keeps the wood material.
  4. Repeat the preceding step for each color option. You see the result in the following figure.

Tip: When several groups or components are nested within other groups and components, SketchUp may not let you paint by clicking the top-most group or component. If you run into this problem, try applying materials to a group or component nested lower in the hierarchy. The Outliner can help you see where your selection is in the hierarchy.

Replacing one material with another

Because SketchUp enables you to replace one material with another, you can experiment with materials quickly and easily. In a kitchen, preview different countertop materials, such as black granite, blue tile, and white composite. If you’re picking out house paint colors, compare yellow siding and dark green trim with navy siding and cream trim. When you know the keyboard modifiers, the process is a cinch. Check them out in the following table.

To Replace One Material with Another … Modifier Key (Microsoft Windows) Modifier Key (Mac OS X)
On adjacent faces Ctrl Option
On all faces in the current context (for example, the same group or component) Shift Shift
On all connected faces Ctrl+Shift Option+Shift

Here’s an example help you visualize how each shortcut works. Say you’re trying to figure out the colors for an abstract mural on two separate walls. The following figure shows the mural mocked up with materials from the Colors-Named collection.

To see how replacing the red with green might look, select the Paint Bucket tool and then select a green from the Materials browser (Microsoft Windows) or Colors browser (Mac OS X). If you Ctrl- or Option-click the red triangle in the upper left, only the adjacent faces with the red material are replaced with green, as shown in the following figure.

If you Shift-click instead, all the red faces become green:

But if you Ctrl+Shift-click or Option+Shift-click, the red faces turn green only on the left wall:

Editing materials

SketchUp enables you to edit materials. As you make changes, any faces painted with the material that you’re editing are updated automatically. Because each material has a color and an optional texture, you can edit the color and texture independently of each other.

A material needs to be saved with your model before you can edit it. To see the materials saved with your model, select Window > Materials to open the Materials browseropen the Materials dialog box in the Default Tray. On the Select tab, click the In Model icon () to display your In Model collection, as shown in the following figure.

If the material you want to edit doesn’t appear in your In Model collection, you can save a material with your In Model collection whether or not the material is currently applied to faces in your model. To add a material to your In Model collection, follow these steps:

  1. Click the Display Secondary Selection Pane icon () in the upper right of the Materials browser.
  2. In the secondary pane at the bottom, browse the collections for the material you want to edit.
  3. Drag the material swatch into your In Model collection.

To edit the material, select it in the In Model collection and click the Edit tab, shown in the following figure.

Here’s a brief introduction to all the tools for editing a material’s color:

  • Picker drop-down list: Use the Picker drop-down list to select between the HLS, (Hue, Light, Saturation), HSB (Hue, Saturation, and Brightness), RGB, (Red, Green, Blue), and Color Wheel color pickers. See Mixing Colors in the Color Picker for details about the color picker.
  • Undo Color Changes swatch: Click this swatch to undo all the color changes you make during an edit session.
  • Match Color of Object In Model button: Click this button to turn the cursor into an eyedropper. With the eyedropper cursor, click an entity to sample its color and apply that color to the material that you’re editing.

    Tip: If you sample a textured material, the texture variations can disguise the material’s color a bit. To sample a specific color from a texture, use the Match Color on Screen button for better results.
  • Match Color on Screen button: Click this button and then click anywhere on the screen with the eyedropper cursor to sample a pixel color. SketchUp then applies that color to the currently selected material.

The following tools enable you to tinker with a material’s texture:

  • Use Texture Image checkbox: When this checkbox is selected, you can include an image file that represents a texture. Deselecting the checkbox removes the texture image file. (Note that selecting the checkbox again doesn’t restore the image file; you’re prompted to select a new image file instead.)
  • Texture image file and Browse button: The texture file field contains the name of an image file (representing a texture), if any, associated with the current material. To change the texture, drag an image file to this field or click the Browse button to display the Choose Image dialog box, where you can browse for an image file on your hard drive. After you apply a texture, you can also adjust how the texture tiles on your model. See the upcoming section, Repositioning textures for details.
  • Edit Texture Image in External Editor button: When you click this button, SketchUp opens the texture image file in your default image editor.

    Note: Your image editor is defined in the SketchUp Preferences dialog box, on the Applications panel. See Customizing SketchUp for details about setting preferences. If you haven’t specified an image editor, SketchUp launches your operating system’s default editor or image display application.
  • Colorize checkbox: Select this checkbox to apply the same hue to the whole texture. The color is defined in the Edit tab’s Color area. This option is useful for files that are not displaying proper colors.
  • Reset Color swatch: Click this color swatch to reset the material to the color in the texture image file.
  • Dimension fields: When you paint a texture on a face, the texture image is tiled to fill the face. Type a value in the width or height box to change the size of the texture tile. By default, the image’s aspect ratio is maintained. So, if you type 2 in the width dimension box, the height box automatically updates to maintain the aspect ratio. Click the chain icon to break the chain (sorry, Fleetwood Mac), and you can distort the aspect ratio to your heart’s content (or malcontent, as the case may be). If you don’t love the results (and will never love them again), click the horizontal and vertical arrow buttons to revert to the previous width and height settings.
  • Opacity slider: Opacity refers to how transparent or opaque your image is. Sliding the opacity slider to the right increases the opacity of the texture, where 100 is totally opaque. Move the slider left to increase the transparency of the texture, where 0 is fully transparent. Alternatively, type a number from 0 to 100 in the Opacity field.

A material needs to be saved with your model before you can edit it. To see the materials saved with your model, select Window > Materials to open the Colors browser. On the Texture Palettes tab (the brick icon), click the Colors In Model icon () or select Colors In Model from the drop-down list to display your Colors In Model collection, as shown in the following figure.

If the material you want to edit doesn’t appear in your Colors In Model collection, apply the material to a face in your model. (Note that if you later replace one material with another, the original material still remains in your Colors In Model collection until you purge unused materials.)

When you’re ready to edit a material, follow these steps:

  1. On the Textures Palette tab (the brick icon), open your Colors In Model collection.
  2. Select the material you want to edit.
  3. From the Color drop-down list, select Edit. Or Control-click the material and select Edit from the menu that appears.
  4. On the Edit Material panel that appears, as shown in the figure, choose your desired edits.
  5. Click the Close button when you’re done.

Here’s an introduction to the options on the Edit Material panel:

  • Name: Enter a new name for a material to change the name of the material being edited.
  • Edit Texture Image in an External Editor: Click this button and the texture’s image file opens in your default image editor or preview program. Make and save your edits to the file and the changes are reflected in the material.
  • Texture drop-down menu: The options on this drop-down menu enable you to edit the texture within SketchUp. Choose Load select a new image file for the texture. Choose Remove to delete the texture image file. (A flat color approximation of the removed image appears when the texture image is removed.) If you’ve colorized the texture, choose Reset Color remove the colorization. Choosing Edit opens the texture image file in your default image editor or preview program. After you apply a texture, you can also adjust how the texture tiles on your model. See the upcoming section, Repositioning textures for details.
  • Width and Height: When you paint a texture on a face, the texture image is tiled to fill the face. Type a value in the Width or Height box to change the size of the texture tile. By default, the image’s aspect ratio is maintained. So, if you type 2 in the width dimension box, the height box automatically updates to maintain the aspect ratio. Click the chain icon to break the chain (sorry, Fleetwood Mac), and you can distort the aspect ratio to your heart’s content (or malcontent, as the case may be). If you don’t love the results (and will never love them again), you have to remember the original dimensions and enter them manually to revert to the original image dimensions.
  • Colorize: When the Edit Material panel is open, you can colorize a texture file. Use any of the color tabs to select a color and apply it to your material preview on the Edit Material panel. Or click the Eyedropper tool at the bottom of the Colors browser and click any material in your model or on the Textures Palettes (brick) tab.

    Tip: Colorizing is a great way to experiment with variations in material color.
  • Opacity: When the Edit Material panel is open, you can also edit a material’s opacity, which refers to how transparent or opaque your image is. Sliding the opacity slider to the right increases the opacity of the texture, where 100 is totally opaque. Move the slider left to increase the transparency of the texture, where 0 is fully transparent. Alternatively, type a number from 0 to 100 in the Opacity field.

Repositioning textures

After you apply a texture to one or more faces in a 3D model, you can adjust how the texture tiles across a face. To do so, you use the Position Texture tool, which has two modes:

  • Fixed Pin mode: In this mode, you can move, rotate, scale, or distort a texture. For example, in this mode, you can adjust a texture on one face so that it lines up with the same texture on another face, such as siding on two faces of a building.
  • Free Pin mode: If you need to stretch or shrink a texture, use Free Pin mode.

Here’s how to adjust a texture in Fixed Pin mode:

  1. Context-click the material and select Texture > Position from the menu that appears. You see a matrix of dotted lines that represents the texture’s individual tiles. The cursor also changes to a hand and four pins are displayed.
  2. If you see the four colored pins, as shown in the following figure, move to the next step. If you don’t, context-click the material and select Fixed Pins.
  3. Use the hand cursor and/or the pins to adjust your texture. In this example, the goal is to move the red pin so the metal roofing on each side of the roof lines up. Here’s a quick rundown of all your options:
    • Click and drag the material with the hand cursor to reposition the texture as a whole.
    • Click a pin to pick it up and click again to drop the pin elsewhere on the texture.
    • Drag a pin to alter the texture. Dragging the blue pin scales or shears the texture. Dragging the yellow pin distorts the texture. Dragging the green pin scales the texture or rotates it around the Move pin’s axis. Dragging the red pin, which is the move pin, moves the texture.

    Tip: In Fixed Pin mode, you can also context-click the texture to see additional options: flip the texture to the left or right or up or down, rotate the texture in increments of 90 degrees. The reset option reverts the texture to its original state, whereas the Undo option simply undoes the last command. If you undo an action, Redo also becomes an option.
  4. When you’re finished changing the texture, context-click the texture and select Done. Or just click outside the texture to exit Fixed Pin mode.

In Free Pin mode, you can set the size of your texture tile relative to your model. Here’s how the process works:

  1. Context-click the material and select Texture > Position from the menu that appears. By default, you’re in Fixed Pin mode.
  2. Switch to Free Pin mode by context-clicking the texture and deselecting the Fixed Pins option. In Free Pin mode, you see four yellow pins, as shown in the following figure.
  3. Click a pin to pick it up and click again to place the pin in its new location. Do this for all four pins to set where the corners of the texture tile appear. If you place the pins in a configuration that isn’t rectangular, you distort the texture.
  4. When you’re finished, context-click the texture and select Done. Or simply click outside the texture to exit Free Pin mode.

Tip: In Free Pin mode, you see the size of the texture tile only on the selected face. To change the size of your texture tile throughout your model, use the Materials browser (Microsoft Windows) or the Colors browser (Mac OS X). See the earlier section, Editing materials, for details.

Calculating material area automatically

If you want SketchUp to calculate the surface area painted with a material, you can context-click the material and select Area > Material. In Windows, you can also context-click the material in the Materials browser, and select Area from the menu. (If the Area menu item is grey, the material isn’t applied to any faces.)

Either way, an Area dialog box shows the total area of faces to which the selected material is applied. The units (such as square feet or square meters) depends on the units specified in your template. See Customizing SketchUp for details about changing your default units.

Managing and organizing materials

The Materials browser (Microsoft Windows) or Colors browser (Mac OS X) helps you find and organize materials. The following list explains how you can manage materials with the options available for your current operating system:

  • Browse the included collections: On the Select tab, choose a collection from the drop-down list to see the materials.
  • Keep track of the materials in your model: Click the In Model icon () to see all the materials you’ve applied to your model.
  • Clear out unneeded materials: Even if you replace a material with another, so that the original material no longer appears in your model, the original material still remains in your In Model collection until you delete it by context-clicking and selecting Delete. To remove all the unused materials in a model, make sure your In Model collection is selected. Then click the Details arrow () and select Purge Unused. Alternately, you can select Delete All to remove all the materials from your model and In Model collection.
  • Create your own collections: You can create a collection for a specific project, or create a collection for materials that you create, such as a specific color scheme, fabric swatches, landscaping options, or anything else you use repeatedly. On the Select tab, click the Details arrow () and choose Open or Create a Collection. In the Browse for FolderSelect a collection folder or create a new one dialog box, navigate to the folder where you want to save your collection. Click the Make New Folder button, give your folder a name (which will become the name of your collection), and click OKSelect Folder. After you create the collection, you can navigate to the folder to open the collection. To add materials to a collection, drag them from the secondary selection pane into your collection, or save materials that you create to your collection.
  • Add frequently used collections to your favorites: On the Select tab, click the Details arrow and choose Add Collection to Favorites. The currently selected collection then appears in a favorites list at the bottom of the drop-down list. You can select the collection, click the Details arrow, and choose Remove Collection from Favorites if you no longer need the collection on your favorites list.

    Note: Click the Details arrow, and you can choose to view materials as small, medium, large, or extra-large tiles. Choose the List option to see the materials names instead of the preview swatches.
  • Browse included collections: To see the materials included with SketchUp, click the Texture Palettes icon (the brick) and choose from the collections in the drop-down menu, such as Brick and Cladding, Fencing, Roofing, Translucent, or Wood. Each material in a collection appears as a swatch that you can click with the Paint Bucket cursor and apply to your model.
  • Keep track of materials in a model: The Colors browser includes a special material collection called Colors In Model, which contains all materials currently used in your model. The contents of this collection are generated automatically as you add materials to your SketchUp model. To see this collection, select Colors In Model from the materials collection drop-down menu, or simply click the Colors In Model icon ().
  • Clear out unneeded materials: Even if you replace a material with another, so that the original material no longer appears in your model, the original material still remains in your Colors In Model collection until you delete it by context-clicking and selecting Remove. To remove all the unused materials in a model, make sure your Colors In Model collection is selected. Then select List > Purge Unused. Alternately, you can select Delete All to remove all the materials from your model and the Colors In Model collection.
  • Creating your own collections: You can create a collection for a specific project, or create a collection for materials that you create, such as a specific color scheme, fabric swatches, landscaping options, or anything else you use repeatedly. Select List > New. In the List Name box that appears, type a name and click OK. You now see the name you entered in the drop-down list of collections.
    To add materials to a new collection, you can drag the swatch next to the Eyedropper at the bottom of the Colors browser into the new collection’s swatches pane. Or create new textures and save them to the collection. To remove the collection, select List > Remove.

Note: If you’re used to using the Materials browser in Windows, note that the Colors browser in Mac OS X doesn’t enable you to add frequently used collections to a favorites list.

Creating your own materials

The materials included in SketchUp help you start using materials and explore how they work. To apply materials specific to your own design or building, you probably need to create your own materials. The process is pretty easy: Start with an image to create a texture tile and then specify a color if needed.

To create a new material from your own files or color codes, follow these steps:

  1. In the Materials browser, click the Create Material icon () in the upper right.
  2. In the Create Material dialog box that opens, type a name for the new material in the text field at the top.
  3. Choose the color, texture, and opacity options for your new material. The options work just like those in the Edit panel. Refer to the earlier section, Editing materials, for details. Or, for help understanding the color options, see Mixing Colors in the Color Picker.
  4. Click OK. Your new material appears selected in the In Model collection.

To create a new material that’s a texture, follow these steps:

  1. In the Colors browser, click the Textures Palette tab (the one with the brick icon).
  2. Select the collection where you want the new material to appear.
  3. Select Color > New Texture.
  4. In the dialog box that appears, select an image file for your texture.
  5. In the panel that appears, type a name for the texture, set the width and height for the tile size, and click OK. If you want to colorize the texture, follow the steps in the earlier section, Editing materials.

And here’s how to save a specific color as a material:

  1. Use any of the color tabs to create your desired color, which appears in the color swatch at the bottom of the Colors browser. See Mixing Colors in the Color Picker for details.
  2. Select the Textures Palette tab (also known as the brick icon).
  3. Navigate to the collection where you want to save the color.
  4. Drag the color swatch from the bottom of the Colors browser into the collection’s swatches area.

Tip: You can also expand your materials collections by downloading materials. Check out this post from the SketchUpdate blog for details.
OS:

Need Help Fast?

SketchUp’s outstanding community of passionate experts have answers to your questions.