How Can We Help?

Modeling Complex 3D Shapes with the Solid Tools

With SketchUp’s Solid tools, you can create new shapes by combining or cutting one shape with another, making it easy to model an outer shell or joinery.

SketchUp’s Solid tools work only on SketchUp solids. In SketchUp, a solid is any 3D model (component or group) that has a finite closed volume. A SketchUp solid cannot have any leaks (missing faces or faces that do not meet at an edge). The following image contains several solids.

Tip: To check whether your group or component is a solid entity, context-click it and choose Entity Info. In the Entity Info dialog box that appears, the upper-left corner indicates if the selection is a solid, as shown in the figure. If you’re having trouble identifying leaks that prevent your model from working as a solid entity, try searching the Extensions Warehouse for a third-party plugin designed to help with this problem.

Check out the following table for a quick introduction to the Solid tools, including what the tool does and whether it’s available in SketchUp Make or only SketchUp Pro.

Tool What It Does Only SketchUp Pro?
Outer Shell Leaves only the outer faces of overlapping solids. Make and
Union Combines two or more solids into a single form.
Subtract One solid removes part of another and is deleted.
In SketchUp Make, use Intersect with Model instead.
Trim One solid trims another but remains in the model.
Intersect Leaves only the intersecting geometry.
Split Splits solids along intersecting geometry.

To find the Solid Tools, look in the following parts of the SketchUp interface:

  • Solid Tools toolbar
  • Tools menu (Select Tools > Outer Shell or Select Tools > Solid Tools and select the other tools from a submenu)
  • Tool palette (Mac OS X)

In the following video, you see examples of the Solid tools in action. In the following sections of this article, you find steps and details about using each tool. (Note, however, that you can’t place SketchUp models in Google Earth anymore.)

Table of Contents
  1. Creating an outer shell
  2. Uniting solids into a single form
  3. Subtracting one solid from another (or use Intersect Faces with Model)
  4. Trimming one solid with another
  5. Leaving only the intersecting geometry
  6. Splitting solids

Creating an outer shell

The Outer Shell tool () removes geometry inside overlapping groups or components, leaving only the outer faces.

Tip: Because an outer shell reduces a model’s geometry, creating an outer shell is helpful when you need to boost SketchUp’s performance.

For example, say you have two models: One is a detailed interior and exterior building model. The other model illustrates the building in a street view that shows surrounding buildings, streets, and landscaping. You can import the detailed building model into your street view. However, all that geometry might slow down your street view model and isn’t necessary. In your street view, creating an outer shell of the building eliminates the interior geometry you don’t need so that your street view model is lighter and renders faster as you work on it.

To create an outer shell from overlapping groups or components, follow these steps:

  1. With the Select tool (), select all the intersecting groups or components you want to include in your outer shell.
  2. Context-click your selection and choose Outer Shell from the menu that appears, as shown in the figure. The outer faces remain.

Or, you can create an outer shell as follows:

  1. Select the Outer Shell tool ().

    Tip: Until you hover over a solid group or component, you see an arrow cursor with a circle and a slash. When your cursor hovers over a solid group or component, the red circle and slash change to a black 1 inside a circle, and you see a Solid Group or Solid Component ScreenTip.
  2. Click to select the first group or component in your outer shell.
  3. Click the second group or component. SketchUp combines your selections into an outer shell so that only the outer faces remain.
  4. (Optional) Continue clicking additional groups or components to add them to your outer shell, as shown in the figure.

Note: The result of an outer shell is similar to the result of a union. However, the result of an outer shell contains only external faces, whereas a union can also contain internal geometry. The following figure shows two square tubes on the left, a union of the tubes in the center, and an outer shell of the tubes on the right.

Uniting solids into a single form

A union merges two or more solid entities into a single solid.

The result of a union is similar to the result of an outer shell. However, the result of a union can contain internal geometry whereas an outer shell contains only external faces. (See the preceding figure for an example.)

Here’s how to use the Union tool to combine solid entities:

  1. Select the Union tool ().

    Tip: Until you hover over a solid group or component, you see an arrow cursor with a circle and a slash. When your cursor hovers over a solid group or component, the red circle and slash change to a black 1 inside a circle, and you see a Solid Group or Solid Component ScreenTip.
  2. Click to select the first group or component for the union.
  3. Click the second group or component. The resulting union of the geometry remains.
  4. (Optional) Continue clicking additional groups or components to add them to the union, as shown in the figure, which uses X-Ray view so that you can see the geometry within each solid.

Tip: Instead of following the preceding steps, you can preselect the groups or components with the Select tool, context-click your selection, and choose Solid Tools > Union from the menu that appears.

Subtracting one solid from another (or use Intersect Faces with Model)

With the Subtract tool, you can use one solid entity to cut another solid entity. Your original solid entity is then subtracted from the model. For the subtraction to work, the two solids need to overlap.

Tip: When you use the Subtract tool, the order in which you select each solid entity matters. To remember which solid to select first, just think, “Use this to cut that.” In other words, the first solid you select is your cutting tool. The second solid you select is the thing that is cut.

To perform a subtraction, follow these steps:

  1. Select the Subtract tool ().

    Tip: Until you hover over a solid group or component, you see an arrow cursor with a circle and a slash. When your cursor hovers over a solid group or component, the red circle and slash change to a black 1 inside a circle, and you see a Solid Group or Solid Component ScreenTip.
  2. Click to select the cutting group or component. In the example shown here, select the peg first to make a hole in the board. After you make a selection, the 1 next to the cursor becomes a 2.
  3. Click the group or component that you want to cut. The cutting group disappears, but makes a hole in the second selection. In this example, you see a peg-sized hole in the board.

Tip: Instead of following the preceding steps, you can preselect your solid entities, context-click the selection, and choose Solid Tools > Subtract from the menu. SketchUp uses the order in which you select each solid entity to determine which is the cutting entity and which entity is cut.

If you’re using SketchUp Make, you can create the effect of a subtraction by using the Intersect with Model command. When you use Intersect with Model, the two shapes don’t need to be solid entities. (If fact, Intersect with Model applies a different effect if your shapes are solids, as explained a little later in this section.) However, when you create a subtraction with the Intersect with Model command, the process requires a few more steps than the process with SketchUp Pro’s Subtract tool.

Here’s how to create a subtraction with the Intersect with Model command:

  1. Create two distinct volumes, such as a box and a cylinder. (See Drawing Basic Shapes and Pushing and Pulling Shapes into 3D for help.)
  2. With the Select tool (), triple-click the first volume, which will be your cutting object. In this example, the cutting object is the cylinder, as shown in the figure.
  3. Move and rotate your cutting shape so that it intersects with the shape you’d like to cut. (See Moving Entities Around and Flipping and Rotating for help.) Leave your cutting shape selected, as shown in the figure.
  4. Context-click the cutting shape, and choose Intersect Faces > With Model from the menu that appears. The command tells SketchUp to create edges where the two shapes intersect.
  5. With the Eraser tool (), erase or move the geometry that you don’t want to keep. In the following figure, you see how the box shape is changed after the cylinder is erased.

    Tip: Remember you can hold down the scroll wheel on your mouse to temporarily switch to the Orbit tool, so you can orbit around and find all the geometry you want do delete. (See Erasing and Undoing for details about the Eraser tool.)

Intersect with Model creates edges in the current context. If your shapes are groups or components, you can create the intersecting lines either within the group or outside it. When you create the intersecting lines outside a group’s context, you can easily separate your original shapes from the edges that SketchUp creates, as shown in the following figure. See Organizing a Model for details about groups and Adding Premade Components and Dynamic Components for an introduction to groups and components, respectively.

Trimming one solid with another

With the Trim tool, you cut one solid entity with another, just like a subtraction. However, when you use the Trim tool, the cutting solid remains in the model. So, if you use a peg to trim a board, the peg remains after it cuts the board. Like all the Solid tools, the Trim tool works only if two solid entities overlap.

Tip: When you use the Trim tool, the order in which you select each solid entity matters. To remember which solid to select first, just think, “Use this to cut that.” In other words, the first solid you select is your cutting tool. The second solid you select is the thing that is cut.

To perform a trim, follow these steps:

  1. Select the Trim tool ().

    Tip: Until you hover over a solid group or component, you see an arrow cursor with a circle and a slash. When your cursor hovers over a solid group or component, the red circle and slash change to a black 1 inside a circle, and you see a Solid Group or Solid Component ScreenTip.
  2. Click to select the cutting group or component. In the example shown here, select the peg first to make a hole in the board. After you make a selection, the 1 next to the cursor becomes a 2.
  3. Click the group or component that you want to cut. The cutting group remains, but makes a hole in the second selection. The result is hard to see at first (refer to Callout 1). However, move the peg out of the hole, as shown in Callout 2, and you see the hole in the board.

Leaving only the intersecting geometry

With SketchUp Pro’s Intersect tool (), you select two or more overlapping solid entities, and only the intersecting geometry is left behind.

To perform an intersection, follow these steps:

  1. Select the Intersect tool ().

    Tip: Until you hover over a solid group or component, you see an arrow cursor with a circle and a slash (). When your cursor hovers over a solid group or component, the red circle and slash change to a black 1 inside a circle, and you see a Solid Group or Solid Component ScreenTip.
  2. Select a solid entity that you want to use in the intersection.
  3. Select one or more additional solids that overlap your initial selection. The resulting intersecting geometry remains. In this example, the intersection of the box and the sphere (Callout 1) creates a point with a rounded base (Callout 2).

Tip: Alternatively, you can preselect the solids you want to intersect. The context-click your selection and choose Solid Tools > Intersect from the menu that appears.

Splitting solids

With the Split tool (), you can divide overlapping solid entities along their intersecting edges. To perform a split, follow these steps:

  1. Select the Split tool ().

    Tip: Until you hover over a solid group or component, you see an arrow cursor with a circle and a slash. When your cursor hovers over a solid group or component, the red circle and slash change to a black 1 inside a circle, and you see a Solid Group or Solid Component ScreenTip.
  2. Click a solid entity.
  3. Click another solid entity that intersects your first selection. SketchUp splits all the geometry along the edges where the selected solids intersect. For example, in the figure, the two groups shown on the left split into 3 groups, as shown on the right.

OS:

Need Help Fast?

SketchUp’s outstanding community of passionate experts have answers to your questions.