How Can We Help?

Softening, Smoothing, and Hiding Geometry

The Soften Edges feature may remind you of a stick of butter or a chocolate bar that got too warm in the sun. In SketchUp, however, the Soften Edges feature does nothing to compromise your model’s structural integrity.

Tip: You can use the Soften Edges feature, along with the Smooth edge property, to change the visibility of your edges and make your model look more realistic with less geometry, which improves your computer’s performance.

Here, you find an introduction to soft, smooth, and hidden geometry and the types of entities they create. After you understand the basics, check out a few tips for improving your model’s appearance and modeling efficiently.

Table of Contents
  1. Understanding the edge properties
  2. Softening and smoothing edges at once
  3. Hiding geometry
  4. Viewing hidden edges

Understanding the edge properties

In SketchUp, the following properties, in various combinations, enable you to control edges’ appearance:

  • Soft: When you soften an edge, the edge is hidden, and the faces that the edge bounds become a surface entity.

    Note: A surface entity joins two or more faces so that they look round. Although you still see inferences for all the geometry that a surface entity contains, the surface entity acts like a single entity when you select or paint it. In the figure, you see that clicking the face on either side of the soft edge (1) selects both faces.
  • Smooth: Smoothing an edge adds shading that makes the faces look smooth. However, when you apply the Smooth property alone, the edge remains visible. (See Edge 2 in the figure.)

You can also hide an edge (or any geometry, the hidden property isn’t exclusive to edges). When you hide an edge, the edge is not visible, but any faces adjoining the edge are not transformed into a surface entity. (Edge 3 in the figure is a hidden edge.)

Softening and smoothing edges at once

In SketchUp, softening and smoothing edges typically go hand-in-hand. That’s why both the Eraser tool and the Soften Edges dialog box apply these properties together.

Tip: Use the Eraser tool to quickly smooth and soften your edges. Open the Soften Edges dialog box when you need more fine-tuned control.

To soften and smooth edges with the Eraser, follow these steps:

  1. Select the Eraser tool () or press the E key.
  2. Hold down the Ctrl key (Microsoft Windows) or the Option key (Mac OS X) as you click the edges you want to hide.

If you make a mistake or change your mind, hold down Ctrl+Shift (Microsoft Windows) or Option+Shift (Mac OS X) and click the edges to undo the softening and smoothing.

To soften and smooth with the Soften Edges dialog box, follow these steps:

  1. Select the edges you want to soften and smooth. (See Selecting geometry for tips and selection techniques.)
  2. Select Window > Soften Edges. Select Window > Default Tray > Soften Edges. Or context-click your selection and choose Soften/Smooth Edges. Either way, the Soften Edges dialog box appears, as shown in the figure.

  3. Click and drag the Angle between normals slider to set the maximum size of all angles that will be smoothed or softened. The higher the setting, the more angles you are likely to smooth or soften. In the example, the slider is set to 20 degrees, which smooths and softens most of the rock’s surface.

  4. (Optional) The Smooth normals check box is selected by default. If you don’t want the shading effect that makes your edges look smooth, deselect this check box.
  5. (Optional) Select the Soften coplanar check box to soften edges between coplanar surfaces, essentially deleting those edges. In the example of the rock, selecting the check box doesn’t impact the rock much, because few (if any) of its faces are on the same plane.

To check or change the properties applied to an edge, context-click it and choose Entity Info. In the Entity Info box, shown here, the type of entity appears in the upper left, and you can select or deselect the Soft and Smooth check boxes. Select a face, and you can see whether it’s a surface entity or another type of geometry.

Tip: Softened and smoothed edges make basic geometry look polished. In a complex model, relying on soft and smooth edges can noticeably lighten the load on your computer’s memory. For example, you can create the corbel shown in the figure by creating a 2D drawing in the shape of the selected edges. Then extrude the face into the 3D shape shown here. The shape is quite basic, but the softened and smoothed edges enhance the model’s dimensions and shape. Also, if you draw and extrude arcs, circles, or curves, these entities apply soft and smooth edges by default.

Hiding geometry

As you draw a model, you don’t necessarily want a line marking every edge in your model. The Soften Edges feature hides the line, but also creates a surface entity, which means you can apply only one material to any face in the surface entity. If you want to hide an unsightly line without creating a surface entity, seek out the Hide feature. You can hide lines, faces, and any SketchUp entity.

Follow these steps to hide a line or any geometry:

  1. Select the geometry you want to hide.
  2. Context-click the selection and choose Hide from the context menu that appears, as shown in the figure. Or choose Edit > Hide. The selected geometry disappears from view, although it is still there, like a ghost in the machine.

After you hide geometry, by default, you can’t select it. To make hidden geometry selectable, you must display hidden geometry or unhide the geometry. (There is a difference.) See Viewing hidden edges for details.

Tip: In SketchUp, styles change the look of your whole model. All you have to do is click a style preset. If you’re hiding edges or geometry to see through your model or change the appearance of your model as a whole, consider whether styles offer an easier way to get the job done.

Viewing hidden geometry

In SketchUp, any geometry that’s hidden is still there. You just can’t see or select it.

To see the hidden geometry but keep it hidden, choose View > Hidden Geometry. All hidden entities appear in a ghosted pattern (as shown in the figure), allowing you to select them. Choose View > Hidden Geometry again to deselect the option and make the ghost pattern disappear.

To change geometry from hidden to visible, you need to unhide it. Select the hidden geometry, context-click the selection, and choose Unhide. (The Hide menu item changes to Unhide when selected geometry is hidden.)


Need Help Fast?

SketchUp’s outstanding community of passionate experts have answers to your questions.