How Can We Help?

Selecting Geometry

The Select tool (Select tool) specifies what entities you want to modify with SketchUp’s other tools or commands. If you want to change the length of a line, first select the line. If you want to scale a box, first select that box. If you want to move a line and a box, you start by selecting both, creating what’s called a selection set.

Here’s where you find the Select tool in SketchUp:

  • The Getting Started toolbar (shown here), the Large Tool Set toolbar, and the Principal toolbar (Microsoft Windows)
  • The Tool Palette (Mac OS X)
  • The Tools menu

Getting Started toolbar

Tip: The Select tool is so important to 3D modeling in SketchUp that the Select tool also has an easy keyboard shortcut: Just the press the Spacebar, and the Select tool is activated.
Table of Contents
  1. Selecting a single entity
  2. Selecting multiple entities
  3. Adding and subtracting from a selection

Selecting a single entity

To select a single entity:

  1. Activate the Select tool (Select tool). The cursor changes to an arrow.
  2. Click an entity. Whatever you select (edge, face, or component for example) is highlighted, like the sofa cushion shown here.
The cushion is selected

If you don’t select the right thing the first time, just try again. If you don’t want anything to be selected, click any empty space in the drawing window.

Selecting multiple entities

When you need to select more than one thing, SketchUp offers a few different selection options. Watch the video to see how these options work and learn tricks for making complicated selections quickly and easily. Or keep reading about ways to select multiple entities.

Tip: No matter what tool is active, you can select Edit > Select All from the menu bar, or press Ctrl+A (Microsoft Windows) or Command+A (Mac OS X) to select everything in your model.
To make sure nothing is selected, select Edit > Deselect All, press Ctrl+T (Microsoft Windows) or Shift+Command+A (Mac OS X), or click any empty space in the drawing area.

When the Select tool is active, you can select multiple entities in any of the following ways:

  • Click and drag to make a selection box. With the Select tool active, click and drag to create a temporary box around the items you want to select. When you release the mouse button, your items become selected. If you click and drag to the left (a crossing selection), anything completely or partially inside the box becomes selected. If you click and drag to the right (a window selection, shown the figure), you select only what’s completely inside the box. For example, notice how only one red cushion is selected, even though the second one is partially inside the window selection box.

    A window selection
  • Double- or triple-click. Depending on what you click, you can select combinations of edges and faces. The following table outlines your options.
    Do This. . . . . .To Select This
    Double-click a faceThe face and all its bounding edges (1)
    Double-click an edgeThe edge and its connected face (2)
    Triple-click an entityAll the connected entities. For example, if you triple-click a face in a cube, the entire cube is selected. (3)

    Double-click a face or edge. Triple-click to select an entitiy.
  • Context-click an edge. When you context-click an edge, a context menu appears with the following options:
    • Select > Connected Faces selects all the faces connected to the selected entity.
    • Select > All Connected selects all entities connected to the selected entity. (The result is the same as triple-clicking the entity.)
    • Select > All on same Layer selects all the entities on the same layer as the selected entity. If you your model doesn’t contain any layers, the result is also the same as triple-clicking.
  • Context-click a face. When you context-click a face, the context menu has all the options you see when you context-click an edge, as well as two other options:
    • Select > Bounding Edges selects all the bounding edges of the selected face.
    • Select > All with same Material selects any entity with the same material as the selected face. If you want to select all the faces with a brick material or red paint, for example, and change that material to something else, this method makes doing so quick and easy.

Adding and subtracting from a selection set

When you’re selecting multiple entities, it’s easy to grab an entity you didn’t want or to miss an entity that you need. To add or remove entities from a selection set, make sure the Select tool is activated; then adjust your selection by using the keyboard modifiers in the following table. For example, to select both red cushions as shown here, select one and then hold down the Ctrl key while selecting the other cushion.

Two entities are selected.

Tip: When you activate a modifier key, the Select tool’s cursor displays a plus or minus sign (The Select tool curor when a modifier key is selected) next to the arrow.
To Do This . . . Press and Hold This Key(s) While Also . . .
Add to the selection set, one entity at a time Ctrl (Microsoft Windows) or Option (Mac OS X) Clicking unselected entities
Change an entity’s selection status. (Select an unselected entity or deselect a selected entity)Shift Clicking an entity
Subtract from the selection set Shift+Ctrl (Microsoft Windows) or Shift+Option (Mac OS X) Clicking selected entities

Tip: If you need a temporary way of quickly reselecting the same group of items, turn your selection into a group. See Organizing a Model for details about creating a group.

Need Help Fast?

SketchUp’s outstanding community of passionate experts have answers to your questions.