Application Preferences dialog box (Microsoft Windows)

      NOTICE: SketchUp 2015 is here! When you look at this Knowledge Center article, be sure to pick "SketchUp 2015" from the red box above to see the 2015 version of that content. If there is no version picker, this content applies to all versions of SketchUp.

SketchUp's application preferences are used to set various global behaviors for SketchUp. Activate the Preferences from the Window menu.

Applications

Use the Applications preferences panel to identify the application used to open an application for editing image files.

Default Image Editor

Use on the Choose button to display the Image Editor Browser. Use the browser to locate an image editor for your image files.

Compatibility

Use the Compatibility preferences panel to identify component and group highlighting and mouse wheel settings.

Bounding box only

Use the Bounding box only checkbox to toggle between displaying only one bounding box or displaying a bounding box for each component and it's corresponding edges when selected.

Invert

Use the Invert checkbox to change SketchUp scroll wheel behavior to match Google Earth scroll wheel behavior (rolling forward zooms out, rolling backward zooms in).

Drawing

Use the Drawing preferences panel to define global mouse (or other input device) behavior.

Click Style

The Click Style options allows you to define how your input device reacts to clicks.

Click-drag-release: Use the Click-drag-release button to force the Line tool to draw by click and holding the mouse button to define the start point of the line, dragging the mouse to extend the line, and releasing the mouse to establish the end point of the line.

Auto detect: Use the Auto detect button to use either Click-drag-release and Click-move-click as necessary.

Click-move-click:Use the Click-move-click button to force the Line tool to draw by clicking and releasing the mouse button to define the start point of the line, moving the mouse to extend the line, and clicking again to establish the end point of the line.

Continue line drawing:Use the Continue line drawing checkbox to force the Line tool to treat an end point as the start point of a new line, saving you one extra click required establish a new start point for the second line.

Miscellaneous

The Miscellaneous options define other global mouse behaviors.

Display crosshairs:Use the Display crosshairs checkbox to display a set of colored crosshairs (corresponding to axes colors) when drawing.

Disable pre-pick on Push/Pull Tool:
By default, you can select a face with the Select tool, orbit the model (even so that the pre-selected face is hidden), click on the Push/Pull tool and push/pull anywhere on the screen to push/pull the pre-selected face. This feature allows you to push/pull faces that are normally hard to select. Check the Disable pre-pick on Push/Pull tool checkbox to disable this pre-pick feature.

Extensions

Use the Extensions preferences panel to add or remove SketchUp extensions. An extension can be an add-on tool or feature created by `s that is not necessarily a part of core SketchUp functionality.

Select the checkbox next to the extension that you want to enable in SketchUp. The extension will be available (menu items and optional toolbar) the next time your run SketchUp.

Files

The Files preferences panel defines various locations for files used by SketchUp (such as the default location for Components and Materials).

Models

Use the Models field to define the default location for all of your models. SketchUp uses this location as the starting point for all open and save file operations.

Components

Use the Components field to define the default location used when you open or create a collection using the Components Browser.

Materials

Use the Materials field to define the default location used when you open or create a collection using the Materials Browser.

Styles

Use the Styles field to define the default location used when you open or create a collection using the Styles Browser.

Texture images

Use the Texture images field to define the default location for all images that can be used as a texture. SketchUp uses this location as the starting point for all File > Insert > Image as Texture operations.

Watermark images

Use the Watermark images field to define the default location for all images that can be used as a watermark.

Export models

Use the Export models field to define the default location for all models that are exported. SketchUp uses this location as the starting point for all File > Export > 3D Model operations.

General

Use the General preferences panel to define global save and settings.

Saving

Create backup: Use the Create backup checkbox to automatically create a backup file whenever you save a drawing. The backup file is the previously saved version of the file. This file will be saved to the same folder as the drawing file. For example, if your drawing is hotel.skp, the backup will be called hotel.skb.

Auto-save:Use the Auto-save checkbox to automatically save changes to your drawing into a temporary file at a specific time interval. This temporary file is available on the file system should SketchUp abnormally exit. Type the auto-save interval, in minutes, into the minutes field.

The temporary file's name will be a combination of the word 'AutoSave' with the original filename, such as AutoSave_hotel.skp. This file is saved in the directory where the original .skp file exists.

Warning: We strongly recommend you keep the Auto-Save option selected to ensure that your valuable work is retained.


SketchUp checks your model for
unrecoverable errors during the auto-save, preventing the overwriting
of a good auto-save file. Sketchup will display a dialog box in the rare
case that unrecoverable
errors are found in your model. This dialog box contains the option to
quit SketchUp and send a report. SketchUp recommends you click on the quit
SketchUp and send report button to terminate SketchUp and preserve your
previously valid auto-save file. This report contains valuable information
regarding the unrecoverable errors.

Check model for problems

The Check Model for Problems options allow you to enable problem checking for your SketchUp models.

Automatically check models for problems: Selecting the Automatically check model for problems checkbox checks for minor problems with your model. These problems can occur given the infinite flexibility that SketchUp provides when designing in 3D. Your model is assessed for problems when it is loaded or saved. SketchUp strongly recommends selecting this box to ensure that problems are corrected proactively, allowing your model to perform optimally. You must manually check for problems using the Fix Problems button in the Statistics panel of the Model Info dialog box if you leave this checkbox deselected.

Automatically fix problems when they are found: Check the Automatically fix problems when they are found checkbox to have SketchUp fix problems found in your model automatically (without having to display a dialog box). Leave this checkbox deselected if you want SketchUp to display a dialog box (with the Always fix my models, Fix it now, and Fix it later options) when a problem is found.

Scenes and Styles

The Scenes and Styles options allow you to enable warnings for style changes.

Warn of style changes when creating scenes:Use the Warn of style changes when creating scenes if you want to be notified when a style has changed when adding scenes to your file.

Software Updates

The Software Updates option allows you to automatically check for software updates.

Automatically check for updates: Check the Automatically check for updates checkbox to allow SketchUp to automatically check for updates to the application when you are connected to the Internet.

OpenGL

Use the OpenGL preferences panel
to define how the OpenGL
standard should be applied within SketchUp.

Note: You might notice intermittent streaks or small spots of light within face shadows. A minimal amount of these artifacts
is to be expected on most systems, and can vary greatly with the quality of your OpenGL driver.


Warning: Certain OpenGL drivers do not fully support casting shadows on faces.


Warning: SketchUp's Shadow feature can have a severe performance impact on slower computers or those using software rendering.


OpenGL Settings

The OpenGL Settings allow
you to speed up OpenGL drawing.

Use
hardware acceleration:
Use the Use Hardware acceleration checkbox
to use the hardware acceleration features of a video card. Unfortunately,
only a small percentage of 3D drivers in the consumer video card market
are 100% OpenGL
compatible and can use this feature (though many cards claim to be 100%
OpenGL compatible).
Most 3d
drivers are designed for games, and are rarely tested using other 3D programs.
Consequently, numerous incompatibility problems can occur requiring a
fix from the video card manufacturer. Disable this option if you are having
problems with the 3D rendering of your models or if your video card is
not 100% OpenGL
compatible and does not support hardware acceleration.

Note: Hardware Acceleration might only be available on your system for certain resolutions and color depths. Check the system settings for your graphics card to see if it supports hardware acceleration (using the Control Panel on Microsoft Windows.

SketchUp cannot control the quality
of the OpenGL
driver on your computer system. Video
card device drivers are proprietary and are maintained solely by the manufacturer
of the video card in your system. Therefore,
SketchUp cannot guarantee that SketchUp will work with hardware acceleration
on your system. Refer to the OpenGL
topic for further information.

Use maximum texture size: Selecting the Use maximum texture size checkbox uses the maximum texture size supported by your graphics card. This option might result in a slowing of SketchUp unless your graphics card and computer can handle what is advertised.

Note: This option only affects textures and images on the screen (not export or print quality).

Use fast feedback: Selecting the
Use fast feedback checkbox increases performance when editing large
models. SketchUp runs a test to assess whether your video card can support
this option on startup. SketchUp will activate this option if
fast feedback is supported. You can also attempt to use this feature by
selecting the Use Fast Feedback checkbox manually; however you will be
warned by SketchUp that enabling this option could cause problems on your
system if fast feedback is not supported.

SketchUp
strongly recommends that you set your driver's anti-aliasing setting to
application controlled (which is normally the default setting for most
graphic card drivers) to ensure that fast feedback functions properly.
It is possible that you will see rendering anomalies, such as blurring
of the model, when using fast feedback under a non-application controlled
setting.

Capabilities

The capabilities
table lists one or more different graphic card settings combinations that
might work well within SketchUp. These combinations were selected by SketchUp,
on execution, from a large list of settings combinations supported by
your graphics card. SketchUp defaults to the most basic of these combinations
to ensure your models will be rendered properly. Choose a different combination
if you want to alter your graphics capabilities within SketchUp.

Anti-Alias: SketchUp generally
defaults to a combination with a zero anti-alias value. Higher
anti-alias values, such as 2x or 4x, can create smoother looking lines
in SketchUp. However, you might experience some flickering and reduced
rendering performance if a higher anti-alias value is selected.

Details button: Use the Details button to view details about your video card.

Shortcuts

Use the Shortcuts preferences
panel to define keyboard shortcuts for most SketchUp commands.

Filter field

Type a phrase in the Filter to list shortcuts of a specific type.

Function list

The Function list contains all of the functions that can be assigned a keyboard shortcut.

Add Shortcut field

Type a keyboard shortcut, to be assigned to the currently selected function, in the Add Shortcut field.

+ button

Use the + button to add the keyboard shortcut in the Add Shortcut field to the currently selected function.

Assigned field

The Assigned field contains a list of keyboard shortcuts assigned to the currently selected function.

- button

Use the - button to remove the currently selected keyboard shortcut (in the Assigned field) from the list of shortcuts assigned to a function.

Reset All button

Use the Reset All button to reset all keyboard shortcuts to their factory defaults.

Import button

Use the Import button to import a keyboard shortcuts file. Refer to Importing Preferences, Including Keyboard Shortcuts for more information.

Export button

Use the Export button to export current keyboard shortcuts as a keyboard shortcuts file. Refer to Exporting Preferences, Including Keyboard Shortcuts for more information.

Template

Use the Template preferences
panel to designate a SketchUp file that you would want to use as a template
for all of your subsequent models.

Default Drawing Template drop-down list

The Default Drawing DrawingTemplateTemplate drop-down list contains a list of all of the templates available in SketchUp.

Browse button

Use the Browse button to browse for a template. The Browse for Template dialog box is displayed. Locate and select a template using this dialog box.

Workspace

Use the Workspace preferences panel to make changes to your SketchUp workspace.

Tool Palette

SketchUp has two differently
sized toolbars. The large tool buttons are easier for some users to see
and use (they provide larger areas to click with your mouse) and are easier
to use with a pen and tablet. Smaller buttons save screen space, allowing
a larger drawing area.

Use
large tool buttons:
Use the Use large tool buttons checkbox
to toggle between large and small tool buttons.

Reset Workspace Button

Use the Reset Workspace button to reset SketchUp to its default configuration (all dialog boxes are closed).