Tools Menu (Windows)

      NOTICE: SketchUp 2015 is here! When you look at this Knowledge Center article, be sure to pick "SketchUp 2015" from the red box above to see the 2015 version of that content. If there is no version picker, this content applies to all versions of SketchUp.

The Tools menu provides access to all of the modification tools in Sketchup. This menu represents one of three mechanisms for accessing these tools (additional mechanisms are the toolbars and keyboard shortcuts).

Select

The Select menu item invokes a Select tool allowing you to select one or more entities to modify.

Keyboard Shortcut: Spacebar

Eraser

Use the Eraser menu item to invoke the Eraser tool allowing you to erase entities from the drawing area. This tool also allows you to hide and soften edges.

Keyboard Shortcut: E

Paint Bucket

The Paint Bucket menu item invokes the Paint Bucket tool used to assign materials to entities in your model. Use the Paint Bucket tool to paint individual elements, fill a number of connected faces, or replace a material in your model.

Keyboard Shortcut: B

Move

The Move menu item invokes the Move tool allowing you to move, manipulate, and copy geometry. This tool can also be used to rotate Component entities.

Keyboard Shortcut: M

Rotate

Use the Rotate menu item to invoke the Rotate tool used to rotate drawing elements and single or multiple objects within a single rotation plane. The Rotate tool can also be used to stretch and distort geometry by selecting only a portion of a model.

Keyboard Shortcut: Q

Scale

The Scale menu item invokes the Scale tool allowing you to resize and stretch selected geometry relative to other elements in your SketchUp model.

Keyboard Shortcut: S

Push/Pull

The Push/Pull menu item invokes the Push/Pull tool used to manipulate faces of your model. This tool can be used to displace, extrude, re-attach, or subtract faces, depending on the context of selected geometry.

Keyboard Shortcut: P

Follow Me

Use the Follow Me menu item to invoke the Follow Me tool used to extrude faces along a path such as an edge or line drawn with the Freehand tool. This tool is useful when adding details to a model because it allows you to draw the detail at one end of a path on the model and then repeat that detail along the path.

Offset

The Offset menu item invokes the Offset tool used to create copies of co-planar lines and faces that are a uniform distance from original lines and faces. Lines and faces can be offset either inside or outside the original face. Offsetting a face will always create a new face.

Keyboard Shortcut: F

Tape Measure

Use the Tape Measure menu item to invoke the Tape Measure tool used to perform a number of dimension-related operations. These operations include measuring the distance between two points, creating guide line entities, and re-scaling an entire model to an exact dimension.

Keyboard Shortcut: T

Protractor

The Protractor menu item invokes the Protractor tool allowing you to measure angles and create guide line entities (usually at some angle).

Axes

The Axes menu item invokes the Axes tool allowing you to move the drawing axes. This tool is often used when constructing rectangular objects that are skewed relative to one another, or to allow for more accurate scaling of entities that are not oriented along the default coordinate planes.

Dimensions

Use the Dimensions menu item to invoke a Dimension tool used to place Dimension entities in your model.

Text

The Text menu item launches a Text tool used to insert Text entities into your model.

3D Text

The 3D Text menu item launches a 3D Text tool used to create modeled 3 dimensional text.

Section Plane

The Section Plane menu item invokes a Section plane tool used to make section cuts in your model.

Utilities

The Utilities submenu contains various utilities and macros created using the Sketchup Ruby API. This menu item only appears after enabling the utilities tools using the Extensions panel of the Preferences dialog box.

Note: Ruby scripts are contained in the Plugins directory under the installation directory.

Create Face

The Create Face menu item invokes the Create Face utility allowing you to troubleshoot face creation and, in most cases, create a face for three or more intersecting edges. Specifically, the Create Face utility is useful when:

  • A model has two edges that have a common end point geometrically (the coordinates of the end point are the same), but the edges are not connected topologically. In this case, the Create Face utility will properly connect edges and create a face.
  • A face cannot be created because edges are not exactly planer, or appear to be connected when there is actually a small gap between the ends of the edges. In these instances, Create Face will not create a face, but displays a message indicating why SketchUp cannot create a face. This message can be used to troubleshoot face creation.

Query tool

The Query tool menu item invokes a Query tool utility that displays the current mouse position in the Measurements toolbar.

Interact

Use the Interact menu item to interact with a dynamic component that has click regions, such as a door that, when clicked, animates.

Sandbox

The Sandbox submenu contains options for modifying terrain. This menu item only appears after enabling the terrain modeling tools using the Extensions panel of the Preferences dialog box. See the Sandbox tools topic for further information.